会计电算化实用基础

会计信息系统实用基础

汤四新 著

作者简介：汤四新，男，软件工程硕士，1992年开始从事财务及企业管理软件的开发、科研与教学工作。曾先后参与和主持分别基于UNIX平台、DOS平台、WINDOWS平台的财务软件总账、报表、工资、固定资产、出纳、内部银行、财务分析、工业材料、成本、产成品、销售、商业进销存等子系统以及医院综合管理信息系统、企业综合信息管理平台的设计与开发工作。1995年开始兼顾多种财务软件及企业管理软件的销售和售后服务工作。截至2005年5月，共出版专著、编著各一部，在全国中文核心期刊财会月刊、财会通讯、中国会计电算化及其它公开发行的专业杂志上发表论文二十篇。获国家版权局《金三门数字智能网企业管理软件》计算机软件著作权登记认证一项。 现任广州小聪软件有限公司企业信息化研究所所长、广东金融学院教师。

该电子读物是广州小聪软件有限公司企业信息化研究所出版的关于企业财务信息化问题研究的力作，可以到 www.jxcchina.com 下载。

该电子读物已被立信会计出版社以《财务软件解析与导购》为书名于2003年1月正式出版。该书内容比电子读物更翔实。全国各地新华书店均有出售。

广州小聪软件有限公司企业信息化研究所简介

一、研究所研究领域

广州小聪软件有限公司企业信息化研究所围绕企业信息化问题，密切结合我国中小型企业信息化现状，对现代企业信息化理论与实务开展三个层面的研究。

第一个层面是纯理论性的研究：重点研究计算机信息处理环境对传统企业管理理论的影响及对策；研究手工信息系统、自动化信息系统、现代信息系统之间的异同和变迁条件；研究现代信息系统应具备的本质特征及内涵。

第二个层面研究企业信息化实践：重点研究企业信息化的现状和未来趋势；研究核算型软件、管理型软件、决策支持型软件的差异及其分别满足企业的哪些财务与业务的管理需求，还有什么需求不能满足；研究财务软件与其它业务软件如何连接，如何实现一体化；研究管理软件如何适应会计制度改革、财税制度改革及业务营销环境变革中出现的新问题。

第三个层面研究企业信息化的技术支持：重点研究如何将现代企业信息化理论运用于企业信息化实践；在指导实践的过程中需要运用哪些逐步规范化的实施技术，需要通过哪些行之有效的组织方式和手段辅助企业信息化的有效实施；研究第三方技术力量如何协调软件开发商与客户之间的利益冲突，确保双赢的策略和技术。

二、研究所业务范围

l 课题类：课题包括本企业计划研究课题、政府部门委托研究课题、企事业单位委托研究课题、学术交流研究课题。

l 培训类：面向企事业单位、机关、学校等社会团体开展旨在提升企业形象、拓展企业业务的有偿或无偿企业信息化问题培训。最终建立基于企业信息化资格认证考证形式的培训体系。

l 研讨类：与其它科研组织或企事业单位联合开展各类研讨活动。

l 开发类：有条件地开展软件的研发和集成工作。

l 实施类：直接参与某些企业信息化实施工作。

l 服务类：为本企业其它部门提供技术辅助性服务工作。

l 项目类：《小聪三门财务软件》、《3W小聪湘财财务ASP平台》及代理记账业务、《3W小聪湘财一体化平台》。

三、研究所工作宗旨

为我国企事业单位信息化、特别是中小型企业信息化提供最满意的整体解决方案。

四、研究所部分科研成果

论文类：

《辅助核算与管理在财务软件和业务软件中实现之差异》 (财会月刊.综合版2005年第2期)

《计算机条件下存货计价方法的改进与创新》 (财会月刊.会计版2005年第1期)

《线材行业业务、财务一体化核算与管理的软件实现分析》 (中国会计电算化2004年第12期)

《论现代会计信息系统对流程管理的依赖性》 (财会通讯.学术版2004年第10期)

《企业进销存软件应用模式分析》 (财会通讯.综合版2004年第10期)

《会计元素论》（财会通讯.学术版2004年第9期）

《企业财务软件应用模式及其识别过程分析》 (财会月刊.A版2004年第7期)

《现代会计信息系统获取－支付成熟度模型研究》 (财会通讯.学术版2004年第6期)

《论战略型财务软件的本质特征》 (中国会计电算化2004年第6期)

《网上银行与财务软件数据接口分析与设计》 (中国金融电脑2004年第1期)

《财务软件凭证处理性能分析》 (中国会计电算化2003年第12期)

《管理软件记账凭证生成机制模型研究与性能评测》 (中国会计电算化2003年第10期)

《也论财务软件发展趋势》 (广东财会2001年会计电算化特刊）

《财务软件科目代码模式设计比较研究》 （广东财会2000年03期）

《第三种财务软件》 （中国会计电算化1999年11期）

《企业成本核算、分析与管理解决方案探讨》 （广东财会1999年会计电算化特刊）

著作类：

《财务软件解析与导购》 (著/2003年1月出版/立信会计出版社)

《会计电算化理论与实务》（编著/2000年1月出版/天津电子出版社）

软件类：

《金三门数字智能网企业管理软件》 (2004年9月通过国家版权局计算机软件著作权登记认证)

五、研究所服务项目

l 专题讲座：一般时间控制在180分钟以内，内容区别听众选择知识性、趣味性较强的课题。重点推介企业信息化理念及本公司解决方案。收费标准：500元/小时。

l 系列讲座：选择企业信息化某一专门领域（如ERP、MRPII、MRP、AIS等）开设系列讲座。可以分成短期/初阶系列（五次课以内）、中期/进阶系列（六至十五次课）、长期/高阶系列（十六至三十次课），每次课约240分钟系列讲座。收费标准：500元/小时。

l 考证课程：结合本公司软件产品提供初级、中级、高级培训及考试发证课程教育。

l 经验交流会：收费标准：2000元/次。

l 学术研讨会：收费标准：2000元/次。

l 企业信息化咨询：收费标准：2000元/次。

l 企业信息化诊断：收费标准：5000元/次。

l 软件工程监理：软件系统造价的10%～20%。

l 项目推广：《3W小聪三门财务软件》、《3W小聪湘财财务ASP平台》及代理记账业务、《3W小聪湘财一体化平台》、第三方行业软件与财务软件一体化专项工程、ERP软件的选型与实施

l 学位实习、论文指导：会计信息化、企业信息化问题研究

六、服务项目涵盖内容

l 理论类：企业信息化框架体系、ERP原理与应用、MRPII原理与应用、MRP原理与应用、管理信息系统、欧美现代会计信息系统、会计电算化原理与应用；

l 实务类：财务软件解析、进销存软件解析、MRP软件解析、MRPII软件解析、ERP软件解析；

l 实践类：企业财务软件应用实践、企业业务软件应用实践、企业财务业务一体化管理软件应用实践、企业MRP软件应用实践、企业MRPII软件应用实践、、企业ERP软件应用实践；

l 研讨类：企业核心业务能级成熟度模型研究、基于模型的企业信息化改进、企业信息化模式研究、财务软件应用模式研究、进销存软件应用模式研究、MRP软件应用模式研究、MRPII软件应用模式研究、ERP软件应用模式研究；

l 推介类：财务软件欣赏、进销存软件欣赏、MRP软件欣赏、MRPII软件欣赏、ERP软件欣赏；

l 其 它：OA、CAD、CAM、CIMS、CRM、SCM、HR、DRP等。

热诚欢迎社会各界与我们

就企业信息化问题开展各类活动

共同推进我国企业信息化事业的蓬勃发展


问题的提出

第一章：问题的提出

第一节：财务软件是什么

财务软件是什么？这个问题提出来第一感觉可能有点唐突。如果您问会计，会计会告诉您财务软件就是帮助他们做账的工具。如果您问电脑技术人员，电脑技术人员多半回答您财务软件是一种应用软件。他们的答案都没错。财务软件是一种需要在计算机上运行的能帮助会计人员高效地完成会计日常记账、算账、报账工作；进行有效的财务管理和控制的计算机应用软件。

♣电脑专家

会计软件是指专门用于会计工作的电子计算机应用软件。具体地讲，会计软件是一组指挥计算机进行会计工作的程序，包括计算机程序、存储数据以及有关资料。例如账务处理软件，包括指挥计算机进行账务处理的程序、基本数据（会计科目、凭证等），还包括软件操作使用手册等有关技术资料等，以指导应用人员如何操作使用。会计软件是我国计算机软件应用领域中比较活跃的一个分支，在我国软件产业中占有重要地位。会计工作范围比较广，一般可分为会计核算、会计管理、会计决策三个部分。会计电算化的初期，会计软件主要是指能进行会计核算工作的软件，即会计核算软件。其主要功能包括账务处理、银行对账、工资核算、固定资产核算、产成品销售核算、成本核算、材料核算、财务报表等。随着会计电算化的发展，会计软件的处理范围也将逐步扩大，包括财务计划管理、财务分析、预测决策等新内容。


为什么要使用财务软件

第二节：为什么要使用财务软件

使用财务软件的第一大好处是可以降低会计人员的劳动强度。众所周知农业机械化可以将农民从“面朝黄土背朝天”的艰辛的手工劳作中解脱出来，同样会计电算化也能将会计人员从传统的手工业务中解放出来。试想在传统会计的证、账、表会计循环中，只需要会计填制记账凭证，电脑自动登记账簿，自动编制报表，会计人员的劳动强度难道不会大幅度下降吗？

使用财务软件的第二大好处是可以提高会计的工作效率与效益。由于电脑速度快、精度高、能成批大量地处理数据，是手工会计无法比拟的，从而大大提高了会计的工作效率；而且，电脑处理可以充分利用各种会计数据，一气呵成地计算出需要的结果，减少系统的资源开销，达到降低成本的目的。这样一来，一方面手工会计中的许多处理步骤在电脑会计中可以省略，另一方面数据处理准确度反而提高。因此，使用财务软件就可以将会计工作的效率与效益同步提高。

使用财务软件的第三大好处是可以改善企业计算机应用状况，提升企业信息管理水平，特别是财务信息管理水平。面对当前知识爆炸的信息时代，每个企事业单位都有必要早日实现自身信息现代化管理。做个信息时代的“弄潮儿”和“幸运儿”。

♦会计专家

会计电算化是以电子计算机为主的当代电子技术和信息技术应用到会计实务中的简称，是一个用计算机来替代人工记账、算账、报账，以及替代部分由人脑完成的对会计信息的分析和判断过程。会计电算化是传统会计信息处理技术的重大变革，对会计工作的各方面产生了深远的影响。其主要意义是：减轻会计人员的劳动强度，提高工作效率；促进会计工作的规范化，提高会计工作的质量；促进会计工作职能的转变，充分地发挥会计的预测、决策职能；对会计人员提出了更高的要求，促进会计队伍素质的提高；加快信息流速，为整个管理现代化奠定基础；促进会计理论研究和会计实务的发展。


企业实施会计电算化的途径

第三节：企业实施会计电算化的途径

企事业单位实施会计电算化一般有两种方式可供选择：其一是从市场上购买基本适合自身需求的通用型商品化会计软件；其二是自行开发专用的会计软件。当然，这两种方法各有千秋。前者的好处是：投资小、见效快、软件运行较稳定、售后服务有保障等；不足之处是：软件不一定完全满足企事业单位的全部需求，业务变动后修改软件难。采用自行开发会计软件的优缺点正好与前者相反，后者的优点是：开发的软件可以完全按本企业的需求开发，可以完全满足本企业的需要、并且由于软件源代码掌握在企业手中，业务变动后增、删、改软件较容易；缺点是：投资大、周期长、软件质量与开发技术水平休戚相关、软件维护成本高。

其实，除了上述两种方法外，还有第三种方法。就是选购“第三种财务软件”再结合自身需求组织个性化实施（详情请参考咨询顾问）。

♣电脑专家

商品化会计软件是指由软件开发单位专门研制的、用于公开在市场上销售的会计软件。其主要特点是通用性强、水平高、投资少、见效快，单位买回即可投入使用，解决了会计软件低水平、重复开发的问题。因而，购买商品化会计软件已成为企事业单位实现会计电算化的一条重要途径。商品化会计软件由于其影响范围比较广，财政部专门规定：商品化会计核算软件必须通过财政部或省、自治区、直辖市、计划单列市财政厅(局)的评审，同时对其功能、试运行时间、范围以及售后服务也有专门要求。随着会计电算化的发展，我国专业从事商品化会计软件开发的单位日益增加。

♠咨询顾问

纵观现在大多数企业实现会计电算化的方式一般有两种：一种是购买通用的财务软件，另一种是实行定点开发。所谓“通用财务软件”是指企业可以在市场上购买到一种成型的同时又适应本企业需求的财务软件，拿来就用；所谓“定点开发”是指企业由于自身业务的特殊性和需求的特殊性在市场上寻找不到一个适应本企业要求的软件，只能采用软件工程的方法进行专项的定点开发。然而，随着企业会计电算化工作的进一步开展，当企业的普遍性需求得到满足后，由业务的特殊性和需求的特殊性引发的对软件的个性化要求会越来越明显、越来越多，企业将面临一个使用通用软件满足不了个性化的要求，采用定点开发又周期太长、费用太高、且存在一定的投资风险的困境。如何解决这个难题呢？我们需要引入一种全新的财务软件来解决这个难题，这种全新的财务软件应该是介于通用财务软件与定点开发财务软件之间的既能满足企业的普遍性也就是通用性需求又能满足企业的特殊性也就是个性化需求的软件。这种软件我们可以称其为“第三种财务软件”或“个性化的财务软件”。

第三种财务软件首先应该具备的第一大特征是“面向数据”。企业特殊性的需求最明显表现出来的是某个处理对象具有一些不同于其他一般对象的属性，第三种财务软件首先应该能满足这种需求。譬如：我们大多数企业的入库单不需要有一个采购定单号字段，但是某个企业为了业务控制的需要在入库单中必须要有一个采购订单号字段。这种特殊性需求的满足要求我们的软件必须具备用户自定义字段的功能，这种用户自定义字段的功能就是我们所说的“面向数据”概念的一部分。其实，“面向数据”还应该包括用户自定义字段之间的勾稽关系、用户自定义输入界面等用于满足数据源和目的库的自定义功能。

第三种财务软件应该具备的第二大特征是“业务导向”。所谓业务导向就是企业可以根据自身业务流程来定义软件的工作流程，是一种软件迁就用户而不是用户迁就软件的模式。譬如：一般企业是先验收后入库，要求入库时必须有验收单，但某个企业由于自身业务量太大，验收工作跟不上来，可能变成先入库后验收的方式，如果一个软件规定必须先验收后入库，那么这个软件在这个企业就不能使用，如果一个软件的业务处理流程用户可以自定义，那么这个软件就能满足这个企业的需求。当然，“业务导向”决非如此简单，它的主要内涵是用户可以自定义工作步骤、处理流程和数据加工方法等。

第三种财务软件应该具备的第三大特征是满足“IOD”的要求。所谓“IOD”就是Information on Demand的缩写，它的意思是指企业需要什么样的信息软件就能加工得到什么样的信息。它主要包括用户可以自定义输出内容、自定义输出格式、自定义输出载体等。

综上所述，我们已经可以看到第三种财务软件是一种有别于通用型财务软件和定点开发财务软件的一种全新的财务软件。它能满足企业普遍性的需求又能满足企业特殊性的需求，而且在满足特殊性需求时无需大动干戈，用户只要稍做改动就能如愿以偿。


财务软件的选择为何成为一个问题

第四节：财务软件的选择为何成为一个问题

目前，通过各省市财政部门评审的商品化财务软件大约有200家左右，通过国家财政部评审的商品化财务软件在40家以上。财务软件的价格也从几十元到几十万元价格不等。面对如此众多的财务软件，作为有需求又有购买力的消费者应该如何选择自己中意的财务软件就成为一个棘手的问题。更何况大多数财务软件厂商为了争夺客户都使出浑身解数有意无意地夸大软件功能，不乏存在对消费者的诱导倾向；大多数的消费者在选择财务软件时对自身需求并不十分清楚；部分消费者缺乏鉴赏财务软件优劣的能力；诸多因素搅和在一起更加加大了消费者选择财务软件的难度。作为一个明智的消费者确实到了一个急须提高自身鉴赏能力，学会保护自己的投资的时刻。

♦会计专家

会计软件根据其适用范围分为通用会计软件、行业会计软件和专用会计软件三类。通用会计软件是指适用于不同行业的会计软件，其适用范围广，可供不同行业、不同规模的单位使用，如通用企业会计软件可适用于工业企业、商业企业等；行业会计软件则主要适用于某一行业会计工作，如行政事业会计软件等；而专用会计软件一般只适用于某一企业的会计业务处理。

♣电脑专家

会计软件按其开发方式可以分为商品化会计软件和定点开发会计软件。商品化会计软件是指由软件开发单位专门研制的、用作销售的会计软件；定点开发会计软件是指专为某一单位开发的会计软件。截止1998年底，已有38个商品化会计软件通过了财政部的评审，160个软件通过了省级财政部门的评审。


国内财务软件简介

第五节：国内财务软件简介

国内财务软件起步于是20世纪七十年代末期，从财务软件的开发深度、应用程度和组织管理等方面综合考虑，国内财务软件的发展大体可以分成三个阶段：初级发展阶段、自发发展阶段、快速发展阶段。1983年之前，少数规模比较大又有开发能力的单位开始实行单项的会计业务电算化工作，当时，最为普遍的是工资核算与管理的电算化；1980年之后在某些有条件的大学的会计专业课程中出现“计算机在会计中的应用”；1981年在长春召开的“财务、会计、成本应用电子计算机专题讨论会”才正式提出了“会计电算化”一词；初级发展阶段的主要特征是：财务软件都是自行设计和开发、会计人员对财务软件普遍缺乏基本的认识、会计电算化发展极为缓慢。1983年，国务院成立了电子化领导小组，号召全国人民迎接新技术革命的挑战，在全国掀起了一个计算机应用的热潮。许多单位都加大了计算机在企业管理中的应用力度，其中最成功的就是计算机在财务工作中的应用。当时，许多财务人员已经初步尝试到了会计电算化的“甜头”，非常期待进一步深化计算机在财务中的应用；另一方面，既精通计算机技术又通晓会计知识的人才十分匮乏，社会上专门从事会计电算化的机构凤毛麟角，致使大多数单位都是在财务人员提要求、计算机技术人员编程序这种各自为政的方式下低水平、重复性地进行自发性的会计电算化工作。1987年，中国会计学会正式成立了会计电算化研究组，1988年研究组召开了首届会计电算化学术讨论会，此时，国内会计电算化才进入了快速发展阶段。1994年财政部在总结多年来会计电算化的发展经验先后颁布了《关于大力发展我国会计电算化事业的意见》、《会计电算化管理办法》、《商品化会计核算软件评审规则》、《会计核算软件基本功能规范》等正式文件，对引导国内会计电算化的规范化、健康发展起到了巨大的推动作用。目前，随着政府职能的转换，财务软件已经进入了一个比较健全的市场经济运作模式，财务软件的宏观管理主要由行业协会（中国软件行业协会财务及企业管理软件分会）进行。

如果从软件功能层次上来划分，国内财务软件层次可以粗略地划分成核算型财务软件、管理型财务软件、战略型财务软件三个层次。

所谓核算型财务软件又叫“甩账型” 财务软件，通俗地讲就是甩掉手工账、采用电脑账；具体地说也就是基本上模仿手工对财务的核算和管理过程，在计算机里建了一个账本，起到减少工作量、减轻劳动强度的作用，把人力解放出来去进行更高级别的财务管理工作。

核算型财务软件主要任务是解决财务会计的问题，由于财务会计主要是对企业已经发生的经济业务进行事后的记录和总结，对过去的生产经营活动进行客观的反映监督。按照一般公认会计原则、会计准则和会计制度对日常经济业务进行符合规范的处理，编制各种会计报表，最终以会计报表的形式向企业外部公众如实反映企业的财务状况和经营成果。因此，核算型财务软件结构比较统一，使用比较简单。

当然，企业使用财务软件不会仅仅停留在解决财务会计问题的水平上，企业更需要的是解决管理会计的问题。管理会计是更多地适应和满足现代企业管理的需要，突破传统会计的领域，利用财务会计提供的会计信息和其他业务信息，运用数学、统计等方面的一系列方法，通过整理、计算、对比、分析等个性化手段的运用，向企业内部各级管理人员提供用以短期或长期经营决策、制定计划、指导和控制企业经营活动的对内报告会计。由于管理会计主要向内部公众提供可以用于指导和控制企业经营活动的信息。因此，管理会计所处理的数据对象也多于财务会计、所遵循的原则和使用的方法也更具个性化。所以，能满足管理会计需求的财务软件就不会是核算型财务软件，而是管理型财务软件。需要注意的是管理型财务软件不是一个独立于核算型财务软件的软件，而是基于核算型财务软件又高于核算型财务软件的软件（换言之，管理型财务软件可以全面解决财务会计和管理会计的问题）。

比如在会计科目体系上，核算型财务软件采用的是一种二维的树型结构，这是符合我国统一会计制度的有关要求，符合财务会计主要对外报送各种会计报表的工作要求。但是，对企业来讲，在满足这个外部管理需要的同时，又要满足企业内部管理的需要，尤其从企业管理发展的角度看，企业内部要按人员、按产品、按部门，甚至还要按照一些工作项目进行核算，才能很清楚地反映出各个部门在整个工作过程中的财务状况。如果按照传统的会计科目体系进行一种以记账凭证为依据，面向外部管理需要的，从凭证到报表的核算过程。这样的过程虽然能够把原始的情况真实地纪录和反映出来，但是，这种将内部管理要素作为一级科目的方式来解决会让会计科目体系成级数增长，且灵活性较差。在这种方式下，无论手工记账还是计算机记账，都很难满足管理的需求。所以，这种手段和方法限制了财务管理的范围，不能更全面细致地进行核算。如何把核算过程进行得更细致、更完整，同时又不增加很多工作量以保证时效性和灵活性呢？要解决这个问题，可以采用项目管理的方法。

所谓项目管理，就是在原来二维科目体系的基础上，新增了一个项目的概念和相关算法，形成一个三维的科目体系。如果要从财务上了解一个项目，例如盖一座楼的工作过程，就要涉及多个科目。在三维的科目体系中，可以在进行核算的同时就将有关信息分配到项目中去。例如报销一笔差旅费6000元，在三维的结构中就不会简单地记一笔差旅费，而是要记录其中有3000元是为了这个工程开销的，其余3000元用于其他目的，也就是说在一笔账发生的同时还要把面向项目的应用反映出来。在以后针对项目进行核算的时候，就可以将这笔费用也计算进去，使每笔资金的流向十分清晰。这样，科目体系既不庞大，又可以将核算过程和管理过程结合在一起。

将财务和业务统一到企业经营目标的大旗下，实行一体化的全面企业管理才是正确的管理型财务软件的解决之道。

在一个单位里，财务部门和业务部门是分开的，财务部门的信息来源是其他部门提供的各种票据，比如报销凭证，只有在事件结束后报账的时候财务部门才能进行事后记账，因而无法反映事件的过程。财务部门当然希望能够更清楚地反映业务过程，但是业务部门去报销的时候，就不会那么细，一般只写个“招待费”之类，至于为什么招待、招待谁，财务上就反映不出来。

财务要真正解决对发生过程的实时反映，对业务事件进行更明细、更清楚的核算和管理，就应该从整个企业管理的角度来看待财务，不是简单地将凭证拿出来，看看赚了多少钱、花了多少钱就完了，而是要了解这些钱是怎么赚来的，又是怎么花出去的。例如在一个工业企业，财务工作除了要进行产值和利润的核算外，还要进行采购的核算、库存的核算、成本的明细核算、产成品的销售核算等，如果还依照传统方式把财务部门和业务部门分离进行单独管理，是很难做到的，因为在其中存在着一个数据的往来和共享的问题。

所以，接下来亟待解决的就是财务部门和业务部门一体化的问题，只有这样才能把财务部门的管理延伸到业务过程，也才可能把这些业务发生的情况更清楚地在财务账面上反映出来。反过来，财务部门也可以给业务部门提供一些及时的财务信息，例如作为一个采购部门，订一个合同的时候应该很及时地了解资金状况。

解决这个问题的方法很多，例如让财务部门去研究研究业务软件，或者开发业务软件的单位也搞财务，但是要真正地解决这个问题，这样做还不行。这是因为两种做法都有一个主从的关系，或是财务部门觉得自己是中心，或是业务部门觉得自己是中心，而实际上围绕的中心应该是一个更高层次的统一，即企业的经营目标。在这个目标下，财务和业务都是企业全面经营管理的有机组成部分。如果只是单纯地重财务轻业务，就只能满足财务部门对业务的核算，不能满足企业的经营管理的需求。如果从企业管理的全局角度出发去管理财务，就不仅仅是事后的凭证，必须与其它的部门协调起来一起考虑相关的财务问题，比如对外要考虑报税、还有银行对账，以及与业务部门的数据往来。

随着市场经济的进一步发展和完善，行业竞争的深度和广度都在不断的变化，要想在激烈的竞争中抢得先机，财务人员就必须学会如何将数据转化为信息，再由信息转化为知识，最后再由知识付诸行动。企业必须放弃狭隘的“闭门造车”式的理财方式，在财务部门采取更加主动的态度和管理方式。

要完成向战略型财务管理的转变，企业所选择的财务信息系统应该是决策支持型的，概括地讲它必须具有以下特点：

一、数据源多样化

来自于记账凭证的财务信息只够支持财务核算与监督的需要。满足战略型财务管理的财务信息系统还必须添加来自于管理计划与控制的信息，来自于市场的各类信息。这样，就表现出数据源的多样化趋势。

二、数据采集环节扁平化、网络化

数据采集环节主要追求的目标是正确性、及时性、完整性和有效性。在传统工具支持下的数据采集过程中，为了保证数据采集的正确性，需要增加一些复核、检查的环节；为了保证数据采集的及时性，不得不以损失完整性为代价简化数据项目与格式；为了保证某些比较重要的数据采集的有效性，不得不牺牲另外一些数据的有效性。总之，在传统工具支持下的数据采集环节层次繁杂、基本呈现出一种树型结构。以电脑为主要工具的数据采集，完全改观了传统的数据采集方式。比如：只要数据源正确，电脑程序正确，那么，数据的后续加工环节将不会减弱这种正确性，几乎所有的检查、复核、对账环节就没有存在的必要，出现了数据采集环节扁平化趋势；借助电脑的数据采集过程，将可以在不损伤数据完整性的前提下极大地提高数据采集及时性，数据采集及时性与完整性的矛盾可以得到有效的调和；同样，基于电脑的数据采集有效性可以在网络化的环境下实现数据的共享，因而，出现了从多角度保证数据的整体有效性的可能，换句话说，就是在保证某些比较重要的数据采集的有效性时，可以不牺牲另外一些数据的有效性，数据采集的整体有效性可以得到显著的提高。

三、数据加工多库化

决策支持型财务信息系统，在数据加工处理环节上应以现代三库理论取代了“数据＋算法＝结果”的简单加工处理方式。出现了数据加工多库化的趋势（三库理论在接下来的♣电脑专家中详细讲解）。

四、业务流程可重组化

业务流程重组（Business Process Reengineering，简称BPR），是90年代由美国MIT教授哈墨(Michael Hammer)和CSC管理顾问公司董事长钱皮（James Champy）提出的，1993年，在他们联手著的《公司重组----企业革命宣言》一书中，哈默和钱皮指出：200年来，人们一直遵循亚当斯密的劳动分工的思想来建立和管理企业，即注重把工作分解为最简单和最基本的步骤；而目前不应围绕这样的概念来建立和管理企业，即把工作任务重新组合到首尾一贯的工作流程中去。他们给BPR下的定义是：“为了飞跃性地改善成本、质量、服务、速度等现代企业的主要运营基础，必须对工作流程进行根本性的重新思考并彻底改革。”它的基本思想就是----必须彻底改变传统的工作方式，企业在广泛应用信息技术的前提下，以市场为导向，以降低成本、提高产品质量、关心客户的需求和提高客户的满意度为目的，对企业内外工作流程进行深入分析，加以重新设计和组建。它包括企业组织结构、生产流程和业务流程的重组。

业务流程重组(BPR)的基本原则是以顾客为中心、企业的业务以“流程”为中心、“流程”改进后具有显效性。以顾客为中心，它是指全体员工以顾客为中心，而不是“上司”为服务中心。顾客可以是外部的，如在零售商业企业，柜台营业员直接面对的是真正的顾客，也可以是内部的，如商场的理货员，他的顾客是柜台小组。每个人的工作质量由他的“顾客”作出评价，而不是“领导”。“流程”是指一组结合在一起能为客户创造价值的相关工作，一个流程是一系列相关职能部门或岗位配合完成的，体现于为顾客创造有益的服务。企业的业务以“流程”为中心，它是指企业不再以专业职能部门为中心，工作设计不再基于等级管理和劳动专业化，而是基于从头至尾的整个流程以及与流程有关的岗位和为客户创造价值上。对流程运行不利的障碍将被铲除，职能部门的意义将被减弱，多余的部门及重叠的流程将被合并。“流程”改进后具有显效性，它是指改进后的流程提高了效率，消除了浪费，缩短了时间，提高了顾客满意度和公司竞争力，降低了公司运作成本。

业务流程重组，在具体实施中，体现在三个方面：单据内容的变化；单据传递过程和方式的变化；单据处理方式和结果的变化。单据内容的变化，包括各种业务单据类型的增减、单据格式的调整、栏目的增减分合。单据传递过程和方式的变化，包括传递对象及岗位的增减变化、各对象和岗位工作人员处理的变化。单据处理方式和结果的变化，包括处理的重点、处理的步骤、数据组织格式、汇总统计口径等方面的变化。

决策支持型财务信息系统应该是完全支持业务流程重组的。

五、理财观念决策化

决策支持型财务信息除了能够完成财务核算与监督、完成财务管理与控制外，无论从信息源的收集、信息的加工处理方法的选择、信息结果的输出等方面，特别是软件的整体设计思想与实现方式更多地紧紧围绕支持决策的方向展开。或者说是一切工作皆是面向决策的。软件的设计理念与实现功能支持决策化只是一个方面，更重要的是软件使用者的理财观念必须决策化。

♣电脑专家

一个完备的电算化会计信息系统包括：电算化会计核算子系统、电算化会计管理子系统、电算化会计决策支持子系统。它通过会计核算反映企业的经营活动情况，通过会计管理监督企业的经营活动情况，通过会计决策参与企业管理，整个系统的结构如图1-1所示。

图1-1

电算化会计管理子系统是建立会计模型来进行会计管理的，方式灵活多变，这样一个系统比较不稳定和半结构化，需要在生命周期法的基础上，采用更灵活的方法实现它。国外通常是采用三库理论的方法。即有一个独立的，能提供各种所需数据的数据库。会计数据库存放会计的原始数据和中间数据，包括原始凭证、记账凭证、总账、各种报表等数据。有一个独立的不受数据变化所影响的，提供各种数学方法和其他方法的方法库。在方法库中，以标准模板方式存储了各种算法，如各种矩阵运算、微积分运算、线性方程求解、常微分方程求解及统计计算等。根据管理上的需要，由数据库提供所需数据和由方法库提供所需方法，互相结合在一起，形成一个能提供管理上所需模型的模型库、例如利用成本核算的数据和回归分析方法，可以建立成本估计模型，利用成本、收入、支出账务数据和运筹学的方法，可以建立利润预测模型。

决策支持系统（DSS）是计算机软、硬件技术迅速发展并应用于管理决策领域的必然结果，它能综合利用各种数据、信息、知识与模型技术，辅助管理者解决半结构化和非结构化的决策问题。会计决策支持系统（ADSS）是DSS的理论和方法在会计决策领域的具体应用，是以计算机为基础和工具，应用现代决策会计的理论和方法，为决策者提供各种信息，辅助决策者进行决策的系统。一个较为成熟的ADSS结构是由交互语言系统、问题求解系统和知识系统构成的，其基本结构如图1-2所示。

不同类型的使用单位，其规模、特点、性质和管理水平各有不同，所采用的会计制度、核算方法、工作习惯也千差万别，因此，会计软件功能模块划分的方法也不能一概而论，特别对于管理子系统和决策支持子系统更是如此。所以，我们只对不同行业企业的会计核算系统的一般划分进行一个简单的介绍。

1、工业企业。工业企业的特点是要对购进的原材料进行加工，使之成为产成品，然后进行销售。这就决定了适应工业企业的会计软件主要是对其供产销过程进行核算、反映和控制。尽管不同的生产特点要求不同的核算方法，但其核算的内容却大同小异。因此，适应工业企业的会计软件功能模块划分的方法基本一致，主要包括：账务处理模块、出纳管理模块、工资核算模块、固定资产核算模块、原材料核算模块、成本核算模块、产成品销售核算模块、报表处理模块等。有些会计软件会把工业中的有关模块集成在一起，构成集成的系统，如把出纳管理模块集成到账务系统中。

2、商业企业。商业企业主要从事商品的销售活动，有关材料、原料方面的核算很少，甚至没有。固定资产管理要求比较简单，成本计算方法单纯，工作量少；但商品采购业务、存货管理业务、销售业务等方面的工作量较大。因此，适应商业企业的会计软件功能模块应包括：账务处理模块、出纳管理模块、工资核算模块、往来核算模块、购货业务模块、存货业务模块、销售核算模块、报表处理模块等。有些会计或商务软件会把商业企业中的几个模块功能集成在一起，构成一个模块。如商业进销存系统（或软件）包括购货业务模块、存货业务模块、销售核算模块、往来模块等。

3、科技、贸易与服务类企业。该类企业主要是向社会提供各种服务，从中收取服务费用。其经营过程要与众多用户打交道，债权债务比较复杂，但几乎没有原材料的耗费，成本计算极为简单，固定资产数量和价值也较小。因此，这类企业会计核算应重点注意各项劳务的发生和费用的收支，相适应的会计软件功能模块的构成主要包括账务处理模块、出纳管理模块、工资核算模块、应收账款模块、应付账款模块、报表处理模块等。

4、行政事业单位，包括政府部门、学校、科研院所等。它们主要靠国家财政拨款来开展工作，不存在成本计算、原料管理，不计算固定资产折旧，但需要按照部门或科研课题管理各种费用，控制支出。因此，适应它们的会计软件主要由账务处理模块、出纳管理模块、工资核算模块构成。对于部门较多的事业单位可专设预算管理模块；对于基建较多的事业单位可专设基建核算模块。

会计软件模块的划分没有固定的模式，随着企业的发展、计算机技术的发展以及会计自身的发展，会计软件模块的划分也必然有一定的发展，有些模块会合并在一起，有些模块会进行重新划分。

图1-2

♥管理专家

我国企业管理软件的发展已经历了十几年的历史，主要划分为四个发展阶段：会计核算软件阶段、财务管理软件阶段、一体化企业管理软件阶段、全面企业管理软件阶段。这几个发展阶段与我国企业的应用阶段是一致的。

一、会计核算软件阶段

会计核算软件阶段从80年代中期开始，80年代后期到90年代初期开始进入商品化阶段，一批年轻人率先成立了多家专门从事会计核算软件开发与经销的公司，在这期间的商品化会计核算软件主要是以替代手工会计核算和减轻会计人员的记账工作量为目标，主要是基于DOS环境下的开发工具和小型桌面数据库系统（如Dbase、FoxBASE、FoxPro、C语言等）开发完成的会计软件以单用户为主。

90年代中期的商品化会计核算软件不断成熟，财政部开展了会计核算软件的评审，1995年开始了大规模的初级培训，为国产会计核算软件的广泛应用创造了条件。这时的软件主要包括：账务处理、报表、工资核算、固定资产核算、采购与应付账款核算、销售与应收账款核算、存货核算等。主要使用WINDOWS环境下的开发工具，部分软件采用了大型数据库系统和C/S结构。

二、财务管理软件阶段

财务管理软件是在90年代中期发展起来的，这时的会计核算软件已经比较成熟，开发商有了进一步扩展功能的精力。这时，无论比较老的软件还是新开发的软件，都向财务管理功能方向发展。财务管理软件不是一个与会计核算软件分开的软件，而是融合在会计核算软件里的。财务管理软件与会计核算软件相比，主要增加了财务分析、财务预测、自动编制财务计划、财务控制等功能。

三、一体化企业管理软件阶段

一体化企业管理软件阶段是从90年代中期开始的。90年代以来，部分企业应用国外成熟的MRP II或ERP软件，由于东西文化上的差异、管理制度上的差异、企业管理模式以及企业管理者观念上的差别等原因，造成了应用不成功或应用效果不佳的局面。

1998年6月26日，中国软件行业协会财务及企业管理软件分会召开了“全面进军企业管理软件领域”新闻发布会，从而吹响了向企业管理软件领域全面进军的号角。目前，许多大型国产财务软件公司都已分别推出大、中或小型一体化企业管理软件。

目前我国企业管理软件的特点是要对企业的资金流、物流和信息流进行一体化、集成化管理。从软件功能上来看，包括财务管理、固定资产管理、采购管理、销售管理、存货管理，还包括对成本的控制以及对人力资源的管理。大型企业管理软件主要采用32位的开发工具，还采用了Web服务器技术（B/S结构），同时已开始考虑电子商务（E-Business）在软件功能中的应用。

四、全面企业管理软件阶段

全面企业管理软件阶段从二十一世纪初开始，此时，我国企业管理软件开发商的开发经验已经相当丰富，广大用户的应用经验也已有很大的提高。全面企业管理软件巨大的需求，极大地带动我国软件业的发展，成为我国软件业的龙头。全面企业管理软件要比现有企业管理软件的功能更加全面，除了原有功能进一步细化外，生产管理部分将成为开发和应用的重点。MRP、MRPII等先进的管理思想将不断地在管理软件中得到运用。


国外财务软件简介

第六节：国外财务软件简介

在国际财务软件市场上，占市场份额较大的软件主要是SAP的R/3、Oracle的APPLICATION、SAA的BPCS等，这些软件都符合GAAC（国际公认会计准则）的要求，其主要特点如下：

一、一般具有财务会计与管理会计的双重功能，又具有针对具体业务的财务管理功能，同时与制造、分销模块无缝的集成，有机结合组成完整的MRPII系统，使管理信息的处理更及时、统一、全面和深入。其具体特点体现在以下两方面：财务系统与制造、分销共用一套数据；财务信息随制造、分销的作业流程同步产生，在产生物流信息的同时产生会计信息。

二、模块组成与我国商品化会计软件有较大差异。

国外的财务管理软件根据管理业务划分成若干模块，各个模块既有独立的相应业务管理功能，又具备集成的财务综合管理能力。主体模块通常由总账、应付账款、应收账款、资产模块、现金管理和成本管理模块组成，各模块的主要功能如下：

总账模块记录企业的全部会计信息并为企业提供经营业绩信息，同时还具有部分管理会计功能。

应付账款模块主要处理对供应商的付款与发票，管理供应商及应付款。

应收账款模块主要处理向客户的收款与发票，管理客户及应收款。

资产模块进行资产维护，负责管理资产，包括固定资产、无形资产等。

现金管理模块的主要功能是根据现金的来源与支出数据进行现金预测、计划。

成本管理模块主要进行存货及成本方面的核算，依据管理会计理论，对企业成本进行模拟、预测、计划、控制分析和考核。

此外，还有库存管理、订单管理、采购管理、车间管理等相关模块。

以上这些特点是国外会计软件在长期实践中形成的，相对我国会计软件有一定的优势。但是，同时外国会计软件用于我国企业单位中也有一些不适应之处，主要表现在以下几个方面：

1、我国长期实行计划经济体制，目前正处于市场经济初创阶段。在长期工作实践中，也形成了一套具有我国特色的业务处理风格和习惯。外国会计软件如果不进行本地化处理，就与我国经济环境、业务处理习惯等有很多不相适应的地方。例如，在我国计划经济体制下，工业企业用料，每半年订货一次，形成大量库存，不适用的材料还要委托外部加工，用不完的材料还要对外销售等等。在市场发达的西方国家，生产企业根据生产计划提出用料清单，直接和供料单位签订合同，按照合同约定定时定量送料，库存量很少，委托加工、材料销售更是绝无仅有，这样，外国会计软件中存货核算就和我国工业企业中的材料核算有很大的差别；又如成本、利润、税收计算等等均与我国存在或多或少的差别。

2、有些外国会计软件的售后服务不如我国企业方便。如一些外国会计软件公司在我国的一些分公司、办事机构是不能改动程序的，如果会计软件需要修改，必须拿回他们的总公司处理，这一般要拖很长时间，加之我国当前正处在经济体制改革过程中，有关的规章制度变动频繁，而他们的软件修改不及时，这便会出现许多不适应之处，影响使用软件企业单位的正常工作。

3、外国软件价格过高，相当于国产软件价格的几十倍，再加上过高的售后服务费用，使我国企业难以承受。

国外会计软件虽然有以上不足，但是，应当看到，我国在经济发展、科学技术、经济管理等方面与发达国家相比，都还有一定的差距。而且，对以上不足，国外会计软件企业也不会视而不见，一定会逐渐改进。因此，我们必须通过引进、学习和借鉴国际先进经验，来促进自身较快的发展。虽然这需要付出一定代价，包括让出一定的市场，给予外方相应的利益；但是，这在市场经济条件下，也是符合国际惯例的，我们必须顺应社会客观规律的要求，在开放中求发展，在竞争中求提高，才能把我国的会计电算化事业不断推向前进。


财务软件选购注意事项

第七节：财务软件选购注意事项

第一点：看软件是否通过财政部门评审

财务软件必须经过财政部门的评审，取得《商品化会计核算软件评审合格证》，才能在市场上合法销售。在国外开发研制并经过实际运行的商品化会计核算软件，也应当经过财政部门组织的评审，确认符合我国法律、法规、规章和其他规定后，才可以在我国市场上销售。商品化会计核算软件评审工作由省、自治区、直辖市财政厅（局）或者财政部组织进行。计划单列市财政局经财政部批准，也可以组织商品化会计核算软件的评审。通过评审的商品化会计核算软件，由组织评审的财政部门核发财政部统一印刷的《商品化会计核算软件评审合格证》。取得《商品化会计核算软件评审合格证》的商品化会计核算软件，在国内的销售不受地区的限制。作为消费者，为了保障自身的合法权益，同时也为了财务软件的安全运行，建议最好购买已经通过评审的财务软件。

☻脚下留神

申请省、自治区、直辖市、计划单列市财政厅（局）评审的商品化会计核算软件，要达到以下基本条件：（一）、申请评审的商品化会计核算软件，应当具备以下基本要求：1、软件开发研制单位是在我国注册的经济实体；具有与软件开发规模相适应的专职软件开发人员；2、软件经销单位（包括分支机构和代理销售机构），其经营范围包括软件产品，且具有与软件销售规模相适应的专职售后服务人员；3、软件开发和经销单位（包括分支机构和代理销售机构）能够依法开展经营活动。（二）、有三种或者三种以上功能模块，其中包括账务处理功能模块；（三）、在三个或者三个以上单位运用并与手工会计核算同时运行三个月，取得与手工会计核算相一致的数据，并且至少有两个单位运用了软件的全部功能模块；（四）、各省、自治区、直辖市、计划单列市财政厅（局）要求的其他条件。

申请财政部评审的商品化会计核算软件，除具备以上要求外，还要达到以下基本条件：（一）、有六种或者六种以上功能模块，其中包括账务处理和报表处理功能模块；（二）、在十个或者十个以上单位运用并与手工会计核算同时跨年度运行，取得与手工会计核算相一致的数据，且至少有五个单位运用了软件申请评审的全部功能模块并已经开始替代相应模块的手工记账；（三）、通过省、自治区、直辖市、计划单列市财政厅（局）的评审一年以上。（四）、由省、自治区、直辖市、计划单列市财政厅（局）或者国务院业务主管部门、中国人民解放军总后勤部推荐。

第二点：看软件功能是否满足自己的需求

应认真考察软件是否能满足本单位会计工作目前和未来的需要。商品化会计软件大都分成各个相对独立的模块，其中一些是各单位可以共同享用的，另一些是针对不同的行业不同的企业特点而设置的。因此，购买时应认真考察软件的个性化特点，并根据自身企业的行业特点和特殊需求提出一些关键性问题，看看软件能否满足自己的要求。

第三点：看软件的使用是否简便、易学

包括是否配备了详细的操作手册，是否提供动态在线帮助功能，是否配备计算器功能，操作界面是否直观易懂，名称术语是否符合会计规范，操作方式是否符合会计业务流程和习惯，凭证、账簿输出打印是否方便等。

第四点：看软件运行是否安全可靠

安全可靠性是对会计软件的最重要的要求。会计软件是否安全可靠，可从如下几个方面进行判断：复核检查措施严密，保证数据的正确性；容错功能，即对各种错误系统能自动地报告并给出提示，以保证输入数据的正确性；备份恢复功能，即对系统运行中产生的数据除了在硬盘上存储外，系统还可进行备份，以备一旦常规数据丢失或损毁，可利用备份文件将数据恢复；日志功能，为所有操作人员留下审计线索；加密功能，即对系统的执行程序和磁盘数据进行加密，以防止对运行程序和账务数据的偷阅或篡改。

第五点：看软件的总体结构是否具备一定的灵活性、可扩展性和开放性

即考察软件在技术上是否先进，包括运行效率、可维护性、安全保密性、可扩充性以及易用性等。还要考虑会计工作发展的需要，看看软件是否适应企业发展的需要，能否进行扩充和升级。若是大型的现代化程度较高的企业，则最好选择网络版的财务软件，使会计电算化一步到位，减少人力、物力、财力的浪费。

第六点：看软件供应商的售后服务是否及时、完善

从一定意义上来说，购买软件就是购买服务，特别是对财务软件及企业管理软件来说，每个用户都要结合企业自身的特点来使用软件，没有技术支持的软件是不太可能用好的。商品化会计软件的售后服务包括：会计软件的日常维护、用户培训、二次开发与相关技术支持及软件版本的升级换代。在选购会计软件时，不仅要将售后服务作为一项重要的内容，而且要针对自身特点与软件经营单位商定售后服务方式，明确售后服务项目，其中哪些是无偿提供，哪些需要交纳服务费，根据这些情况来综合判断售后服务是否完善、合理。

第七点：看软件的价格是否合理

软件的价格是左右财务软件选择的一个较为重要的因素。软件的价格是否合理，主要在于购买者的实际购买力和心理承受能力，财务软件从几十元至几十万元价格不等，究竟应该花多大的价钱买财务软件才算合算呢？其实，软件的价格是可以进行量化比较分析的。

第八点：看软件的运行平台

财务软件运行平台是指构成计算机会计信息系统使用的硬件系统、系统软件（主要指操作系统和数据库管理系统）以及应用软件开发工具包等相关技术共同组成。

作为消费者，应该结合自身企业的现状、实际需要和未来发展需要，结合信息技术的发展趋势作出切合实际的选择。

♣电脑专家

财务软件运行平台可以按如下情况进行分类：

（一）、单机系统：就是由单机结构构成的会计软件运行平台。运行在该平台下的会计软件被称为单机版会计软件。一般，单机版会计软件的运行平台可以分为以下几类：1、DOS单机系统，就是以DOS作为操作系统的单机系统。使用DOS平台下运行的会计软件又称为DOS单机版会计软件，这种会计软件一般运行在单台微机的DOS操作系统之上，使用XBASE类型系列的关系型数据库管理软件进行数据库管理。我国早期研制的会计软件绝大多数都是DOS单机版会计软件。DOS平台下的会计软件一般采用字符界面（部分采用图形界面），操作一般都是通过键盘，因此，人机界面不友好，使用不够灵活。2、Windows 平台，Windows 平台就是以Windows 95/98/2000（对于较早会计软件来讲，还应当包括Windows3.X）作为操作系统的单机系统。随着微软公司推出了Windows操作系统后，我国大多数会计软件开发公司在90年代中期，相继推出了在Windows平台上运行的会计软件，一般被称为Windows版会计软件。Windows版会计软件大多是Windows 95/98/2000上进行开发的。Windows平台是图形界面，使用时可以通过鼠标和键盘结合进行操作，与DOS平台相比，界面较友好，操作更加灵活。

（二）、多用户平台：就是由多用户结构构成的会计软件运行平台。多用户平台一般使用UNIX作为主机操作系统。在多用户平台下运行的会计软件，被称为多用户版的会计软件。在我国，多用户版的会计软件一般用于银行中，企业中很少使用多用户版会计软件。

（三）、网络平台：就是由网络结构构成的会计软件运行平台。在网络平台下运行的会计软件，被称为网络版会计软件。一般按网络的体系结构，网络平台又可分为以下几种：1、文件／服务器体系结构（F/S）：文件／服务器体系结构的网络结点是主要由文件服务器和工作站共同构成。网络以文件服务器为核心，数据库和应用程序全部或部分存储在文件服务器上，应用程序则在工作站上运行，运行所需要的整个文件在文件服务器与工作站间传输。文件／服务器体系结构的缺点是：网络传输负荷大；服务器文件读写负荷大。因此，当服务器的负荷超大时，其效率会明显的下降。另外，文件／服务器体系结构下的会计软件，一般采用小型数据库，数据的安全性无法得到可靠的保证，而且当多人并发访问数据库时，很容易破坏数据的完整性，甚至出现死机。在我国，采用文件／服务器体系结构的会计软件，其运行平台结构一般是：在服务器上使用Novell公司的Netware网络操作系统，在工作站上使用DOS操作系统。人们按习惯，把这种类型的会计软件称为DOS网络版。一般来说，这类软件平台价格便宜，适合于业务量不大的中、小型企业应用。2、（传统）客户/服务器（C/S）体系结构：客户/服务器体系结构主要由数据库服务器和客户端（可以在工作站上，也可以在服务器，一般在工作站上）共同构成。它的主要特点是：将网络应用的用户交互界面（GUI）和业务应用处理与数据库访问处理相分离，服务器与客户端之间通过消息传递机制进行对话，由客户端发出请求给服务器，服务器进行相应的处理后经传递机制送回客户端。对数据库的大量操作通过远程数据库访问的方式交给了后台数据库服务器去完成，这提高了用户交互界面的反应速度，降低客户端（Client）对CPU处理能力的要求，而且应用开发简单。目前，客户/服务器技术已基本成熟，具有较多功能强大的前台开发工具，如DELPHI、VB、POWERBUILDER、C++BUILDER等；并受到大多数数据库管理系统产品的支持，特别是一些企业级的大型网络数据库，如SYBASE、ORACLE、INFORMIX、SQL SERVER等的支持。甚至一些单机上的小型数据库应用软件，也是用C／S方式进行工作。因此，我国目前大多数WINDOWS上运行的会计软件，不论其是在单机上运行，还是网络上运行，一般都是用C／S方式开发的。基于C／S体系结构的网络会计软件，由于服务器可以采用功能强大的计算机，甚至是大型计算机，可以承受很重的负荷，如可承受成百上千人对数据库的同时访问。因此，相对F／S体系结构而言，对于规模和业务量比较大的企业，往往应采用C／S体系结构的会计软件。3、分布式多层客户/服务器（C/S）体系结构：C／S体系结构虽然性能大大超过了F/S体系结构，但也有很多明显的问题。如客户端和后台数据库服务器数据交换频繁，当大量用户访问时，易造成网络瓶颈；由于要分别对客户端和后台数据库服务器进行维护，当应用业务逻辑变化时，必须修改客户端应用程序并需在每个工作站上重新安装配置等。为了解决这些问题，人们提出了“中件” （MIDDLEWARE）技术，将用户交互、应用业务处理和数据管理彼此之间彻底分离。从而形成了由数据库服务器、中件和客户端共同构成的分布式三层客户/服务器体系结构。中件技术可以帮助开发者解决透明数据库的访问以及互操作性，达到在复杂网络应用环境下，支持同时对多种数据的高效透明访问、远程数据库访问、分布式数据库访问和网络数据库访问，这种提供数据访问的中件被称作数据访问中件（DATA ACCESS MIDDLEWARE）。复杂的中件（如应用服务器中件），还通过各种方式提高对数据库操作的响应速度，提供高度的扩展和负荷分担，甚至分步提交（TWE－PHAT）等功能，满足大用户量对大型数据库的超负荷访问。多级分布体系结构与一般的C／S体系结构不同之处是在中间插入了专门完成应用业务处理功能的服务器，它相对于前台Client和后台数据库服务器均构成C／S结构。这种中立的应用服务器即是所谓的应用中件。Client端的功能注重在用户交互（GUI）和数据表象。后台数据库完成数据访问和数据管理，应用服务器则专司应用业务处理。该结构可将复杂的业务处理分割成相互之间可交互、调用和通信的若干业务功能部件或对象，并可将其分配到多个网络互联的应用服务器中件实现负荷分担。应用服务器中件往往还具备对分布对象的管理和实时调度功能，实现真正的分布处理和动态负荷分担。4、浏览器／服务器(B/S)体系结构：随着Internet技术的不断发展，尤其是基于Web的信息发布和检索技术、Java跨网络操作系统计算技术以及CORBA网络分布式对象技术三者的有机结合（Web十Java十 CORBA），导致了整个应用系统的体系结构从C／S的主从结构向灵活的多级分布结构的重大演变成为可能，使其在当今以Web技术为核心的信息系统应用中予以更新的内涵。这将是我国会计软件平台与技术发展的一个重要方向。

第九点：看软件运行总体拥有成本是否可接受

软件买回来了，就可以用了。但是，软件的使用不会象我们买回家的电视机、电冰箱一样，电视机、电冰箱只要接上电源，就可以用，就可以很好地发挥它们的作用。财务软件，特别是大型的财务软件就没有这么简单了。把软件买回来，安装调试成功，只能说财务软件可以用了，至于怎么用，怎么才能用得好这些问题才刚刚开始。据资料介绍，软件的购置成本只占软件的总体成本的20%左右，在软件的整个使用过程中，保证软件能够正常地运转所花费的支出将占软件的总体成本的80%左右。这些支出主要花费在修改软件本身隐含的错误，保证软件能够适应变化了的业务的需要，进一步完善软件的功能，更新软件的现有功能，升级软件运行的软、硬件平台以及培训和提高操作员及系统管理人员的技能等方面。因此，大家必须清醒地意识到：软件的购置成本相对于软件总体拥有成本而言，只是露出水面的冰山的一角。当然，不同级别、不同规模的软件其总体拥有成本的总额及组成会存在一定的差异。但是，购置成本与总体拥有成本的概念是同样存在并起作用的。因此，购买软件时，考察软件的总体拥有成本是否可接受也是一个非常重要的方面。

♥管理专家

软件工程中明确指出：在软件的整个生命周期中，软件的正确性维护成本、软件的适应性维护成本、软件的完善性维护成本、软件的升级费用、软件的培训费用将远远高于软件的一次性购置成本。而且，软件的规模愈大、软件使用难度愈高，这种趋势愈明显。 这已被无数的软件工程项目所证实，已是一个不争的事实。

♫前车之鉴

众所周知，会计电算化工作已经势在必行，那么买一台电脑，再买一套财务软件是不是就算实现了会计电算化？当然不是！

财务软件的好坏直接关系到整个会计电算化工作能否顺利进行！

选购一套称心如意的财务软件，最重要的一点是该财务软件是否最大程度地满足了您现在的需求和将来可能会发生的需求！

或许，您是初次接触电脑，不太清楚自己的需求到底是什么，那么您在选购财务软件时要注意防范“捡到篮里就是菜”的毛病，以免将来发现问题后骑虎难下，手中的财务软件如同鸡肋食之无味弃之可惜。

对大多数财会人员来讲，目前对财务软件所能提出的要求大多是使用以后可以“甩手工账”，而这制单记账的“簿记”工作又恰恰是所有财务软件最起码的功能，凡是商品化的财务软件百分之百能做到的。

那么，您在选购时还应该注意些什么问题呢？

（一）、针对财务软件本身

会计思想是否准确。财务软件是用计算机语言编成，一般财会人员对计算机编程感到神秘甚至敬畏，只想着自己去适应财务软件，却没有意识到自己是“上帝”。记住以下两点：并不是编出来的程序就一定是优秀的程序，就象写出来的文章不一定是好文章一样！并不是通过财政部门评审的财务软件就一定是优秀的财务软件，就象通过老师批改的作文未必是好作文一样！ 因此，判断一个财务软件的优劣，最重要的是看这个财务软件表达了一种什么样的会计思想？这种思想是否正确？它又是如何表达的？

所谓会计思想，这里我们姑且把它看作是财务软件开发人员对会计工作的理解。开发人员对会计工作的理解程度愈高，其财务软件的实用性和可操作性就愈强，不但能使其计算机的功能发挥得淋漓尽致，而且能令财会人员感到开发者的匠心独运，心意相通的财务软件自然是用起来得心应手。

可以说，使用财务软件，就好比在读一篇由财务软件开发人员撰写的作品。好的作品能令读者理解并产生共鸣。相反，糟糕的作品用词蹩脚行文拙劣，不忍卒读。

或许，在财务软件销售人员演示的时候您感觉眼花缭乱，没法看懂，更无从体会其中的会计思想。这时，强调结果可能是最有效的办法，把您要的结果描述出来，让财务软件销售人员实现它。

以往来账为例，您就可以向销售人员提问：“贵公司的财务软件能否实现往来账的两清？能否进行应收应付的轧抵工作？能否打印出往来户对账单？能否进行账龄分析？账龄分析表是怎样的？

在强调结果的基础上，再去耐心地比较各家财务软件的实现方式（例如查询或打印出的表格是否符合您的习惯或要求），这样您就不会觉得无所适从了。

汉字输入量较小。您要使用电脑，汉字输入是无法逃避的一件事情，无论如何您必须掌握一种汉字输入方法。对初学者而言，本来对英文键盘就不太熟悉，还要掌握一种汉字输入法，无疑有困难。财会人员大多是初学电脑，倘若一个财务软件的汉字输入量太大，将明显不利于日常使用。

记忆量较小。该财务软件能为财会人员提供各种方便，减少编码或功能键等记忆量。

稳定性较好。世界上没有一个软件绝对不存在错误，也没有一个软件生产商肯承认自己的软件不稳定。通过打电话直接询问该财务软件的用户使用情况是一种客观的办法，或者也可以向专业经销财务软件的专卖店咨询。

通常，存在时间较长和用户数量较多的财务软件相对会稳定些。随着开发技术的成熟和测试手段的完善，大多数财务软件稳定性都较好。

运行速度较快。用过电脑的人都知道，计算机前多等一分钟也是难以容忍的，时间就是金钱。

人机对话界面美观舒适，易于控制。五彩缤纷并不是件有趣的事，毕竟天天要对着屏幕操作财务软件。若是该财务软件能支持鼠标操作，并提供全部的且一致的快捷键功能，将会带来较多的方便。不要过于迷信多任务多窗口的宣传，实际上，对于初学电脑者来说，多任务多窗口的操作控制是有难度的，弄到最后屏幕一团糟，后果不可预料。

（二）、生产商的选择

正如对软件本身的评价需要多方面多角度一样，知名度不是选择生产商的唯一评价指标。

假如您固执地认为非名牌财务软件公司不予考虑的话，那么不妨拿些报刊杂志作个统计，挑广告做得最多最轰轰烈烈的一家就是了，多么简单痛快！

之所以要选择生产商，主要是为今后财务软件的升级考虑。会计制度或者其它情况发生了变化，而这时生产商能不能及时地推出新版本来适应新情况呢？万一生产商不再对该财务软件进行支持怎么办？万一生产商破产倒闭了怎么办？

上述问题不能不予考虑，但也决不能因此而草率地作出选大公司肯定不错的决定。正如我们不能拒绝看一部由无名公司拍摄的优秀影片一样，您同样不应该因为是小公司生产而拒绝使用它的优秀软件。

（三）、供应商／销售商的选择:

直接到财务软件生产商处购买财务软件的好处是用户感觉比较放心，生产商直销，售后服务自然有保障。谁都知道，财务软件的售后服务是相当重要的一个环节，服务的好坏对多数初涉会计电算化工作的单位来说是成败关键。

到财务软件供应商／销售商处购买财务软件的好处是选择比较的机会多一些。在财务软件销售商(特别是专卖店)处集中了市面上各类流行的财务软件，这样在购买的时候可以货比多家。甚至在您买了某种品牌财务软件试用后觉得不适合，仍然有免费换用其它品牌财务软件的机会。关于售后服务归属，一般来说销售商和生产商之间都有协议，您在购买的时候应该会得到明确的书面答复，防止将来供应商／销售商与生产商扯皮。

（四）、售后服务确实是您应当重视的问题

每个供应商（或生产商）在您没有购买软件之前都会信誓旦旦地保证服务没问题。而当您选择定了某个财务软件付款后，在某一天申请服务时，忽然就有了问题:或曰公司维护部没人;或曰路太远上门不便;或曰你放心我就来结果几天不见人影；更可怕的是对方业务人员跳槽后，服务自动取消了，跟公司关门没什么区别……

事实上，财务软件知名度和该财务软件的售后服务好坏并不完全成正比。这背后往往存在着这样一个奇怪的现象：用户对知名度较低的财务软件的售后服务质量评价较好！

我们大致是这样理解的：知名度低的软件处于创牌子阶段，所以对售后服务更重视些，而店大难免欺客小。

为了您将来顺利地使用财务软件进行工作，花上些时间了解供应商的售后服务情况还是值得的。最好的了解办法是找一批不在供应商开列的用户名单上的用户。

以上介绍仅供参考。总之，您在选购财务软件时应权衡再三，慎重为好。


账务系统的作用

第二章：账务系统解析

第一节：账务系统的作用

账务系统也叫总账系统，是财务软件中最基础、最核心的部分。几乎每一个使用财务软件的单位都要使用账务系统，几乎每一个财务软件应用效果好的单位都已经用好了账务系统，因此，账务系统是财务软件中最基础、最核心的部分。账务系统主要实现手工方式下会计人员所进行的填制会计凭证，登记各级各类明细账，科目汇总，登记总分类账等功能。在计算机处理方式下，会计人员完成科目等基础代码设置后，只需编制会计凭证，登记有关辅助核算资料，由系统自动登记总账、各级明细账及辅助账，并产生各类账表，自动进行期末结账，自动生成调汇凭证和汇兑损益调整表，完成有关科目的期末结转等工作。

♠咨询顾问

大多数会计电算化专家认为账务系统是整个计算机会计信息系统的中心。既是控制中心，又是传输中心。账务系统要涉及到整个会计核算与管理系统中的记账、算账、报账、预算、控制等过程，以及会计数据处理中的凭证、账簿、报表、计划指标等，因而账务系统是整个计算机会计信息系统的控制中心。其它子系统的工作必须在账务系统上进行汇总、传递，账务系统的接口好坏，将影响到其它子系统数据传递的质量好坏。因而账务系统又是整个计算机会计信息系统的传输中心。账务系统与其它子系统之间存在三种数据传输方式：（1）、各子系统的处理结果要输入账务系统。比如工资核算的工资费用计提凭证、工资发放凭证要传递给账务系统；固定资产核算的折旧凭证、增减及变动凭证要传递给账务系统。（2）、各子系统需要账务系统的基础数据。比如各子系统需要账务系统关于凭证类型、科目代码、账户发生额及余额等数据，一般来说，各子系统只能读取账务系统的数据，不能直接写账务系统的数据。（3）、报表系统需要账务系统及其它子系统的数据。总之，账务系统的品质优劣，直接影响到整个计算机会计信息系统的品质优劣。


账务系统系统初始化

第二节：系统初始化

当您新买回一个财务软件，安装完毕后，第一件需要做的事就是进行系统初始化。所谓系统初始化就是根据贵单位的实际情况，结合您购买的软件，将符合贵单位实际的数据按所使用软件的具体格式一一在财务软件中进行有效的设置，以便财务软件能按您的要求完成有关账务处理工作。系统初始化包含的工作很多，也很重要。不同品牌的软件，甚至同一品牌不同版本的软件都略有区别，在此，我们重点介绍一些关键的功能设置。

一、新建账套

在使用账务系统前，应新建账套。在新建时，要根据用户单位的业务特点，对账务系统的一些系统选项进行设置，以便账务系统配置相应的功能或执行相应的控制。账套中存放的内容包括：会计科目、记账凭证、各种账簿、会计报表资料等。在一个账套中只能保存一个单独核算单位的账务资料，但是在实际工作中您可以根据需要建立任意数量的账套文件。通过合理地组织账套文件，及时掌握各下属独立核算单位的财务状况，为加强管理和经济核算提供必要的信息。

大多数财务软件此处都提供一个建账向导帮助用户新建账套，比较重要的选项有：

♥电算专家

大多数财务软件的新建账套功能只授权予系统管理员。

账套名称：一般是使用该账套的单位名称，用于标识该账套所属的会计主体。账套名称将在输出凭证、账簿、报表等业务资料时使用，所以在此处请输入单位全称，以防混淆不清。

♥电算专家

某些财务软件的账套名称一旦设定就不允许修改，对这类财务软件用户在设置账套名称一定要使用本单位的名称全称。某些财务软件的账套名称在使用过程中是允许修改的，显然，后者比较灵活。

记账本位币：指一个单位在进行会计核算时统一使用的记账货币，其它货币都要折算为本位币。在我国一般为人民币。

账套建账期间：指用户开始使用软件处理账务数据的那一个会计期间。通俗地讲，就是用户开始输入数据的那一个年月时间。例如您想从2002年08月开始使用财务软件，账套建账期间就应该是2002年08月。

♥电算专家

某些财务软件的账套建账期间一旦设定就不允许修改，对这类财务软件用户在设置时务必想清楚才下手，因为事后想改变时只能重新建账。某些财务软件的账套建账期间在初试化结束之前允许修改，用户应选择后者。

☻脚下留神

大多数的财务软件都要求账务系统的启用期间早于或等于其它子系统的启用期间，因为账务系统无法处理其它子系统在账务系统启用之前的数据。

所属行业：指企业用户所属的行业，换句话说，就是企业用户采用哪个行业的会计制度。选择行业之后可以得到该行业由会计制度规定的预设科目和报表。

♦会计专家

我国会计制度分为企业会计制度和预算会计制度。企业会计制度是从事生产经营业务，以营利为目的的企业法人进行会计核算的规范，目前制定有13种不同的行业会计制度，还制定有股份公司会计制度。预算会计制度则是国家财政部门和行政事业单位进行会计核算的规范。目前我国的预算会计制度包括财政总预算会计制度、事业单位会计制度、行政单位会计制度。有鉴于此，财务软件也就有了企业版与行政事业版之分。企业版适用于采用企业会计制度的单位，其所属行业一般在十四个选项以上。行政事业版适用于采用预算会计制度的单位。

根据财政部颁布的最新企业会计制度及未来若干年内的企业会计制度改革精神，预计未来几年内将取消分行业的会计制度，代之以统一的会计制度。同时考虑到特定小规模企业和金融保险企业的特点，未来会计制度将分成三类。即大多数企事业单位适用的统一的企业会计制度；特定小规模企业适用的会计制度和和金融保险企业适用的会计制度。

☻脚下留神

某些财务软件的所属行业选项多于十四个，是因为这些财务软件进一步细化了企业分类。其实，多于十四种的意义并不大。更值得注意的是某些财务软件提供了一个“不设置行业” 选项，此选项的作用在于不取预设科目和报表，让用户自定义科目和报表。另外，与“不设置行业” 选项配套使用的还有“一级科目长度” 选项。此选项允许用户单位自定义一级科目长度。此功能有一定的实用价值。按照会计制度的规定一级科目的长度只能为三位或四位，当用户单位确实不属于十四个行业选项时，该类财务软件给了用户一个比较灵活的选择。

科目模式：指会计科目的级别以及各级长度的确定。

♥电算专家

科目模式的设置应综合考虑各方面的因素，既要便于操作又要为今后的发展留有余地。因为一旦新建账套完成，所设定项目均无法再做任何修改。某些财务软件提供有一些科目模式变动工具，用户单位可以根据自身的需要参照使用。

♠咨询顾问

目前市场上流行的财务软件科目代码模式可分成两大类：固定型科目代码模式和灵活型科目代码模式。

所谓固定型科目代码模式是指一旦设定软件系统就不允许随意修改，比如：某企业将科目代码模式设置为３２４３就意味着该企业所使用的财务软件的科目体系一级科目代码长度为三位，二级科目代码长度为二位，三级科目代码长度为四位，四级科目代码长度为三位。企业一旦设定，整个软件系统的科目代码都要遵循相同的模式，且最低级明细科目级数为四，级长为三位。目前市场上流行的大多数财务软件都是采用这种科目代码模式。

所谓灵活型科目代码模式是指财务软件中并没有对科目代码模式作统一的规定，系统只规定相同父科目的明细科目级长一致，而不同父科目的明细科目级长可以不同。例如：１０２１表示银行存款－工行，１１３０００１表示应收账款－甲单位，这就意味着该企业银行存款的科目代码模式为３１（即一级科目代码长度为三位，二级科目代码长度为一位，且银行存款最低级明细科目级数为二），而应收账款的科目代码模式为３４（即一级科目代码长度为三位，二级科目代码长度为四位，且应收账款最低级明细科目级数为二）。

固定型科目代码模式和灵活型科目代码模式各有其利弊和适应场合。 固定型科目代码模式简单、统一，用户容易理解和接受，故大多数财务软件都采用这种模式。但这种模式“钢性”太大，如遇上文提及的某企业用１０２１表示银行存款－工行，１１３０００１表示应收账款－甲单位，由于其开户行少，所以银行存款二级科目代码用一位足够表示，而往来客户多，应收账款二级科目代码用四位才够表示。使用固定型科目代码模式，该企业就必须通盘考虑或采用折中方法使得银行存款二级科目代码不因用四位而浪费位数，应收账款二级科目代码不因用一位而不够位数表示。（在实际工作中这种情况是普遍存在的）。灵活型科目代码模式顾名思义是一种比较灵活的方式，它可以较好地解决上述问题，应该说它更能适应和方便实际工作。但由于大多数财务会计人员对编码缺乏认识和其它方面的原因，采用这种科目代码模式的财务软件市场上寥寥无几。

其实从本质上讲，灵活型科目代码模式可以包含固定型科目代码模式，是一种比较理想的科目代码模式。

建账按钮：指当一切选项设置完毕，按此按钮系统即自行建账。

二、凭证字设置与控制

凭证字设置：凭证字又叫凭证类别，用户单位为了对记账凭证进行分类管理，一般对记账凭证进行分类编制，但各单位的分类方法不尽相同，所以财务软件要提供凭证类别设置功能，用户单位可以按照本单位的需要对凭证进行分类设置。财务软件在进行凭证类别设置，系统一般提供如下几种常用分类方式供选择：

（1）记账凭证

（2）收款、付款、转账凭证

（3）现金、银行、转账凭证

（4）现金收款、现金付款、银行收款、银行付款、转账凭证

（5）自定义凭证类别

如果贵单位所使用的凭证分类不属于以上（1）至（4），选项，那么请选择（5），凭证类别完全由用户自行设置。

♥电算专家

某些类别的凭证在制单时可以对科目有一定限制，这种控制就叫凭证合法性控制。大多数财务软件一般提供以下限制类型供选择：

（1）、借方必有：指定该类凭证借方必须存在的科目。如：收款类凭证借方必有的科目可定义为“现金”、“银行存款”等，在录入收款类凭证时，系统就会检查凭证中借方科目是否存在“现金”或“银行存款”科目，如不存在则该凭证不能保存。

（2）、贷方必有：指定该类凭证贷方必须存在的科目。如：付款类凭证可定义为“现金”、“银行存款”等。

（3）、借方必无：指定该类凭证借方必须不能出现的科目。

（4）、贷方必无：指定该类凭证贷方必须不能出现的科目。

（5）、凭证必有：指定该类凭证的借方或贷方必须存在的科目。如：银行类凭证可指定为“银行存款”科目，即表示该类凭证的借方或是贷方必须存在“银行存款”科目。

（6）、凭证必无：指定该类凭证的借方和贷方都必须不能出现的科目。如：转账类凭证可指定为“现金” 、“银行存款”科目，即表示该类凭证的借方和贷方不能存在“现金” 、“银行存款”科目。

（7）、无限制：制单时，此类凭证可使用所有合法的科目。

☻脚下留神

已使用的凭证类别不能删除，大多数软件还不允许修改类别字。

对于凭证合法性控制的使用要特别小心。凭证合法性控制的目的是为了加强凭证编制过程中的会计监控，提高凭证编制的质量，但是，由于凭证合法性控制的使用存在一定的难度，设置不当往往会犯画蛇添足的错误。如果您不太清楚凭证合法性控制的使用方法，您面临的选择只有两个：要么不进行凭证合法性控制的设置，要么咨询有关人士完全搞清楚后再设置，千万切忌似懂非懂地进行凭证合法性控制设置。

另外，有些软件对凭证类别的操作权限进行查询、修改、使用的控制。

♥电算专家

所谓凭证类别操作权限控制就是对什么操作员具备什么凭证类别的查询、修改、使用权限进行控制。应该说凭证类别操作权限控制对于财务分工比较明细的企业可以起到加强财务分工控制的作用。对于会计人数不多的企业意义不大。

三、凭证控制

凭证编号控制：凭证编号控制主要包括两层控制。第一，凭证制单时，凭证是否自动连续编号。当系统设置的凭证编号方式为自动连续编号时，连续制作凭证时凭证编号由系统自动取一个最小的凭证空号。当系统参数设置的凭证编号方式为非自动连续编号时，凭证编号由系统自动取上一凭证的凭证号加1，用户可以修改凭证号。第二，凭证记账时，凭证号是否必须连续。如果选中该选项则在凭证记账时会要求凭证号连续。

♥电算专家

凭证编号控制主要解决凭证填制过程中的凭证编号连续性控制问题，按照会计原理的要求，记账凭证的凭证编号必须连续，不允许出现“断号”现象。优秀的财务软件对于凭证编号连续性的控制比较灵活。这主要包含四层意思：在填制记账凭证的过程中系统缺省控制凭证编号的连续性，但允许修改，不硬性强求凭证编号的连续性；凭证审核后，凭证编号不再允许修改；凭证记账时如果发现存在不连续的记账凭证，系统给予断号凭证提示；月末结账时，严格检查凭证编号的连续性，如果没有断号凭证，系统允许结账，否则，系统生成断号凭证表，不允许结账。

审核与记账是否合并控制：如果选择该选项则凭证记账审核可合并为一个步骤，记账前不需要先审核，否则记账前必需先审核。

♥电算专家

记账凭证处理存在一个“三步曲”，填制、审核、记账。一张凭证填制完毕后，必须经过审核，只有审核无误的凭证才可以记账。从量上看，凡是经过审核的凭证，都要记账；凡是要记账的凭证，都要经过审核。两者是完全相等的。因此，可以将审核与记账合并，将整个记账三步曲合成两步完成。就好象跳交际舞的“快三”一样，踩着三步的点子实际上只跳两步。这种处理方式可以看成是会计电算化有别于手工会计操作的特色或者进步。

制单人与审核人是否允许相同控制：如果选择该选项则制单人与审核人可以相同，否则凭证制单人与审核人必为不同人。

♥电算专家

按照会计原理的严格规定，凭证的制单人与审核人必须为不同的人，这样规定主要是为了加强对凭证正确性、合法性的监控。会计电算化后，凭证的正确性控制已经完全地交给了系统，合法性控制也部分地交给了系统。这样一来，传统会计的这条规定就可以淡化处理了。

出纳签章控制：如果选择该选项则含有现金、银行存款科目的凭证必须由出纳人员通过【出纳签章】功能对其核对签字后才能记账。

资金及往来赤字控制：如果选择该选项则在制单时，当现金、银行存款科目的最新余额出现负数时，系统将予以提示。

可以使用其他系统受控科目：若某科目为其他系统的受控科目（如：客户往来科目为应收、应付系统的受控科目），一般说来，为了防止重复制单，应只允许其受控系统来使用该科目进行制单，总账系统是不能使用此科目进行制单的，但如果您希望在总账系统中也能使用这些科目填制凭证，则应选择此项。

允许修改他人填制的凭证：如果选择该选项则在制单时可修改别人填制的凭证，否则不能修改。

♥电算专家

按照会计原理的规定，凭证的修改只能由原制单人进行。会计电算化后，一般情况下面我们都应该遵循这条规定。但是，我们知道，会计电算化大大提高了会计工作的速度，也为局部改变会计工作的某些传统习惯提供了可能。“发现错误，马上修改”与“发现错误，责成修改”应该选择哪条规则主要看用户单位的具体情况和规章制度而定。因此，优秀的财务软件一般提供允许修改他人填制的凭证复选框控制。

凭证正确性控制：凭证正确性控制主要解决凭证填制过程中对凭证内容的完整性及合理性的基本控制。主要包括以下方面的控制：

日期：必须非空, 必须是合法的公历日期, 在指定账套、会计年度的起止日期之内, 在指定账套的启用时间之后, 日期所对应的会计月份未结账。

☻脚下留神

一般来说，凭证填制日期必须是本记账会计期间和本记账会计期间之后的合法的公历日期，不能是本会计期间之前的日期。好的财务软件可以跨月度、跨年度输入记账凭证。

凭证类别字：必须非空, 必须是已在【凭证类别设置】中定义的类别。

摘要：必须非空。

科目编码：分录行中的科目编码必须非空, 必须是已在【会计科目设置】中定义, 必须为最低级明细科目编码。

每张凭证借贷合计相等：凭证保存时借贷双方发生额合计必须相等。

♥电算专家

每张凭证借贷合计相等是符合“有借必有贷，借贷必相等”这条会计原理的记账规则要求的。在财务软件中对于处于“待审”状态的记账凭证确实应该符合“有借必有贷，借贷必相等”的要求。我们知道使用财务软件的基本要求是借助电脑凭证处理的辅助功能在电脑上直接、快速、准确地填制凭证。而不是先手工填制凭证，再将手工填制好的凭证输入电脑。在手工填制凭证时，凭证的填制过程可以由人灵活控制，比如：一张凭证填制到一半，发现附件不全，暂停下来，等附件齐了接着填，一张凭证填制的时间跨度超过一两天的情况是有可能发生的。但是，在电脑上直接填制凭证时是不可能允许出现一张凭证填制的时间跨度超过一两天的。因此在电脑上凭证的状态可以分成以下四种：未完、待审、已审、记账，它们都是由系统自动判断后生成的。其中未完凭证是指借贷不平或凭证分录内容没有输入完全的凭证。未完凭证须成为待审凭证才能进行审核；待审凭证是指借贷相平、每一笔分录已经录入科目、有摘要等，可审核登账的完整的凭证；已审凭证是指已经审核后不能直接修改的凭证，可以直接记账的凭证；记账凭证是指标识该凭证已经记账，原则上是不能再修改的凭证。

☻脚下留神

目前，大多数财务软件的凭证状态只支持待审、已审、记账三种，同时支持四种的不多。用户选择软件时对此项功能不妨留意一下。

凭证套打控制：选择该选项则凭证打印时可按事先设置好的格式、在事先印刷好的凭证打印纸上快速地进行凭证的打印。

☻脚下留神

凭证套打的实现主要包括两方面的内容：第一，设置凭证的输出格式，按设置的凭证格式印刷凭证打印纸。第二，设置凭证套打选项。几乎每家财务软件公司都提供由财政部门监制的本公司统一的凭证套打纸，对于用户单位来说，最简单的方法是选择由软件公司提供的统一格式的凭证套打纸。但是，如果本单位对记账凭证的格式有特殊的要求，并且记账凭证的输出量比较大。就有必要考虑自行设计印刷凭证套打纸。

超出计划数报警控制：选择该选项，如果录入了科目计划或录入了项目计划，则当科目实际发生数或项目实际发生数超过计划数，系统会自动报警。

♦会计专家

管理会计的预算控制，预算编制、控制（对不同的费用预算采用不同的控制方法）与分析，可以借助财务软件的计划/预算编制机制、超出计划数报警控制机制、生成计划/预算报告表机制、编制包含计划/预算的内部管理报表等机制实现。

以上是凭证控制中一些比较重要的控制内容，不同的财务软件在凭证控制中还含有其它更多的控制内容。用户单位要结合自身的实际情况灵活配置。一般来说，大多数的控制参数都是可以在运用过程中随时调整的。

四、科目设置与控制

科目设置与控制主要完成科目的增加、删除、修改以及有关科目是否设置数量核算、是否设置外币核算、是否设置其它辅助核算等控制。科目设置与控制比较重要的选项有：

科目代码：对会计科目进行代码化管理是会计电算化的必然结果。也是任何计算机管理信息系统的基本特征。科目代码不允许重复。

科目名称：即会计科目的名称。财务软件一般不允许科目名称重复。当出现科目名称重复时，软件应给予提示，但不应阻止。因为科目名称重复有一定的合理性。

♥电算专家

财务软件对科目名称的命名方式一般可以分成两类。 一类称为前缀命名法，就是指给每一级科目命名的时候必须将其所有上级科目的科目名称一并写上；另一类称为独立命名法，就是指给每一级科目命名的时候只须给本级科目命名。采用前缀命名法时，科目名称重复的可能性几乎为零；而采用的独立命名法时，出现科目名称重复的概率就比较大。现代大多数主流财务软件都是采用的独立命名法，因为这样既可节省输入数据的工作量，又可节省计算机存储空间。

外币核算：如果贵单位存在外币业务，就要进行外币核算的设置。在进行外币设置之前，一定要先进行外币种类的设置。外币核算设置一般包括以下选项：

不核算外币单选按钮：选择该选项表示本科目不进行外币核算，只核算本位币。

核算所有外币单选按钮：选择该选项表示本科目对本账套中设定的所有货币进行核算。在处理到该科目时系统一般默认核算本位币，用户可以选择其它币种进行核算。

核算单一外币单选按钮：选择该选项表示本科目只对本账套中某一种外币进行核算。若选择核算单一外币，要求选择一种进行核算的外币的名称。

期末调汇复选框：若进行外币核算，确定是否在期末进行汇率调整。如选择期末调汇则在期末执行“期末调汇”功能时对此科目进行调汇。

数量核算：选择该选项表示本科目需要进行数量金额式核算，则要选定“数量金额核算”的复选框，且要输入相应的计量单位。

科目操作权限控制：有相当一部分财务软件对科目的查询、使用、修改、增加等权限进行了管理。只有经过授权的操作员才能对相关的科目具备相应的权利。这种控制对会计人员多的企业起到了一定的控制作用。而对于会计人员不多的企业在使用时一定要谨慎。

☻脚下留神

建议不论会计人员多少的企业在初次使用科目操作权限控制时应尽量放开控制，待使用软件比较熟练之后，再结合本企业的实际管理需要进行设置。

科目维护约束控制：科目维护约束条件主要是指科目删除与科目修改的有关控制。目前财务软件一般都规定当本期该科目余额不为零或本年有发生额时，该科目不允许删除；换句话说，只有当该科目当前余额为零并且本年累计借、贷方发生额均为零时，该科目允许删除。规定科目代码一旦定义就不允许修改。

五、辅助核算项目设置、控制与维护

目前财务软件的辅助核算项目可以分为单辅助核项目和多辅助核算项目两种。不论哪一种辅助核算项目我们都可以把它看成是会计科目的延伸，与设置明细科目相比它更具灵活性和便利性。因为选择一个辅助核算项目则此辅助核算项目下设置的所有核算项目都可参与该科目的核算。因此，我们可以将本单位具有相同属性的一些会计要素定义为某一辅助核算项目加以统一管理。比如不同费用账户下存在相同的部门设置，这时我们就可以将部门设置为一种辅助核算项目，将部门统一编码，然后，将需要进行分部门核算的费用账户设置为进行部门辅助核算，这样就可以让它们共享部门分类的统一编码了。当然，辅助核算项目的作用还不止如此。更重要的是辅助核算项目还能提供比按账户方式组账生成的账簿更多、更丰富、更全面的辅助账（或称业务台账）。

（一）、单辅助核算项目

目前，大多数的财务软件都支持以下形式的单辅助核算项目：

１． 部门核算：

设置某科目为部门核算，表示在凭证录入时科目的发生额都要明确是哪个部门的发生额；同时除了可以按科目生成的各类账簿外，还可以按部门生成的各类辅助账簿；除了可以进行按科目的预算管理外，还可以进行按部门的预算管理。

♥电算专家

部门核算是一种值得大力提倡的辅助核算形式，他比通过科目代码进行分部门的管理与核算要方便得多、功能强大得多。各位不妨一试。

２． 职工核算：

设置某科目为职工核算，表示在凭证录入时科目的发生额都要明确是哪个职工的发生额；同时除了可以按科目生成的各类账簿外，还可以按职工生成的各类辅助账簿；除了可以进行按科目的预算管理外，还可以进行按职工的预算管理。

♥电算专家

由于一个单位参与账务核算的职员毕竟是少数，为了减少数据初始化（或账务处理）时职员参与辅助核算所带来的设置困难，建议避免使用职员参与会计科目的辅助核算，可以使用新建核算项目类别，诸如“单位业务员、应收/付款职员”等类型。

３． 往来单位核算：

设置某科目为往来单位核算，表示在凭证录入时科目的发生额都要明确是哪个往来单位的发生额；同时除了可以按科目生成的各类账簿外，还可以按往来单位生成的各类辅助账簿；除了可以进行按科目的预算管理外，还可以进行按往来单位的预算管理。

４． 往来业务核算：

此选项是在选中往来单位核算后的一个可以附加的选项。设置某科目为往来业务核算，表示在凭证录入时科目的发生额都要明确是哪个往来单位的哪一笔往来业务的发生额；选择该选项将影响到“往来业务初始化”、“往来业务对账单”和“账龄分析表”。

♥电算专家

会计上由于购销业务产生的往来业务主要涉及到应收账款、预收账款、应付账款、预付账款四个账户。

５． 自定义核算项目核算：

当以上几种核算项目都不能满足要求时，就可以考虑采用自定义核算项目。所谓自定义核算项目就是用户可以根据本企业的需要定义辅助核算项目。比如：一个商业企业非常注重按合同进行业务活动，其收入和开支要按合同分类核算，此时就可以增设一个合同辅助核算项目，并且合同的描述要素也可以自定义；一个工业企业需要粗略地按产品、按成本中心进行费用的归集及收入的分类核算，此时就可以分别增设一个产品、一个成本中心辅助核算项目；一个施工企业非常注重工程项目的管理，要求按工程项目核算所有的开支和收入，此时就可以增设一个工程辅助核算项目，并且工程的描述要素也可以自定义。

♥电算专家

自定义核算项目给用户带来了比较大的自由空间，用户可以充分地利用辅助核算项目这种核算与管理机制对本企业某些管理要素进行核算与管理。

（二）、多辅助核算项目

多辅助核算项目主要是满足用户对某些会计科目使用单辅助核算项目还不够的情况下，必须使用多辅助核算项目，从多方面多角度对该会计科目进行辅助明细核算与台账管理。

１．会计科目多辅助核算项目的设置：

一般来说，选择多辅助核算项目核算时，可同时选择“部门”、“职员”、“往来单位”、“往来业务”、“自定义核算项目”五个项目中的任意两个至任意五个选项。比如： 113（应收账款）、203（应付账款）、501（销售收入）可以设置成多辅助核算项目，其它往来、成本类科目也可根据实际需要设置。

比如：应收账款113设置为“部门、往来单位、职员”多核算项目后，录入凭证时，用户在使用113会计科目时，必须输入部门、往来单位、职员等内容，保存凭证并登账后，您就可在辅助核算账簿中得到各种单个或交叉的辅助核算台账。会计科目是否有必要设置成多辅助核算项目必须在系统初始化时事前确定规划好。如果在初始化结束后，对已经发生业务的会计科目再要求修改成多辅助核算项目属性，就比较麻烦了。某些财务软件提供了以下方法帮助用户解决这个问题：

方法一：删除相关业务资料，反过账或反结账或重新初始化，再修改会计科目属性。

方法二：将该科目余额调整为0。需要注意的是，对关系到该科目以前的业务资料不可删除，否则系统将出现不可预料的错误。

２．多辅助核算项目科目在凭证中的处理：

在凭证增加或修改时，如果会计科目为多辅助核算项目，录入时必须输入每个辅助核算项目的发生额并且个个辅助核算项目发生额的合计数必须相等。财务软件的凭证处理界面一般弹出一个多核算项目窗口方便录入。

３．多辅助核算项目科目初始化数据：

参考七、期初数据录入及试算平衡之３．辅助核算项目类之３．６．多辅助核算项目。

（三）、核算项目的维护

所有辅助核算项目中，本年无业务发生的项目可以删除；本年有业务发生但余额为零的项目可以删除，删除后可以恢复；本年有业务发生但余额不为零的项目，不能删除。

（四）、辅助核算项目账簿体系

辅助核算作为科目的一种延伸，一方面可以减轻科目体系无限扩展与难以维护的压力，另一方面提供有别于标准会计账户的组账方式用于统计分析有关业务数据。目前财务软件辅助核算的账簿体系一般提供以下形式的组账形式：

１．辅助核算总账：

２．辅助核算明细账：

３．辅助核算余额表：

４．自定义综合账：

５．往来对账单：

６．账龄分析表：

７．辅助核算分析：

以上七项详情请参见第四节：会计账簿中有关辅助核算账簿内容。

♠咨询顾问

辅助核算是管理型财务软件的一大特色，也是使用过程中的一大难点。之所以如此，是因为辅助核算项目并非是万能的，并且目前财务软件的辅助核算项目功能还处在不断完善发展之中。如果用户希望通过辅助核算功能完成比较复杂的会计对业务的监督管理工作，还不如使用纯粹的业务管理软件来得得心应手。因此，用户在使用辅助核算项目功能时千万不要对其期望过高。

六、其它基础信息设置与控制

币别设置：如果本单位存在外币业务，就必须进行币别的设置和维护。币别设置比较简单，主要包括币种代码、币种名称、年初汇率、期初汇率、计算方法等进行设置。凡存在外币业务的企业必存在期末调汇工作。有关期末调汇工作，由于大多数财务软件都将它放在期末处理中，因此我们在期末处理中讲解。

♦会计专家

上文提到的计算方法主要影响在凭证处理及其它涉及与汇率有关的计算时，汇率采用直接标价法还是间接标价法表示。比如：计算方法乘号（*）表示外币金额*汇率=折本位币金额，计算方法除号（/）表示外币金额/汇率=折本位币金额。当计算方法选择乘号（*）时，在凭证处理中输入的汇率应该是采用直接标价法的汇率；反之，当计算方法选择乘号（/）时，在凭证处理中输入的汇率应该是采用间接标价法的汇率。

结算方式设置：任何一个企事业单位都要通过银行进行款项的收付业务。结算方式是指本单位可以通过哪些银行结算方式与外界进行业务往来。比如通常使用的三票（支票、汇票、本票）、一卡（信用卡）、三方式（汇兑、委托收款、托收承付）以及信用证等都是经常使用结算方式。用户单位要使用哪些结算方式就必须进行结算方式的设置与维护。结算方式设置比较简单，主要包括代码、名称两项内容。结算方式设置的目的主要是连接账务系统与出纳系统，完成会计银行存款账与出纳银行存款日记账的稽核、银行存款余额调节表的编制。换句话说，如果用户单位不准备使用出纳系统、不准备使用电脑进行银行存款余额调节表的编制就可以不进行结算方式设置工作。

会计期间设置：会计期间是为适应企业会计核算管理的要求，根据不同情况人为划定的会计分期，不同的会计主体可能有不同的会计期间划分。

♦会计专家

在《企业会计准则》中，规定我国企业的会计期间按年度划分，以公历年度为一个会计年度，即从每年1月1日至12月31日为一个会计年度。软件中一般以公历年度作为默认值。

七、期初数据录入及试算平衡

系统初始化的最后一步工作是将所有科目的余额及发生额录入电脑并试算平衡。涉及的主要项目包括：

１．余额类：

如果用户是年初建账，则只要录入每个科目年初余额；如果是年中建账，则只要录入建账月的月初余额。目前大多数财务软件只要求录入最低级明细科目的余额。

１．１．本位币余额：

对于所有账户都要录入本位币账户的最低级明细科目的年初余额（年初建账）或月初余额（年中建账）。

１．２．外币余额：

对于外币类账户除了录入本位币余额外，还要录入原币余额以及汇率（或者录入原币余额及汇率后自动计算本位币余额，但本位币余额允许修改）。并且要求满足原币余额*汇率（采用直接标价法）=本位币余额或者原币余额/汇率（采用间接标价法）=本位币余额的恒等关系。当然，在此也只要求录入外币类账户的最低级明细科目的年初余额（年初建账）或月初余额（年中建账）及其汇率。

１．３．数量余额：

对于数量金额类账户除了录入本位币／外币余额外，还要录入计量单位、数量及单价（或者录入数量及单价后自动计算金额，但金额允许修改；或者录入数量及金额后自动计算单价，但单价允许修改）。并且要求满足数量*单价=金额的恒等关系。同样，在此也只要求录入数量金额类账户的最低级明细科目的年初数量（年初建账）或月初数量（年中建账）及其计量单位与单价。

１．４．综合本位币余额：

综合本位币余额是财务软件将输入的各个币种的余额折合本位币汇总后的余额，并且财务软件进行试算平衡的余额采用的是综合本位币余额。

２．发生额类：

如果用户是年初建账，则不需录入发生额；如果是年中建账，用户不需要报表系统生成年度报表，则也不需要录入发生额；如果是年中建账，用户又需要报表系统生成年度报表，则一定要录入每个科目的从年初到建账月的借方累计发生额和贷方累计发生额（另外，如果是年中建账，用户还需要报表系统生成季度报表，则还要录入分季度的借方累计发生额和贷方累计发生额）。目前大多数财务软件只要求录入最低级明细科目的发生额。

２．１．本位币发生额：

对于需要录入发生额的所有账户都要录入本位币账户的最低级明细科目的借方累计发生额和贷方累计发生额。

２．２．外币发生额：

对于需要录入发生额的外币类账户除了录入本位币发生额外，还要录入最低级明细科目的原币借方累计发生额和原币贷方累计发生额。

２．３．数量发生额：

对于数量金额类账户除了录入本位币／外币发生额外，还要录入最低级明细科目的累计收入数量和累计发出数量。

３．辅助核算项目类：

３．１．部门辅助核算：

对于设置成部门辅助核算的账户要求录入各部门的期初余额、借方累计发生额及贷方累计发生额。

３．２．职工辅助核算：

对于设置成职工辅助核算的账户要求录入各职工的期初余额、借方累计发生额及贷方累计发生额。

３．３．往来单位辅助核算：

对于设置成往来单位辅助核算的账户要求录入各往来单位的期初余额、借方累计发生额及贷方累计发生额。

３．４．往来业务辅助核算：

往来业务辅助核算是在选中往来单位核算后的一个可以附加的选项。设置某科目为往来业务核算，要求录入各往来单位期初的每一笔业务的业务编号、发生日期、摘要、币别、发生额以及包括当前发生额在内的当前余额等项目。以便对每笔业务进行监控管理。

３．５．自定义辅助核算项目：

对于设置成自定义辅助核算项目的账户要求录入各自定义辅助核算项目的期初余额、借方累计发生额及贷方累计发生额。

３．６．多辅助核算项目：

由于多辅助核算项目设置的目的是为了从多角度对该会计科目进行辅助明细核算与台账管理。因此，在系统初始化时，对多辅助核算项目科目录入，必须满足一定的恒等关系。比如：应收账款113设置为“部门、往来单位、职员”多核算项目后，113应收账款及各辅助核算项目的科目余额、累计借方、累计贷方都必须存在以下恒等关系式：

【113】= 【113-部门】= 【113-往来单位】= 【113-职员】

♥电算专家

目前市面上流行的财务软件多辅助核算项目的功能大都存在一定的局限性，用户在使用多辅助核算项目功能时千万不要对其期望太高。

４．余额与发生额的关系：

对于资产类账户存在年初余额＝月初余额+本年累计借方发生额－本年累计贷方发生额；对于负债类、所有者权益类账户存在年初余额＝月初余额+本年累计贷方发生额－本年累计借方发生额。

☻脚下留神

综合本位币试算平衡是结束初始化的必要条件，在我们真正结束初始化前还必须考虑其它因素。第一：资产、负债、所有者权益的合计数是否与软件系统使用前相一致；第二：科目体系是否完整，是否符合本企业的财务核算与管理的要求，比如各科目的级数与级长是否好用、够用；第三：辅助核算项目体系是否完善，是否既能与其它业务系统有效衔接，又能满足财务管理的需求；第四：使用的财务软件是否支持重新初始化，如果不支持一定记得在结束初始化时备份数据。应该说，许多企业初始化工作都不是一次成功的。是否能一次成功视乎用户单位的财务核算复杂性；用户单位会计人员对财务软件应用的熟悉程度，特别是正在使用的财务软件应用的熟悉程度；财务软件供应商的技术支持力度等多方面因素的综合作用。如果未能一次成功，也不是一件有失体面的事。还有的用户在使用了一段时间之后，为了能更好地使用财务软件会自行重新初始化。


凭证处理

第三节：凭证处理

图2.1记账凭证界面

凭证处理是账务系统使用频率最高的部分。主要包括：凭证填制、辅助工具（计算器、自动置平、摘要维护、科目维护、辅助代码维护）、审核与记账、凭证模板、凭证批处理（记账、打印、汇总）、记账凭证分录序时簿（凭证处理集成环境）等功能模块。

一、凭证填制

凭证填制主要是指将手工已编制好的记账凭证输入系统或根据原始凭证直接在系统内制作记账凭证，同时可对输入的记账凭证进行修改、删除、打印、查找等操作。其处理的内容主要包括凭证头与凭证体两部分：

１．凭证头主要组成项目：

１．１．日期（年、月、日）：每张凭证的填制时间。该日期可以不同于当前会计期间的日期，但必须大于或等于账务系统当前会计期间。

１．２．凭证类型：从已设置好的凭证类型中选择输入。

１．３．凭证号：凭证的编号。此项目受凭证编号控制设置影响。具体情况请参见凭证编号控制。

１．４．附件：输入实际的凭证附件张数。

１．５．制单：用户以某一个已设好的用户编码登录系统，新增或修改凭证时，财务软件一般自动填入该用户编码对应的姓名于制单栏。

１．６．审核：用户以某一个已设好的用户编码登录系统，对凭证进行审核操作时，审核一栏由系统自动填入该用户编码对应的姓名。

１．７．出纳：用户以出纳的身份登录系统，对凭证进行审核时，出纳一栏由系统自动填入该用户编码对应的姓名。

１．８．记账：记录对该凭证进行登账处理的用户姓名。

１．９．状态：记录凭证的当前状态。

♥电算专家

目前大多数财务软件的凭证状态可以分四类：未完、待审、已审、记账，它们都是由系统自动判断后生成的。未完凭证：是指借贷不平或凭证分录内容没有输入完全的凭证。未完凭证须成为待审凭证才能进行审核。待审凭证：是指借贷相平、每一笔分录已经录入科目、有摘要等，可审核登账的完整的凭证。已审凭证：是指已经审核后不能直接修改的凭证，可以直接记账的凭证。记账凭证：是指标识该凭证已经记账是不能修改的凭证。

２．凭证体主要组成项目：

２．１．摘要：字符类型不限，字符个数不限，且不能为空。如果您已设置了摘要代码和摘要内容，在“摘要”栏可直接输入相应的摘要代码即可显示摘要内容。如果不记得摘要代码，则可以单击“摘要”栏中光标所在行中的命令按钮进入摘要代码名称对照表，选择您需要的摘要内容，您也可以增加或删除摘要内容，直到您找到您需要的摘要，单击“确定”按钮，确定选择并退出。

☻脚下留神

大多数财务软件的摘要长度是受限的。

２．２．会计科目：根据经济业务录入对应的预先设置好的会计科目。会计科目的录入方法有多种。归纳大多数财务软件凭证填制处会计科目的录入方法大致有以下几种：

２．２．１．科目代码录入法：其一是直接录入最低级明细科目科目代码；其二是录入非最低级明细科目科目代码，系统一般会弹出一个包含该非最低级明细科目科目代码的所有最低级明细科目科目代码表让用户选择。

２．２．２．科目别名录入法：如果在科目代码中设置了科目别名，在“会计科目”栏可直接输入相应的科目别名即可显示会计科目。

２．２．３．科目名称录入法：其一是直接录入科目名称，它支持一级到多级；其二是输入科目名称的某一个汉字或一部分汉字然后按回车键，系统将弹出包含所输入汉字的所有明细科目，您可以从中选择需要的科目。

２．２．４．临时增加录入法：对于不存在的会计科目，系统一般提供即时增加会计科目，即刻使用的方式。操作方式大致如下：单击“会计科目”栏中光标所在行中的命令按钮进入会计科目代码名称对照表维护窗口，用户在此可以进行全方位的科目代码维护工作。如增、删、改、选中会计科目等工作。

２．２．５．借方金额、贷方金额：输入实际发生的借方发生额或贷方发生额。此处财务软件一般都提供“计算器”辅助工具。

２．２．６．合计、大写金额：由系统自动计算填入。

２．２．７．汇率、原币金额：如果输入的会计科目设置了外币核算，那么当该会计科目输入后汇率、原币金额项目就会被激活并允许且要求输入。

２．２．８．辅助核算项目代码：如果输入的会计科目设置了辅助核算项目例如往来、部门、职工、自定义项目等，那么当该会计科目输入后相应的输入项目就会被激活并要求输入。

２．２．９．业务编号：如果输入的会计科目设置了往来业务核算，那么当该会计科目输入后业务编号项目就会被激活并允许且要求输入。

２．２．１０．数量、单价：如果输入的会计科目设置了数量金额核算，那么当该会计科目输入后，数量、单价项目就会被激活并允许且要求输入。

２．２．１１．结算类型、结算号：如果在“账套参数”的“凭证”项中设置了“录入银行结算单号”，那么当您录入102银行存款的明细科目时，结算类型、结算号就会被激活并允许输入，但可以不输入。

二、辅助工具

在凭证的填制过程中，为了提高凭证的填制速度和准确性，财务软件都提供有若干辅助工具用于帮助用户既快速又准确地完成凭证的填制工作。这些辅助工具一般包括以下类别：

１．计算器：在日常财会工作中，经常要用到计算器。为了方便用户计算，财务软件一般在有可能使用到计算器的位置都提供了计算器功能。有些财务软件的计算器功能非常强大，比如提供税率设置、提供舍位设置等高级功能。并且还提供了计算结果回填功能。

♥电算专家

计算器回填功能就是首先将光标定位于要填入计算结果的单元内，调用计算器进行计算，系统就可将计算器的计算结果直接填入预先定位的单元内。财务软件中设有计算器回填功能的位置一般分布在以下几处：（一）、凭证录入处：在凭证录入窗口，有关金额及数量、单价的地方均能回填计算器的结果。（二）、初始数据录入处：在初始数据录入窗口，凡是能填入金额的单元均能回填计算结果。（三）、预算数据录入处：在科目及核算项目的预算数据录入窗口中，凡能修改的地方均可回填。（四）、固定资产录入处：在固定资产录入（变动）窗口，凡录入金额的地方，均可回填。（五）、工资数据录入处：在工资数据录入窗口，所有为数字型的工资项目，均可用计算器回填功能填入计算结果。（六）、报表单元格录入处：在报表编辑窗口，所有单元格，均可回填。

２．自动置平：“有借必有贷，借贷必相等”这是填制记账凭证的基本要求。财务软件在填制凭证处一般都提供有一个让凭证满足“有借必有贷，借贷必相等”基本记账规则要求的按钮。单击该按钮，可使光标所在分录行的金额由系统自动填入一个金额，该金额与其他分录行的金额满足记账规则的要求，使得该凭证平衡。

♥电算专家

严格地说自动置平可以分为自动借方置平、自动贷方置平和自动判断借贷方置平，但财务软件中一般只对应一个按钮。当光标在借方栏时，自动填入一个金额到借方，此为自动借方置平；当光标在贷方栏时，自动填入一个金额到贷方，此为自动贷方置平；不论光标在借方栏还是贷方栏，按与其它分录金额的借贷之和相等、方向相反的方式自动填入一个金额到借方栏或贷方栏，此为自动判断借贷方置平。

☻脚下留神

遗憾的是同时具备三种置平功能的财务软件太少了。

３．凭证正确性校验：是指记账凭证填制过程中必须满足的最基本的要求，或者说是凭证填制的语法规定。比如：哪些项目是必录域、哪些是项目录入必须满足的权限性或存在性要求。归纳起来大概有以下几个方面的内容：

３．１．凭证第一分录摘要不允许为空。如果为空，系统就应该提示“凭证第一条分录无摘要！”。

３．２．记账凭证的日期不允许为空，也不允许在账务当前会计期间之前（只允许填制当前会计期间及以后的凭证）。

３．３．相同凭证字的凭证号不允许重号。

３．４．不允许录入不存在的科目、不允许录入非最低级明细科目。

３．５．不允许当前操作员录入无权限使用的科目。

３．６．如果启用了某些业务系统，而且选中了业务由业务系统核算选项，在账务系统的凭证填制中就不允许使用相关的科目。比如：已经使用往来核算业务系统进行往来核算与管理，就不能在凭证填制中直接使用往来类科目（如：应收账款、应付账款、预收账款、预付账款等）；已经使用固定资产核算软件就不能在凭证填制中直接使用用固定资产科目。

♠咨询顾问

此功能颇有争议。有人认为在目前财务软件的功能框架内，业务系统功能并不能包罗该类业务的所有类型，功能还有待完善；而会计业务又非十分规范。这就造成了某些凭证业务系统不能做，又不允许账务系统填制的尴尬局面。如何解决这类问题呢？对于财务软件实业界的朋友也是一个难题。在此，笔者不妨提一个两全其美的方案。设置一个业务系统核算开关项，并且该开关项可以动态设置。当开关打开时，不允许账务系统填制该类业务凭证；当开关关闭时，允许账务系统填制该类业务凭证。当然，这种方式也存在一定的弊病，具体情况可以灵活变通地解决。

３．７．不允许录入不存在的核算项目。

３．８．在需要录入往来业务编号时，不允许往来业务编号为空或为录入系统不允许的其它符号。

３．９．不允许录入不存在的币别。

３．１０．货币汇率必须为正数。

３．１１．是否遵循基本的凭证输入原则。如借贷平衡等。

４．凭证合法性校验：凭证合法性校验是系统针对输入凭证的合理、合法性检查的简称。或者说是记账凭证填制之后的语义检查。它一般在凭证保存之前检查，或另设检查按钮实行专项检查。其检查范围及标准有：

４．１．用户自行设置的非法对应科目检查。如当凭证的借方出现固定资产科目时，不允许借方再出现应交税金――应交增值税――进项税科目等。

４．２．凭证字规定许可的会计科目检查。如转账凭证不允许出现现金或银行存款类科目等。

５．摘要维护：大多数财务软件在填制凭证的过程中摘要录入处是允许进行摘要维护的。用户可以增、删、改、回填任意一个摘要。

６．科目维护：大多数财务软件在填制凭证的过程中科目录入处是允许进行科目维护的。用户可以增、删、改、回填任意一个科目，如同初始化时进行科目维护一样。

７．辅助项目维护：大多数财务软件在填制凭证的过程中辅助项目录入处是允许进行辅助项目维护的。

８．模板凭证：在填制凭证处，财务软件一般都提供了可随时将某凭证保存为模板凭证和调入模板凭证的功能，以方便在录入凭证时，根据需要可以随时调入模板凭证作为用户输入凭证时的基本界面，以减轻凭证录入的工作量。

♥电算专家

有些财务软件提供了更好的模板凭证方式。比如：有一种软件提供了一种叫会计事务处理的功能。会计事务处理就是将用会计语言描述的处理对象提升为用自然语言描述的会计事项。如提现、报销、销售商品等一些较为频繁，而且凭证的填制模式较为一致的经济业务，就可通过此功能进行描述，用户只需用自然语言描述会计事务的基本要素，会计凭证及其后续作业就可以全部自动完成。

三、凭证审核与记账

记账凭证处理存在一个“三步曲”，填制、审核、记账。一张凭证填制完毕后，必须经过审核，只有审核无误的凭证才可以记账。财务软件的审核功能可以简单地归结为当记账凭证准确无误时，就在记账凭证审核栏填入审核人的姓名；当记账凭证存在错误时，就在记账凭证审核栏填入出错标志。记账功能则不同，如果用一句话来概括记账功能的话就是用通过审核的记账凭证中的会计分录更新科目余额及发生额文件。

四、凭证批处理

目前，大多数的财务软件都提供有凭证批量处理的机制。提供此机制的主要目的是加快凭证处理的速度，方便用户的操作。批处理一般包括以下几类：

１．批量记账：完成某会计期间批量凭证一次性记账。

２．批量打印：完成某会计期间批量凭证一次性打印。做得好的财务软件在此处还提供有其它打印条件设置功能。如设置凭证合并打印级别（包含三个选项：不合并科目打印、相同科目合并打印、指定合并科目级别打印）等。

３．汇总：提供某会计期间批量凭证任意汇总功能。生成科目汇总表。做得好的财务软件在此处还提供了汇总级别设置功能。

五、凭证处理集成环境

凭证处理比较繁琐，对应凭证处理的操作很多，为了方便凭证的处理和加快处理速度。大多数财务软件都提供有凭证处理集成环境。在此环境中将所有关于凭证处理的功能汇集在一起，大大提高了凭证处理的效率。有的软件还提供有类似于传统会计的会计分录序时簿的机制来统一集成管理记账凭证。此功能也是手工会计无法比拟的，当然就是会计电算化的特色和优势。


会计账簿

第四节：会计账簿

会计电算化后，会计账簿不再是“登”出来的，而是由电脑生成的。因此，我们称电算化后的账为“生成账”。另外，在WINDOWS平台上运行的财务软件会计账簿的输出包含了查询、打印、另存为其它格式文件等内容，符合“所见即所得”的要求。目前大多数财务软件在生成账簿之前都首先让用户设置一定的生成条件，然后电脑再根据用户所设置的条件生成账簿。以下分几类分别介绍：

♥电算专家

与传统会计的狭义会计账簿概念相比，会计电算化后的会计账簿有所扩充。如果一定要做一个类比，可以这么讲，会计电算化后会计账簿包含了传统会计的会计账簿、各种业务台账、科目余额表、科目计息表等。

♣电脑专家

“所见即所得”是英文“what you see，what you get！”的翻译，其完整的意思是指：在WIN9X/NT/2000操作系统下的应用软件的输出设计追求的目标是：使用者查询到的是什么内容的信息在显示器以什么样的格式表现出来，就可以原样不变地在打印机上打印出来;同样的信息可以按不同的格式转储到不同的介质或位置，甚至直接以电子邮件的方式发送到信息目的地。

一、总账类

主要包括总分类账、外币式总分类账、数量金额式总分类账。

１．如图2.2所示，查询条件主要组成项目：

图2.2总账查询条件设置

１．１．会计年度：当前年度，通过增量按钮选择年份。

１．２．会计期间：起始月份到终止月份。通过增量按钮选择起始月份及终止月份。

１．３．起始会计科目/迄止会计科目：输入起始及迄止会计科目代码。起始会计科目代码与迄止会计科目代码相同则查询某一个科目的总分类账；两个科目代码不同，则查询两者之间（包括两者）的科目的总分类账；只输入起始会计科目代码，而迄止会计科目代码为空，则查询大于起始会计科目代码的所有科目（包括起始科目）的总分类账；起始科目代码和迄止会计科目代码均为空，则表示查询所有科目的总分类账。

１．４．币别：可通过单击“币别”栏目的下拉式列表框选择,系统默认为本位币。

非总账科目：只对非总账科目查询。

１．５．级别：单击“非总账科目”复选框，选择该选项可弹出级别项设置。按任一级别查询，可通过“级别”的增量按钮选择级别即可。

♥电算专家

在总分类账查询中，除了查询一级科目的总分类账外，还可查询其他级别的科目分类账。

２．账簿主要组成项目：

１．１．会计科目：指明账户名称，一般在账页的左边。

１．２．会计期间：指明所在会计期间，一般在账页的右边。

１．３．年：指明年份。

１．４．月：指明月份。

１．５．日：指明日。

１．６．凭证字号：指明业务发生涉及的凭证字号。

１．７．摘要：业务内容的简要说明。

１．８．借方发生额：指明业务发生涉及的借方发生额。

１．９．贷方发生额：指明业务发生涉及的贷方发生额。

２．１０．余额方向：指明当前行余额的方向，其值只能是“借”、“贷”、“平”三者之一。

２．１１．余额：指明当前行余额。

    如果是数量金额式总账则８、９、１０、１１四项改成以下三项：

２．１２．收入栏下设三项：单价、数量、金额。

２．１３．发出栏下设三项：单价、数量、金额。

２．１４．结余栏下设三项：单价、数量、金额。

♠咨询顾问

其实，使用科目余额汇总表的变形表代替总分类账是一种理想的选择。因此，目前大多数主流的财务软件都还提供一个科目余额汇总表供用户使用。

二、明细账类

主要包括三栏式明细账、外币式明细账、数量金额式明细账、外币数量金额式明细账。

１．如图2.3所示，查询条件主要组成项目：

图2.3明细账查询条件设置

１．１．会计年度：当前年度，通过增量按钮选择年份。

１．２．会计期间：起始月份到终止月份。通过增量按钮选择起始月份及终止月份。

１．３．起始会计科目、迄止会计科目：输入起始及迄止会计科目代码。起始会计科目代码与迄止会计科目代码相同则查询某一个科目的明细账；两个科目代码不同，则查询两者之间（包括两者）的科目的明细账；只输入起始会计科目代码，而迄止会计科目代码为空，则查询大于起始会计科目代码的所有科目（包括起始科目）的明细账；起始科目代码和迄止会计科目代码均为空，则表示查询所有科目的明细账。

１．４．币别：可通过单击“币别 ”栏目的下拉式列表框选择,币种默认为本位币。

１．５．选择辅助核算项目：如果单击“选择辅助核算项目”复选框则“辅助核算类别”、“起始项目代码”和“迄止项目代码”选项被激活，此时“非明细级科目”项失效。

１．６．辅助核算类别：可通过单击“辅助核算类别”栏目的下拉式列表框选择,所有已定义的辅助核算类别都是选项。

１．７．“起始项目代码“和“迄止项目代码”的操作同“起始会计科目代码”和“迄止会计科目代码”的操作。

１．８．非明细级科目：当不选中辅助核算项目复选框时，可选中“非明细级科目”复选框，按非明细科目生成明细账。

１．９．级别：选中“非明细级科目”复选框时，选择该选项可弹出级别项设置。通过“级别”的增量按钮选择级别。

１．１０．包括未记账凭证：系统不仅提供了已登账数据查询，还提供了未登账数据查询。如果查询某一科目未登账数据的明细账，则单击“包括未记账凭证”复选框选择该选项即可。

１．１１．筛选条件：按以上条件设置生成账簿条件后，系统还提供了可以由所有凭证组成项目组成的“与”和“或”的逻辑表达式作为出账筛选条件的再次过滤设置。用以帮助用户进行更细致的范围定位。

☻脚下留神

筛选条件的选用可以进一步缩小查找凭证的范围，但一定要记住：此方式得出的账簿，绝非完整的账簿。不能作为存档使用。

２．账簿主要组成项目：

与总账类似，除了总账组成项目外，还可以取到业务发生时凭证中登记了的其他项目与对方科目。

三、日记账类

主要包括现金日记账、银行存款日记账、其他日记账。

１．查询条件主要组成项目：

１．１．会计年度: 当前年度，通过增量按钮选择年份。

１．２．会计期间：起始月份到终止月份。通过增量按钮选择起始月份及终止月份。

１．３．起始会计科目、迄止会计科目：输入起始及迄止会计科目代码。起始会计科目代码与迄止会计科目代码相同则查询某一个科目的日记账；两个科目代码不同，则查询两者之间（包括两者）的科目的日记账；只输入起始会计科目代码，而迄止会计科目代码为空，则查询大于起始会计科目代码的所有科目（包括起始科目）的日记账；起始科目代码和迄止会计科目代码均为空，则表示查询所有科目的日记账。

１．４．非明细级科目:可按非明细科目生成明细账。

１．５．级别：单击“非明细级科目”复选框，选择该选项可弹出级别项设置。通过“级别”的增量按钮选择级别。

１．６．包括未记账凭证：系统不仅提供了已登账数据查询，还提供了未登账数据查询。如果查询某一科目未登账数据的日记账，则单击“包括未记账凭证”复选框选择该选项即可。

２．账簿主要组成项目：

与明细账类似，只是一定包含对方科目。

四、多栏式明细账类

主要包括包括借方多栏式明细账、贷方多栏式明细账、借贷双方多栏式明细账。

１．多栏式明细账的定义：

多栏式明细账的定义一般可以分成两大步骤：

第一步：进行多栏式明细账账本名称及属性定义。主要包含两个项目。

１．会计科目：会计科目可以输入要出多栏账的某一非明细科目,如：要输出“521管理费用”下的多栏账,则会计科目可输入“521”。 此外会计科目也可不输入，表示多栏账将跨多个总账科目组账，如可将“101”，“102”，“109”组织为货币资金多栏账。

２．多栏账名称：多栏式明细账的账本名。

３．属性选项：

３．１．贷方小计：在贷方栏的最后增加贷方小计栏。

３．２．借方小计：在借方栏的最后增加借方小计栏。

３．３．余额：在多栏式明细账的最后增加余额栏。

第二步：进行多栏式明细账栏目定义。主要包含以下项目：

１．序号：表示栏目的排列顺序，一般由系统自动判断填入，亦可修改。

２．科目代码：输入栏目的科目代码。

３．项目代码：输入栏目的项目代码。

４．栏目名称：系统自动显示该科目对应的科目名称，亦可修改。

５．方向：表示此处所取科目发生额为“借”或“贷”。可通过单击该栏目所在区域，所显示的下拉式列表框中来选择，可选择方向为借或为贷。

６．数据来源：表示多栏明细账中各科目数据的来源，数据来源共有三种方式：借方金额、贷方金额和发生额。

♥电算专家

多栏明细账的结构一般都可以随时修改、删除。例如：在栏目设置时，可通过单击“缺省”按钮，由系统自动列出多栏账科目的所有栏目及其属性，即设定多栏账科目的所有明细科目为栏目科目，可以对其属性进行修改或删除。将光标落在某一栏目所在行，单击“删除”按钮可以删除该科目。将光标落在某一栏目所在行，单击“排序”按钮可按修改后的序号重新进行排序等。

２．条件选择 ：

在定义完多栏式明细账格式后，就可以随时按已定义好的格式生成多栏式明细账，在生成多栏式明细账时还可以进行查询条件的设置。查询条件主要组成项目如下：

２．１．会计年度：通过增量按钮选择会计年度。

２．２．会计期间：通过增量按钮选择会计期间起始月份及迄止月份。

２．３．包括未记账凭证：系统不仅提供了已记账凭证数据查询，还提供了未记账凭证数据的预览式查询。如果查询某一科目的多栏式明细账，该明细账中包含未登账数据，则单击“包括未记账凭证”复选框选择该选项即可，否则该项为失效状态。

当以上设置完毕后就可以按“出账” 按钮生成多栏式明细账了。

五、科目余额表类

１．查询条件主要组成项目：

１．１．会计年度：需要查询的会计年度。

１．２．会计期间：通过增量按钮选择会计期间起始月份及迄止月份。

１．３．起始会计科目、迄止会计科目：选择需要查询科目的范围，前一个科目的输入表示从哪一个科目查起，后一个科目的录入，表示查询到该科目即结束。

１．４．币种：可通过单击“币别 ”栏目的下拉式列表框选择,系统默认为本位币。

１．５．非总账科目：此项用来选择科目余额及发生额表所显示的科目是总账科目还是低级明细科目，如果想得到的是有关明细科目的余额及发生额表，就需要选中“非总账科目”复选框，并且在“级别”选项中设置按哪级明细科目显示“科目余额发生额表”； 系统默认为按总账科目显示“科目余额发生额表”。

２．账簿主要组成项目：

２．１．科目代码：指明科目的完整代码。

２．２．科目名称：指明对应科目的完整名称。

２．３．期初余额：分借贷方两栏分别指明该科目对应账户的期初余额。

２．４．本月累计发生额：分借贷方两栏分别指明该科目对应账户的本月累计发生额。

２．５．期末余额：分借贷方两栏分别指明该科目对应账户的本期期末余额。

２．６．本年累计发生额：分借贷方两栏分别指明该科目对应账户的本年累计发生额。

♥电算专家

以上项目用户可以根据自身需求自行增删。

六、辅助账类

辅助账是出现辅助核算项目后，在会计账簿体系中出现的一类备查账，按其组成形式主要可以分成以下类别：

１．辅助核算总账：指按总账格式生成包含辅助核算项目的账簿。

２．辅助核算明细账：指按明细账格式生成包含辅助核算项目的账簿。

３．辅助核算余额表：指按科目余额表格式生成包含辅助核算项目的账簿。

４．自定义综合账：指按任意科目组合在一起作为一本账输出。

♥电算专家

例如：将“101现金”、“102银行存款”、“109其他货币资金”三账合并成货币资金账输出；将“501产品销售收入”、“511其他业务收入”、“541营业外收入” 三账合并成综合收入账输出等。自定义综合账可以这么描述更精确：您想让哪几个账合并在一起，就可以让它们合并在一起；它们的期初数组成合并后的期初数，它们的发生额组成合并后的发生额，合并后的余额就是按常规方式生成的余额。

５．往来对账单：指与往来客户的往来发生及结余情况。

♥电算专家

有些软件只提供按往来客户账户抵消应收账款或应付账款的往来对账单；有些软件提供按往来客户抵消应收账款与应付账款的往来对账单，甚至按往来客户任意设置抵消某几个往来账户的往来对账单。并且对账的条件也非常丰富和灵活。一般主流财务软件都提供有三种对账方式：按业务编号相同、方向相反、金额相同自动勾对；按方向相反、金额相同自动勾对；手工勾对。

６．账龄分析表：指按自定义的账龄区间生成的账龄分析表。

７．辅助核算分析：指对指定分析期的有关辅助核算类科目进行各类数据的单项和综合分析。

８．科目计息表：指按给定的计息期间和利息率计算某账户的利息。

♥电算专家

科目计息表类似于银行会计分类账簿的乙种账或丙种账。

♥电算专家

总体来说，辅助账类确实加强了会计账簿的性能。但是，我们也应该看到，作为辅助账类的功能还有大力加强的必要。比如辅助核算项目交叉核算账簿；会计科目级别变动账簿等。

♥电算专家

传统会计中，在查询账簿的时候经常需要查找对应的记账凭证。目前，主流的财务软件基本上都提供从账簿到凭证的账证一体化查询功能。具体可以分成以下几类：一、从总账查询对应账户的明细账；二、从明细账查询当前行分录对应的凭证；三、从辅助账查询当前行分录对应的凭证。


期末处理

第五节：期末处理

由于会计核算是分期进行的，到了每个会计期末都要做一些例行的处理工作。例如：将各费用项目及收入项目结转到本年利润；各种待摊项目的摊销；各种预提项目的提取；有外币业务时各种外币的期末调整汇率；结清各账户余额等工作。在手工会计中这些都是比较繁琐的事情，会计电算化后，我们可以借助计算机简便、快速地完成这些工作。以下分别介绍目前大多数财务软件基本上都具备的几项辅助期末处理的功能。

一、期末调汇

期末调汇是指每月月末软件根据外币账户的账簿记录和月末当日的市场汇率，计算汇兑损益，并自动生成结转凭证及汇兑损益调整表。软件执行此功能时，是根据在会计科目中的科目属性来进行的，只有在会计科目中设定为期末调汇的科目才会进行期末调汇处理。

软件在自动生成调汇凭证及汇兑损益调整表前，需要设置调汇科目、调整汇率等参数。主要包括以下内容：

１．调整汇率：每种外币都要通过此处确定一个期末调汇计算时采用的调整汇率。

２．转账凭证字：一般通过下拉式列表框选择汇兑损益转账凭证采用的凭证字。

３．汇兑损益明细科目：一般通过该栏右边的小图标选择汇兑损益明细科目。该科目须为最低级明细科目。

♥电算专家

汇兑损益是在持有外币货币性资产和负债期间，由于外币汇率变动而引起的外币货币性资产和负债的价值发生变动而产生的损益。目前，大多数财务软件仅提供期末进行一次性汇兑损益调整的功能。这一点是符合我国现行会计制度的规定和大多数企业的需求的。某些企业由于外币业务频繁，汇兑损益需要不定期调整。特别是有频繁且大宗进出口业务的外贸企业一方面要求能随时进行汇兑损益调整，另一方面要求汇率设置的小数较长。目前只有极少数财务软件提供此项功能。

二、自动转账

自动转账是一项非常有实用价值的功能。可以这样说，功能完善的自动转账力求完成用户所能提出所有关于转账类凭证的自动编制过程。自动转账既可以大大减轻会计人员填制凭证、特别是复杂转账凭证的工作量，又可以保证填制凭证的正确性。每一个使用财务软件的用户都有必要充分利用财务软件提供的此项功能。一般来说，财务软件提供的自动转账功能可以分成两个层次：普通自动转账和高级自动转账。每个层次的自动转账的实现过程又包括凭证定义与生成两个步骤。下面分别介绍：

图2.4自动转账设置

１．普通自动转账：是用来完成常规性的月末结转工作，并生成有关的转账凭证。例如：对只有借方发生额的产品销售成本、产品销售费用、产品销售税金及附加、销售折扣与折让、其他业务支出、管理费用、财务费用、营业外支出等各项费用结转到本年利润的借方；对只有贷方发生额的销售收入、其他业务收入、营业外收入等各项收入结转到本年利润的贷方；按应交税金－应交营业税的贷方发生额的一定比率计算并结转城市维护建设税、教育费附加等；将本年利润的年末余额转到利润分配－未分配利润；进行所有能确定金额的摊销与预提的结转等。总之，普通自动转账能够完成按账户的余额、发生额的某个比率进行一借多贷或一贷多借转账类凭证的自动编制工作。

１．１．普通自动转账的定义：在普通自动转账定义界面一般包括以下项目：

１．１．１．转入会计科目：可通过该栏右边的小图标选择转入会计科目。确认选择转入科目。

１．１．２．转入方向：可通过下拉式列表框选定“借”或“贷”。

１．１．３．凭证类型：可通过下拉式列表框选定转账凭证的类型。

以上三项为转账凭证头定义，以下为为转账凭证体定义（凭证体支持多记录行定义）。

１．１．４．序号：该栏手工输入转出科目分录的序号，该序号可以手工改变，不支持重号，可以按序号重排。

１．１．５．科目代码：可通过该栏右边的小图标选择转出会计科目，亦可直接输入科目代码。此处科目可为非最低级明细科目。此时表示将该非最低级明细科目对应的所有下级科目全部转出。

１．１．６．摘要：该栏输入对应该行转出科目分录的摘要。

１．１．７．借贷：可通过下拉式列表框选择“借”或“贷。”

１．１．８．金额来源：可通过单击该栏右边的下拉式列表框选择“借方发生额”、“贷方发生额”、“余额”、“借方减贷方”、“贷方减借方”。

♥电算专家

以上定义自动转账凭证的原理与过程与我们填制记账凭证的过程非常类似，大家可以参照理解。

１．２．普通自动转账的生成：普通自动转账定义完成后，选定要生成自动转账凭证的凭证名称行，单击“转账”按钮，系统就自动生成转账凭证，还会生成凭证字号。同时还支持对生成转账凭证的查询、或重新生成功能。

☻脚下留神

用户在使用自动转账凭证生成前，切记将有关转出科目业务的凭证预先进行审核登账工作，换言之，要保证转出科目业务能够正确地自动转账，必须保证涉及转出科目所有记账凭证都已审核登账。另一方面，系统自动生成的转账凭证也要审核登账。

２．高级自动转账：

高级自动转账与普通自动转账不同之处主要表现在转账的条件设置上提供更多更丰富的设置方式。比如：可以按辅助核算项目设置；可以按其它核算系统的明细项目设置；可以从报表取数分析设置等。总之，高级自动转账可以完成比普通自动转账难度更大的转账类凭证的编制与生成工作。主要差异表现在以下三个方面：

２．１．支持多借多贷自动转账凭证的定义（此项功能建议用户尽量少用）。

２．２．支持金额公式、外币公式、数量公式同时定义（当然是在对应科目具备相应属性的情况下），在定义过程中提供类似通用报表取数公式向导功能的界面来完成金额公式、外币公式、数量公式的定义。

２．３．支持分录转账条件设置。条件设置窗口类似于查询条件的设置。

所以说，分部门分人员类别的工资费用分摊、分产品分车间分班组的制造费用分摊、其他分辅助核算项目的各种结转等都必须借助高级自动转账完成。

♠咨询顾问

高级自动转账功能的使用对用户来说有一定的困难，因此，许多可以通过高级自动转账功能完成的工作都交给专项核算系统完成。如果大家在使用过程中遇到麻烦，立刻咨询软件服务商是最明智的选择。

三、期末结账

按照我国会计制度的要求，每月月末都要进行结账。期末结账将结束当前会计期间的会计业务处理，将会计期间转至下一会计月度。结账前请先确认当前会计期间的业务都已处理完毕。在执行期末结账时有几点注意事项：

１．上月未结账，则本月不能记账，但可以填制、复核凭证。

２．本月还有未记账凭证时，则本月不能结账。

３．若总账与明细账对账不符，则不能结账。

４．已结账月份不能再填制凭证。


系统管理

第六节：系统管理

现在，我们都知道使用财务软件可以大大减轻会计人员的劳动强度，提高会计工作的效率和效益。但是，也存在一些工作是手工会计不需要做，而电脑会计却是必不可少的。比如说操作员维护与授权、数据的备份与恢复等。其实，这部分工作在传统会计中也存在，只是实现的方式方法不同而已。会计电算化后，我们可以充分利用计算机的优势将这些工作以一种更安全、更高效的方式实现。

一、操作员管理与操作日志

操作员管理主要完成允许使用财务软件的操作人员的设置和使用权限分配。目前，大多数的财务软件都设置有一个特殊用户或特殊用户组，一般称之为“系统管理员”或“系统管理员组”。 系统管理员或系统管理员组的成员可以对其他用户进行授权、可以增加和删除用户。

系统管理员或系统管理员组的操作员可以执行以下操作：

１．用户组设置：用户组设置主要用于对用户组进行设置和管理，提供了新增、修改、删除三项功能，可对用户组进行增加、删除等项处理。

２．用户设置：主要用于对用户的新增、改组、删除、授权及权限复制五项功能，主要用于对普通操作人员进行管理。

１．明细权限设置：

３．１．明细账查询科目权限设置：本功能是查询和打印明细账权限的一个补充。一般说来，凡是拥有查询明细账权限的操作员都可以查询所有科目的明细账，但是有些时候，希望对查询和打印权限作进一步细化，如只允许某操作员查询或打印某科目明细账，而不能查询或打印其它科目的明细账。这种情况下，可以通过此功能进行设置。

３．２．制单科目权限设置：本功能是制单权限的一个补充。一般说来，凡是拥有制单权限的操作员都可以使用所有科目填制凭证，但是有些时候，希望对制单权限作进一步细化，如只允许某操作员使用某些科目填制凭证。这种情况下，可以通过此功能进行设置。

３．３．凭证审核权限设置：本功能是凭证审核权限的一个补充。一般说来，凡是拥有凭证审核权限的操作员都可以审核其他所有操作员填制的凭证，但是有些时候，希望审核权限作进一步细化，如只允许某操作员审核其本部门的操作员填制的凭证，而不能审核其他部门操作员填制的凭证。这种情况下，可以通过此功能进行设置。

而普通操作员就只能执行被授权的操作。

♥电算专家

操作员管理对应于手工会计的岗位设置与权限划分，只是比手工控制更严密、更可靠而已。作为企业会计电算化主管，一定要善于利用操作员管理提供的功能加强管理。

操作日志是用于记录什么时间，哪个用户，进行了何种操作，以及操作的结果，以便留下审计线索。操作日志只能进行查询（包含过滤查询）、删除、另存为、打印等项处理。

二、数据备份

数据备份是为了防止系统出现故障、感染病毒等不可预料的情况，造成数据丢失，影响财务工作的正常进行，将存放在电脑硬盘某目录中的数据备份到其它存储设备上，如备份到软盘、光盘、磁带或硬盘的其它目录的操作。备份可以分成强制性备份和非强制性备份；完全备份和增量备份。

♥电算专家

所谓强制性备份是指规定必须要做的备份，许多财务软件在结账时都采用强制性备份策略作为增强数据安全性的有效措施。所谓非强制性备份是指软件提供一种随机备份的策略，用户可以在需要备份的时候进行备份。所谓完全备份是指不管原来是否做过备份，每次都将所有的数据进行完整的备份。所谓增量备份是指备份时可以进行选择性的备份某一部分数据。

☻脚下留神

一般来说，数据库的安全级别越高、服务器工作越稳定，备份的频率可以越小。如果您使用的是桌面小型数据库，请多备份几次；如果您使用的是大型数据库，而且您的服务器性能也相当的稳定，您可以每月只进行一次备份增量，每年进行一次完全备份；所有软件规定的强制性备份您都必须做。

三、数据恢复

数据恢复是数据备份的反操作，是将存储在其它存储设备上的数据（如软盘、光盘、磁带或备份硬盘）重新恢复到电脑硬盘上来，从而使财务软件可以重新处理这些数据。

☻脚下留神

不到万不得已，请不要进行数据恢复。


高级功能

第七节：高级功能

本节介绍的功能在手工会计中被认为是无法实现或实现非常困难的，甚至某些功能被传统会计所不提倡或禁止的。然而，在会计电算化实践中，我们发现某些功能在会计电算化后是非常必要的或必不可少的。本着尊重事实的原则我们在此也作一些简要的介绍。

一、 反记账

反记账是将当前会计期间的全部或部分已记账凭证退回到待审凭证。如果记账包含了登账过程，反记账还要取消这部分凭证的登账操作。

♥电算专家

反记账可以理解为手工会计的重新填制记账凭证，包含反登账时可以理解为重新登记账页。

二、 反结账

反结账功能将当前会计期间返回到上一会计期间，如果是某年度的01月份，则进行年度反结账,返回到上一年度的12月份。

☻脚下留神

反结账功能请慎重操作。

三、 重新初始化

如果由于种种原因造成初始数据的录入错误，而导致以后账务系统的操作困难，您可以通过运行重新初始化功能进行初始数据的重新录入及修改。前提是必须将当前会计期间设置为建账年月。修改完毕后，您还需要再次结束初始化，并将当前会计期间追回至实际会计期间；整个过程才结束。

☻脚下留神

运行重新初始化的必要条件是当前会计期间一定是建账年月（建账年月是指第一次使用电脑记账的会计期间）。如果不是，请使用反结账功能使当前会计期间退回到建账年月。

四、 财务预算控制与分析

目前大多数财务软件都提供有基于科目（即账户）的预算编制与控制机制。该机制还提供有科目预算执行报告；项目预算执行报告；可对预算与实际情况进行比较分析、准确形象地反映企业预算执行情况；可对预算进行其它常规的分析。

五、 我的账簿

我的账簿是为了方便用户录入查询条件而提供的查账工具，它可将用户常用的查询条件加以保存，以便在下次查询时可直接调用。

♥电算专家

目前，有部分软件的我的账簿功能提供跨年度查询的功能。

六、 账套维护工具

对于财务软件来说，账套一经定义，很少需要修改，甚至某些项目不允许修改。早期的财务软件在这方面规定的都比较严格。这与当时人们对会计电算化的认识水平和掌握计算机的技术水平息息相关。随着会计电算化的日益普及，实践提出了许多比较尖锐的问题，导致现代财务软件开发商不得不重新考虑某些过去被视为不可动摇的做法。以下介绍的内容请大家注意，到目前为止也并非每一个财务软件都具备。

６．１．账套代码是否可更改：账套代码使用后一般不允许修改，但是某些特殊的原因出现时需要修改。目前，只有极少数软件提供此功能。

６．２．账套是否可隐藏：账套是否允许逻辑隐藏，结合操作系统及数据库管理系统可实现物理隐藏。目前，只有极少数软件提供此功能。

６．３．账套是否可加密：账套是否允许设置账套密码，当设置指向该账套并第一次打开该使用账套时，此密码生效。

６．４．账套数据是否可发送：账套数据发送可以分成以下四类：

６．４．１．发送所有数据：系统将源账套所有数据复制到目标账套。此操作主要用于制作数据副本或更换数据库系统。

６．４．２．发送初始数据：系统将源账套中初始化结束时的初始数据复制到目标账套。

６．４．３．发送用户档案及权限：系统将源账套中所有已设置的用户资料及权限复制到目标账套。

６．４．４．期末转期初发送：系统将源账套中当前期末余额转换成期初余额复制到目标账套。此操作相当于不保留凭证重建账套。

６．５．账套数据是否可整理：对于某些桌面小型数据库提供重新整理的功能以加强数据读写速度及减少数据容量。

６．６．建账会计期间是否可更改：在会计电算化实际工作中，经常会出现初始化建账日期需要改变的情形。目前，有极少数软件提供在初始化过程中允许修改建账日期的功能。

６．７．账套名称是否可更改：账套名称是否允许修改。

６．８．记账本位币否可更改：在初始化过程中是否允许修改记账本位币币种。目前，只有极少数软件提供此功能。

６．９．已使用过的记账凭证类型编码是否可更改：目前，只有极少数软件在重新初始化时允许修改已使用过的记账凭证类型编码，但绝不允许删除已使用过的记账凭证类型编码。

６．１０．已使用过的银行传票类型编码是否可更改：同上。

６．１１． 已使用过的辅助核算类别编码是否可更改：同上。

６．１２．已使用过的科目模式是否可更改：科目模式是指会计科目的级别以及各级长度。目前，很多财务软件的科目模式一旦设定，终身不允许改变。随着人们对会计电算化本质认识的提高，这一陈规陋习已被某些会计电算化先驱打破。目前，极少数软件提供了修改科目模式的功能。

６．１３．记账凭证是否可导入导出：记账凭证及与之关联的科目代码、辅助核算项目代码等可以自由的在不同账套间导入、导出。在导入、导出过程中还支持条件过滤和重排。目前，完整地支持此项功能的软件不多。

♥电算专家

此处提到的功能，普通用户一般不要随意使用。某些功能软件厂商提供给用户，掌握在系统管理员手中；某些功能软件厂商只提供给软件供应商，掌握在软件技术支持人员手中。


报表系统的作用及特点

第三章：报表系统解析

第一节：报表系统的作用及特点

报表系统是用于满足用户单位编制各类会计报表的电子表格处理系统。目前，市面上流行的各种财务软件的报表系统都是通用型的财经类电子表格处理系统。它们具备的共同特点是：报表均可“一次定义，多次使用”；报表均可自动生成。使用财务软件提供的财经类电子表格处理系统与手工编制报表、使用普通电子表格软件（如：EXCEL）编制报表的最大区别是：由计算机根据事先设置的取数公式从账务系统和其它各子系统取得各种财务和业务数据后自动生成报表。

♦会计专家

会计报表是用统一的货币计量单位，以日常会计核算资料为主要依据，运用各种规定的表格形式，总括地反映会计主体在一定时期内的财务状况、经营成果和理财过程的报告文件。它是会计核算的最终产品。每个企业都要定期地编制会计报表。会计报表按反映的内容可以分成动态报表和静态报表。按编制的时间可以分成月报、季报和年报。按服务对象可以分成内部报表和外部报表。

♥电算专家

报表系统除了可以满足财务会计对传统会计报表的编制需求外，还提供了许多实现管理会计和业务管理所需要的编制业务报表的功能。比如：报表系统不但可以取得货币计量的各种余额、发生额，还可以取得数量余额、发生额，各种预算数，各种项目数；不但可以从账务系统取数，还可以从其它核算系统如工资核算系统、进销存核算系统取数，不但可以从本表取数，还可以跨会计期间从其它表取数；不但可以编制各种定期报表如：年报、季报、月报、周报、日报，还可以编制各种不定期报表；不但可以以表格的形式反映，还可以以各种丰富的图形反映。


报表的定义

第二节：报表的定义

报表系统必须先定义，后使用。报表定义是一件相对费时和复杂的工作。但是报表一旦定义好后，使用起来就相当方便了。换句话说，报表的定义是报表系统的精髓和关键部分，报表系统的功能强弱、品质优劣就由报表定义的功能强弱、品质优劣来决定。总结各种财务软件的报表系统定义功能基本都可以分成以下部分。

一、报表的注册

图3.1报表注册界面

报表定义的第一个步骤是报表注册，报表注册主要完成报表的新增、修改、删除等有关报表的登记管理工作。目前绝大多数财务软件的报表系统对应报表注册的操作称之为对“文件”的操作。其中包括的重要选项如下：

新建：完成报表的新增工作。大多数财务软件都会采用类似EXECEL电子表格的形式，当用户按下“新建”按钮后，进入一张空表的编辑状态。

打开：打开一张已存在的报表。一般来讲，财务软件都能根据用户打开的报表安全性设置来确定用户的操作权限。

保存：完成保存一张正在定义的报表。主要包括以下项目的设置：

1．报表类型: 选择当前新建报表的类型。如：年报、季报、月报、日报、不定期报表等。

2．报表期间：选择当前报表所处的的会计期间，由于报表系统的会计期间一般与账务系统保持一致,所以在报表期间栏默认的会计期间也是您账务系统所处的会计期间。当然，在用户保存的时候也可以根据报表所属的会计期间改变。

♥电算专家

报表系统与账务系统的会计期间偶合度越小越好。目前市面上流行的财务软件大多数要求报表系统的当前会计期间与账务系统的当前会计期间一致，也就是说，报表系统的会计期间跟着账务系统的改变而改变。这样一来，报表系统就似乎成了账务系统的一种延伸，一种附属品。其实，我们仔细分析就可以看出两者的关系。一方面，账务系统是报表系统的数据来源，比如：账户的期初余额、发生额、期末余额等。但是，报表系统除了从账务系统取数外，还可以从其它系统取数，比如：从进销存系统、从工资系统、从固定资产系统等。因此，我们在看到账务系统是报表系统的一个重要的数据来源的同时，也应该看到报表系统的数据来源的多样性，特别是在现代决策支持型财务软件中，强调报表系统数据来源的多样性，逐步减少账务系统占报表系统数据来源的比重已成为一种不可阻挡的趋势。另一方面，报表系统有其本身存在的独立性。如何理解这种独立性呢？可以这样说，即使报表系统不能从财务软件其它系统取数，报表系统也有其独立存在的价值。君不见许多单位在用EXECL编制各种财务报表吗？

基于以上两点分析，相信大家能和我达成一个共识：报表系统与账务系统的会计期间偶合度越小越好。或者说报表系统的结转与账务系统的结转可以不同步，报表系统可同时操作多月报表。用户在选择财务软件的时应该擦亮眼睛。

3．报表名称: 输入当前报表的名称。

4．报表单位: 选择当前报表所属单位(账套名称)。

另存为：将正在定义的一张报表另外保存。在保存过程中可以相应改变报表类型、报表期间、报表名称、报表单位等报表属性。

另存为模板：所谓“模板”从字面上解释就是“模型、底板”在此处可以理解为报表的模型。其实，报表模板就是一张已定义好报表，只是它不归属于任何一个会计期间，新建时可以从报表模板生成。

♥电算专家

您可以认为报表模板就是一个存储报表的仓库,每到一个新的会计期,从仓库中取出各张报表,分别计算,从而得出当前月的各报表数据。具体地说，就是当一个新的会计期间需要出报表时,打开一张新报表，单击文件菜单中“新建”按钮,系统将为您自动弹出新建报表窗口，其中，列出了可供使用的模板。选择其中一张报表模板，单击“确定”,新的报表就生成了，它的内容，公式，格式与模板中的原报表完全一致，只有报表时间自动更新为您的账务系统当前期间；通过单击“全部”按钮，系统将把此模板中的所有报表都生成出来。单击“计算”，本月报表就计算出来了，通过这种方式，任何会计期间的报表都能及时，准确地生成。

☻脚下留神

并非所有的财务软件都提供了“报表模板”这项功能。应该说，采用“报表模板”的方式实现不同会计期间的报表定义的传递是一种符合潮流的技术。另一方面，较之传统方式它又多了一个报表定义的传递途径。

导入：导入数据是指将别的系统产生的数据导入本系统的过程。其中主要包括格式的导入、数据的导入和公式的导入。能否接受外系统的数据是衡量报表系统开放性非常重要的方面。目前大部分财务软软件的报表系统都具备导入功能。区别主要在于支持文件格式的多少，以及转换内容的程度（格式、数据、公式）。一般来说，大多数的财务软件都支持以下文件格式的转换。文件格式主要包括文本格式*.TXT、EXCEL格式*.XLS、DBASE数据库格式*.DBF、ACESS数据库格式、LOTUS格式、HTML格式等。由于不同文件格式之间本身存在一定的不兼容性，所以不同文件格式的转换势必带来不同程度的内容损失。

导出：导出数据是导入数据的一个逆向操作过程。

页面设置：与其它电子报表软件如EXECL类似，主要包括纸张大小、页边界、工作表、页眉/页脚的设置。

打印预览：在打印报表之前预先浏览。此功能有实用价值。

打印：将计算完毕的报表通过输出设备打印输出。

套打：将计算完毕的报表在预先印刷好的空表里只打印变动部分。

报表的保护：指对当前报表的数据通过一定的密码设置，使当前报表数据处于只读状态（其他用户不能对该报表数据进行修改）。具体内容如下：

1．全部保护状态：将报表设置为“全部保护状态”，用户不能对该报表再进行写操作。

2．区别保护状态：“区别保护状态”就是进行报表工作表的选择性保护，也就是选定一张报表中的某些区域进行保护。

3．解除保护：对实行保护的报表解除保护状态。一般来说，必须知道保护密码才能解除保护。

报表的共享：报表的共享属性可以分成四类:

1．不共享: 设置为“不共享”,使其他任何用户不能进入当前报表。

2．只读共享: 设置为“只读共享”,用户需要在“只读密码”对话框内输入密码;那么只有掌握了该密码的用户才能阅读当前报表,但不能进行增、删、改等操作。

3．完全共享: 设置为“完全共享”, 用户需要在“完全控制密码”对话框内输入密码; 那么只有掌握了该密码的用户才能进入当前报表进行完全操作。

4．根据密码访问: 设置为“根据密码访问”, 用户必须在“只读密码”和“完全控制密码”两栏内分别输入一个密码, 那么其他用户进入当前报表使用的是哪一个密码,他就只有与之相应的权限。此时 “只读密码” 和”完全控制密码” 不能相同。

♥电算专家

报表的保护与共享实际上是对报表读写权限的控制。目前市面上流行的财务软件都或多或少地提供了上文提及的部分功能。之所以要提供此类控制，是因为确实存在对某些报表实施读写控制的需要。特别是在电脑比较普及，网络比较流行的今天。出于报表维护的需要或出于商业机密的需要，我们希望将某些信息控制在一定范围之内。但是，报表的保护与共享机制也是一把“双刃剑”。使用不当会影响正常工作。特别是有些软件的报表的保护与共享机制本身也不是十分完善。因此，用户在使用此机制时一定要谨慎从事。在此，郑重建议用户对一般信息尽量不使用此机制，只有在非常必要的时候才使用此机制。具体地说，对报表的保护机制可以由报表编制者控制使用。对报表的共享机制可以根据报表信息的使用范围由报表主管控制使用。

关闭：对当前报表操作完毕，关闭当前报表。

退出：报表系统使用完毕，退出报表系统。

二、报表的编辑

图3.2报表结构图

如图3.2所示，报表的编辑功能类似EXECL的编辑功能。为了叙述的方便我们先对有关报表编辑的若干术语进行简要的说明：

1．单元格：在报表内有许多方格,这些方格被称作单元格,单元格是存放数据的基本单元。在报表内,横向称之为行,行一般以连续的阿拉伯数字编号。报表内纵向称之为列,列一般以英文字母编号。在报表内,以某列某行表示某个单元格。例如: A4表示第1列第4行的单元格。

2．活动单元格：在众多单元格内,一般有一个与众不同的外框有虚线边框的单元格,称之为活动单元格。活动单元格通常表示当前等待或正在处理的单元格。任何一个单元格，在对它进行输入或修改前必须首先设置为活动单元格。设置某单元格为活动单元格的方法一般是：鼠标单击该单元格，就可以设定该单元格为活动单元格。例如,若想在某个单元格内输入数据,则可以将该单元格设定为活动单元格再输入；若想修改某个单元格内输入的数据,则可以将该单元格设定为活动单元格,然后再编辑该单元格的内容。

3．单元格区域：如果用户想要表示某个连续区域的单元格,视情形分别采用下列三种。

连续单元格区域位于同一列,其表示格式如下:

最上单元格：最下列单元格，例如: A6:A9 代表A6,A7,A8,A9四个单元格。

连续单元格区域位于同一行,其表示格式如下：

最左单元格：最右单元格，例如: A3:E3 代表A3,B3,C3,D3,E3五个单元格。

连续单元格区域同时含有多列和多行, 其表示格式如下：

左上角单元格：右下角单元格，例如 A1:C4 代表A1,A2,A3,A4,B1,B2,B3,B4,C1,C2,C3,C4十二个单元格。

4．工具栏：自定义报表中除了将所有功能设计成命令方式在各下拉菜单内以外,同时也将常用的功能设计成工具按钮放在工具栏内,以方便用户操作。若想了解工具栏内某个工具钮的简要说明,只要将鼠标放在该工具钮上,大约一秒钟后,工具钮下方将显示工具钮的名称。

5．报表的其它有关概念 ：

5．1．标题: 报表的表名。

5．2．表头: 报表上部的描述部分,如编制单位,日期等。

5．3．表体: 报表的主要组成部分,包括项目及数据等。

5．4．表尾: 报表底部的描述部分,如填制人等。

5．5．报表名称: 当前所选报表的名称。

5．6．报表单位: 当前所选报表的所属单位(账套名称)。

♥电算专家

目前市面上流行的财务软件的报表系统对报表结构的划分有两种有代表性的分法。一种是将整张报表定义为一个编辑区域，为了叙述的方便人为地将一个完整的编辑区域分成表头、表体、表未三部分，三部分同时出现在一个编辑界面，用户可以很方便地从一个部分进入另一个部分，用户还可以在表头与表尾部分进行公式定义，甚至有些软件还提供了一些表头处理的特殊函数，如自动取当前会计期间的“报表期间”、自动取填制单位的“编报单位”等。也就是说，这种风格的报表系统是真正意义上的电子表格系统，系统使用“单元格”将表头、表体、表未三部分一视同仁地对待。另一种是将整张报表分成表头和表体两部分，表头与表体分别单独编辑，打印时将两部分再合并到一起输出。此种方式的报表系统用户使用起来感觉不够直观，市面上已越来越少。

剪切：将选定的单元格或单元格区域的内容（包含相应的公式）剪下，然后将它放到剪贴板内。用户应如下操作：首先选定单元格或单元格区域，然后单击编辑菜单中的“剪切”，即将选定内容剪下。

复制：将选定的单元格或单元格区内域的内容（包含相应的公式）复制。用户应如下操作：选定单元格（区域），单击编辑菜单中的“复制”命令即将选定的内容复制，而选定单元格（区域）内容仍保持不变。

粘贴：将剪贴板的内容（包含相应的公式）或复制的内容放到指定位置。用户应如下操作：用鼠标单击指定位置，然后单击编辑菜单中的“粘贴”命令，即将剪贴板的内容放至指定的位置。

粘贴数据: 将剪贴板的内容或复制的内容中有关数据的部份（不包括公式、格式）放到指定的位置，其操作同“粘贴”功能的操作。

清除：清除操作一般可以分成以下三种：

1．清除全部：选择需处理的单元格（区域），单击“全部”则所选定区域内容包括公式，数据及格式全部被清除。

2．清除格式：选择需处理的单元格（区域），单击“格式”则所选区域的单元格格式被清除。

3．清除内容：操作同以上两项处理。只是它导致的效果是将您选定区域的数据及公式全部清除。

删除：删除操作一般可以分成以下四种：

1．右侧单元格左移：选定单元格的右侧整体单元格向左移动一格并覆盖选定单元的所有内容。

☻脚下留神

右侧单元格左移与插入单元格右移成反操作。用户应注意此两项功能的搭配使用。

2．下方单元格上移：选定单元的下方单元格整体向上移动一格，并覆盖选定单元格的所有内容。

☻脚下留神

下方单元格上移与插入单元格下移成反操作。用户应注意此两项功能的搭配使用。

３．整行：删除选定单元格所在行。

４．整列：删除选定单元格所在列。

三、报表的视图

视图菜单用于设置报表的工作环境，选项前有“√”标志，则表示该选项处于选中状态。

工具栏：在报表的编辑过程中，我们经常需要方便地利用一些工具帮助我们进行报表的编辑工作。虽然我们可以通过菜单或快捷键来使用这些工具，但是我们更习惯通过点击图标的方式使用这些工具。工具栏就是让我们能方便地选用这些工具的一种设置。通过单击工具栏选项，我们可以将工具栏中的工具钮(屏幕上部的小图标)分为四类:“常用”,“格式”,“编辑”,“绘图”,左侧有“√”标志的表明该类工具钮处于显示状态（屏幕上部显示该类工具的图标按钮）,反之,则处于未显示状态；用户可通过反复单击这些选项使工具钮在显示与不显示状态之间来回切换,而达到便于操作的目的。

编辑栏：设置报表活动单元格内容的编辑框是否显示。在编辑栏的左侧“√”标志的表明该编辑栏区处于显示状态，反之表明该编辑栏区处于未显示状态。

行号：设置报表是否显示行号。在“行号”左侧“√”标志表明行号处于显示状态，反之表明行号区处于未显示状态。

列标：设置报表是否显示列标。在“列标”的左侧“√”标志表明列标区处于显示状态，反之表明列标区处于未显示状态。

网格线：设置报表网络线是否显示。在网格线的左侧“√”标志表明网格线处于显示状态，反之表明网格线处于未显示状态。

零值：用于设置在对报表计算后，当项目输出结果为零时，零值是否显示。处于“√”状态下，显示“0”；反之，不显示“0”。

页眉/页脚：通过页眉/页脚的设置对报表的打印格式进行调整。

四、报表的插入

单元格右移：在选定单元格左边插入一空活动单元格,选定单元格及右边所有单元格均向右移动一个单元。

☻脚下留神

插入单元格右移与右侧单元格左移成反操作。用户应注意此两项功能的搭配使用。

单元格下移：在选定单元格上边插入一空活动单元格,即选定单元格及下边所有单元格均向下移动一个单元，且选定该单元格。

☻脚下留神

插入单元格下移与下方单元格上移成反操作。用户应注意此两项功能的搭配使用。如插入单元格下移后使用下方单元格上移可以使报表复原。

行：在选定单元格所在行上边插入一空行。

列：在选定单元格所在列左边插入一空列。

列分页符：选定某一列,单击本按钮,那么您的报表就由此左右一分为二(预览报表可看到此效果);如果您想撤消该操作,需再次选定这一列单元格,单击插入菜单中的“删除列分页符”(此时,“列分页符”一栏已切换为”删除列分页符”) 表即恢复至原来状态。

行分页符：操作同上。

五、报表的格式

单元格：单击格式菜单第一项“单元格”, 弹出“单元格格式”窗口。其中一般包含以下项目：

１．数字：单击“数字”按钮,我们可以看到,在“分类”选项框中,已将所有的数字格式分为若干类,而每一类数字格式都在“类型”选项框中列出其模式,或是小数形式,或是分数形式, 或是百分数形式, 或是货币等等。此类操作类似EXECL中的方式。

２．对齐：单击“对齐”按钮屏幕弹出窗口。其中一般包含以下项目：

２．１．水平：窗口中的“水平”域用于设置水平方向的对齐关系, 有以下几个选项：

常规：缺省选项，文字左对齐，数字右对齐。

左：选定某单元格（区域），单击本选项，选定的单元格中的数据在单元格内靠左对齐。

居中：操作本选项将使选定数据在单元格内居中对齐，操作同上。

右：本选项使选定数据在单元格内靠右对齐,操作同上。

填充：本选项选定数据在单元格内重复复制,直至将本单元格充满。

跨列居中：选定某合并单元格,单击本按钮,使其中的数据处于该合并单元格的绝对居中位置。

２．２．垂直：该选项用于设置垂直方向的对齐关系,有以下几个选项：

靠上：该选择使选定数据沿单元格顶端对齐。

居中：使选定数据位于单元格垂直居中位置。

靠下：使选定数据沿着单元格底端对齐。

自动换行：选定某单元格(区域),单击本选项,那么如果您在本单元(区域)所输入的数据超过其显示范围,系统将这些数据自动进行换行处理。

字体：单击“字体”按钮,弹出窗口。一般包含以下项目：

１．字体：该选项框提供若干种字体,用户只需选定某单元格(区域)然后单击其中某种字体,则您所选区域中的文字都变化为所设定的字体。

２．字体风格：在这里可以设置多种风格,如：常规,加粗,斜体, 加粗斜体,其操作过程同字体设置。

３．大小：设置字体的字号，从而改变字体的显示大小。

４．特殊效果：在此处设置了删除线和下划线两个选项。

５．颜色：此处提供多种颜色选择，通过色彩的设置，可使用户的报表更加精致美观。

边框：单击“边框”按钮,弹出窗口。该功能一般用于设置选定区域的边框。包括边框的线型、颜色。首先从提拱的多种线型选择一种,然后从若干种颜色中挑选出用户所需要的,最后再选择边框类型。具体操作类似EXECL的边框设置。

行：该选项一般包含以下几个选项：

１．行高：该选项用于更改行高。

２．最适合行高：选定需要更改行高的行，单击“最适合行高” 系统将选定行行高设置为最适合当前字体的高度。

３．行隐藏：该选项用于隐藏活动单元格所在行或选定的多行，使其不在屏幕上显示。

４．行隐藏取消：该选项用于恢复被隐藏的行；选定被隐藏区域，单击本菜单选项，可恢复被隐藏行。

列：该选项操作类似行的操作。只是对列起作用而已。如：列宽、最适合列宽、列隐藏、列隐藏取消等。

工作表：工作表用于定义报表的显示设置。一般包含以下项目：

１．表格数据：该域包括“公式”，“网络线”，“零值”，“行号”，“列标”等多个选项，如果用户想在报表界面中显示其中某项内容，就需单击该选项，使之左侧选项框打上“√”标志，这就表明该项目将显示。

２．滚动条：分为垂直滚动条和水平滚动条，可以将其设置为“自动”，“打开”，“关闭”三种状态。

２．１．自动状态：滚动条在常规状态下不显示，当单击滚动条所在位置时，滚动条会弹出。

２．２．打开状态：滚动条始终处在显示状态。

２．３．关闭状态：滚动条不显示。

选择：该选项用来设置是否能够对单元格进行选定，从而进行相关操作，它同样也分为“自动”，“打开”，“关闭”三种状态；通过这种方式来限制对报表的操作。

表格范围：该域是用来显示报表大小所能达到的最大范围，用户可以根据报表的实际行、列数在此处输入适当的数字。

视图比例：可根据用户的需要，设置不同比例，来浏览报表。

固定行、固定列：在通过滚动条浏览报表时，如果您需要固定某一行或某一列来对照阅读后面的数据，就可以在此处进行相关定义。例如需要固定A、B、C叁列，操作如下：在“固定列”一栏中输入“$A:$C”然后单击“确定”即可。固定行通过同样的操作也可以达到要求。

报表：该选项页一般包括如下标签页：

１．计算：

１．１．自动计算：报表的计算结果系统自动生成。

１．２．手工计算：报表的计算结果需单击“计算”按钮才生成。

１．３．反复操作：设定报表是否允许循环操作。

１．４．最大迭代次数：设定报表所允许的最大循环次数。

１．５．最大误差：设定报表数据计算的最大误差值。

１．６．显示精确值：设定报表数据显示的精确值。

２．广义表定义与自动填充：在报表中可能需要填入一月、二月、三月直至十二月这样有规律排列的词组，如果逐个输入，显然比较麻烦，某些财务软件提供如下简便操作：在“广义表”下拉框中选择月份这条记录后，单击“确认”，退回到报表窗口，用户只要输入头一个词组“一月”，然后鼠标点中该词组所在单元格右下角交点拖动至某单元格，则鼠标拖动所覆盖区域已自动将一月以后的月份填充上去。在“广义表”下拉框中已经存储了一些类似词组，而且，用户可以通过“当前广义表”编辑框，输入其它一些类似词组，以便以后操作。

３．颜色：通过该选项，可以调整调色板(包括线条和底纹)的颜色。

合并单元格：该选项用于将若干个单元格合并为一个单元格。

拆分单元格：该选项是“合并单元格”的反操作。选定被合并的单元格，选择本操作，则已合并的单元格恢复原样。

六、报表的数据

公式定义：选定某单元格,选择本操作,则进入该活动单元格的“单元公式定义”状态。

♥电算专家

目前几乎所有的财务软件的报表系统的公式定义都是采用“公式导航”来引导用户进行公式的设置。这种通过“公式导航”进行公式设置的方式几乎成为了一种行业标准。其实，公式定义是报表系统中非常重要的部分。用户可以从两方面考查其功能的好坏与强弱。一方面看公式导航是否直观、是否符合会计人员的思维定势与操作习惯；另一方面看公式导航提供的公式是否足够，多并不代表足够，能够满足外部及内部报表的编制要求、特别是满足内部管理报表的编制要求，能够从账务系统以外的系统取数，能够允许用户自定义公式的公式导航才算是比较足够的。

重新计算：当报表设置完毕计算出结果后,发现某处错误,为了进一步验证, 选择“重新计算”操作。

稽核定义：此功能用于设置报表的稽核项目。每个稽核项目可以通过若干稽核公式的定义完成。稽核公式的定义过程类似于报表公式的定义过程。

报表稽核：此功能用于报表的稽核检验。也就是执行稽核定义中的所有稽核公式。可能出现两种情况。

１．稽核成功：稽核公式成立，系统提示“稽核成功”。

２．稽核不成功：稽核公式不成立，系统弹出“稽核报告”显示稽核不成功的有关项目列表。用户可以循着这些线索,进行查证修改,直至最后稽核成功。

报表属性：

１．常规：在“常规”页状态下,系统为您显示当前报表的有关信息,如：报表名称,报表单位,报告期间,报表属主等。

２．共享：在“共享”页状态下，系统允许用户设置报表的共享属性，一般可以分成四类:

２．１．不共享: 设置为不共享,使其他任何用户不能进入当前报表。

２．２．只读共享: 选择“只读共享”, 用户就需要在“只读密码”对话框内输入密码;那么只有掌握了该密码的用户才能阅读当前报表,但不能进行增、删、改等操作。

２．３．完全共享: 选择“完全共享”, 用户就需要在“完全控制密码”对话框内输入密码; 那么只有掌握了该密码的用户才能进入当前报表进行完全操作。

２．４．根据密码访问: 选定“根据密码访问”, 用户就必须在“只读密码”和“完权控制密码”两栏内分别输入一个密码, 那么其他用户进入当前报表使用的是哪一个密码, 他就只有与之相应的权限。此时 “只读密码” 和”完全控制密码” 不能相同。

保存报表项目：报表项目可以理解为报表单元格的别名，定义报表项目有利于表间与表内逻辑运算的实现。此操作将当前报表中定义的报表项目名称进行归集保存，以便定义其他报表使用。

♥电算专家

报表项目的主要功能是支持表间与表内的逻辑运算。所谓逻辑运算是指该类运算符可以与报表的物理位置无关，只与报表项目有关。报表物理格式的差别和变化不影响基于报表项目的逻辑运算。从而使跨行业的格式不同的会计报表进行自动汇总成为可能，且汇总设置方便简单。

查询详细资料：此功能提供报表、账簿、凭证的一体化穿透性查询。

♥电算专家

在手工会计操作中，报表的查询核对往往需要结合账簿、凭证，三者相互印证。所谓报表、账簿、凭证三位一体的穿透性查询是指打开某张报表，在报表中选定某栏需查询的数据（非合计栏），选择“查询详细资料”操作，系统就会弹出选定单元格有关科目的科目余额表窗口。选定其中某科目，单击“明细账”按钮，则系统弹出被选科目明细账窗口。在明细账中选定某条发生记录，单击“凭证”按钮，系统弹出该张凭证窗口。在穿透查询的过程中，处于任一窗口，您都可以单击“退出”按钮回到上一窗口；也就是说，您可以在几个状态之间任意切换，最大限度保证您查对方便。并且在追溯过程中的各个窗口的原有功能均得到完全保持。

☻脚下留神

报表、账簿、凭证三位一体的穿透性查询这种功能非常有用。但是，目前市面上流行的财务软件具备完整的此项功能的并不多。

七、报表的工具

锁定行(锁定列)：这两项命令的操作效果与格式菜单中的“工作表”选项中的“固定行”、“固定列”相同,但是其操作较前者简单。首先选定需锁定的行（列），然后单击工具菜单的锁定行（列）即可。如果您想取消以上操作，只需再次进入工具菜单单击“取消锁定行（列）”。

绘图：用户可以选择直线、矩形、椭圆、圆、多边形、图表等绘图方式在报表中进行绘图。

保护：该选项设置的报表保护功能对该报表的所有操作者都发生作用，而不论操作者是其他用户还是以编报者身份进入当前报表，所以我们可以称其为“绝对保护”。关于该功能的操作及应用已在第二节：报表的定义之一、报表的注册之报表的保护中讲述过。

计算器：单击此选项，系统会弹出“计算器”窗口。用户可以在任何需要的时候，选择使用，并通过它回填计算结果。

表页选择：如果用户的报表附有图表页，那么可以通过此命令进行各图表页之间的来回切换，单击工具菜单中的“表页选择”按钮，弹出“表页选择”窗口。在该对话框中选择某一报表页，然后单击确认，即可将界面切换到选定页的窗口。

文件传送与文件接收：为了方便用户之间的信息交流,财务软件一般都要或多或少地提供文件传送与文件接收的功能。这种传送与接收未必只针对报表文件，也可以使用于其它类型的文件。当然，支持文件传送与文件接收的方式很多。比如：通过点对点的通讯方式、通过电子邮件的方式等。


报表的生成

第三节：报表的生成

♠咨询顾问

一张报表定义好了，将它保存起来。此时报表的编辑工作就基本上完成了。至于报表内容是否正确、格式是否美观就是进一步的工作。

格式是否美观，我们自己可以一眼就看出来。当然，这里还涉及一个设计者与使用者的审美观问题。相对来说，内容是否正确是一个更重要的问题。内容是否正确主要是指报表公式定义是否正确。严格地说，内容是否正确包含两方面的因素：一是语法；二是语义。这两种问题类似于任何一种有文字的语言使用中的语法与语义问题概念一样。所谓语法问题就是指报表公式是否按报表系统的公式使用规范使用公式，比如：代表公式名称的字母是否拼错，公式需要的变量是否足够等。所谓语义问题就是指所引用的报表公式是否正确地表达了需要表达的意义。

对于目前大多数财务软件，语法问题已经得到了比较妥善的解决。比如：提供公式向导帮助用户完成公式定义过程，从而减少有可能出现的语法错误；在公式保存之前系统自动进行语法检查，确保保存成功的报表不会出现语法错误等等。语义问题就比较麻烦了，因为语义方面的错一般是用户不能有效地理解报表项目的内涵或不能有效地掌握报表公式的使用造成的。就好象一篇文章字字都没有错，但看过的人都不知道说了什么一样。报表的语义问题用户必须借助于报表生成及相关功能来加以解决。

报表生成又可以称为报表计算，就是根据报表定义阶段定义好的格式和公式生成最终的报表。作为用户，我们没有必要去探究计算机是怎样处理的，我们只要知道我们需要什么，我们可以通过公式让电脑帮助我们找出来，放到我们要放的位置就行了。本书不是一本介绍程序设计的书。也不准备过多地介绍报表生成。作为使用者，关于报表生成我们主要关注以下几点就可以了：

报表计算迭代次数：一般来说，报表计算过程中报表项目都要按一定的顺序依次计算。但是，为了某些特殊需要，往往存在迭代运算的现象，例如：位于计算顺序前面的单元要到位于后面的单元取数、合计数的位置位于明细项的前面等等。这些问题的解决都有待于迭代运算来解决。目前大多数软件都有一个最大迭代次数的设置来设定报表迭代运算的次数。其实，最好的解决方案是让软件自动判断，智能控制是否需要迭代运算、需要多少次迭代。

报表计算误差控制：任何计算都有计算误差控制问题，报表计算也不例外。财务软件误差控制方式基本相同。

报表项目自动计算：报表项目自动计算是指定义公式完毕，系统立刻按公式计算并将结果回填。此功能并非每个财务软件都具备。

重新计算：强制性要求报表彻底重新计算一遍。

报表验证的运算：报表验证是指用户对报表某一单元格的数据有输入限制，可通过报表验证设置，以后，在此单元格键入数据时，如果该数据违返了设置的规则，系统就会出现报警提示。例如：将两个不同的数据单元格进行数值比较的验证，当条件满足时，验证通过，否则验证失败，系统就显示失败提示。

报表稽核的运算：报表稽核是指用户对报表应成立的勾稽关系进行的检查。大多数财务软件的报表稽核都是通过稽核项目的定义（稽核项目又通过稽核公式的定义）来完成的。一般都有对应设置报表稽核项目和启动报表稽核的按钮完成报表稽核的运算。详情请参见六、报表的数据之稽核定义与报表稽核两项。


报表与其他子系统的关系

第四节：报表与其他子系统的关系

现代财务软件的报表系统一般都是一个通用型的工具性电子表格系统。报表系统可以从财务软件的任意子系统取数；可以按用户的个性化要求定制专门化取数接口；可以按用户规定的格式和报送方式自由地设置。比如：报表系统可以从账务系统中取得各种账簿数据（余额、发生额等），甚至还可以从记账凭证取得数据。报表系统还可以从其它子系统如：工资核算系统、固定资产核算系统、材料核算系统、成本核算系统、产成品核算系统、销售核算系统取得与业务有关的数据，生成有关某类业务的报表或某几类业务的综合报表。

♥电算专家

其实各个业务系统都拥有一定数量的业务报表。一般来说，业务系统的报表我们称之为专用报表，它只能完成该业务范围内有限变动因素报表编制的需求，有些软件的这类报表的格式与数据来源基本上是固定的或只能做有限变动的。作为工具性的通用型报表系统与专用报表相比具有完全不同的风格。通用型报表系统的报表格式是用户自由设置的；通用型报表系统的数据是通过一套完整的公式定义取得的。从这两方面考察。我们不难得出一个结论：通用型报表系统的灵活性大，同时使用难度也较专用报表大。


报表高级功能

第五节：高级功能

随着会计电算化的进一步发展，报表系统的功能不断得到提高和丰富。主要表现在两个方面。首先，报表系统原有功能得到扩充与升华；其次，报表系统新增了许多功能。以下主要介绍这两方面的突破。

一、报表数据预览

传统会计遵循一个会计传统，即所有凭证登账后才能生成报表，然后进行相应的财务分析；这样，由于信息反馈的滞后性，使得单位决策层不能及时掌握企业的财务状况，从而影响企业的经营运作，造成不必要的损失。目前许多财务软件的报表系统都增设有报表数据预览功能。报表数据预览是指只要账务凭证已录入，即使未审核登账，也不管是否结账，即可完整地动态生成各种管理会计报表。有利于随时掌握本单位的财务状况，作出及时、科学的决策。报表数据预览功能是通过一个称为“是否包含未登账凭证”的开关来实现的。回答“是”，则包含未登账凭证的所有凭证数据进入报表；从而满足用户随时查询报表、把握公司状况的需求。

二、穿透查询

在传统会计中，报表的查找核对往往需要结合各种账簿、凭证，三者相互参照对比印证。目前，有一部分财务软件提供有一种报表、账簿、凭证三位一体的穿透性查询功能。可以有效的解决这种需求。具体过程大致如下：打开某张报表，在报表中选定需查询数据（非合计栏）详细来源的某栏，单击菜单中的“穿透查询” 菜单或单击图表按钮，系统弹出选定单元格有关科目的科目余额表窗口。选定其中某科目，单击“明细账”按钮，则系统弹出被选科目明细账窗口。在明细账中选定某条发生记录，单击“凭证”按钮，系统弹出该张凭证窗口。在穿透查询的过程中，无论处于哪个窗口，用户都可以单击“退出”按钮回到上一窗口；换句话说，用户可以在几个状态之间任意切换，最大限度保证查对方便。

☻脚下留神

此处介绍的“穿透查询”功能，对于使用者来说是非常有实用价值的，但并非每个财务软件的报表系统都有提供，应该说，具备此项功能的财务软件并不多。用户在选购财务软件的时候不妨多留意一下。

三、图表页

该功能的作用在于制作报表的附件以及将报表中的数据通过各种丰富的图表形象地描述出来。单击菜单中的“图表页”，系统弹出一空白报表，您可以在此输入附件内容，或制作主表的各种图表格式。图表页的数据与主表的同步更新。一般来说，图表表现方式比较直观、生动、形象。图表页的制作过程比较复杂，并且不同的软件有不同的实现方式。主流的财务软件一般都是通过类似公式导航的方式实现的。

四、二次开发工具

１．自定义批命令：所谓命令就是告诉计算机执行某动作的一个指令，所谓批命令就是把多个命令集中在一起，让计算机连贯地依此执行每条命令的处理，即在一个批命令文件中可以编写多个命令，执行这个批命令文件就可以一次性完成这些命令。批命令在许多时候是必不可少的。大部分命令和函数均可在批命令中使用；批命令可以嵌套、递归和带参调用；批命令还可以在批命令和自定义菜单中调用。批命令文件可以在命令编辑窗口中编写，编写完成后可以以独立文件方式保存。

２．自定义菜单：是由用户编写的，用以实现特定功能和操作流程的菜单，它可以取代系统菜单和报表菜单。自定义菜单在菜单编辑窗口中编写，编写完成后以独立文件方式保存。在系统窗口或报表窗口中可以执行菜单文件，执行之后它将取代系统菜单和报表菜单。

３．自定义公式：是由用户编写的，以公式的方式实现特定功能的操作。自定义公式在公式编辑窗口中编写，编写完成后可以添加到系统的公式组中，其使用方式和方法与其它公式类似。

４．自定义函数：是由用户编写的，以函数的方式实现特定功能的操作。自定义函数在函数编辑窗口中编写，编写完成后可以添加到系统的函数组中，其使用方式和方法与其它函数类似。

☻脚下留神

二次开发工具所包含的四项工具是财务软件报表系统的高级功能，用户使用起来有一定的难度。但其作用是显然的。如果您对报表系统有特殊的要求，就应该考察您正在或准备使用的财务软件的报表系统是否提供二次开发工具。目前市面上全面提供四项工具的软件非常少。

五、安全性机制

在计算机应用越来越普及的今天，人们越来越关心保存在计算机中的信息安全性。现代财务软件的报表系统顺应潮流，及时增加了增强报表安全性的功能。概括起来可以包括以下种类：

一、系统级操作权限控制

财务软件都提供有操作员操作权限的设置功能。通过操作权限的设置可以达到对报表系统功能级操作权限的控制。

二、报表级共享保护控制

报表定义者可以设置共享属性，即可以独占报表，也可以将报表与其他人共享；对设置为共享的报表还可以就报表的读、写共享分别设置密码保护，只有提供密码才能进行相关的读、写操作。

三、单元格级锁定与隐藏控制

报表可设置某单元格或某单元格区域的数据、格式的锁定和公式的隐藏，还可使用只读方式打开。

以上安全性控制，用户应根据报表信息的保密程度加以有效应用。切记不要滥用。控制越细，保密程度越高，操作越繁。

☻脚下留神

在让安全性控制成为窃取商业机密者无法逾越的屏障的同时，不能让它成为妨碍自己的枷锁。

可以肯定报表系统的功能还会随着会计电算化的深入发展在深度和广度上得到不断的提高和扩展。本章只是在一些已经取得突破方面作了一些概括性的论述，让我们共同期待着更优秀、更理想的报表系统的来临。


清楚自己的需要

第八章：最后的忠告

“船到码头车到站”，到了第八章，最后一章。掩卷沉思，您是否对财务软件有了更深入的认识？您是否觉得自己已经可以对财务软件“指点江山，激扬文字”甚至“粪土当年万户侯”？让我为您再快马加一鞭、锦上添一花。

第一节：清楚自己的需要

如果我们对什么事没有十足的把握，采取的政策往往是“走一步、看一步”或者“到什么山、唱什么歌”。其实，购买财务软件大可不必如此。只要您充分了解自己的需求，知道自己要的是什么样的财务软件，就再也不会犹豫不决了。

如果您想清楚自己的需要，您将以下几个问题问一问自己，就可以帮助您得出比较理想的答案。

一、我的需求是什么？

二、财务软件能帮助我做什么？

三、使用财务软件要达到什么总体目标？

♥管理专家

总体目标至少应分解为三个分目标:即最低要求是什么？，中期计划如何？、最高目标是什么？

四、我的情况怎么样?

♥管理专家

自身的情况主要包括企业的业务量大小，企业领导对财务软件的接受程度及对财务管理的要求，企业购买力状况，企业会计人员的素质等方面。


咨询的价值

第二节：咨询的价值

通过以上问题的分析，如果您对自己的需求还不能准确地把握、想更清楚地知道自己的需求，不妨进行一些有益的咨询，并在咨询过程中逐步求精自身的需求。咨询的渠道有以下几个方面：

一、向已经使用了财务软件的其它企业咨询

二、向已经使用了财务软件的同类企业咨询

三、向财务软件厂商咨询

四、向财务软件经销商咨询

五、向提供咨询服务的专业机构咨询


货比三家

第三节：货比三家

当您明确了自己的需求，并制定了详细的计划准备实施会计电算化时。别忘了“货比三家”的古训。

目前，财务软件市场非常繁荣，已是买方市场。各企事业单位有条件也有必要在多个软件中进行比较和筛选。


成功的个案

第四节：成功的个案

再好的软件也必须看到成功的案例。因为，成功的案例是信心的保障；最好的案例是业务类似、规模类似、管理水平类似的成功应用。


试用的价值

第五节：试用的价值

有一个成语“橘化为枳”相信大家都知道它的意思。同样，一个软件在一个企业用的好，把他搬到另一个企业就不一定能用的好了。因此，软件试用是绝对有必要的一件事情。当然，软件的试用（或叫试运行）不是一件非常简单的事情。在投入一定的人力和物力的同时，更应讲究试用的艺术。

♥管理专家

试用主要讲究以下几点：（一）、抓住企业关键的业务进行试用；（二）、抓住企业局部的业务进行试用；（三）、抓住企业个性化的需求进行试用；（四）、试用必须有适宜的物力、财力和人力的投入；（五）、务求得到可信的结论。


最高原则

第六节：最高原则

说一千、道一万，要用好财务软件务必遵守以下几条最高原则：

一、满足需求

所选用的财务软件一定能满足企业的财务核算与管理的需求。否则，一切免谈。

二、性能价格比最优

性能价格比是指在满足规定性能指标的前提下考虑所支付的成本。追求性价比最优的方案。

三、售后服务良好

买软件，就是买服务。服务有口皆碑的软件就是好软件，服务没有保障的软件就值得考虑。当然，随着软件市场的进一步规范和发展，服务也是有价的。

四、总体拥有成本最低

软件的应用包括购置成本和维护成本，软件有别于其他商品的最大特征就是其维护成本远远高于购置成本。根据软件工程的理论，在软件的整个生命周期中，维护成本大体上是购置成本的四倍左右，也就是说，在软件的总体拥有成本中购置成本只占了20%左右，而维护成本占了80%左右。软件的应用追求总体拥有成本最低，财务软件也不例外。

♣电脑专家

软件的维护成本是可以进行有效控制的。简单的说，要使软件保持良好的运行状态就必须在以下几个方面下足工夫。（一）、硬件维护：指保持计算机硬件良好运行所支付的人力、物力的开支。（二）、软件维护：包括系统软件如操作系统、数据库系统、网络系统的维护和应用软件的正确性、适应性和完善性维护。（三）、数据维护：指对业务数据的编码与备份维护。各方面都要结合企业实际状况进行有效的管理和控制，就可以有效地控制维护成本。


选购之后．．．．．．

第七节：选购之后．．．．．．

财务软件选定并开始启用之后，请大家记住这还只是万里长征的第一步。后面还有更多更艰巨的工作等着我们去克服。因为，企业管理无止境，财务管理无止境，自然财务软件的应用也无止境。

♥管理专家

计算机会计信息系统是一个人机系统，其中会计人员和计算机系统必须相互配合才能有效地完成系统的既定目标。在计算机会计信息系统中，会计软件处理流程和会计人员工作业务流程往往需要不断地协调才能保持步调一致。因此，它们有着共同的创新内容。

会计工作作为一种管理活动，应当与其它业务流程创新共同进行，这样才能完成企业管理的整体改造。下面，我们简单地介绍管理业务流程创新技术──管理过程再造：

管理过程再造（BPR，Business Process Reengineering）是应用企业再造工程（Reengineering the Corporation）管理理念的一种管理业务流程创新技术。其有以下几个特点：

（一）、根本性：管理过程再造强调对管理业务流程进行根本性的改变，要求通过提出“为什么我们要做现在正在做的事情”这样的质疑重新审视整个企业的原有管理业务流程，要求彻底打破企业旧的业务模式和常规形式。（二）、关键性：为了创造性的使用信息技术，管理过程再造强调要对各种管理业务流程产生的问题进行追根溯源，找出关键因素和步骤。（三）、戏剧性：管理过程再造强调进行业务流程改造要有远大的目标，其目的是为了大幅度提高管理的工作效率，而非少许的改善。（四）、过程导向：用信息系统过程的观点，即所有管理业务都是输入、转换和输出构成的过程，来指导整个管理过程再造工程。

许多发达国家的大公司在实践中已经全部或部分地进行了管理再造过程，如福特公司。

80年代初期，福特公司的美国总部有500名会计出纳人员，为了提高效率，引入了计算机系统，结果减少了100人。福特公司本以为这样已经是大大降低了人工成本。但是，当公司的领导者了解到日本的马自达公司只有5名会计时，他们震惊了。为了达到同样的管理水平，充分发挥计算机系统的效率，他们重新审视了整个工作过程和内容，他们找出了很多延续的传统做法是完全不必要的。为此，他们引入了大型数据库管理系统，根据计算机系统应用的需要，重新改造了整个工作过程。这一举措，使其员工人数减少了75%，也使公司的计算机系统真正发挥了效率：整个业务流程所耗费的时间大大缩短，工作效率成倍提高。


上机实验要求

上机实验步骤及要求

  1、根据资料1，选择企业类型和本位币，建立新账套，账套名称设置为“紫牛公司”+学号，建账年月设为：2002年12月。

  2、根据自己的实际情况设置用户并赋予权限。

  3、根据资料2，设置记账凭证类型。

  4、根据资料3，设置部门代码。

5、根据资料4，设置外币代码及其汇率。

6、根据资料5，设置有关项目。

7、根据资料6，设置公司主要往来客户。

8、根据资料7、8、9，设置科目代码及其属性。

9、根据资料7、8、9，输入初始数据。

10、根据资料10、11、12、13输入记账凭证（包括设置自动转账凭证），并进行有关的账务处理。

11、设置和查询“管理费用”、“应交税金-应交增值税”的多栏式明细账。进行其它总账、明细账、辅助账、数量金额账、试算表、科目余额表的查询。

12、注意年末结帐与月末结帐的差异。

13、利用报表模板编制资产负债表、损益表。

14、根据资料14、15的基本格式，利用软件的报表定义功能，自定义有关的内部管理报表。


资料1

资料 1：模拟实验紫牛公司的基本情况

紫牛公司为一家工业企业，该公司为一般纳税人，记账本位币为人民币。其下属有一个生产部门，下设有两个基本生产车间和两个辅助生产车间。在两个基本生产车间中，一车间生产P1和P2两种产品，二车间生产产品P3和P4两种产品。两个辅助生产车间分别为机修车间和供汽车间。

该企业原材料核算采用计划成本法：产成品核算采用移动平均法；成本计算采用品种法。

资料2：记账凭证类型

紫牛公司财会部门的记账凭证类型有记账一种。

资料3：部门一览表

（部门核算的目的是为了对部门的办公经费或一般费用进行控制，不包括工资、福利费以及直接的产品成本、销售成本、销售费用中的经费。）

代码 | 部门名称
001 | 行政管理部门
00101 | 经理办公室
00102 | 财务部
00104 | 物资及采购部
00105 | 市场营销部
002 | 生产部
00201 | 厂部
00202 | 一车间
00203 | 二车间
00204 | 机修车间
00205 | 供汽车间

资料4：外币汇率一览表

代号 | 名称 | 各 期 汇 率
 |  | 2002年初 | 2002年11月末 | 2002年12月末 | 2003年1月末
USD | 美元 | 8.21 | 8.21 | 8.23 | 8.22
HKD | 港元 | 1.06 | 1.06 | 1.08 | 1.07

资料5：项目及其对应科目一览表

项目代号 | 项目名称 | 进行项目核算的科目代码
001 | 在建工程 | 169、170
00101 | 出包工程 |
0010101 | 行政办公楼 |
0010102 | 集体宿舍 |
00102 | 自营工程 |
0010201 | 安装工程 |
0010202 | 职工食堂 |
002 | 生产成本 | 401011、401012、401013
00201 | P1产品 |
00202 | P2产品 |
00203 | P3产品 |
00204 | P4产品 |

资料6：公司主要往来客户一览表

客户代码 | 客户名称 | 简要说明
101 | 双凌有限责任公司 | 供应商
102 | 富岗公司 | 业务合作伙伴
10201 | 富岗（广州）分公司 | 以人民币结算
10202 | 富岗（深圳）分公司 | 以港元结算
103 | 净方有限责任公司 | 客户，以美元结算
104 | 天脉实业有限公司 | 供应商
105 | 自力百货商场 | 客户
106 | 灵虎百货商场 | 客户
107 | 大辉公司 | 业务合作伙伴
108 | 天元公司 | 客户


资料7

资料7：科目代码及其初始本位币金额一览表

说明：外币、数量、往来、部门和项目栏中“✓”表示对应科目设置该属性；会计科目代码栏没有代码的，不是科目设置的内容，而是有关的辅助核算项目。

科目 代码 | 科目名称 | 余额方向 | 余额 | 往 来 | 项 目 | 部 门 | 外 币 | 数 量
101 | 现金 | 借 | 5600 |  |  |  |  |
102 | 银行存款 | 借 | 2085339 |  |  |  |  |
1021 | 工行理桥办 | 借 | 1327069 |  |  |  |  |
1022 | 中行理桥办 | 借 | 697850 |  |  |  | ✓ |
1023 | 中行天河办 | 借 | 60420 |  |  |  | ✓ |
109 | 其他货币资金 | 借 | 20000 |  |  |  |  |
1091 | 银行本票存款 | 借 | 20000 |  |  |  |  |
1092 | 银行汇票存款 | 借 |  |  |  |  |  |
111 | 短期投资 | 借 | 30000 |  |  |  |  |
11101 | 债券投资 | 借 | 30000 |  |  |  |  |
11102 | 股票投资 | 借 |  |  |  |  |  |
112 | 应收票据 | 借 | 35000 | ✓ |  |  |  |
 | 天元公司 |  | 35000 |  |  |  |  |
113 | 应收帐款 |  | 53019 |  |  |  |  |
11301 | 人民币户 | 借 | 5213 | ✓ |  |  |  |
 | 灵虎百货商场 |  | 2450 |  |  |  |  |
 | 大辉公司 |  | 2763 |  |  |  |  |
11302 | 港元户 | 借 | 47806 | ✓ |  |  | ✓ |
 | 富岗（深圳）分公司 |  | 47806 |  |  |  |  |
11303 | 美元户 |  |  | ✓ |  |  | ✓ |
114 | 坏帐准备 | 贷 | 159.19 |  |  |  |  |
115 | 预付帐款 |  | 296846 |  |  |  |  |
11501 | 人民币户 | 借 | 4570 | ✓ |  |  | ✓ |
 | 富岗(广州)分公司 |  | 4570 |  |  |  |  |
11502 | 港元户 | 借 |  |  |  |  |  |
11503 | 美元户 | 借 | 292276 | ✓ |  |  | ✓ |
 | 净方有限责任公司 |  | 292276 |  |  |  |  |
119 | 其他应收款 | 借 | 2340 |  |  |  |  |
121 | 材料采购 | 借 | 4200 |  |  |  |  |
121001 | 甲材料 | 借 |  |  |  |  |  | ✓
121002 | 乙材料 | 借 | 4200 |  |  |  |  | ✓
121003 | 丙材料 | 借 |  |  |  |  |  | ✓
123 | 原材料 | 借 | 313822.5 |  |  |  |  |
123001 | 甲材料 | 借 | 173502 |  |  |  |  | ✓
123002 | 乙材料 | 借 | 65110.5 |  |  |  |  | ✓
123003 | 丙材料 | 借 | 75210 |  |  |  |  | ✓
129 | 低值易耗品 | 借 | 2300.6 |  |  |  |  |
131 | 材料成本差异 | 借 | -244.4 |  |  |  |  |
131001 | 甲材料 | 借 | -324 |  |  |  |  |
131002 | 乙材料 | 借 | 45.6 |  |  |  |  |
131003 | 丙材料 | 借 | 34 |  |  |  |  |
137 | 产成品 | 借 | 1646562 |  |  |  |  |
13701 | P1产品 | 借 | 121278 |  |  |  |  | ✓
13702 | P2产品 | 借 | 89224 |  |  |  |  | ✓
13703 | P3产品 | 借 | 691400 |  |  |  |  | ✓
13704 | P4产品 | 借 | 744660 |  |  |  |  | ✓
139 | 待摊费用 | 借 | 3551 |  |  |  |  |
151 | 长期投资 | 借 | 42615.44 |  |  |  |  |
151001 | 长期股权投资 | 借 |  |  |  |  |  |
151002 | 长期债权投资 | 借 | 42615.44 |  |  |  |  |
161 | 固定资产 | 借 | 3575780 |  |  |  |  |
165 | 累计折旧 | 贷 | 13678 |  |  |  |  |
166 | 固定资产清理 | 借 |  |  |  |  |  |
169 | 在建工程 | 借 | 592091 |  | ✓ |  |  |
 | 行政办公楼 |  | 342021 |  |  |  |  |
 | 集体宿舍 |  | 232057 |  |  |  |  |
 | 安装工程 |  | 5690 |  |  |  |  |
 | 职工食堂 |  | 12323 |  |  |  |  |
170 | 工程物资 | 借 | 9970 |  | ✓ |  |  |
 | 安装工程 |  | 1340 |  |  |  |  |
 | 职工食堂 |  | 8630 |  |  |  |  |
171 | 无形资产 | 借 |  |  |  |  |  |
181 | 递延资产 | 借 | 4560 |  |  |  |  |
191 | 待处理财产损溢 | 借 |  |  |  |  |  |
19101 | 待处理流动资产损溢 | 借 |  |  |  |  |  |
19102 | 待处理固定资产损溢 | 借 |  |  |  |  |  |
201 | 短期借款 | 贷 | 600000 |  |  |  |  |
202 | 应付票据 | 贷 |  | ✓ |  |  |  |
203 | 应付帐款 | 贷 | 185838.9 |  |  |  |  |
20301 | 人民币户 | 贷 | 121308.3 | ✓ |  |  |  |
 | 富岗(广州)分公司 |  | 30010 |  |  |  |  |
 | 天脉实业有限公司 |  | 56704 |  |  |  |  |
 | 大辉公司 |  | 34594.3 |  |  |  |  |
20302 | 港元户 | 贷 |  | ✓ |  |  | ✓ |
20303 | 美元户 | 贷 | 64530.6 | ✓ |  |  | ✓ |
 | 净方有限责任公司 |  | 64530.6 |  |  |  |  |
204 | 预收帐款 | 贷 | 726060 |  |  |  |  |
20401 | 人民币户 | 贷 | 666700 | ✓ |  |  |  |
 | 自力百货商场 | 贷 | 340000 | ✓ |  |  |  |
 | 灵虎百货商场 | 贷 | 280000 | ✓ |  |  |  |
 | 大辉公司 | 贷 | 46700 | ✓ |  |  |  |
20402 | 港元户 | 贷 | 59360 | ✓ |  |  | ✓ |
 | 富岗(深圳)分公司 |  | 59360 |  |  |  |  |
20403 | 美元户 | 贷 |  | ✓ |  |  | ✓ |
209 | 其他应付款 | 贷 | 45050 |  |  |  |  |
211 | 应付工资 | 贷 | 345908 |  |  |  |  |
214 | 应付福利费 | 贷 | 468900 |  |  |  |  |
221 | 应交税金 | 贷 | 695263 |  |  |  |  |
22101 | 增值税 | 贷 | 16187 |  |  |  |  |
2210101 | 进项税额 | 借 | 7800 |  |  |  |  |
2210102 | 销项税额 | 贷 | 23987 |  |  |  |  |
2210103 | 已交税金 | 借 |  |  |  |  |  |
2210104 | 出口退税 | 贷 |  |  |  |  |  |
2210105 | 进项税额转出 | 贷 |  |  |  |  |  |
22102 | 应交所得税 | 贷 | 679076 |  |  |  |  |
22103 | 应交城建税 | 贷 |  |  |  |  |  |
223 | 应付利润 | 贷 |  |  |  |  |  |
229 | 其他应交款 | 贷 |  |  |  |  |  |
2291 | 应交教育费附加 | 贷 |  |  |  |  |  |
231 | 预提费用 | 贷 | 4534 |  |  |  |  |
23101 | 租金 | 贷 |  |  |  |  |  |
23102 | 保险费 | 贷 |  |  |  |  |  |
23103 | 借款利息 | 贷 | 4534 |  |  |  |  |
23104 | 修理费用 | 贷 |  |  |  |  |  |
23105 | 水电费 | 贷 |  |  |  |  |  |
233 | 待扣税金 | 贷 |  |  |  |  |  |
241 | 长期借款 | 贷 | 500000 |  |  |  |  |
24101 | 一年以上到期的长期借款 | 贷 | 500000 |  |  |  |  |
24102 | 一年内到期的长期借款 | 贷 |  |  |  |  |  |
251 | 应付债券 | 贷 |  |  |  |  |  |
25101 | 债券本金 | 贷 |  |  |  |  |  |
25102 | 债券利息 | 贷 |  |  |  |  |  |
25103 | 一年以上到期的长期借款 | 贷 |  |  |  |  |  |
261 | 长期应付款 | 贷 |  |  |  |  |  |
26101 | 一年以上到期的长期应付款 | 贷 |  |  |  |  |  |
26103 | 一年内到期的长期应付款 | 贷 |  |  |  |  |  |
301 | 实收资本 | 贷 | 4000000 |  |  |  |  |
311 | 资本公积 | 贷 |  |  |  |  |  |
313 | 盈余公积 | 贷 | 600590.05 |  |  |  |  |
321 | 本年利润 | 贷 | 548664 |  |  |  |  |
322 | 利润分配 | 贷 |  |  |  |  |  |
32202 | 盈余公积补亏 | 借 |  |  |  |  |  |
32203 | 提取盈余公积 | 借 |  |  |  |  |  |
32204 | 应付利润 | 借 |  |  |  |  |  |
32205 | 应交特种基金 | 借 |  |  |  |  |  |
32206 | 未分配利润 | 借 |  |  |  |  |  |
401 | 生产成本 | 借 | 11293 |  |  |  |  |
40101 | 基本生产成本 | 借 | 11293 |  |  |  |  |
401011 | 原材料 | 借 | 5045 | ✓ |  |  |  |
 | P2产品 |  | 2700 |  |  |  |  |
 | P3产品 |  | 2345 |  |  |  |  |
401012 | 直接工人工资 | 借 | 5793 | ✓ |  |  |  |
 | P2产品 |  | 3450 |  |  |  |  |
 | P3产品 |  | 2343 |  |  |  |  |
401013 | 制造费用 | 借 | 455 |  |  |  |  |
 | P2产品 |  | 210 |  |  |  |  |
 | P3产品 |  | 245 |  |  |  |  |
40102 | 辅助生产成本 | 借 |  |  |  |  |  |
401021 | 机修车间 | 借 |  |  |  |  |  |
401022 | 供汽车间 | 借 |  |  |  |  |  |
405 | 制造费用 | 借 |  |  |  |  |  |
40501 | 工资 | 借 |  |  |  |  |  |
40502 | 福利费 | 借 |  |  |  |  |  |
40503 | 折旧费 | 借 |  |  |  |  |  |
40504 | 修理费 | 借 |  |  |  | ✓ |  |
40505 | 办公费 | 借 |  |  |  | ✓ |  |
40506 | 供汽及水电费 | 借 |  |  |  | ✓ |  |
40507 | 物料消耗 | 借 |  |  |  | ✓ |  |
40508 | 劳动保护费 | 借 |  |  |  | ✓ |  |
40509 | 其它 | 借 |  |  |  | ✓ |  |
40510 | 低值易耗品摊销 | 借 |  |  |  |  |  |
40512 | 差旅费 | 借 |  |  |  | ✓ |  |
40513 | 费用分配 | 借 |  |  |  |  |  |
501 | 产品销售收入 | 贷 |  |  |  |  |  |
502 | 产品销售成本 | 借 |  |  |  |  |  |
503 | 产品销售费用 | 借 |  |  |  |  |  |
50301 | 工资 | 借 |  |  |  |  |  |
50302 | 福利费 | 借 |  |  |  |  |  |
50303 | 业务费 | 借 |  |  |  | ✓ |  |
50304 | 运输费 | 借 |  |  |  |  |  |
50305 | 装卸费 | 借 |  |  |  |  |  |
50306 | 包装费 | 借 |  |  |  |  |  |
50307 | 保险费 | 借 |  |  |  |  |  |
50308 | 展览费 | 借 |  |  |  |  |  |
50309 | 广告费 | 借 |  |  |  |  |  |
50310 | 物耗 | 借 |  |  |  | ✓ |  |
50312 | 差旅费 | 借 |  |  |  | ✓ |  |
504 | 产品销售税金及附加 | 借 |  |  |  |  |  |
505 | 销售折扣折让 | 借 |  |  |  |  |  |
511 | 其他业务收入 | 贷 |  |  |  |  |  |
512 | 其他业务支出 | 借 |  |  |  |  |  |
521 | 管理费用 | 借 |  |  |  |  |  |
52101 | 工资 | 借 |  |  |  |  |  |
52102 | 福利费 | 借 |  |  |  |  |  |
52103 | 物耗费 | 借 |  |  |  | ✓ |  |
52104 | 工会经费 | 借 |  |  |  |  |  |
52105 | 业务招待费 | 借 |  |  |  | ✓ |  |
52106 | 房产税 | 借 |  |  |  |  |  |
52107 | 车船使用税 | 借 |  |  |  |  |  |
52108 | 土地使用税 | 借 |  |  |  |  |  |
52109 | 印花税 | 借 |  |  |  |  |  |
52110 | 技术转让费 | 借 |  |  |  |  |  |
52111 | 无形资产摊销 | 借 |  |  |  |  |  |
52112 | 职工教育经费 | 借 |  |  |  |  |  |
52113 | 折旧 | 借 |  |  |  |  |  |
52114 | 待业保险费 | 借 |  |  |  |  |  |
52115 | 研究开发费 | 借 |  |  |  |  |  |
52116 | 坏帐损失 | 借 |  |  |  |  |  |
52117 | 其他 | 借 |  |  |  | ✓ |  |
52118 | 差旅费 | 借 |  |  |  | ✓ |  |
52119 | 办公费 | 借 |  |  |  | ✓ |  |
52120 | 低值易耗品摊销 | 借 |  |  |  |  |  |
52121 | 交际费 | 借 |  |  |  | ✓ |  |
522 | 财务费用 | 借 |  |  |  |  |  |
52201 | 利息支出 | 借 |  |  |  |  |  |
52202 | 手续费 | 借 |  |  |  |  |  |
52203 | 汇兑损益 | 借 |  |  |  |  |  |
52204 | 利息收入 | 借 |  |  |  |  |  |
52299 | 其他 | 借 |  |  |  |  |  |
531 | 投资收益 | 贷 |  |  |  |  |  |
541 | 营业外收入 | 贷 |  |  |  |  |  |
542 | 营业外支出 | 借 |  |  |  |  |  |
551 | 所得税 | 借 |  |  |  |  |  |

资料8：数量核算数据

科目代码 | 名称 | 单位 | 数量余额 | 单位成本
121001 | 甲材料 | 公斤 |  |
121002 | 乙材料 | 袋 | 2000 |
121003 | 丙材料 | 公斤 |  |
123001 | 甲材料 | 公斤 | 34020 | 5.1
123002 | 乙材料 | 袋 | 31005 | 2.1
123003 | 丙材料 | 公斤 | 25070 | 3
137001 | P1 | 件 | 35670 | 3.4
137002 | P2 | 件 | 2348 | 38
137003 | P3 | 箱 | 34570 | 20
137004 | P4 | 箱 | 35460 | 21

资料9：原币初始数据

科目代码 | 科目名称 | 客户名称 | 借贷方向 | 币种代号 | 原币金额
1022 | 中行理桥办 |  | 借 | USD | 85000
1023 | 中行天河办 |  | 借 | HKD | 57000
11302 | 港元户 | 富岗（深圳）分公司 | 借 | HKD | 45100
11303 | 美元户 |  | 借 | USD |
11502 | 港元户 |  | 借 | HKD |
11503 | 美元户 | 净方有限责任公司 | 借 | USD | 35600
20302 | 港元户 |  | 贷 | HKD |
20303 | 美元户 | 净方有限责任公司 | 贷 | USD | 7860
20402 | 港元户 | 富岗（深圳）分公司 | 贷 | HKD | 56000
20403 | 美元户 |  | 贷 | USD |


资料10

资料10：紫牛公司2002年12月经营业务资料

1、12月1日，上月向大辉公司购入的2000袋乙材料，单位成本2.1元，已验收入库。（凭证：1）

2、12月1日，向富岗（广州）分公司销售P3产品30000箱，单价21元，款项已经收到。（凭证：2）

3、12月1日，公司从双凌公司购入材料一批（增值税率为17%），其中：甲材料5000公斤，单价5元；乙材料1000袋，单价2元。财务部门开出一张六个月的商业承兑汇票，用于支付货款。另外，公司还用现金支付双凌公司运杂费2400元（其中甲材料分配运杂费2000元；乙材料分配运杂费400元，运杂费增值税率为10%）。（凭证：3、4、5）

4、12月1日，经理办公室报销办公费用590元，以现金支付。（凭证：6）

5、12月2日，向自力百货商场销售P1产品6000件，单价6元，款项尚未收到。（凭证：7）

6、12月3日，归还工商银行短期贷款600000元及利息8000元。（凭证：8）

7、12月4日，按工商银行收帐通知，应收天元公司的商业汇票35000元已经入帐。（凭证：9）

8、12月4日，接中行天河办收帐通知：富岗（深圳）分公司所欠货款HK$45100已经入帐。（凭证：10）

9、12月5日，从工商银行提取现金2000元，用于日常开支，现金支票＃991202。（凭证：11）

10、12月6日，一车间领用甲材料1000公斤，其中用于生产P1产品的有600公斤，用于生产P2产品的有400公斤。（凭证：12）

11、12月7日，根据合同，向富岗（深圳）分公司销售已经预收帐款的P3产品一批，共1400箱，单价HK$40，余款未收到。（凭证：14）

12、12月7日，二车间领用丙材料3000公斤，乙材料4000袋，全部用于P4产品的生产。（凭证：15）

13、12月9日，市场营销部门报销办公费用460元，业务费用4500元，业务招待费2000元，开出一张现金转账支票支付。（凭证：16）

14、12月11日，中行传来付款通知：所欠净方有限责任公司7860美元的款项已经划转。（凭证：17）

15、12月13日，职工食堂工程领用乙材料5000袋。（凭证：18）

16、12月14日，购入机器设备一台，价值160000元，须安装才能使用。（凭证：19）

17、12月15日，提取现金350000元，用以备发工资，支票991206。（凭证：20）

18、12月15日，以现金发放工资，金额345908。（凭证：21）

19、12月16日，厂部报销办公费127元，差旅费450元，以现金支付。（凭证：22）

20、12月19日，富岗（广州）分公司购P4产品4000箱，单价港元50元，货已发出，款项尚未收到。（凭证：23）

21、12月21日，实际成本为15000元的工程物资在职工食堂工程中被消耗使用。（凭证：24）

22、12月22日，二车间领用丙材料7000公斤，用于P3生产的有6000公斤，用于P4生产的有1000公斤。（凭证：25）

23、12月24日，计提本月工资，其中管理部门工资123451元，车间管理部门工资82056元，直接工资140401元，其中P1产品40400元，P2产品21051元，P3产品30950元，P4产品48000元，安装工程项目的1450元，职工食堂工程7346元。并按14%比例计提福利费。（凭证：26、27）

24、12月24日，上月开始安装的一部设备已经完工，设备实际成本共计6100元。（凭证：28）

25、12月25日，购买电脑三台，每台价值5000元，款项以用银行存款（工商行）支付。（凭证：29）

26、12月25日，开出转账支票一张＃991204，金额56704元，归还上月所欠天脉实业有限公司的货款。（凭证：30）

27、12月25日，物资及采购部人员张某预借差旅费3000元，以现金支付。（凭证：31）

28、12月25日，物资及采购报销办公费450元，业务招待费1200元，以现金支付。（凭证：32）

29、12月26日，总经理王某报销外地考察差旅费2120元，上月王某已经预借了差旅费2340元，余款王某以现金。（凭证：33、34）

30、12月27日，向已经预付货款的净方有限责任公司采购丙材料60000公斤，单价0.4美元，材料已经验收入库，预付款余款7520美元也已经通过银行转账退回。（凭证：35、36、37）

31、12月28日，各部门领用低值易耗品一批，其中经理办公室领用材料价值150元，物资及采购部领用120元，市场营销部领用210元，厂部领用230元。（凭证：38）

32、12月29日，销售P2产品给自力百货商场10000件，单价45元；灵虎百货商场7000件，单价50元。上述两家商场已经预付部分货款，余款还未收到。（凭证：39、40）

33、12月30日，生产车间及其各部门领用乙材料一批，其中生产P1产品领用3000袋，生产P2产品领用2000袋，生产P3产品领用3000袋，机修车间500袋，供汽水车间领用700袋，经理办公室领用材料价值领用100袋，物资及采购部领用40袋，市场营销部领用30袋，厂部领用220袋。（凭证：41）

34、12月31日，预提本月借款利息8000元。（凭证：42）

35、12月31日，计提各部门的折旧费，其中生产车间折旧2300元，行政管理部门折旧3400元。（凭证：43）

36、12月31日，结转材料成本差异。（凭证：48、49、50、51）

37、12月31日，结转分配辅助生产成本的制造费用，其中机修车间410元，供汽车间327元。（凭证：52）

38、12月31日，结转分配辅助生产车间的生产成本，分配辅助车间之间的费用分配采用直接法。机修车间费用分配如下：一车间476.8元、二车间578.9元、厂部408.8元。供汽车间费用分配如下：一车间574.3元、二车间668.4元、厂部560.6元。（凭证：53、54）

39、12月31日，结转分配制造费用，其中P1产品分配24134.7元，P2产品分配29971.51元，P3产品分配25794.35元，P4产品分配19745.06元。（凭证：55）

40、12月31日，结转入库产品的制造成本，其中P1产品入库20000件，单位成本3.57元；P2产品入库1600件，单位成本37.6元；P3产品入库4500箱，单位成本19.8元；P4产品入库4500箱，单位成本20.7元。（凭证：56）

41、12月31日，结转销售出库产品的成本，其中：P1产品6000件，单位成本3.4611元；P2产品17000件，单位成本37.8379元；P3产品31400箱，单位成本19.977元；P4产品4000箱，单位成本20.9662元。（凭证：57）

42、12月31日，根据资料4，调整外币帐户并计算汇兑损益。（凭证：13）（提示：使用软件“期末调汇功能”）。

43、12月31日，计提教育费附加和城市建设维护税。（凭证：60）（提示：使用软件的自动转账功能）

44、12月31日，按本月利润的33%，计提本月的所得税。（凭证：61、62）（提示：使用软件的自动转账功能）

45、12月31日，结转损益类科目。（凭证：58、59）（提示：使用软件的自动转账功能）

46、12月31日，将“本年利润”账户余额结转至“利润分配――未分配利润”账户。（凭证：63）（提示：使用软件的自动转账功能）

47、12月31日，按本年利润10%的比例计提本年法定公积金。按本年净利润的20%向投资者分配利润，暂不支付。（凭证：64）

48、12月31日，将“利润分配”各明细账户余额转入“利润分配――未分配利润”账户。（凭证：65）

资料11：紫牛公司2003年1月的业务资料

1、1月4日，销售给大辉公司P1产品8000件，单价7元，除了抵消其预收货款外，余款未收到。（凭证：1）

2、1月5日，向富岗（广州）分公司购买丙材料3000公斤，单价2.9元，除了抵消公司预付款外，余款未付，材料已经入库，增值税率为17%。（凭证： 2、3）

3、1月7日，一车间领用甲材料2600公斤，其中用于生产P1产品的有1200公斤，用于生产P2产品的有1400公斤。（凭证： 4）

4、1月8日，以现金支票提取现金4000元。（凭证：5）

5、1月10日，市场营销部门报销办公费用560元，业务费用1500元，业务招待费2000元，以现金支付。（凭证：6）

6、1月11日，上月开始安装的一部设备已经完工，设备实际成本共计6100元。（凭证：7）

7、1月15日，提取现金350000元，用以备发工资，支票991206。（凭证：8）

8、1月15日，以现金发放工资，金额345908元。（凭证：9）

9、1月16日，收到灵虎百货公司还欠款2450元。（凭证：10）

10、1月19日，物资及采购部人员张某出差返回，报销差旅费2100元，余款退还现金。（凭证：11）

11、1月24日，计提本月工资，其中管理部门工资123451，车间管理部门工资82056元，直接工资140401元，其中P1产品40400元，P2产品21051元，P3产品30950元，P4产品48000元，机修车间3400元，供汽车间4500元，安装工程项目的1450元，职工食堂工程7346元。并按14%比例计提福利费。（凭证：12、13、28、29）

12、1月27日，二车间领用丙材料3000公斤，其中用于生产P3产品的有1800公斤，用于生产P4产品的有1200公斤。（凭证：14）

13、1月31日，预提本月长期借款利息8000元。（凭证：15）

14、1月31日，计提各固定资产折旧，其中生产部门提折旧2670元，行政管理部门提折旧3400元。（凭证：16、27）

15、销售给灵虎百货商场P4产品30000箱，单价90元，款项已经收到。（凭证：17）

16、1月31日，以银行存款交纳上年应交所得税742881.57元。（凭证：18）

17、1月31日，结转材料成本差异。（凭证：19、20、21）

18、1月31日，结转分配辅助生产的制造费用，其中机修车间315元，供汽车间157元。（凭证：22）

19、1月31日，结转分配辅助生产的生产成本，分配辅助车间之间的费用分配采用直接法。机修车间费用分配如下：一车间1341元、二车间1116元、厂部1734元。供汽车间费用分配如下：一车间1256元、二车间2103元、厂部1928元。（凭证：23、24）

20、1月31日，结转制造费用，其中P1产品分配27893.2元，P2产品分配35871.4元，P3产品分配21433元，P4产品分配20022.24元。本月无产品生产入库。（凭证：25）

21、1月31日，结转销售出库产品的成本。其中：P1产品8000件，单位成本3.4611元；P4产品30000箱，单位成本20.9662元。（凭证：26）

22、1月31日，计提个人所得税；计提教育费附加和城市建设维护税。（凭证：30、33）（提示：利用自动转账凭证）

23、1月31日，按利润所得的33%，计提本月的所得税。（凭证：34、35）

24、1月31日，结转损益类科目。（凭证：31、32）（提示：利用自动转账凭证）


凭证处理注意事项：

1、输入以下凭证有辅助核算项目的要输入辅助核算的内容。

2、凭证日期、外币汇率、存货的单价和数量等内容可在前面的业务资料中查到。

3、相同字号的会计分录输入在同一凭证中。

4、摘要内容只做参考，可自行设置。

  5、尽量使用软件提供的简便功能。

资料12：2002年12月份的记账凭证

凭证 字号 |  | 科目 代码 | 摘要 | 借方 金额 | 贷方 金额 | 币 种 | 原币 金额 | 客户 代号 | 部门 代号 | 项目 代号
记账 | 1 | 123002 | 材料入库 | 4200 |  | RMB | 4200 |  |  |
记账 | 1 | 121002 | 材料入库 |  | 4200 | RMB | 4200 |  |  |
记账 | 2 | 1021 | 销售产品 | 737100 |  | RMB | 737100 |  |  |
记账 | 2 | 501 | 销售产品 |  | 630000 | RMB | 630000 |  |  |
记账 | 2 | 2210102 | 销售产品 |  | 107100 | RMB | 107100 |  |  |
记账 | 3 | 2210101 | 采购材料 | 4590 |  | RMB | 4590 |  |  |
记账 | 3 | 121001 | 采购材料 | 25000 |  | RMB | 25000 |  |  |
记账 | 3 | 121002 | 采购材料 | 2000 |  | RMB | 2000 |  |  |
记账 | 3 | 202 | 采购材料 |  | 31590 | RMB | 31590 | 101 |  |
记账 | 4 | 123001 | 材料入库 | 25500 |  | RMB | 25500 |  |  |
记账 | 4 | 123002 | 材料入库 | 2100 |  | RMB | 2100 |  |  |
记账 | 4 | 121001 | 材料入库 |  | 25500 | RMB | 25500 |  |  |
记账 | 4 | 121002 | 材料入库 |  | 2100 | RMB | 2100 |  |  |
记账 | 5 | 121001 | 采购材料 | 1800 |  | RMB | 1800 |  |  |
记账 | 5 | 121002 | 采购材料 | 360 |  | RMB | 360 |  |  |
记账 | 5 | 2210101 | 采购材料 | 240 |  | RMB | 240 |  |  |
记账 | 5 | 101 | 采购材料 |  | 2400 | RMB | 2400 |  |  |
记账 | 6 | 52119 | 支付办公费用 | 590 |  | RMB | 590 |  | 00101 |
记账 | 6 | 101 | 支付办公费用 |  | 590 | RMB | 590 |  |  |
记账 | 7 | 11301 | 销售产品 | 42120 |  | RMB | 42120 | 105 |  |
记账 | 7 | 501 | 销售产品 |  | 36000 | RMB | 36000 |  |  |
记账 | 7 | 2210102 | 销售产品 |  | 6120 | RMB | 6120 |  |  |
记账 | 8 | 201 | 还借款 | 600000 |  | RMB | 600000 |  |  |
记账 | 8 | 52201 | 还借款 | 8000 |  | RMB | 8000 |  |  |
记账 | 8 | 1021 | 还借款 |  | 608000 | RMB | 608000 |  |  |
记账 | 9 | 1021 | 收回帐款 | 35000 |  | RMB | 35000 |  |  |
记账 | 9 | 112 | 收回帐款 |  | 35000 | RMB | 35000 | 108 |  |
记账 | 10 | 1023 | 收回帐款 | 47806 |  | KHD | 45100 |  |  |
记账 | 10 | 11302 | 收回帐款 |  | 47806 | KHD | 45100 | 10202 |  |
记账 | 11 | 101 | 提取现金 | 2000 |  | RMB | 2000 |  |  |
记账 | 11 | 1021 | 提取现金 |  | 2000 | RMB | 2000 |  |  |
记账 | 12 | 40111 | 领料 | 3060 |  | RMB | 3060 |  |  | 00201
记账 | 12 | 40111 | 领料 | 2040 |  | RMB | 2040 |  |  | 00202
记账 | 12 | 123001 | 领料 |  | 5100 | RMB | 5100 |  |  |
记账 | 13 | 1022 | 期末汇率调整 | 1693.2 |  | USD |  |  |  |
记账 | 13 | 1023 | 期末汇率调整 | 2042 |  | HKD |  |  |  |
记账 | 13 | 52203 | 期末汇率调整 | 1676 |  | RMB | 1676 |  |  |
记账 | 13 | 11302 | 期末汇率调整 |  | 5411.2 | HKD |  |  |  |
记账 | 14 | 20402 | 销售产品 | 59360 |  | KHD | 56000 | 10202 |  |
记账 | 14 | 11302 | 销售产品 | 10091.2 |  | KHD | 9520 | 10202 |  |
记账 | 14 | 501 | 销售产品 |  | 59360 | RMB | 59360 |  |  |
记账 | 14 | 2210102 | 销售产品 |  | 10091.2 | RMB | 10091.2 |  |  |
记账 | 15 | 40111 | 领料 | 17400 |  | RMB | 17400 |  |  | 00204
记账 | 15 | 123002 | 领料 |  | 8400 | RMB | 8400 |  |  |
记账 | 15 | 123003 | 领料 |  | 9000 | RMB | 9000 |  |  |
记账 | 16 | 52119 | 报销费用 | 460 |  | RMB | 460 |  | 00105 |
记账 | 16 | 50303 | 报销费用 | 4500 |  | RMB | 4500 |  | 00105 |
记账 | 16 | 52105 | 报销费用 | 2000 |  | RMB | 2000 |  | 00105 |
记账 | 16 | 1021 | 报销费用 |  | 6960 | RMB | 6960 |  |  |
记账 | 17 | 20303 | 还欠款 | 64530.6 |  | USD | 7860 | 103 |  |
记账 | 17 | 1022 | 还欠款 |  | 64530.6 | USD | 7860 |  |  |
记账 | 18 | 170 | 领料 | 10500 |  | RMB | 10500 |  |  | 0010203
记账 | 18 | 123002 | 领料 |  | 10500 | RMB | 10500 |  |  |
记账 | 19 | 169 | 安装设备 | 160000 |  | RMB | 160000 |  |  | 0010201
记账 | 19 | 1021 | 安装设备 |  | 160000 | RMB | 160000 |  |  |
记账 | 20 | 101 | 提取现金 | 350000 |  | RMB | 350000 |  |  |
记账 | 20 | 1021 | 提取现金 |  | 350000 | RMB | 350000 |  |  |
记账 | 21 | 211 | 发工资 | 345908 |  | RMB | 345908 |  |  |
记账 | 21 | 101 | 发工资 |  | 345908 | RMB | 345908 |  |  |
记账 | 22 | 40505 | 报销费用 | 127 |  | RMB | 127 |  | 00201 |
记账 | 22 | 40512 | 报销费用 | 450 |  | RMB | 450 |  | 00201 |
记账 | 22 | 101 | 报销费用 |  | 577 | RMB | 577 |  |  |
记账 | 23 | 11302 | 销售产品 | 248040 |  | KHD | 234000 | 10202 |  |
记账 | 23 | 501 | 销售产品 |  | 212000 | RMB | 212000 |  |  |
记账 | 23 | 2210102 | 销售产品 |  | 36040 | RMB | 36040 |  |  |
记账 | 24 | 169 | 工程领料 | 15000 |  | RMB | 15000 |  |  | 0010203
记账 | 24 | 170 | 工程领料 |  | 15000 | RMB | 15000 |  |  | 0010203
记账 | 25 | 40111 | 领料 | 18000 |  | RMB | 18000 |  |  | 00203
记账 | 25 | 40111 | 领料 | 3000 |  | RMB | 3000 |  |  | 00204
记账 | 25 | 123003 | 领料 |  | 21000 | RMB | 21000 |  |  |
记账 | 26 | 40112 | 计提工资 | 48000 |  | RMB | 48000 |  |  | 00204
记账 | 26 | 169 | 计提工资 | 1450 |  | RMB | 1450 |  |  | 0010201
记账 | 26 | 169 | 计提工资 | 7346 |  | RMB | 7346 |  |  | 0010203
记账 | 26 | 52101 | 计提工资 | 123451 |  | RMB | 123451 |  |  |
记账 | 26 | 40501 | 计提工资 | 82056 |  | RMB | 82056 |  |  |
记账 | 26 | 40112 | 计提工资 | 40400 |  | RMB | 40400 |  |  | 00201
记账 | 26 | 40112 | 计提工资 | 21051 |  | RMB | 21051 |  |  | 00202
记账 | 26 | 40112 | 计提工资 | 30950 |  | RMB | 30950 |  |  | 00203
记账 | 26 | 211 | 计提工资 |  | 354704 | RMB | 354704 |  |  |
记账 | 27 | 52102 | 计提福利费 | 17283.14 |  | RMB | 17283.14 |  |  |
记账 | 27 | 40502 | 计提福利费 | 11487.84 |  | RMB | 11487.84 |  |  |
记账 | 27 | 40112 | 计提福利费 | 5656 |  | RMB | 5656 |  |  | 00201
记账 | 27 | 40112 | 计提福利费 | 2947.14 |  | RMB | 2947.14 |  |  | 00202
记账 | 27 | 40112 | 计提福利费 | 4333 |  | RMB | 4333 |  |  | 00203
记账 | 27 | 40112 | 计提福利费 | 6720 |  | RMB | 6720 |  |  | 00204
记账 | 27 | 169 | 计提福利费 | 203 |  | RMB | 203 |  |  | 0010201
记账 | 27 | 169 | 计提福利费 | 1028.44 |  | RMB | 1028.44 |  |  | 0010203
记账 | 27 | 214 | 计提福利费 |  | 49658.56 | RMB | 49658.56 |  |  |
记账 | 28 | 161 | 工程竣工 | 6100 |  | RMB | 6100 |  |  |
记账 | 28 | 169 | 工程竣工 |  | 6100 | RMB | 6100 |  |  | 0010201
记账 | 29 | 161 | 购入固定资产 | 15000 |  | RMB | 15000 |  |  |
记账 | 29 | 1021 | 购入固定资产 |  | 15000 | RMB | 15000 |  |  |
记账 | 30 | 20301 | 还欠款 | 56704 |  | RMB | 56704 | 104 |  |
记账 | 30 | 1021 | 还欠款 |  | 56704 | RMB | 56704 |  |  |
记账 | 31 | 119 | 预借款项 | 3000 |  | RMB | 3000 |  |  |
记账 | 31 | 101 | 预借款项 |  | 3000 | RMB | 3000 |  |  |
记账 | 32 | 52105 | 报销费用 | 1200 |  | RMB | 1200 |  | 00104 |
记账 | 32 | 52119 | 报销费用 | 450 |  | RMB | 450 |  | 00104 |
记账 | 32 | 101 | 报销费用 |  | 1650 | RMB | 1650 |  |  |
记账 | 33 | 101 | 报销差旅费 | 220 |  | RMB | 220 |  |  |
记账 | 33 | 119 | 报销差旅费 |  | 220 | RMB | 220 |  |  |
记账 | 34 | 52118 | 报销差旅费 | 2120 |  | RMB | 2120 |  | 00101 |
记账 | 34 | 119 | 报销差旅费 |  | 2120 | RMB | 2120 |  |  |
记账 | 35 | 121003 | 采购材料 | 197040 |  | RMB | 197040 |  |  |
记账 | 35 | 2210101 | 采购材料 | 33496.8 |  | RMB | 33496.8 |  |  |
记账 | 35 | 11503 | 采购材料 |  | 230536.8 | USD | 28080 | 103 |  |
记账 | 36 | 123003 | 材料入库 | 180000 |  | RMB | 180000 |  |  |
记账 | 36 | 121003 | 材料入库 |  | 180000 | RMB | 180000 |  |  |
记账 | 37 | 1022 | 收回预付款 | 61739.2 |  | USD | 7520 |  |  |
记账 | 37 | 11503 | 收回预付款 |  | 61739.2 | USD | 7520 | 103 |  |
记账 | 38 | 52103 | 领料 | 150 |  | RMB | 150 |  | 00101 |
记账 | 38 | 52103 | 领料 | 120 |  | RMB | 120 |  | 00104 |
记账 | 38 | 52103 | 领料 | 210 |  | RMB | 210 |  | 00105 |
记账 | 38 | 40507 | 领料 | 230 |  | RMB | 230 |  | 00201 |
记账 | 38 | 129 | 领料 |  | 710 | RMB | 710 |  |  |
记账 | 39 | 20401 | 销售产品 | 340000 |  | RMB | 340000 | 105 |  |
记账 | 39 | 11301 | 销售产品 | 186500 |  | RMB | 186500 | 105 |  |
记账 | 39 | 501 | 销售产品 |  | 450000 | RMB | 450000 |  |  |
记账 | 39 | 2210102 | 销售产品 |  | 76500 | RMB | 76500 |  |  |
记账 | 40 | 20401 | 销售产品 | 280000 |  | RMB | 280000 | 106 |  |
记账 | 40 | 11301 | 销售产品 | 129500 |  | RMB | 129500 | 105 |  |
记账 | 40 | 501 | 销售产品 |  | 239316.24 | RMB | 239316.24 | 106 |  |
记账 | 40 | 501 | 销售产品 |  | 110683.76 | RMB | 110683.76 | 105 |  |
记账 | 40 | 2210102 | 销售产品 |  | 59500 | RMB | 59500 |  |  |
记账 | 41 | 40111 | 领料 | 6300 |  | RMB | 6300 |  |  | 00201
记账 | 41 | 40111 | 领料 | 4200 |  | RMB | 4200 |  |  | 00202
记账 | 41 | 40111 | 领料 | 6300 |  | RMB | 6300 |  |  | 00203
记账 | 41 | 40121 | 领料 | 1050 |  | RMB | 1050 |  |  |
记账 | 41 | 40122 | 领料 | 1470 |  | RMB | 1470 |  |  |
记账 | 41 | 52103 | 领料 | 210 |  | RMB | 210 |  | 00101 |
记账 | 41 | 52103 | 领料 | 84 |  | RMB | 84 |  | 00104 |
记账 | 41 | 52103 | 领料 | 63 |  | RMB | 63 |  | 00105 |
记账 | 41 | 40507 | 领料 | 462 |  | RMB | 462 |  | 00201 |
记账 | 41 | 123002 | 领料 |  | 20139 | RMB | 20139 |  |  |
记账 | 42 | 52201 | 预提利息费用 | 8000 |  | RMB | 8000 |  |  |
记账 | 42 | 23103 | 预提利息费用 |  | 8000 | RMB | 8000 |  |  |
记账 | 43 | 40503 | 提折旧费用 | 2300 |  | RMB | 2300 |  |  |
记账 | 43 | 52113 | 提折旧费用 | 3400 |  | RMB | 3400 |  |  |
记账 | 43 | 165 | 提折旧费用 |  | 5700 | RMB | 5700 |  |  |
记账 | 44 | 166 | 计提工资 | 15600 |  | RMB | 15600 |  |  |
记账 | 44 | 40112 | 计提工资 | 18080.9 |  | RMB | 18080.9 |  |  | 00201
记账 | 44 | 40501 | 计提工资 | 14030.9 |  | RMB | 14030.9 |  |  |
记账 | 44 | 50301 | 计提工资 | 9050 |  | RMB | 9050 |  |  |
记账 | 44 | 52101 | 计提工资 | 7000 |  | RMB | 7000 |  |  |
记账 | 44 | 52101 | 计提工资 | 7250 |  | RMB | 7250 |  |  |
记账 | 44 | 211 | 计提工资 |  | 71011.8 | RMB | 71011.8 |  |  |
记账 | 45 | 40502 | 计提福利费 | 6679.65 |  | RMB | 6679.65 |  |  |
记账 | 45 | 50302 | 计提福利费 | 1267 |  | RMB | 1267 |  |  |
记账 | 45 | 52102 | 计提福利费 | 1995 |  | RMB | 1995 |  |  |
记账 | 45 | 214 | 计提福利费 |  | 9941.65 | RMB | 9941.65 |  |  |
记账 | 46 | 209 | 计提个人所得税 | 6101.1 |  | RMB | 6101.1 |  |  |
记账 | 46 | 22106 | 计提个人所得税 |  | 6101.1 | RMB | 6101.1 |  |  |
记账 | 47 | 40503 | 计提折旧 | 6751.11 |  | RMB | 6751.11 |  |  |
记账 | 47 | 52113 | 计提折旧 | 10837.94 |  | RMB | 10837.94 |  |  |
记账 | 47 | 165 | 计提折旧 |  | 17589.05 | RMB | 17589.05 |  |  |
记账 | 48 | 131001 | 结转材料成本差异 | 1300 |  | RMB | 1300 |  |  |
记账 | 48 | 131002 | 结转材料成本差异 | 260 |  | RMB | 260 |  |  |
记账 | 48 | 131003 | 结转材料成本差异 | 17040 |  | RMB | 17040 |  |  |
记账 | 48 | 121001 | 结转材料成本差异 |  | 1300 | RMB | 1300 |  |  |
记账 | 48 | 121002 | 结转材料成本差异 |  | 260 | RMB | 260 |  |  |
记账 | 48 | 121003 | 结转材料成本差异 |  | 17040 | RMB | 17040 |  |  |
记账 | 49 | 40111 | 结转材料成本差异 | 100 |  | RMB | 100 |  |  | 00202
记账 | 49 | 40111 | 结转材料成本差异 | 150 |  | RMB | 150 |  |  | 00201
记账 | 49 | 131001 | 结转材料成本差异 |  | 250 | RMB | 250 |  |  |
记账 | 50 | 52103 | 结转材料成本差异 | 0.27 |  | RMB | 0.27 |  | 00105 |
记账 | 50 | 40111 | 结转材料成本差异 | 27 |  | RMB | 27 |  |  | 00201
记账 | 50 | 40111 | 结转材料成本差异 | 18 |  | RMB | 18 |  |  | 00202
记账 | 50 | 40111 | 结转材料成本差异 | 27 |  | RMB | 27 |  |  | 00203
记账 | 50 | 40111 | 结转材料成本差异 | 36 |  | RMB | 36 |  |  | 00204
记账 | 50 | 40121 | 结转材料成本差异 | 4.5 |  | RMB | 4.5 |  |  |
记账 | 50 | 40122 | 结转材料成本差异 | 6.3 |  | RMB | 6.3 |  |  |
记账 | 50 | 170 | 结转材料成本差异 | 45 |  | RMB | 45 |  |  | 0010203
记账 | 50 | 40507 | 结转材料成本差异 | 1.98 |  | RMB | 1.98 |  | 00201 |
记账 | 50 | 52103 | 结转材料成本差异 | 0.9 |  | RMB | 0.9 |  | 00101 |
记账 | 50 | 52103 | 结转材料成本差异 | 0.36 |  | RMB | 0.36 |  | 00104 |
记账 | 50 | 131002 | 结转材料成本差异 |  | 167.31 | RMB | 167.31 |  |  |
记账 | 51 | 40111 | 结转材料成本差异 | 1204.23 |  | RMB | 1204.23 |  |  | 00203
记账 | 51 | 40111 | 结转材料成本差异 | 1003.53 |  | RMB | 1003.53 |  |  | 00204
记账 | 51 | 131003 | 结转材料成本差异 |  | 2207.76 | RMB | 2207.76 |  |  |
记账 | 52 | 40121 | 结转制造费用 | 410 |  | RMB | 410 |  |  |
记账 | 52 | 40122 | 结转制造费用 | 327 |  | RMB | 327 |  |  |
记账 | 52 | 40512 | 结转制造费用 |  | 410 | RMB | 410 |  | 00204 |
记账 | 52 | 40512 | 结转制造费用 |  | 327 | RMB | 327 |  | 00205 |
记账 | 53 | 40504 | 结转辅助车间生产成本 | 476.8 |  | RMB | 476.8 |  | 00202 |
记账 | 53 | 40504 | 结转辅助车间生产成本 | 578.9 |  | RMB | 578.9 |  | 00203 |
记账 | 53 | 40504 | 结转辅助车间生产成本 | 408.8 |  | RMB | 408.8 |  | 00201 |
记账 | 53 | 40121 | 结转辅助车间生产成本 |  | 1464.5 | RMB | 1464.5 |  |  |
记账 | 54 | 40506 | 结转辅助车间生产成本 | 574.3 |  | RMB | 574.3 |  | 00202 |
记账 | 54 | 40506 | 结转辅助车间生产成本 | 668.4 |  | RMB | 668.4 |  | 00203 |
记账 | 54 | 40506 | 结转辅助车间生产成本 | 560.6 |  | RMB | 560.6 |  | 00201 |
记账 | 54 | 40122 | 结转辅助车间生产成本 |  | 1803.3 | RMB | 1803.3 |  |  |
记账 | 55 | 40113 | 结转制造费用 | 24134.7 |  | RMB | 24134.7 |  |  | 00201
记账 | 55 | 40113 | 结转制造费用 | 29971.51 |  | RMB | 29971.51 |  |  | 00202
记账 | 55 | 40113 | 结转制造费用 | 25794.35 |  | RMB | 25794.35 |  |  | 00203
记账 | 55 | 40113 | 结转制造费用 | 19745.06 |  | RMB | 19745.06 |  |  | 00204
记账 | 55 | 40513 | 结转制造费用 |  | 99645.62 | RMB | 99645.62 |  |  |
记账 | 56 | 137001 | 结转入库产品成本 | 71400 |  | RMB | 71400 |  |  |
记账 | 56 | 137002 | 结转入库产品成本 | 60160 |  | RMB | 60160 |  |  |
记账 | 56 | 137003 | 结转入库产品成本 | 89100 |  | RMB | 89100 |  |  |
记账 | 56 | 137004 | 结转入库产品成本 | 93150 |  | RMB | 93150 |  |  |
记账 | 56 | 40111 | 结转入库产品成本 |  | 27132.72 | RMB | 27132.72 |  |  | 00203
记账 | 56 | 40111 | 结转入库产品成本 |  | 20823.74 | RMB | 20823.74 |  |  | 00204
记账 | 56 | 40112 | 结转入库产品成本 |  | 41245.37 | RMB | 41245.37 |  |  | 00201
记账 | 56 | 40112 | 结转入库产品成本 |  | 24761.41 | RMB | 24761.41 |  |  | 00202
记账 | 56 | 40112 | 结转入库产品成本 |  | 36622.45 | RMB | 36622.45 |  |  | 00203
记账 | 56 | 40112 | 结转入库产品成本 |  | 53148.32 | RMB | 53148.32 |  |  | 00204
记账 | 56 | 40113 | 结转入库产品成本 |  | 21613.79 | RMB | 21613.79 |  |  | 00201
记账 | 56 | 40113 | 结转入库产品成本 |  | 27227.22 | RMB | 27227.22 |  |  | 00202
记账 | 56 | 40113 | 结转入库产品成本 |  | 25344.83 | RMB | 25344.83 |  |  | 00203
记账 | 56 | 40113 | 结转入库产品成本 |  | 19177.94 | RMB | 19177.94 |  |  | 00204
记账 | 56 | 40111 | 结转入库产品成本 |  | 8540.84 | RMB | 8540.84 |  |  | 00201
记账 | 56 | 40111 | 结转入库产品成本 |  | 8171.37 | RMB | 8171.37 |  |  | 00202
记账 | 57 | 502 | 结转销售产品成本 | 1375153.5 |  | RMB | 1375153.5 |  |  |
记账 | 57 | 137004 | 结转销售产品成本 |  | 83864.8 | RMB | 83864.8 |  |  |
记账 | 57 | 137001 | 结转销售产品成本 |  | 20766.6 | RMB | 20766.6 |  |  |
记账 | 57 | 137002 | 结转销售产品成本 |  | 643244.3 | RMB | 643244.3 |  |  |
记账 | 57 | 137003 | 结转销售产品成本 |  | 627277.8 | RMB | 627277.8 |  |  |
记账 | 58 | 501 | 结转收入 | 271360 |  | RMB | 271360 | 10202 |  |
记账 | 58 | 501 | 结转收入 | 630000 |  | RMB | 630000 | 10201 |  |
记账 | 58 | 501 | 结转收入 | 239316.24 |  | RMB | 239316.24 | 106 |  |
记账 | 58 | 501 | 结转收入 | 596683.76 |  | RMB | 596683.76 | 105 |  |
记账 | 58 | 321 | 结转收入 |  | 1737360 | RMB | 1737360 |  |  |
记账 | 59 | 321 | 结转费用、成本、税金 | 1652116.19 |  | RMB | 1655477.19 |  |  |
记账 | 59 | 40111 | 结转费用、成本、税金 |  | -2384.21 | RMB | -2384.21 |  |  | 00204
记账 | 59 | 40111 | 结转费用、成本、税金 |  | 886.63 | RMB | 886.63 |  |  | 00202
记账 | 59 | 40111 | 结转费用、成本、税金 |  | 3743.51 | RMB | 3743.51 |  |  | 00203
记账 | 59 | 40111 | 结转费用、成本、税金 |  | 996.16 | RMB | 996.16 |  |  | 00201
记账 | 59 | 40112 | 结转费用、成本、税金 |  | 22891.53 | RMB | 22891.53 |  |  | 00201
记账 | 59 | 40112 | 结转费用、成本、税金 |  | 1571.68 | RMB | 1571.68 |  |  | 00204
记账 | 59 | 40112 | 结转费用、成本、税金 |  | 1003.55 | RMB | 1003.55 |  |  | 00203
记账 | 59 | 40112 | 结转费用、成本、税金 |  | 2686.73 | RMB | 2686.73 |  |  | 00202
记账 | 59 | 40113 | 结转费用、成本、税金 |  | 567.12 | RMB | 567.12 |  |  | 00204
记账 | 59 | 40113 | 结转费用、成本、税金 |  | 2954.29 | RMB | 2954.29 |  |  | 00202
记账 | 59 | 40113 | 结转费用、成本、税金 |  | 694.52 | RMB | 694.52 |  |  | 00203
记账 | 59 | 40113 | 结转费用、成本、税金 |  | 2520.91 | RMB | 2520.91 |  |  | 00201
记账 | 59 | 40501 | 结转费用、成本、税金 |  | 96086.9 | RMB | 96086.9 |  |  |
记账 | 59 | 40502 | 结转费用、成本、税金 |  | 18167.49 | RMB | 18167.49 |  |  |
记账 | 59 | 40503 | 结转费用、成本、税金 |  | 9051.11 | RMB | 9051.11 |  |  |
记账 | 59 | 40504 | 结转费用、成本、税金 |  | 578.9 | RMB | 578.9 |  | 00203 |
记账 | 59 | 40504 | 结转费用、成本、税金 |  | 408.8 | RMB | 408.8 |  | 00201 |
记账 | 59 | 40504 | 结转费用、成本、税金 |  | 476.8 | RMB | 476.8 |  | 00202 |
记账 | 59 | 40505 | 结转费用、成本、税金 |  | 127 | RMB | 127 |  | 00201 |
记账 | 59 | 40506 | 结转费用、成本、税金 |  | 668.4 | RMB | 668.4 |  | 00203 |
记账 | 59 | 40506 | 结转费用、成本、税金 |  | 560.6 | RMB | 560.6 |  | 00201 |
记账 | 59 | 40506 | 结转费用、成本、税金 |  | 574.3 | RMB | 574.3 |  | 00202 |
记账 | 59 | 40507 | 结转费用、成本、税金 |  | 693.98 | RMB | 693.98 |  | 00201 |
记账 | 59 | 40512 | 结转费用、成本、税金 |  | -327 | RMB | -327 |  | 00205 |
记账 | 59 | 40512 | 结转费用、成本、税金 |  | -99195.62 | RMB | -99195.62 |  | 00201 |
记账 | 59 | 40512 | 结转费用、成本、税金 |  | -410 | RMB | -410 |  | 00204 |
记账 | 59 | 502 | 结转费用、成本、税金 |  | 1375153.5 | RMB | 1375153.5 |  |  |
记账 | 59 | 50301 | 结转费用、成本、税金 |  | 9050 | RMB | 9050 |  |  |
记账 | 59 | 50302 | 结转费用、成本、税金 |  | 1267 | RMB | 1267 |  |  |
记账 | 59 | 50303 | 结转费用、成本、税金 |  | 4500 | RMB | 4500 |  | 00105 |
记账 | 59 | 52101 | 结转费用、成本、税金 |  | 137701 | RMB | 137701 |  |  |
记账 | 59 | 52102 | 结转费用、成本、税金 |  | 19278.14 | RMB | 19278.14 |  |  |
记账 | 59 | 52103 | 结转费用、成本、税金 |  | 204.36 | RMB | 204.36 |  | 00104 |
记账 | 59 | 52103 | 结转费用、成本、税金 |  | 273.27 | RMB | 273.27 |  | 00105 |
记账 | 59 | 52103 | 结转费用、成本、税金 |  | 360.9 | RMB | 360.9 |  | 00101 |
记账 | 59 | 52105 | 结转费用、成本、税金 |  | 1200 | RMB | 1200 |  | 00104 |
记账 | 59 | 52105 | 结转费用、成本、税金 |  | 2000 | RMB | 2000 |  | 00105 |
记账 | 59 | 52113 | 结转费用、成本、税金 |  | 14237.94 | RMB | 14237.94 |  |  |
记账 | 59 | 52118 | 结转费用、成本、税金 |  | 2120 | RMB | 2120 |  | 00101 |
记账 | 59 | 52119 | 结转费用、成本、税金 |  | 460 | RMB | 460 |  | 00105 |
记账 | 59 | 52119 | 结转费用、成本、税金 |  | 590 | RMB | 590 |  | 00101 |
记账 | 59 | 52119 | 结转费用、成本、税金 |  | 450 | RMB | 450 |  | 00104 |
记账 | 59 | 52201 | 结转费用、成本、税金 |  | 16000 | RMB | 16000 |  |  |
记账 | 59 | 52203 | 结转费用、成本、税金 |  | 1676 | RMB | 1676 |  |  |
记账 | 60 | 504 | 计提教育和城建税 | 27321.14 |  | RMB | 27321.14 |  |  |
记账 | 60 | 22103 | 计提教育和城建税 |  | 19124.8 | RMB | 19124.8 |  |  |
记账 | 60 | 22901 | 计提教育和城建税 |  | 8196.34 | RMB | 8196.34 |  |  |
记账 | 61 | 551 | 计提所得税 | 209189.58 |  | RMB | 209189.58 |  |  |
记账 | 61 | 22102 | 计提所得税 |  | 209189.58 | RMB | 209189.58 |  |  |
记账 | 62 | 321 | 结转所得税 | 236510.72 |  | RMB | 236510.72 |  |  |
记账 | 62 | 504 | 结转所得税 |  | 27321.14 | RMB | 27321.14 |  |  |
记账 | 62 | 551 | 结转所得税 |  | 209189.58 | RMB | 209189.58 |  |  |
记账 | 63 | 321 | 结转本年利润 | 397397.09 |  | RMB | 397397.09 |  |  |
记账 | 63 | 32206 | 结转本年利润 |  | 397397.09 | RMB | 397397.09 |  |  |
记账 | 64 | 32203 | 利润分配 | 39739.71 |  | RMB | 39739.71 |  |  |
记账 | 64 | 32204 | 利润分配 | 79479.42 |  | RMB | 79479.42 |  |  |
记账 | 64 | 313 | 利润分配 |  | 39739.71 | RMB | 39739.71 |  |  |
记账 | 64 | 223 | 利润分配 |  | 79479.42 | RMB | 79479.42 |  |  |
记账 | 65 | 32206 | 结转利润分配 | 119219.13 |  | RMB | 119219.13 |  |  |
记账 | 65 | 32203 | 结转利润分配 |  | 39739.71 | RMB | 39739.71 |  |  |
记账 | 65 | 32204 | 结转利润分配 |  | 79479.42 | RMB | 79479.42 |  |  |


资料13

资料13：2003年1月份的记账凭证

凭证 字号 |  | 科目 代码 | 摘要 | 借方 金额 | 贷方 金额 | 币 种 | 原币 金额 | 客户 代号 | 部门 代号 | 项目 代号
记账 | 1 | 20401 | 销售产品 | 46700 |  | RMB | 46700 | 107 |  |
记账 | 1 | 11301 | 销售产品 | 18820 |  | RMB | 18820 | 107 |  |
记账 | 1 | 501 | 销售产品 |  | 56000 | RMB | 56000 |  |  |
记账 | 1 | 2210101 | 销售产品 |  | 9520 | RMB | 9520 |  |  |
记账 | 2 | 121003 | 采购材料 | 8700 |  | RMB | 8700 |  |  |
记账 | 2 | 2210101 | 采购材料 | 1479 |  | RMB | 1479 |  |  |
记账 | 2 | 11501 | 采购材料 |  | 4570 | RMB | 4570 | 10201 |  |
记账 | 2 | 20301 | 采购材料 |  | 5609 | RMB | 5609 | 10201 |  |
记账 | 3 | 123003 | 材料入库 | 9000 |  | RMB | 9000 |  |  |
记账 | 3 | 121003 | 材料入库 |  | 9000 | RMB | 9000 |  |  |
记账 | 4 | 40111 | 领料 | 6120 |  | RMB | 6120 |  |  | 00201
记账 | 4 | 40111 | 领料 | 7140 |  | RMB | 7140 |  |  | 00202
记账 | 4 | 123001 | 领料 |  | 13260 | RMB | 13260 |  |  |
记账 | 5 | 101 | 提现 | 4000 |  | RMB | 4000 |  |  |
记账 | 5 | 1021 | 提现 |  | 4000 | RMB | 4000 |  |  |
记账 | 6 | 52119 | 报销费用 | 560 |  | RMB | 560 |  | 00105 |
记账 | 6 | 50303 | 报销费用 | 1500 |  | RMB | 1500 |  | 00105 |
记账 | 6 | 52105 | 报销费用 | 2000 |  | RMB | 2000 |  | 00105 |
记账 | 6 | 101 | 报销费用 |  | 4060 | RMB | 4060 |  |  |
记账 | 7 | 161 | 安装设备 | 6100 |  | RMB | 6100 |  |  |
记账 | 7 | 169 | 安装设备 |  | 6100 | RMB | 6100 |  |  | 0010201
记账 | 8 | 101 | 提现 | 350000 |  | RMB | 350000 |  |  |
记账 | 8 | 1021 | 提现 |  | 350000 | RMB | 350000 |  |  |
记账 | 9 | 211 | 发工资 | 345908 |  | RMB | 345908 |  |  |
记账 | 9 | 101 | 发工资 |  | 345908 | RMB | 345908 |  |  |
记账 | 10 | 1021 | 收回帐款 | 2450 |  | RMB | 2450 |  |  |
记账 | 10 | 11301 | 收回帐款 |  | 2450 | RMB | 2450 | 106 |  |
记账 | 11 | 101 | 收回预借款 | 900 |  | RMB | 900 |  |  |
记账 | 11 | 52118 | 报销差旅费 | 2100 |  | RMB | 2100 |  | 00104 |
记账 | 11 | 119 | 报销差旅费 |  | 3000 | RMB | 3000 |  |  |
记账 | 12 | 40112 | 计提工资 | 21051 |  | RMB | 21051 |  |  | 00202
记账 | 12 | 40112 | 计提工资 | 30950 |  | RMB | 30950 |  |  | 00203
记账 | 12 | 40112 | 计提工资 | 48000 |  | RMB | 48000 |  |  | 00204
记账 | 12 | 40121 | 计提工资 | 3400 |  | RMB | 3400 |  |  |
记账 | 12 | 40122 | 计提工资 | 4500 |  | RMB | 4500 |  |  |
记账 | 12 | 169 | 计提工资 | 1450 |  | RMB | 1450 |  |  | 0010201
记账 | 12 | 169 | 计提工资 | 7346 |  | RMB | 7346 |  |  | 0010203
记账 | 12 | 52101 | 计提工资 | 123451 |  | RMB | 123451 |  |  |
记账 | 12 | 40501 | 计提工资 | 82056 |  | RMB | 82056 |  |  |
记账 | 12 | 40112 | 计提工资 | 40400 |  | RMB | 40400 |  |  | 00201
记账 | 12 | 211 | 计提工资 |  | 362604 | RMB | 362604 |  |  |
记账 | 13 | 169 | 计提福利费 | 1028.44 |  | RMB | 1028.44 |  |  | 0010203
记账 | 13 | 52102 | 计提福利费 | 17283.14 |  | RMB | 17283.14 |  |  |
记账 | 13 | 40502 | 计提福利费 | 11487.84 |  | RMB | 11487.84 |  |  |
记账 | 13 | 40112 | 计提福利费 | 5656 |  | RMB | 5656 |  |  | 00201
记账 | 13 | 40112 | 计提福利费 | 2947.14 |  | RMB | 2947.14 |  |  | 00202
记账 | 13 | 40112 | 计提福利费 | 1330 |  | RMB | 1330 |  |  | 00203
记账 | 13 | 40112 | 计提福利费 | 6720 |  | RMB | 6720 |  |  | 00204
记账 | 13 | 40121 | 计提福利费 | 476 |  | RMB | 476 |  |  |
记账 | 13 | 40122 | 计提福利费 | 630 |  | RMB | 630 |  |  |
记账 | 13 | 169 | 计提福利费 | 203 |  | RMB | 203 |  |  | 0010201
记账 | 13 | 214 | 计提福利费 |  | 47761.56 | RMB | 47761.56 |  |  |
记账 | 14 | 40111 | 领料 | 5400 |  | RMB | 5400 |  |  | 00203
记账 | 14 | 40111 | 领料 | 3600 |  | RMB | 3600 |  |  | 00204
记账 | 14 | 123003 | 领料 |  | 9000 | RMB | 9000 |  |  |
记账 | 15 | 52201 | 预提利息费用 | 8000 |  | RMB | 8000 |  |  |
记账 | 15 | 23103 | 预提利息费用 |  | 8000 | RMB | 8000 |  |  |
记账 | 16 | 52113 | 提折旧费用 | 3400 |  | RMB | 3400 |  |  |
记账 | 16 | 40503 | 提折旧费用 | 2670 |  | RMB | 2670 |  |  |
记账 | 16 | 165 | 提折旧费用 |  | 6070 | RMB | 6070 |  |  |
记账 | 17 | 1021 | 销售产品 | 3159000 |  | RMB | 3159000 |  |  |
记账 | 17 | 501 | 销售产品 |  | 2700000 | RMB | 2700000 |  |  |
记账 | 17 | 2210102 | 销售产品 |  | 459000 | RMB | 459000 |  |  |
记账 | 18 | 22102 | 交纳税金 | 742881.57 |  | RMB | 742881.57 |  |  |
记账 | 18 | 1021 | 交纳税金 |  | 742881.57 | RMB | 742881.57 |  |  |
记账 | 19 | 121003 | 结转材料成本差异 | 300 |  | RMB | 300 |  |  |
记账 | 19 | 131003 | 结转材料成本差异 |  | 300 | RMB | 300 |  |  |
记账 | 20 | 40111 | 结转材料成本差异 | 22.91 |  | RMB | 22.91 |  |  | 00201
记账 | 20 | 40111 | 结转材料成本差异 | 26.73 |  | RMB | 26.73 |  |  | 00202
记账 | 20 | 131001 | 结转材料成本差异 |  | 49.64 | RMB | 49.64 |  |  |
记账 | 21 | 40111 | 结转材料成本差异 | 335.84 |  | RMB | 335.84 |  |  | 00203
记账 | 21 | 40111 | 结转材料成本差异 | 223.9 |  | RMB | 223.9 |  |  | 00204
记账 | 21 | 131003 | 结转材料成本差异 |  | 559.74 | RMB | 559.74 |  |  |
记账 | 22 | 40121 | 结转材料成本差异 | 315 |  | RMB | 315 |  |  |
记账 | 22 | 40122 | 结转材料成本差异 | 157 |  | RMB | 157 |  |  |
记账 | 22 | 40512 | 结转材料成本差异 |  | 315 | RMB | 315 |  | 0204 |
记账 | 22 | 40512 | 结转材料成本差异 |  | 157 | RMB | 157 |  | 00205 |
记账 | 23 | 40506 | 结转辅助车间生产成本 | 1256 |  | RMB | 1256 |  | 00201 |
记账 | 23 | 40506 | 结转辅助车间生产成本 | 2103 |  | RMB | 2103 |  | 00202 |
记账 | 23 | 40506 | 结转辅助车间生产成本 | 1928 |  | RMB | 1928 |  | 00203 |
记账 | 23 | 40122 | 结转辅助车间生产成本 |  | 5287 | RMB | 5287 |  |  |
记账 | 24 | 40504 | 结转辅助车间生产成本 | 1341 |  | RMB | 1341 |  | 00201 |
记账 | 24 | 40504 | 结转辅助车间生产成本 | 1116 |  | RMB | 1116 |  | 00202 |
记账 | 24 | 40504 | 结转辅助车间生产成本 | 1734 |  | RMB | 1734 |  | 00203 |
记账 | 24 | 40121 | 结转辅助车间生产成本 |  | 4191 | RMB | 4191 |  |  |
记账 | 25 | 40113 | 结转制造费用 | 27893.2 |  | RMB | 27893.2 |  |  | 00201
记账 | 25 | 40113 | 结转制造费用 | 35871.4 |  | RMB | 35871.4 |  |  | 00202
记账 | 25 | 40113 | 结转制造费用 | 21433 |  | RMB | 21433 |  |  | 00203
记账 | 25 | 40113 | 结转制造费用 | 20022.24 |  | RMB | 20022.24 |  |  | 00204
记账 | 25 | 40513 | 结转制造费用 |  | 105219.84 | RMB | 105219.84 |  |  |
记账 | 26 | 502 | 结转销售产品成本 | 656674.8 |  | RMB | 656674.8 |  |  |
记账 | 26 | 137001 | 结转销售产品成本 |  | 27688.8 | RMB | 27688.8 |  |  |
记账 | 26 | 137004 | 结转销售产品成本 |  | 628986 | RMB | 628986 |  |  |
记账 | 27 | 40503 | 计提折旧 | 6751.11 |  | RMB | 6751.11 |  |  |
记账 | 27 | 52113 | 计提折旧 | 10380.71 |  | RMB | 10380.71 |  |  |
记账 | 27 | 165 | 计提折旧 |  | 17131.82 | RMB | 17131.82 |  |  |
记账 | 28 | 166 | 工资转入 | 10300 |  | RMB | 10300 |  |  |
记账 | 28 | 401012 | 工资转入 | 11100 |  | RMB | 11100 |  |  | 00201
记账 | 28 | 40501 | 工资转入 | 9450 |  | RMB | 9450 |  |  |
记账 | 28 | 50301 | 工资转入 | 5900 |  | RMB | 5900 |  |  |
记账 | 28 | 52101 | 工资转入 | 5000 |  | RMB | 5000 |  |  |
记账 | 28 | 52101 | 工资转入 | 5500 |  | RMB | 5500 |  |  |
记账 | 28 | 211 | 工资转入 |  | 47250 | RMB | 47250 |  |  |
记账 | 29 | 40502 | 计提福利费 | 4319 |  | RMB | 4319 |  |  |
记账 | 29 | 50302 | 计提福利费 | 826 |  | RMB | 826 |  |  |
记账 | 29 | 52102 | 计提福利费 | 1470 |  | RMB | 1470 |  |  |
记账 | 29 | 214 | 计提福利费 |  | 6615 | RMB | 6615 |  |  |
记账 | 30 | 209 | 计提个人所得税 | 2300 |  | RMB | 2300 |  |  |
记账 | 30 | 22106 | 计提个人所得税 |  | 2300 | RMB | 2300 |  |  |
记账 | 31 | 501 | 结转收入 | 2700000 |  | RMB | 2700000 | 106 |  |
记账 | 31 | 501 | 结转收入 | 56000 |  | RMB | 56000 | 107 |  |
记账 | 31 | 321 | 结转收入 |  | 2756000 | RMB | 2756000 |  |  |
记账 | 32 | 321 | 结转费用、成本、税金 | 1160809.12 |  | RMB | 1160809.12 |  |  |
记账 | 32 | 401011 | 结转费用、成本、税金 |  | 7166.73 | RMB | 7166.73 |  |  | 00202
记账 | 32 | 401011 | 结转费用、成本、税金 |  | 3823.9 | RMB | 3823.9 |  |  | 00204
记账 | 32 | 401011 | 结转费用、成本、税金 |  | 5735.84 | RMB | 5735.84 |  |  | 00203
记账 | 32 | 401011 | 结转费用、成本、税金 |  | 6142.91 | RMB | 6142.91 |  |  | 00201
记账 | 32 | 401012 | 结转费用、成本、税金 |  | 57156 | RMB | 57156 |  |  | 00201
记账 | 32 | 401012 | 结转费用、成本、税金 |  | 32280 | RMB | 32280 |  |  | 00203
记账 | 32 | 401012 | 结转费用、成本、税金 |  | 23998.14 | RMB | 23998.14 |  |  | 00202
记账 | 32 | 401012 | 结转费用、成本、税金 |  | 54720 | RMB | 54720 |  |  | 00204
记账 | 32 | 401013 | 结转费用、成本、税金 |  | 20022.24 | RMB | 20022.24 |  |  | 00204
记账 | 32 | 401013 | 结转费用、成本、税金 |  | 27893.2 | RMB | 27893.2 |  |  | 00201
记账 | 32 | 401013 | 结转费用、成本、税金 |  | 21433 | RMB | 21433 |  |  | 00203
记账 | 32 | 401013 | 结转费用、成本、税金 |  | 35871.4 | RMB | 35871.4 |  |  | 00202
记账 | 32 | 40501 | 结转费用、成本、税金 |  | 91506 | RMB | 91506 |  |  |
记账 | 32 | 40502 | 结转费用、成本、税金 |  | 15806.84 | RMB | 15806.84 |  |  |
记账 | 32 | 40503 | 结转费用、成本、税金 |  | 9421.11 | RMB | 9421.11 |  |  |
记账 | 32 | 40504 | 结转费用、成本、税金 |  | 1116 | RMB | 1116 |  | 00202 |
记账 | 32 | 40504 | 结转费用、成本、税金 |  | 1734 | RMB | 1734 |  | 00203 |
记账 | 32 | 40504 | 结转费用、成本、税金 |  | 1341 | RMB | 1341 |  | 00201 |
记账 | 32 | 40506 | 结转费用、成本、税金 |  | 1256 | RMB | 1256 |  | 00201 |
记账 | 32 | 40506 | 结转费用、成本、税金 |  | 2103 | RMB | 2103 |  | 00202 |
记账 | 32 | 40506 | 结转费用、成本、税金 |  | 1928 | RMB | 1928 |  | 00203 |
记账 | 32 | 40512 | 结转费用、成本、税金 |  | -105219.84 | RMB | -105219.84 |  | 00201 |
记账 | 32 | 40512 | 结转费用、成本、税金 |  | -315 | RMB | -315 |  | 00204 |
记账 | 32 | 40512 | 结转费用、成本、税金 |  | -157 | RMB | -157 |  | 00205 |
记账 | 32 | 502 | 结转费用、成本、税金 |  | 656674.8 | RMB | 656674.8 |  |  |
记账 | 32 | 50301 | 结转费用、成本、税金 |  | 5900 | RMB | 5900 |  |  |
记账 | 32 | 50302 | 结转费用、成本、税金 |  | 826 | RMB | 826 |  |  |
记账 | 32 | 50303 | 结转费用、成本、税金 |  | 1500 | RMB | 1500 |  | 00105 |
记账 | 32 | 52101 | 结转费用、成本、税金 |  | 133951 | RMB | 133951 |  |  |
记账 | 32 | 52102 | 结转费用、成本、税金 |  | 18753.14 | RMB | 18753.14 |  |  |
记账 | 32 | 52105 | 结转费用、成本、税金 |  | 2000 | RMB | 2000 |  | 00105 |
记账 | 32 | 52113 | 结转费用、成本、税金 |  | 13780.71 | RMB | 13780.71 |  |  |
记账 | 32 | 52118 | 结转费用、成本、税金 |  | 2100 | RMB | 2100 |  | 00104 |
记账 | 32 | 52119 | 结转费用、成本、税金 |  | 560 | RMB | 560 |  | 00105 |
记账 | 32 | 52201 | 结转费用、成本、税金 |  | 8000 | RMB | 8000 |  |  |
记账 | 33 | 504 | 计提教育和城建税 | 74025.24 |  | RMB | 74025.24
记账 | 33 | 22103 | 计提教育和城建税 |  | 51817.67 | RMB | 51817.67
记账 | 33 | 22901 | 计提教育和城建税 |  | 22207.57 | RMB | 22207.57
记账 | 34 | 551 | 计提所得税 | 526412.99 |  | RMB | 526412.99
记账 | 34 | 22102 | 计提所得税 |  | 526412.99 | RMB | 526412.99
记账 | 35 | 321 | 结转所得税 | 600438.23 |  | RMB | 600438.23
记账 | 35 | 504 | 结转所得税 |  | 74025.24 | RMB | 74025.24
记账 | 35 | 551 | 结转所得税 |  | 526412.99 | RMB | 526412.99


资料14

资料14：产品项目费用发生表的基本格式：

项目 | P1产品 | P2产品 | P3产品 | P4产品 | 合计
材料费 |  |  |  |  |
人工费 |  |  |  |  |
制造费用 |  |  |  |  |
合计 |  |  |  |  |

资料15：部门费用明细表（部分）的基本格式：

部门 | 办公费 | 差旅费 | 业务招待费 | 物耗费 | 合计
经理办公室 |  |  |  |  |
物资及采购部 |  |  |  |  |
市场营销部 |  |  |  |  |
厂部 |  |  |  |  |
合计 |  |  |  |  |


报表的参考答案

1、紫牛公司2002年12 月资产负债表

                                    资产负债表

编报单位：紫牛公司 　2002年12月

项目 | 行次 | 期初数 | 期末数 | 负债及所有者权益 | 行 次 | 期初数 | 期末数
流动资产： |  |  |  | 流动负债： |  |  |
货币资金 | 1 | 2,110,939.00 | 1,731,219.80 | 短期借款 | 45 | 600,000.00 |
短期投资 | 2 | 30,000.00 | 30,000.00 | 应付票据 | 46 |  | 31,590.00
应收票据 | 3 | 35,000.00 |  | 应付账款 | 47 | 185,838.90 | 64,604.30
应收股利 | 4 |  |  | 预收账款 | 48 | 726,060.00 | 46,700.00
应收利息 | 5 |  |  | 应付工资 | 49 | 345,908.00 | 425,715.80
应收账款 | 6 | 53,019.00 | 616,053.00 | 应付福利费 | 50 | 468,900.00 | 528,500.21
其他应收款 | 7 | 2,340.00 | 3,000.00 | 应付股利（利润） | 51 |  | 79,479.42
预付账款 | 8 | 296,846.00 | 4,570.00 | 应交税金 | 52 | 695,263.00 | 1,186,702.88
期货保证金 | 9 |  |  | 其他应交款 | 53 |  | 8,196.34
应收补贴款 | 10 |  |  | 其他应付款 | 54 | 45,050.00 | 38,948.90
应收出口退税 | 11 |  |  | 预提费用 | 55 | 4,534.00 | 12,534.00
存货 | 12 | 1,977,933.70 | 1,054,023.13 | 预计负债 | 56 |  |
其中：原材料 | 13 | 313,822.50 | 451,483.50 | 一年内到期的长期负债 | 57 |  |
产成品（库存商品） | 14 | 1,646,562.00 | 585,218.50 | 其他流动负债 | 58 |  |
待摊费用 | 15 | 3,551.00 | 3,551.00 | 流动负债合计 | 59 | 3,071,553.90 | 2,422,971.85
待处理流动资产净额 | 16 |  |  | 长期负债： |  |  |
一年内到期的长期债权投资 | 17 | 42,615.44 | 42,615.44 | 长期借款 | 60 | 500,000.00 | 500,000.00
其他流动资产 | 18 |  |  | 应付债券 | 61 |  |
流动资产合计 | 19 | 4,509,469.51 | 3,442,257.74 | 长期应付款 | 62 |  |
长期投资： |  |  |  | 专项应付款 | 63 |  |
长期股权投资 | 20 |  |  | 其他长期负债 | 64 |  |
长期债权投资 | 21 | 42,615.44 | 42,615.44 | 其中：特准储备资金 | 65 |  |
＊合并差价 | 22 |  |  | 长期负债合计 | 66 | 500,000.00 | 500,000.00
长期投资合计 | 23 | 42,615.44 | 42,615.44 | 递延税款： |  |  |
固定资产： |  |  |  | 递延税款贷项 | 67 |  |
固定资产原值 | 24 | 3,575,780.00 | 3,596,880.00 | 负债合计 | 68 | 3,571,553.90 | 2,922,971.85
减：累计折旧 | 25 | 13,678.00 | 36,967.05 | 所有者权益（或股东权益） |  |  |
固定资产净值 | 26 | 3,562,102.00 | 3,559,912.95 | 少数股东权益 | 69 |  |
减：固定资产减值准备 | 27 |  |  | 实收资本(或股本） | 70 | 4,000,000.00 | 4,000,000.00
固定资产净额 | 28 | 3,562,102.00 | 3,559,912.95 | 国家资本 | 71 |  |
工程物资 | 29 | 9,970.00 | 5,515.00 | 集体资本 | 72 |  |
在建工程 | 30 | 592,091.00 | 771,018.44 | 法人资本 | 73 |  |
固定资产清理 | 31 |  | 15,600.00 | 其中：国有法人资本 | 74 |  |
待处理固定资产净损失 | 32 |  |  | 集体法人资本 | 75 |  |
固定资产合计 | 33 | 4,164,163.00 | 4,352,046.39 | 个人资本 | 76 |  |
无形资产及递延资产: |  |  |  | 外商资本 | 77 |  |
无形资产 | 34 |  |  | 减：已归还投资（中外合作经营企业填列） | 78 |  |
其中：土地使用权 | 35 |  |  | 实收资本（或股本）净额（中外合作经营企业填列） | 79 |  |
递延资产（长期待摊费用） | 36 | 4,560.00 | 4,560.00 | 资本公积 | 80 |  |
其中：固定资产修理 | 37 |  |  | 盈余公积 | 81 | 600,590.05 | 640,329.76
固定资产改良支出 | 38 |  |  | 其中：法定盈余公积 | 82 |  |
其他长期资产 | 39 |  |  | 公益金 | 83 |  |
其中：特准储备物资 | 40 |  |  | 补充流动资本 | 84 |  |
无形资产及其他资产合计 | 41 | 4,560.00 | 4,560.00 | 未确认的投资损失（以“-”号填列） | 85 |  |
 | 42 |  |  | 未分配利润 | 86 | 548,664.00 | 278,177.96
递延税款： |  |  |  | 外币报表折算差额 | 87 |  |
递延税款借项 | 43 |  |  | 所有者权益（或股东权益）合计 | 88 | 5,149,254.05 | 4,918,507.72
资产总计 | 44 | 8,720,807.95 | 7,841,479.57 | 负债和所有者权益（或股东权益）总计 | 89 | 8,720,807.95 | 7,841,479.57

注：表中带*科目为合并会计报表专用

2、紫牛公司2002年12月损益表

损益表

编制单位：紫牛公司　　　　　　　　2002年12月　　　　　　　　　　　　单位：元

项目 | 行次 | 本月数 | 本年数
一、主营业务收入 | 1 | 1,737,360.00 | 1,737,360.00
其中：出口产品(商品)销售收入 | 2 |  |
进出口产品(商品)销售收入 | 3 |  |
减：折扣与折让 | 4 |  |
二、主营业务收入净额 | 5 | 1,737,360.00 | 1,737,360.00
减：主营业务成本 | 6 | 1,375,153.50 | 1,375,153.50
其中：出口产品(商品)销售成本 | 7 |  |
主营业务税金及附加 | 8 | 27,321.14 | 27,321.14
经营费用 | 9 | 14,817.00 | 14,817.00
其他 | 10 |  |
加：递延收益 | 11 |  |
代购代销收入 | 12 |  |
其他 | 13 |  |
三、主营业务利润（亏损以“-”号填列） | 14 | 320,068.36 | 320,068.36
加：其他业务利润(亏损以“-”号填列) | 15 |  |
减：营业费用 | 16 | 14,817.00 | 14,817.00
管理费用 | 17 | 178,875.61 | 178,875.61
财务费用 | 18 | 17,676.00 | 17,676.00
其他 | 19 |  |
四、营业利润（亏损以“-”号填列） | 20 | 123,516.75 | 123,516.75
加：投资收益（亏损以“-”号填列） | 21 |  |
期货收益 | 22 |  |
补贴收入 | 23 |  |
其中：补贴前亏损企业补贴收入 | 24 |  |
营业外收入 | 25 |  |
其他 | 26 |  |
其中：用以前年度含量工资结余弥补利润 | 27 |  |
减：营业外支出 | 28 |  |
其他支出 | 29 |  |
其中：结转的含量工资包干结余 | 30 |  |
加：以前年度损益调整 | 31 |  |
五、利润总额（亏损以“-”号填列） | 32 | 123,516.75 | 123,516.75
减：所得税 | 33 | 209,189.58 | 209,189.58
*少数股东损益 | 34 |  |
加：*末确认股东投资损失 | 35 |  |
六、净利润（净亏损以“-”号填列） | 36 | -85,672.83 | -85,672.83

注：表中带*科目为合并会计报表专用

补充资料：

项 目 | 本月数 | 本年累计数
1、出售、处置部门或被投资单位所得收益 |  |
2、自然灾害发生的损失 |  |
3、会计政策变更增加(或减少)利润总额 |  |
4、会计估计变更增加(或减少)利润总额 |  |
5、债务重组损失(或收益，亏损以“-”号填列) |  |
6、其他 |  |

3、紫牛公司2002年12月部门费用明细表

部门费用明细表

单位：紫牛公司 2002年12月 计量单位：元

部 门 | 办公费 | 差旅费 | 业务招待费 | 物耗费 | 合 计
经理办公室 | 590.00 | 2,120.00 |  | 360.90 | 3,070.90
物资及采购部 | 450.00 |  | 1,200.00 | 204.36 | 1,854.36
市场营销部 | 460.00 |  | 2,000.00 | 273.27 | 2,733.27
厂部 | 127.00 | 450.00 |  | 693.98 | 1,270.98
合计 | 1,627.00 | 2,570.00 | 3,200.00 | 1,532.51 | 8,929.51

4、紫牛公司2002年12月本月产品成本项目费用发生表

产品成本项目费用发生表

单位：紫牛公司 2002年12月 计量单位：元

项 目 | P1产品 | P2产品 | P3产品 | P4产品 | 合 计
材料费 | 9,537.00 | 6,358.00 | 28,531.23 | 18,439.53 | 62,865.76
人工费 | 64,136.90 | 23,998.14 | 35,283.00 | 54,720.00 | 178,138.04
制造费用 | 24,134.70 | 29,971.51 | 25,794.35 | 19,745.06 | 99,645.62
合 计 | 97,808.60 | 60,237.65 | 89,608.58 | 92,904.59 | 340,649.42


紫牛公司2003年01月资产负债表

资产负债表

编报单位：紫牛公司 2003年01月

项目 | 行次 | 期初数 | 期末数 | 负债及所有者权益 | 行 次 | 期初数 | 期末数
流动资产： |  |  |  | 流动负债： |  |  |
货币资金 | 1 | 1,731,219.80 | 3,800,720.23 | 短期借款 | 45 |  |
短期投资 | 2 | 30,000.00 | 30,000.00 | 应付票据 | 46 | 31,590.00 | 31,590.00
应收票据 | 3 |  |  | 应付账款 | 47 | 64,604.30 | 70,213.30
应收股利 | 4 |  |  | 预收账款 | 48 | 46,700.00 |
应收利息 | 5 |  |  | 应付工资 | 49 | 425,715.80 | 489,661.80
应收账款 | 6 | 616,053.00 | 632,423.00 | 应付福利费 | 50 | 528,500.21 | 582,876.77
其他应收款 | 7 | 3,000.00 |  | 应付股利（利润） | 51 | 79,479.42 | 79,479.42
预付账款 | 8 | 4,570.00 |  | 应交税金 | 52 | 1,186,702.88 | 1,491,392.97
期货保证金 | 9 |  |  | 其他应交款 | 53 | 8,196.34 | 30,403.91
应收补贴款 | 10 |  |  | 其他应付款 | 54 | 38,948.90 | 36,648.90
应收出口退税 | 11 |  |  | 预提费用 | 55 | 12,534.00 | 20,534.00
存货 | 12 | 1,054,023.13 | 383,178.95 | 预计负债 | 56 |  |
其中：原材料 | 13 | 451,483.50 | 438,223.50 | 一年内到期的长期负债 | 57 |  |
产成品（库存商品） | 14 | 585,218.50 | -71,456.30 | 其他流动负债 | 58 |  |
待摊费用 | 15 | 3,551.00 | 3,551.00 | 流动负债合计 | 59 | 2,422,971.85 | 2,832,801.07
待处理流动资产净额 | 16 |  |  | 长期负债： |  |  |
一年内到期的长期债权投资 | 17 | 42,615.44 | 42,615.44 | 长期借款 | 60 | 500,000.00 | 500,000.00
其他流动资产 | 18 |  |  | 应付债券 | 61 |  |
流动资产合计 | 19 | 3,442,257.74 | 4,849,713.99 | 长期应付款 | 62 |  |
长期投资： |  |  |  | 专项应付款 | 63 |  |
长期股权投资 | 20 |  |  | 其他长期负债 | 64 |  |
长期债权投资 | 21 | 42,615.44 | 42,615.44 | 其中：特准储备资金 | 65 |  |
＊合并差价 | 22 |  |  | 长期负债合计 | 66 | 500,000.00 | 500,000.00
长期投资合计 | 23 | 42,615.44 | 42,615.44 | 递延税款： |  |  |
固定资产： |  |  |  | 递延税款贷项 | 67 |  |
固定资产原值 | 24 | 3,596,880.00 | 3,602,980.00 | 负债合计 | 68 | 2,922,971.85 | 3,332,801.07
减：累计折旧 | 25 | 36,967.05 | 60,168.87 | 所有者权益（或股东权益） |  |  |
固定资产净值 | 26 | 3,559,912.95 | 3,577,532.00 | 少数股东权益 | 69 |  |
减：固定资产减值准备 | 27 |  |  | 实收资本(或股本） | 70 | 4,000,000.00 | 4,000,000.00
固定资产净额 | 28 | 3,562,102.00 | 3,577,532.00 | 国家资本 | 71 |  |
工程物资 | 29 | 9,970.00 | 5,515.00 | 集体资本 | 72 |  |
在建工程 | 30 | 592,091.00 | 774,945.88 | 法人资本 | 73 |  |
固定资产清理 | 31 | 15,600.00 | 25,900.00 | 其中：国有法人资本 | 74 |  |
待处理固定资产净损失 | 32 |  |  | 集体法人资本 | 75 |  |
固定资产合计 | 33 | 4,352,046.39 | 4,349,172.01 | 个人资本 | 76 |  |
无形资产及递延资产: |  |  |  | 外商资本 | 77 |  |
无形资产 | 34 |  |  | 减：已归还投资（中外合作经营企业填列） | 78 |  |
其中：土地使用权 | 35 |  |  | 实收资本（或股本）净额（中外合作经营企业填列） | 79 |  |
递延资产（长期待摊费用） | 36 | 4,560.00 | 4,560.00 | 资本公积 | 80 |  |
其中：固定资产修理 | 37 |  |  | 盈余公积 | 81 | 640,329.76 | 640,329.76
固定资产改良支出 | 38 |  |  | 其中：法定盈余公积 | 82 |  |
其他长期资产 | 39 |  |  | 公益金 | 83 |  |
其中：特准储备物资 | 40 |  |  | 补充流动资本 | 84 |  |
无形资产及其他资产合计 | 41 | 4,560.00 | 4,560.00 | 未确认的投资损失（以“-”号填列） | 85 |  |
 | 42 |  |  | 未分配利润 | 86 | 278,177.96 | 1272,930.61
递延税款： |  |  |  | 外币报表折算差额 | 87 |  |
递延税款借项 | 43 |  |  | 所有者权益（或股东权益）合计 | 88 | 4,918,507.72 | 5,913,260.37
资产总计 | 44 | 7,841,479.57 | 9,246,061.44 | 负债和所有者权益（或股东权益）总计 | 89 | 7,841,479.57 | 9,246,061.44

注：表中带*科目为合并会计报表专用

紫牛公司2003年01月损益表

损益表

编制单位：紫牛公司　　　　　　　2003年01月　　　　　　　　　　　　　单位：元

项目 | 行次 | 本月数 | 本年数
一、主营业务收入 | 1 | 2,756,000.00 | 2,756,000.00
其中：出口产品(商品)销售收入 | 2 |  |
进出口产品(商品)销售收入 | 3 |  |
减：折扣与折让 | 4 |  |
二、主营业务收入净额 | 5 | 2,756,000.00 | 2,756,000.00
减：主营业务成本 | 6 | 656,674.80 | 656,674.80
其中：出口产品(商品)销售成本 | 7 |  |
主营业务税金及附加 | 8 | 74,025.24 | 74,025.24
经营费用 | 9 | 8,226.00 | 8,226.00
其他 | 10 |  |
加：递延收益 | 11 |  |
代购代销收入 | 12 |  |
其他 | 13 |  |
三、主营业务利润（亏损以“-”号填列） | 14 | 2,017,073.96 | 2,017,073.96
加：其他业务利润(亏损以“-”号填列) | 15 |  |
减：营业费用 | 16 | 8,226.00 | 8,226.00
管理费用 | 17 | 171,144.85 | 171,144.85
财务费用 | 18 | 8,000.00 | 8,000.00
其他 | 19 |  |
四、营业利润（亏损以“-”号填列） | 20 | 1,837,929.11 | 1,837,929.11
加：投资收益（亏损以“-”号填列） | 21 |  |
期货收益 | 22 |  |
补贴收入 | 23 |  |
其中：补贴前亏损企业补贴收入 | 24 |  |
营业外收入 | 25 |  |
其他 | 26 |  |
其中：用以前年度含量工资结余弥补利润 | 27 |  |
减：营业外支出 | 28 |  |
其他支出 | 29 |  |
其中：结转的含量工资包干结余 | 30 |  |
加：以前年度损益调整 | 31 |  |
五、利润总额（亏损以“-”号填列） | 32 | 1,837,929.11 | 1,837,929.11
减：所得税 | 33 | 526,412.99 | 526,412.99
*少数股东损益 | 34 |  |
加：*末确认股东投资损失 | 35 |  |
六、净利润（净亏损以“-”号填列） | 36 | 1,311,516.12 | 1,311,516.12

注：表中带*科目为合并会计报表专用

补充资料：

项 目 | 本月数 | 本年累计数
1、出售、处置部门或被投资单位所得收益 |  |
2、自然灾害发生的损失 |  |
3、会计政策变更增加(或减少)利润总额 |  |
4、会计估计变更增加(或减少)利润总额 |  |
5、债务重组损失(或收益，亏损以“-”号填列) |  |
6、其他 |  |


也论财务软件发展趋势

广东财会2001年会计电算化特刊 汤四新

一、财务软件的本质特征

财务软件是一种能够帮助会计人员完成财务工作的应用软件，是会计人员可以借助并用来做帐、算帐、报帐以及进行财务管理与控制的现代化工具。换句话说，企业会计人员没有财务软件同样要进行财务工作。因此，从本质上讲财务软件就象历史悠久的算盘一样，只是一种工具。众所周知，工具之于劳动是不能改变劳动本身的性质，而只能对劳动的效率、劳动的组织方式产生影响。同样的道理，财务软件也不能改变会计本身的性质，而只能对会计工作的效率、会计工作的组织方式产生影响。

二、影响财务软件发展的因素

对国内财务软件的发展构成影响的因素很多，本文基于财务软件是一种工具的观点，从以下九个方面论述一下我国财务软件未来的发展趋势。不当之处敬请各位读者批评指正。一、会计理论及会计制度的变化发展要求财务软件必须适应会计的变化发展。综观建国以来的会计发展史，我们不难看出每次会计理论及会计制度的重大变化对我国会计工作都造成了比较大的影响。会计工作本身发生了变化，作为工具的财务软件理所当然地必须适应会计工作的变化。这一点从早期的财务软件与现在的财务软件的对比也可看出。二、政府部门主要是财政部门和税务部门宏观管理的需要要求财务软件必须适应他们管理的要求。随着市场经济的进一步发展和完善，现代企业制度的确立，国有资产管理制度改革步伐的加剧以及社会保障制度的不断完善，政府部门特别是财税部门对企业的宏观管理模式也在调整变化之中，这种来自政府管理部门管理方式方法的改变必将对企业会计数据的真实性、有效性、一致性等产生新的要求。同样作为会计工作的工具的财务软件势必也要满足这方面的要求。三、企事业单位深化微观管理改革要求财务软件适应他们业务管理的要求。企事业单位作为国家经济命脉的细胞，本身内部也会不断产生对会计工作要求的变革和提高，这种变化也是财务软件不可忽视的方面。实际上目前大多数财务软件厂商都非常关注这方面的问题。将财务软件是否适应企事业单位微观管理的需求摆到非常重要的位置上。四、计算机软件技术及硬件技术、特别是网络技术的突飞猛进从实现手段上改观了财务软件的功能特征。财务软件作为一种计算机软件，理所当然计算机软件技术及硬件技术的变化发展会对财务软件造成影响。如果说财务软件是会计工作的工具，那么可以说计算机软硬件技术是财务软件的制造工具和运行平台。近几年财务软件的变化发展就充分地体现了这方面的情况。如WINDOWS版财务软件的出现、多媒体财务软件的出现、网络财务软件的出现无不是计算机软硬件技术、特别是网络技术的突飞猛进从制造工具和运行平台上改观了财务软件的功能特征。五、信息科学、管理科学的变化发展要求财务软件改变传统的运作模式。财务软件作为一种企业资金流信息加工工具和企业管理辅助工具，也势必要受到信息科学及管理科学的影响，最主要的是受到社会主流所接受和应用的信息科学及管理科学的影响。六、主流财务软件开发商的开发水平的不断提高导致财务软件更新换代的不断提速。目前财务软件的版本更新速度大约是一年出一个新版，从许多用户的感受来看似乎财务软件的更新太快了，搞得有些用户无所适从。但冷静地分析一下，我们不能看出：一方面财务软件版本的更新速度不断加剧从积极的意义来说加快了财务软件的发展，另一方面如果更新换代的只是平台的变换或主要是开发平台和运行平台的变化就避免不了炒作的嫌疑，它所带来的负面影响比正面影响更大。我们希望在财务软件的升级换代中看到更多的是功能的增强，更多的是设计思想的更新。七、财务人员的应用水平不断提高要求财务软件提供更强大的功能。随着会计电算化的不断普及，财会人员的计算机应用水平已今非昔比。知道的愈多要求也就愈高，对财务软件的功能需求就更高。是否能满足这方面的需求是真正衡量和判断财务软件是否适应会计工作的非常重要的方面。八、财务软件市场竞争态势的不断加剧导致财务软件档次的不断分化和真正行业化倾向的加强。2000年在财务软件市场出现了几个低端产品，销量不错，但应用效果不佳。从一定程度上打乱了原来财务软件市场的秩序。同时，国外高端财务软件也有不少进入了中国市场，虽然销量不大，但成交额可喜。这两个方面的同时作用，让财务软件的竞争态势愈演愈烈。买方市场已经形成，操作更加规范。财务软件出现了真正的分行业分客户群的发展方向。九、财务软件与其它企业管理软件集成过程中的互相融合及影响。在整个企业管理信息系统中，财务软件只是一个解决财务部门会计工作的部门级软件，企业的资金流实际上是伴随着物资流、信息流、工作流的流动而形成的。因此，财务软件势必与其它企业管理软件发生联系。在企业实施企业级管理软件的过程中，财务软件也需要不断调整以满足与其它管理软件的衔接。

三、对下一代财务软件的预测

经过近二十年的发展，我国财务软件有了一个长足的发展，许多学术界和实业界的朋友都认为财务软件发展到今天在整体结构上不会有大的变化。说变化也是小的完善性改变，或者是开发平台或运行平台的改变。笔者在此抒一己见。

现在大多数企业实现会计电算化的方式一般有两种：一种是购买通用的财务软件，另一种是实行定点开发。所谓“通用财务软件”是指企业可以在市场上购买到一种成型的同时又适应本企业需求的财务软件，拿来就用；所谓“定点开发”是指企业由于自身业务的特殊性和需求的特殊性在市场上寻找不到一个适应本企业要求的软件，只能采用软件工程的方法进行专项的定点开发。然而，随着企业会计电算化工作的进一步开展，当企业的普遍性需求得到满足后，由业务的特殊性和需求的特殊性引发的对软件的个性化要求会越来越明显、越来越多，企业将面临一个使用通用软件满足不了个性化的要求，采用定点开发又周期太长、费用太高、且存在一定的投资风险的困境。如何解决这个难题呢？需要引入一种全新的财务软件来解决这个难题，这种全新的财务软件应该是介于通用财务软件与定点开发财务软件之间的既能满足企业的普遍性也就是通用性需求又能企业的特殊性也就是个性化的需求的软件。这种软件可以称其为“第三种财务软件”或“个性化的财务软件”。那么第三种财务软件应该具备什么样的特征呢？

第三种财务软件首先应该具备的第一大特征是“面向数据”。企业特殊性的需求最明显表现出来的是某个处理对象具有一些不同于其他一般对象的属性，第三种财务软件首先应该能满足这种需求。譬如：我们大多数企业的入库单不需要有一个采购定单号字段，但是某个企业为了业务控制的需要在入库单中必须要有一个采购订单号字段。这种特殊性需求的满足要求我们的软件必须具备用户自定义字段的功能，这种用户自定义字段的功能就是我们所说的“面向数据”概念的一部分。其实，“面向数据”还应该包括用户自定义字段之间的钩稽关系、用户自定义输入界面等用于满足数据源和目的库的自定义功能。

第三种财务软件应该具备的第二大特征是“业务导向”。所谓业务导向就是企业可以根据自身业务流程来定义软件的工作流程，是一种软件迁就用户而不是用户迁就软件的模式。譬如：一般企业是先验收后入库，要求入库时必须有验收单，但某个企业由于自身业务量太大，验收工作跟不上来，可能变成先入库后验收的方式，如果一个软件规定必须先验收后入库，那么这个软件在这个企业就不能使用，如果一个软件的业务处理流程用户可以自定义，那么这个软件就能满足这个企业的需求。当然，“业务导向”决非如此简单，它的主要内涵是用户可以自定义工作步骤、处理流程和数据加工方法等。

第三种财务软件应该具备的第三大特征是满足“IOD”的要求。所谓“IOD”就是Information on Demand的缩写，它的意思是指企业需要什么样的信息软件就能加工得到什么样的信息。它主要包括用户可以自定义输出内容、用户可以自定义输出格式、用户可以自定义输出载体等。

综上所述，已经可以看到第三种财务软件是一种有别于通用型财务软件和定点开发财务软件的一种全新的财务软件。它能满足企业普遍性的需求又能满足企业特殊性的需求，而且在满足特殊性需求时无需大动干戈，用户只要稍做改动就能轻松实现。也许这就是下一代主流财务软件的风范。


企业成本核算

企业成本核算、分析与管理解决方案探讨

广东财会1999年会计电算化特刊 汤四新

一、 成本核算、分析与管理对企业的重要性

在知识经济时代，面对愈来愈激烈的市场竞争，企业如何增强自己的竞争力，赢得客户？采用现代化的管理方法，借助先进的管理工具和管理手段对企业实施电脑化管理，充分发挥电脑及时、准确的优点，代替人脑的部分劳动，将人从繁重的脑力劳动中解脱出来，以此赢得时间，方能抢占先机，领先同侪。

对于工商业企业而言，采购、仓储、销售三大职能部门构成一套完整的进销存核算与管理系统，企业大量的业务信息和财务信息在三大职能部门间快速流动，如何充分利用这些信息达到减少和降低采购成本与费用、仓储成本与费用、销售成本与费用，提高客户满意度呢？关键在于建立一套完全适应企业本身经营规模和业务流程及管理需求的业务与财务进销存核算与管理系统，实现整个企业资源共享。

对于制造业企业来说，生产管理与控制是各业务管理系统的重中之重，而成本核算与管理又是生产管理与控制的核心。可以说，一个没有成本核算与管理的生产管理与控制系统犹如人之没有大脑，人之没有灵魂。

对于财务部门来说，会计电算化不仅包括帐务系统、报表系统、工资核算、固定资产核算的电算化，更应包括采购核算与管理、库存核算与管理、销售核算与管理、成本核算分析与管理的电算化。可以说，前者的电算化只完成了整个会计电算化工作的20%左右的工作，而后者的电算化才能将会计人员从繁重的重复性脑力劳动中解脱出来，真正将精力放到财务计划、预算、分析、控制上来。

二、 目前成本核算与管理系统解决方案综述

目前市场上存在许多品牌的财务与企业管理软件，到目前为止通过财政部评审的财务软件就有38家，通过各地省级以下财政部门评审的就更多了。在如此众多的财务软件中，许多软件公司都有自己解决成本核算与管理问题的方法。综观目前国内外软件公司对生产管理与控制、对成本核算、分析与管理的实现方式不外乎两种：有的厂商信奉所谓“最佳业务实践”，希望从成功企业的管理模式和业务流程中提炼出精华，集成到自己开发的软件中来，这种软件往往大而全，企业在做实施时一般要做业务流程重组（BPR）,然后再进行软件的安装与调试，因此这种软件对企业的要求也比较高。而且，所谓的“最佳业务实践”也未必是放之四海而皆准的。这类成本核算与管理软件一般提供所谓的行业版特种成本核算与管理系统。还有一些厂商，他们的产品按照不同的功能分成许多非常细的功能子系统，用户可以自由选择、自由设定本企业的业务流程与处理方法，具体到成本核算来说就是用户可以根据自身生产流程和成本核算的需要自行设置成本计算步骤和费用归集与分配方法。这种结构的软件灵活性非常强，实施商可根据用户的要求进行二次开发，为每一用户提供量身定做的解决方案。因此，当用户的经营环境和业务流程发生改变时，系统本身也可以轻松地加以改变，适应新的需求。目前我们能看到的软件大多是前者，属于后者的软件寥寥无几。

一般而言，财务及企业管理软件的功能模块可以用下表加以概括：

部门级

产品名称 |  | 主 要 模 块
普及版 |  | 总帐、报表管理系统（含现金流量表）、出纳、往来管理
标准版 |  | 总帐、报表管理系统（含现金流量表）、出纳、往来管理、财务分析、工资管理、固定资产管理
工业版 | 基础版 | 总帐、报表管理系统（含现金流量表）、出纳、往来管理、财务分析、工资管理、固定资产管理、采购核算与管理、库存核算与管理、销售核算与管理
 | 完全版 | 总帐、报表管理系统（含现金流量表）、出纳、往来管理、财务分析、工资管理、固定资产管理、采购核算与管理、库存核算与管理、销售核算与管理、成本核算与管理
商业版 |  | 总帐、报表管理系统（含现金流量表）、出纳、往来管理、财务分析、工资管理、固定资产管理、进销存核算与管理
行政事业版 |  | 总帐、报表管理系统（含现金流量表）、出纳、往来管理、财务分析、工资管理、固定资产管理
报表合并 |  | 报表多级汇总与合并
经理/厂长查询系统 |  | 经理、厂长查询分析系统
二次开发
 |  | 按企业业务流程定制进销存核算与管理（含与财务对接）
 |  | 按企业成本核算流程定制工业成本核算、分析与管理
企业级
商贸企业综合业务信息管理系统 |  | 总帐、报表（含现金流量表）、出纳、往来管理、财务分析、工资管理、固定资产管理、采购核算与管理、库存核算与管理、销售核算与管理、经理、厂长查询分析系统
制造企业生产控制与管理信息系统 |  | 总帐、报表（含现金流量表）、出纳、往来管理、财务分析、工资管理、固定资产管理、采购核算与管理、库存核算与管理、销售核算与管理、成本核算与管理、经理、厂长查询分析系统

企业实现电脑化管理，总体上可分三步走：

第一步：从资金流的管理入手，首先实施财务部门的部门级电算化。对工业企业而言有以下可选方案：

方案一：普及版+（标准版-普及版）+（工业基础版-标准版）+（工业完全版-工业基础版）

方案二：标准版+（工业基础版-标准版）+（工业完全版-工业基础版）

方案三：工业基础版+（工业完全版-工业基础版）

方案四：工业进销存+成本核算与管理

第二步：在第一步初战告捷之后，企业已经初步体验到电脑化管理的好处，在此基础上希望电脑帮助他们解决更多更复杂的业务与核算问题，更注重企业个性化的需求的满足，这时可根据企业成本核算流程与业务流程的量身定制工业进销存与成本核算与管理系统。

第三步：在第二步顺利完成的基础上，企业已经完全解决好资金流的管理问题，下一步应该向解决物流、人流、其它信息流如供应商、分销商、客户的管理上来，在此阶段可实施企业级的以财务管理为核心的财务与业务一体化的企业级管理信息系统的二次开发工作。

三、 一个优秀的成本核算、分析与管理解决方案

笔者最近有幸参加了一个《企业成本核算、分析与管理解决方案研讨会》，在研讨会上见到了一个由三门公司推出的企业成本核算、分析与管理软件。该方案针对我国国情，提出了一个面向数据、满足业务导向、满足按需信息（Information On Demand）[参考注释]的适合我国大多数企业现状与未来发展的解决方案。

成本核算与管理模块是财务软件中逻辑关系上最复杂的一个系统，为了解决这个问题，他们引进了不少巧妙的算法，定义了一些财务专用函数和命令，如：

十多种财务专用函数 如： yje@mo_

自动矫正误差的分配命令 如：F Lxx=(exp,Lyy)

几类生成转帐凭证的命令 如：Zx(....)

按代号传送命令

如：DH(Lxx=G(w,~&Lyy[exp]),j_=b,e)

报表分解合并命令 如：HB(......)

与此同时，提出了全息表、后备库、装配表三位一体的新概念，三位一体作整个核算单体系的一个环节，或一个登记行，或一个结点。

具体来讲，似乎没有一个工厂不具有自己的特点，生产流程，核算方法，核算顺序，如果企图编一个方法程序库，用点菜单的方法来解决这个问题，是没有指望的，编程者将永无出头之路。那么怎么做呢？他们的做法是：设计与每一步相应的成本分析单，该分析单应当允许用户任意画表，任意从其他库、表中取信息、执行运算加工命令等等；而先做什么，后做什么，体现在本系统对核算环节的登记、复制、撤消与管理之中，点菜单执行了某些环节后，又随时可到其他模块去执行统计、转帐、登帐、再来核算，分配，如此往来数次，就可解决工厂的成本核算与管理问题。

为了配合成本分析，该软件在各个子系统的万能登记管理库中登记生成了有关各库,为成本分析扫清了障碍。

如：（通过扩展系统解决）

收料子系统完成本期库存数量、材料价格动态的核算；

领料子系统完成库存数量、价格、差异分配、领用各单位的各统计表；

工资的各种统计表及转帐也构成了成本分析的一个分量；

零星的报帐已经体现到当月凭证或科目金额库之中；

上期的在制成本也已在有关模块中准备就绪；

在成本分析模块中只管归集、分配、再归集、再分配，最后再进行“完工产品”与“在制产品“的分配，前者得到了产品的工厂或企业成本，后者滚到下期，又作期初成本。

最后，按财务数据需要生成各流程相应的转帐凭证，经财务负责人审核通过，生成当期报表。

注释：面向数据的意思是用户可以根据自己的要求定义数据项，定义数据源和目标库；业务导向的意思是用户可以根据自己的业务流程定义软件的工作流程，让软件迁就用户的业务流程，而不要用户去迁就软件的要求；按需信息即IOD是Information On Demand的缩写，意思是用户自己可以根据自己的需求定义输出各种表格和图表。


企业财务软件应用模式及其识别过程分析

财会月刊.A版2004年第7期 汤四新

随着软、硬件价格的大幅下跌，企业信息化浪潮一浪高过一浪，越来越多的企业准备上马或升级会计电算化软件项目。然而，其效果总是差强人意。原因何在？笔者认为，造成这种情形主要有三个方面的原因：首先，企业对会计电算化的应用模式缺乏认识，不具备应用模式识别能力；其次，软件供应商出于成本与利益计，不能或不愿提供应用模式免费咨询服务；最后，第三方咨询业不发达，企业咨询意识普遍淡薄。本文只就会计电算化应用模式及应用模式识别过程略作分析。旨在抛砖引玉、提高认识、服务社会。

目前，国内市场上大多数财务软件主要包括账务、报表、出纳、工资、固定资产、财务分析六大模块（不同品牌的软件其模块划分略有差异）。所谓应用模式可以理解为对财务软件六大模块的使用组合策略与使用顺序策略。而应用模式识别过程可以理解为企业通过一系列活动，运用一系列方法从众多的应用模式中筛选符合企业实际的应用模式的过程。试想，若企业具备了财务软件应用模式及其识别过程的知识与技能，上述诸多原因就会灰飞湮灭，问题也可迎刃而解。

１．应用模式的分类

如果用穷举法列举财务软件六大模块的应用模式，将有1957种之多（P60+P61+ P62+ P63+ P64+ P65+ P66）。从分析各应用模式的应用目标、应用前提、应用重点、选用模块、模块间集成度等特征出发，则可将其划分为五种不同层次的基本类型。即：辅助做账模式、甩手工账模式、专项核算模式、一体核算模式和财务管理模式。

１．１辅助做账模式

辅助做账就是财务人员借助某种电子表格软件（如：Excel软件）进行会计凭证、会计账簿、会计报表、工资计算、成本计算等会计处理。此模式下，虽然许多会计资料都可以在电脑中加工、存贮和输出，但是会计数据间的勾稽关系基本上由人工控制，会计数据间一致性、安全性无法确保。因此，此模式未被大多数企业采用。在会计实务中，一般而言，当企业已购置了电脑、却因会计业务特殊、认识不清而暂时未能获取合适的财务软件；或只用于记录业务台账时采用此模式。

１．２甩手工账模式

甩手工账模式就是主要采用账务、报表两大模块，使用财务软件进行会计凭证、会计账簿、会计报表的集成处理。此模式能够妥善地解决证、账、表会计数据的一致性和安全性问题。会计数据处理的自动化程度得到了提高。因此，此模式是目前会计电算化实务中应用最广的模式。

１．３专项核算模式

专项核算模式就是采用出纳、工资、固定资产等专项模块，使用软件进行会计专项业务的核算与管理。例如：使用工资模块进行工资的计算与发放；使用固定资产模块进行固定资产卡片账的管理；使用出纳模块进行现金日记账、银行存款日记账的登记以及银行对账单的对账和银行存款余额调节表的自动编制；等等。因此，此模式重点解决会计业务中某些专项业务的核算与管理，固称之为专项核算模式。在会计实务中，一般而言，只有当企业某些业务采用人工管理难以奏效时，就会采用此模式。例如：某企业由于业务需要，开户帐户多，结算频繁，此时，会采用出纳专项核算；某企业员工类型多，工资结构复杂，此时，会采用工资专项核算；等等。

１．４一体核算模式

一体核算模式就是采用账务、报表、出纳、工资、固定资产五大模块，在保证证、账、表集成处理和各专项系统的核算与管理的基础上，充分实现各模块间的数据共享和相互控制，从而将五大模块连接成一体。例如：出纳模块的出纳日记账与账务模块的会计日记账之间的稽核与控制；工资模块与账务模块之间关于工资计提、工资发放及其它与工资有关的各项税费计提的转账凭证的生成与传递；固定资产模块与账务模块之间关于固定资产新增、变动、折旧等处理的各转账凭证的生成与传递；等等。因此，一体核算模式是一种追求会计数据充分共享、确保会计数据相互稽核的核算模式。

１．５财务管理模式

财务管理模式就是全面采用账务、报表、出纳、工资、固定资产、财务分析六大模块，在一体核算模式的基础上增加财务分析与预测功能、运用各种模型加强财务管理与控制，从而将事后核算、事中控制与事前预测通过各模块间的无缝连接、数据共享机制有机地组合在一起，最终达到利用财务软件完成财务管理职能的目的。

２．应用模式识别过程

在众多的应用模式中，企业应选择适合自身的应用模式，方能取得事半功倍的应用效果。实际上，企业的应用模式识别不是一次性的工作。初次使用财务软件固然存在应用模式识别问题，日后升级或完善会计电算化时也同样存在应用模式识别问题。因此，应用模式识别是贯穿企业会计电算化工作始终的一个必不可少的过程。笔者参照软件实施的IDEAL模型，将应用模式识别过程划分为启动、诊断、建造、实施和学习五个子阶段，并且这五个子阶段呈现出一环扣一环、一层套一层的螺旋式上升趋势。

IDEAL模型是一个单位用于启动、规划和实现过程改善措施蓝图的模型，概括了建立一个成功的过程改善项目的必要步骤，其中I代表Initiating(启动)、D代表Diagnosing(诊断)、E代表Establishing(建造/建立)、A代表Acting(实施/行动)、L代表Learning(学习)。图1是详细的IDEAL五阶段模型。其中：启动—获得改进的支持和责任；诊断—确定改进的范围；建造/建立—选择和计划特定的改进活动；实施/行动—设计、指导、实现以及改进的制度化；学习—确定基于IDEAL模型的改进活动。

图1详细的IDEAL五阶段模型

２．１启动阶段

启动阶段要安排会计电算化的理论学习和实地考察，结合企业现状进行优势、劣势分析，从中寻找改进会计电算化工作的契机，制定总体工作计划。简言之，启动阶段主要解决企业“要什么”的问题。

启动阶段主要任务如下：1）成立会计电算化工作领导小组；2）获得启动资源；3）形成问题发现小组并研究有关议题；4）阶段性确立包括人、财、物在内的资源需求清单和总体工作计划书。

２．２诊断阶段

诊断阶段要建立当前会计电算化工作状态说明，改进措施等，启动详细行动计划的开发。简言之，诊断阶段主要解决企业“做什么”的问题。

诊断阶段主要任务如下：1）确定工作状态；2）形成最底/最高工作目标；3）措施建议；4）结果展示；5）与组织就最终结果和建议报告进行沟通。

２．３建造阶段

建造阶段要建立工作目标体系和优先权，完成详细行动计划的开发，成立实施小组。简言之，建造阶段主要解决企业“怎么做”的问题。

建造阶段主要任务如下：1）选择和得到实施技术的培训；2）评审目标；3）评审行动计划；4）确定关键改进点；5）评审过去的改进工作；6）说明改进的动机；7）确定当前和将来的改进工作；8）确定改进活动和优先级；9)协调各方资源；10）形成实施工作小组。

２．４实施阶段

实施阶段要研究和开发改进工作的解决方案，并执行解决方案。简言之，实施阶段主要解决企业“动手做”的问题。

实施阶段主要任务如下：1）开发解决方案；2）试验有潜力的解决方案；3）选择解决方案提供商；4）确定长期的支持需要；5）开发首次实施模板；6）整理改进模板；7）首次实行解决方案；8)转移到长期支持。

２．５学习阶段

学习阶段要总结经验教训，指出本次会计电算化改进工作取得的成果，存在的不足，应用学到的经验教训完善当前工作，并为以后再次进行会计电算化改进工作提供参考。简言之，学习阶段主要解决企业“缺什么”的问题。

学习阶段主要任务如下：1）收集学到的经验教训；2）分析学到的经验教训；3）修改工作方法及章程；4）评审工作人员工作；5）建立高级的目标；6）开发下一轮改进提议；7）继续进行会计电算化改进工作。

３．应用案例

假设某企业从未有过财务软件使用经验，并且财务人员对电脑也感到十分陌生。也许，现实中该情形已不多见，但作为一个案例却极具代表性，因为该企业可以遍历五种应用模式。

当企业从未使用过财务软件，懂电脑的人也不多时，此情形宜采用辅助做账模式。企业可以先购置部分电脑，一方面减少财务人员对电脑的陌生感，另一方面可以借助电脑完成某些简单的来回誊写的会计工作。

经过一段时间之后，企业财务人员对电脑有了一定认识，不满足于只是使用电脑协助完成来回誊写的工作，自然而然就会产生更多的需求，此情形宜采用甩手工账模式。企业通过购买财务软件的账务、报表模块，对员工实施必要的会计电算化理论与实务操作培训，实现证、账、表的自动处理。此时，企业会计人员只要将经济业务编制成记账凭证，就可以通过电脑自动登记各类会计账簿、通过预先定义的会计报表自动编制各类会计报表。

随着证、账、表的自动处理，财务人员感受到了会计电算化的巨大魅力，就会开始设想能否对某些专项核算进行电脑管理。如：出纳能否借助电脑登记日记账，实行银行自动对账，自动编制银行存款余额调节表；工资核算员能否借助电脑完成定期的工资计提与发放业务，自动编制与工资核算有关的各种记账凭证，实现工资业务管理与会计核算的集成；固定资产核算员能否借助电脑完成固定资产卡片账的管理，完成固定资产新增、变动、折旧等记账凭证的自动编制，实现固定资产台账管理与会计核算的集成；等等。此种情形则宜首先采用专项核算模式，然后过渡到一体核算模式。

一般而言，企业上升到一体核算模式后，将处于一个相对稳定的状态。此时，财务人员有可能会感到十分满意，从而不思进取。其实，一体核算模式只是解决了部分会计核算的问题（进销存核算、成本核算尚未包含在内），远未能达到借助电脑实行全面会计核算，更未达到进行全面财务管理的目的。此时，企业应加大会计电算化的培训力度，组织适度的外出参观学习，做好过渡到财务管理模式的各种准备。也许此时企业未必能有效地获取称心如意的管理型财务软件，因此，有可能回到类似辅助做账模式时采用的借助电子表格软件完成某些一体核算模式力所不能的财务分析与管理工作，直至找到合适的管理型财务软件。才会进入到财务管理模式。企业从一体核算模式跃升到财务管理模式并非易事，它是企业会计电算化工作的二次革命。企业必须慎重对待才能平稳过渡。

在各种模式的选型与升迁过程中，正确地、适当地运用本文第二部分论述的应用模式识别过程框架能帮助企业多快好省地完成模式辨别工作。也许，企业起初会感到疑惑，甚至感觉无从下手，但是，只要把握好“要什么”、“做什么”、“怎么做”、“动手做”、“缺什么”的步骤就可轻松上手。事实上，企业会计电算化的过程，就是不断学习和运用应用模式识别过程知识、不断提升和掌握应用模式识别过程技能、不断从事和完善应用模式识别过程实践、从而确保企业会计电算化工作有效性的过程。


企业进销存软件应用模式分析

财会通讯.综合版2004年第10期 汤四新

摘 要：企业进销存软件的应用具有明显的个性化和动态性特征，从而导致市场上五花八门的进销存软件的存在。通过分析，作者将企业进销存软件的应用划分成五种应用模式，并指出了企业进行模式选择时应确立的五个应用理念。

关键词：企业进销存软件 应用模式 应用理念

企业进销存管理过程就是以工作流为基础，以票据流为载体，反映企业货物流与资金流的来龙去脉的过程。从现代会计信息系统的角度看，进销存过程包括了“获取/支付过程”和“销售/收款过程”的大多数业务事件。

在企业进销存管理过程中，由于企业经营物品的不同，客观上要求采用不同的工作流程，设计不同的票据内容和格式，生成满足不同管理需求的账表，从而使得企业进销存管理具有明显的个性化的特征。另一方面，在企业的整个发展过程中，外界环境的变化、企业规模的变化都会引起企业进销存管理需求的变动，从而使得企业进销存管理表现出动态性的特征。企业进销存管理的这两大特征，决定了作为管理工具的进销存软件也必须具备个性化和动态性的特征。这正是进销存软件实施成功率和通用化程度远远低于财务软件的根本原因。

那么，在企业进销存管理过程中如何引入进销存软件呢？笔者认为，通过分析、比较进销存软件应用模式，掌握各应用模式的特征和适用条件，将有利于企业少犯错误、少走弯路。故此，本文拟对进销存软件应用模式进行探索性分析。希望对企业运用进销存软件有所裨益。

一、模式划分

事实上，任何使用软件从事进销存管理的系统都是人机系统，在系统中，作业的执行或者交由机器完成、或者由人与机器共同完成、或者由人手工单独完成。如果从工作流、票据流、货物流、资金流、信息流入手，分析进销存管理的人机交互机制与界面，可以将进销存软件应用划分为五种模式：传统经典模式，以仓库管理为中心的模式，以商务管理为中心的模式，业务、财务一体化管理模式和个性化专家管理模式。

（一）传统经典模式

传统经典模式是一种依照传统手工进销存管理工作流程，软件只管理引起企业货物或资金余额产生变更的票据，只反映基于已登记票据的采购、库存、销售账表及客户往来账表，其它业务仍由手工完成的应用模式。使用该模式，在工作流上表现为企业不需要改变现有的工作流程；在票据流上表现为企业不需要将所有票据交给软件处理；在货物流上表现为软件只管理货物的库存数量与库存金额，对库存形态不区分管理；在资金流上表现为软件只管理应收款和应付款；在信息流上表现为软件不提供除货物流、资金流外的账表。从软件功能上看，软件支持购货单、购货退回单、销货单、销货退回单、内部调拨单、盘盈盘亏单、收款单、付款单八种单据的独立处理，不支持单据间的生成与稽核，其中前四种单据及盘盈盘亏单涉及仓库账和财务账的登记，内部调拨单只需登记仓库账，收款单、付款单只需登记财务账。软件据此八种单据生成有关采购类、库存类和销售类的业务、财务账表和客商往来账表。目前，市面上大多数低端进销存软件属于此应用模式。

（二）以仓库管理为中心的模式

以仓库管理为中心的模式是一种在传统经典模式的基础上进一步细分仓储业务，强化仓库管理的应用模式。使用该模式，在工作流上表现为企业必须局部优化涉及仓库管理的工作流程；在票据流上表现为企业必须增加涉及仓库管理的票据并交由软件处理；在货物流上表现为企业细分仓储管理，增加了借入物品、借出物品、寄存物品三种物品形态；在资金流与信息流上表现与传统经典模式类似。从软件功能上看，软件增加支持六种涉及仓储管理的单据，即：借入单、借入归还单、借出单、借出归还单、寄存单、寄存取货单，其中前两者要登记借入物品账，中间两者要登记借出物品账，后两者要登记寄存物品账。软件据此六种单据可以生成有关借入物品、借出物品、寄存物品的相关账表。

（三）以商务管理为中心的模式

以商务管理为中心的模式是一种在以仓库管理为中心的模式的基础上强化采购与销售环节的业务管理为特征的应用模式。使用该模式，在工作流上表现为企业必须局部优化采购和销售环节的工作流程，实现购销环节的计划管理；在票据流上表现为增加有关强化购销业务管理的票据；在货物流与信息流上表现与以仓库管理为中心的模式类似；在资金流上表现为软件可以反映因购销计划的执行或变更而引起的企业资金需求计划与应收款、应付款、预收款、预付款的变动情况。从软件功能上看，软件增加支持四种单据，即：询价单、采购订单、报价单、销售订单，其中前两者用于改进和反映采购业务过程，后两者用于改进和反映销售业务过程。软件据此四种单据可以生成有关采购询价过程、销售报价过程的报表，有关采购订单、销售订单的执行情况及执行结果的报表，有关企业资金使用预测与计划的报表。

（四）业务、财务一体化管理模式

业务、财务一体化管理模式是在以商务管理为中心的模式的基础上加强业务管理与财务核算的协同处理和相互稽核的应用模式。使用该模式，在工作流上表现为企业必须根据企业的管理需求调整业务与财务分工协作的工作流程，主要体现在合并工作岗位和减少单据传递控制等环节上；在票据流上表现为必须区分业务确认与财务确认而导致可同步或不可同步处理的票据；在货物流上表现为增加业务与财务间的稽核报表；在资金流与信息流上表现与以商务管理为中心的模式类似。从软件功能上看，软件增加支持业务确认与财务确认不同步处理的八种单据，即：验收单、验收退还单、采购单、采购退回单、发货单、退货单、销售单、销售退回单，其中验收单和验收退还单相当于只登记仓库账的购货单和购货退回单，采购单和采购退回单相当于只登记财务账的购货单和购货退回单，发货单和退货单相当于只登记仓库账的销货单和销货退回单，销售单和销售退回单相当于只登记财务账的销货单和销货退回单。软件据此八种单据可以达到购销环节的业务确认与财务确认在数量上和时点上的异步处理。

（五）个性化专家管理模式

个性化专家管理模式是在业务、财务一体化管理模式的基础上，根据企业管理的个性化需求，进一步完善各种管理的应用模式。使用该模式，在工作流上表现为企业可以进行业务流程重组，进一步改善工作流的效能；在票据流上表现为企业可以实现票据内容订制、票据格式调整、票据功能合并与分立等票据个性化处理；在货物流与资金流上的表现与业务、财务一体化管理模式类似；在信息流上表现为企业可以自定义反映个性化管理需求的各式报表。从软件功能上看，软件增加支持单据功能合并与分立的单据十九种，即：借入转采购单、采购转借入单、销货转借出单、借出转销货单、销售发票、采购发票、委托代销发货单、委托代销退货单、委托代销结算单、受托代销收货单、受托代销退货单、受托代销销货单、受托代销销货退回单、受托代销结算单、委外加工发货单、委外加工发货退回单、委外加工收货单、委外加工收货退回单、委外加工结算单，其中借入转采购单同时完成借入归还单和采购单的功能，采购转借入单同时完成采购退回单和借入单的功能，销货转借出单同时完成销货退回单和借出单的功能，借出转销货单同时完成借出归还单和销货单的功能，销售发票和采购发票用于登记企业往来票款，委托代销发货单、委托代销退货单、委托代销结算单用于专门管理委托代销物品账，受托代销收货单、受托代销退货单、受托代销销货单、受托代销销货退回单、受托代销结算单用于专门管理受托代销物品账，委外加工发货单、委外加工发货退回单、委外加工收货单、委外加工收货退回单、委外加工结算单用于专门管理委外加工物品及其结算业务。软件据此十九种单据可以达到分立与合并票据，更好地满足企业管理个性化的需求。

综上所述，每一种模式在工作流、票据流、物资流、资金流、信息流等方面存在显著的差异。因此，实务中选择合适的应用模式并非易事，企业能否根据自身状况和管理需求完成模式选择与其拥有的应用理念关系甚密。因此，建立正确的应用理念至关重要。

二、应用理念

（一）软件系统是人机系统

无论企业选择哪一种模式，都不可能将所有的事务交给电脑完成，都需要人工不同程度的参与，模式之间的区别仅仅在于软件自动化程度的不同、软件管理明细程度的不同和软件管理覆盖面的不同。在人机系统中人始终处于主导地位，人是工作流的制订者，人是票据流的执行者，人是货物流、资金流、信息流的使用者。因此，选择模式的问题首先是解决人的问题，人的观念、人的技能、人的需求最终决定选择模式的合理性和有效性。

（二）进、销、存是统一体

企业的采购、库存、销售三大业务彼此之间是互相依存的，是一个整体性的统一体。处于不同发展规模和拥有不同管理需求的企业，存在着不同的管理重点。以库存管理为中心的模式认为库存是进销存管理的中心，采购是为了保持一定的库存，销售是一个独立于采购却依赖于库存的活动。因此，在这种指导思想下，保持一定的库存水平是进销存管理的重点。以商务管理为中心的模式认为销售是进销存管理的中心，销售是业务的起点，没有销售也就不需要库存，更不需要采购。因此，在这种指导思想下，企业认为商务活动、特别是销售活动是进销存管理的重点，至于库存则是为执行销售活动的手段，如果可能，企业可以追求零库存销售、甚至无库存销售（如服务）。业务、财务一体化管理模式认为企业进销存管理离开了财务管理只是一个部门级的管理，不能达到企业级的协同，是不完善的管理。因此，只有将业务、财务进行一体化管理才能最终保证企业经营目标的实现，才是企业利润最大化的保证。事实上，企业的采购、库存、销售业务管理与财务管理本身是一个有机的统一体。企业在进行工作流设计、模式选择时应多从统一体的整体性出发，维护其整体性能最优。某些软件将进销存软件拆分为多个模块的做法是对统一体的破坏和误导。

（三）增值流是流设计优劣的评判标准

如何确定信息的源头，如何进行流程重组，如何设计票据流向是模式确定的难点，弄得不好会出现多头管理、因人设岗、票据混乱等现象。检验工作流、票据流设计正确与否的标准是该流是否形成增值流，即工作流中是否存在多余的岗位或环节，票据流中是否存在无用的票据或票据内容，既满足管理需求又简练的工作流和票据流是最佳的设计。

（四）伴随性

表面上看，物资流、资金流、信息流是进销存软件管理的对象和最终的结果，实质上，物资流、资金流、信息流是伴随工作流、票据流的运动而产生的，是第二位的。因此，企业应重点关注工作流与票据流的设计，然后才是物资流、资金流、信息流。当然，工作流与票据流的设计不可忽视物资流、资金流、信息流的管理需求。但是，企业一定要确信工作流与票据流是“主流”，物资流、资金流、信息流是伴随“主流”的运动而产生的“从流”。

（五）螺旋上升性

企业对模式的选择从时点的角度看，“没有最好、只有最合适”；从过程的角度看，“没有终点、只有起点”；五种模式的更替呈现螺旋上升的趋势。因此，企业模式选择时大可不必贪大求全，只要因地制宜地选择“好用、够用”的模式即可，当环境改变后，重新选择模式不迟。

作为本文的结尾，笔者有一句话想与广大进销存软件用户共勉：“模式适当、成功一半”。


会计元素论

财会通讯.学术版2004年第9期 汤四新

摘　要：本文在分析现行会计核算方法体系及会计科目体系存在问题的基础上，提出一种新的基于“会计元素”的会计核算方法体系。并阐述会计元素体系与会计科目体系的比较优势，及建立会计元素体系替代现行会计核算方法体系及会计科目体系的必要性、可行性和优越性。

关键词：会计革新　会计元素

一、现行会计核算方法体系及会计科目体系存在的问题

现行会计理论认为：对一个企业来说，会计对象就是会计要素及其增减变化。而会计要素的内容包括企业全部的经济业务。一般地，会计要素可划分为类目别、项目别、科目别、子目别四个层次。而会计科目就是根据经济管理和会计核算的要求，在对各个会计要素所包括的具体内容进行分类的基础上，赋予每一类别的名称。并且，大部分会计科目的名称与会计要素按科目别的分类名称相一致。

现行会计核算方法主要包括设置会计科目和账户、复式记账、填制和审核会计凭证、登记账簿、成本计算、财产清查、编制会计报表等七种主要方法。这七种方法相互联系、密切配合，共同构成了一个会计核算方法体系。该体系有其成立与存在的必要性和合理性，在会计实践中也发挥了其应有的价值。但是，现实总爱跟我们开玩笑，不可否认，已经有越来越多的人对会计信息的使用缺乏信心，特别是需要根据企业提供的会计信息去进行某些决策的时候，人们更愿意凭借非会计信息辅助决策。

论述现行会计核算方法体系的缺陷的文章已不在少数。归纳起来，现行的会计核算方法体系至少存在以下四个方面的不足：

（一）、科目体系设置的呆板性

在现行的会计核算方法体系中会计科目有着举足轻重的作用，如果不设置合理、全面的会计科目体系，企业就无法准确地填制会计凭证、登记账簿和编制会计报表，更谈不上成本核算、财务管理等其它财务职能的运用与发挥。由此可见，科目代码体系的设置是如此的重要。可惜的是，如此重要的科目代码体系却又表现得非常呆板。比如：库存商品──金属部──二号仓库──螺纹钢，这个四级会计科目是由一级科目“库存商品”，二级科目“金属部”，三级科目“二号仓库”和四级科目“螺纹钢”按顺序组成的。这样设置，可以非常清晰的看到每个部门、每个仓库、每种存货的会计资料。然而，会计科目一旦设定就不能轻易更改，从而账簿体系也就不能轻易更改，通过会计所反映的各类经济指标也就不能轻易调整。假若该企业存在三个仓库，三个仓库都存有螺纹钢，想知道该企业螺纹钢的总存量就必须逐一查找对应每个仓库的存量后再相加。也就是说必须将库存商品──金属部──一号仓库──螺纹钢、库存商品──金属部──二号仓库──螺纹钢、库存商品──金属部──三号仓库──螺纹钢三账并账后才能得到我们需要的结果。

（二）、会计数据加工的繁琐性

现行会计核算方法体系为了保证会计信息处理结果的正确性、可靠性，对会计数据处理程序作了许多规定。比如：严格规定记账凭证处理的“三步曲”，既填制、审核、记账。在填制环节，严格规定会计人员必须按照会计制度和借贷记账法的规定根据原始凭证正确填写，在审核环节，要求审核人与制单人不能为同一人，规定审核人对所审核凭证的正确性、合法性负有连带审核责任，在记账环节，严格规定必须按平行登账法由不同的会计人员根据相同的记账凭证分别登记总账、分类账、明细账、日记账和其它备查账。报表编制必须遵循严格的钩稽关系。会计核算形式更是五花八门。虽然规定如此的繁杂，我们仍不时的听到某某会计为了两分钱的差异而通宵达旦的加班加点。难怪有人将会计循环比喻成一首不断重复的、繁重的证、账、表加工的脑力劳动的咏叹调，将做会计比作做苦力。

（三）、会计信息的现实有用性不足

现行会计核算方法体系的会计信息主要来源于以会计科目为标识的账户发生额及余额。其中账户可以分成总账、分类账、明细账、日记账等；发生额可以有月度、季度、年度之分，余额也有期初与期末之分；此外发生额及余额除了提供记账本位币计量标准外，还可以提供外币、数量等其它计量标准。这些数据加上复式记账法的运用确实能够正确反映企事业单位经济业务的来龙去脉。然而，基于以上方法收集的会计数据至少缺少以下四个方面的信息：

１、缺少关于企业未来发展趋势和前景的会计信息

对于主要来源于以会计科目为标识的账户发生额及余额的会计信息大多数是企业已经发生的若干经济事项的会计记录，缺乏对企业未来发展趋势及前景的预测信息。

２、缺少关于同行业的可比指标的会计信息

同样的，对于主要来源于以会计科目为标识的账户发生额及余额的会计信息只能提供关于企业自身情况的会计信息，让我们的信息使用者犹如坐井观天，让我们的企业管理者很容易夜郎自大。

３、缺少关于市场的经济情报的会计信息

在市场经济中，商情瞬息万变。企业赖以生存和发展的基本条件越来越取决于企业能够收集和把握的市场风向。“适者生存”已经成为市场经济环境中一条颠簸不破的真理。可悲的是，作为企业经济状况“晴雨表”的会计信息却未能有效的收集和管理市场商情信息。

４、缺少关于政府部门相关经济法规的会计信息

目前，政府部门相关经济法规对企业行为的约束和影响很难通过会计信息系统对企业经济行为发生作用，导致许多企业不能及时掌握和利用经济法规为企业服务。事实上，目前政府部门相关经济法规对会计的约束和影响更多的是通过对会计制度的调整和相关会计操作制度的调整来实现的。

由此观之，运用建筑在主要来源于以会计科目为标识的账户发生额及余额基础之上的财务核算、财务分析、财务管理及财务辅助决策等工具的企业管理者或投资者就象“铁达尼号”游轮上的船长和游客一样，时刻面临着航行的风险。

（四）、现行会计核算方法体系理论上的局限性

１、重权责发生制、轻收付实现制

权责发生制与收付实现制是一对相对称的概念。权责发生制的核心是根据权责关系（不论款项是否收付）的实际发生期间来确认收入与费用的归属期。而收付实现制是以款项收付（不论权责关系是否成立）的实际发生期间来确认收入与费用的归属期。从理论上讲，两者各有千秋。然而，现行会计核算方法体系中出于多方面的考虑采用了权责发生制而抑制收付实现制。

２、重历史成本、轻重置成本

所谓历史成本，是指取得或制造某项财产物资时所实际支付的现金及其他等价物。重置成本是指在当前市场同等条件下重新购置或建造具有相同使用价值的财产物资所需要实际支付的现金及其他等价物。现行会计核算方法体系在大多数情况下之所以选择历史成本是因为历史成本是实际发生的，具有客观性，而且历史成本的取得比较容易。然而，现行会计核算方法体系中为了更真实地反映企业的实际情况在某些情形下（比如：在企业分立或合并时）却又不得不警慎地、保守地采用重置成本。特别是对固定资产的核算与管理更是如此。

３、重货币计量、轻非货币计量

无可非议，货币作为一般等价物，用以充当会计的统一的计量单位，是非常合适的。但是，非货币计量也非常重要。特别是对象人力资源、无形资产等有时很难使用或并不适合使用货币做为计量单位的管理对象，货币计量就有点勉为其难。可见，现行会计核算方法体系中强调以货币计量为主、非货币计量为辅的方式未免顾此失彼。

４、重表内科目、轻表外科目

“有借必有贷，借贷必相等”做为现行会计核算方法体系中的一条重要的记账原则被视为金科玉律加以贯彻和执行。然而，我们也不无遗憾地看到这条金科玉律有时也不灵光。比如：对于银行会计中的空白支票、对于外贸会计中的外汇收支核算中都不得不采用表外科目对经济业务的发生加以补充登记。

５、重期间编报、轻实时编报

现行会计核算方法体系中出于有效控制会计信息加工成本及其它因素的考虑，在会计分期这一假设前提条件下自然而然地选择了定期编报的习惯做法。然而，这样做并非表示作为信息使用者就不想得到实时报表，不想会计提供实时编报。

６、重有形资产、轻技术资产

现行会计核算方法体系中非常重视对物质财富、有形资产的核算与管理。然而，在科学技术就是第一生产力的今天。现行会计核算方法体系对于象人力资源、无形资产等技术资产的核算与管理就显得力不从心。

现行会计核算方法体系的问题是客观存在的。我们可以这样说，现行的会计系统就象一条建造于15世纪的经过多次修缮而仍在服役的轮船，需要消耗过多的能源，却又只能提供低速和充满风险的航行。有没有一个好的方法可以让会计系统改头换面，变成一艘用现代科学技术和设备仪器装备的既安全、又高效的轮船呢？答案是肯定的。如果我们乐意采用新的轮船设计技术和制造工艺就完全有可能。笔者试图基于会计信息系统论、特别是计算机会计信息系统的观点提出一种新的方法论“会计元素体系”。对目前会计科目、会计科目体系及会计核算方法体系作一革新，使之既能完全具备现行会计核算方法体系的所有功能，又能克服以上诸多不足，让会计焕然一新。

二、什么叫会计元素及会计元素体系

我们可以把企业经济业务中具有某一共同属性的一类对象称之为会计元素。如：部门、职员、往来客商、开户银行、商品等。会计元素既可以对应企业中实实在在存在的某一类可计量（包括货币计量和非货币计量）的对象，如：商品；也可以是某一类统计类别，如：成本项目、计划数、预算数、同业指标等。

会计元素有主、从会计元素之分。所谓主会计元素可以看成类似于或对应于现行会计科目体系的一级科目，它主要用于对经济业务进行类似于科目别的分类统计和管理。除主会计元素以外的其它会计元素可称之为从会计元素，如：大多数企业都会存在的部门、职员、往来客商、开户银行等会计元素。

我们可以把由若干会计元素组成的（其中必须包含且只能包含一个主会计元素），在企业财务核算与管理中作为一个不可分割的整体出现的会计对象称之为会计元组。如：库存商品──金属部──二号仓库──螺纹钢就是由主会计元素“库存商品”和从会计元素“部门”、“仓库”、“商品”共同组成的会计元组。

会计元组可以有主、从会计元组之分。所谓主会计元组是指类似于在记账凭证中出现的具有固定会计元素成员及会计元素成员排列顺序的会计元组；除主会计元组以外的其它会计元组称之为从会计元组。

主会计元组作为会计处理的最基本、最小的经济业务记录单位，可以保证我们设定的最基本的会计核算与管理要求，也可以与目前记账凭证填制方法中要求填制最低级明细科目相对应。对于不包含在主会计元组中的会计元素可以在记账凭证的附件──原始凭证中记录。

我们把企业发生的经济业务进行有效的分类，将其中会引起会计元素发生变化的经济业务定义成会计事务。我们只要将会计事务涉及到的会计元素及业务发生额描述清楚，就可以让会计事务自动完成类似于会计分录的编制、记账凭证的填制、账簿的登记、报表的编制等工作（下文有例子对会计事务进行举例解释）。当然，会计事务的定义和功能的发挥我们最好借助计算机来完成。

同时，我们还可以对账簿体系做些调整。一方面提供账簿格式自定义，做到只要在会计元组中（或者类似于记账凭证及原始凭证中）出现过的会计元素都可以作为账簿中的内容；另一方面提供可以按主会计元组出账，也可以按从会计元组出账，还可以按会计元组及其它会计元素出账。这样一来，账簿体系就变成了会计元组的附庸，只是会计元组的不同表现形式而已。

由此，基于会计事务、会计元组、会计元素的会计报表编制就变得简单而高效了。不但可以完成定期编报、而且可以提供实时编报。

会计元素、会计元组、会计事务、会计报表构成了会计元素论的四大组成部分，它们互相有机组合、配合使用就构成了完整的会计元素体系。

三、会计元素体系与会计科目体系相比较的优势

（一）、会计元组设置的灵活性

在企业经济业务中，按照是否具备某一共同属性将管理对象分成若干会计元素。在会计元素的分类标准上遵循分类标准的一致性和归属的唯一性就可以解决好会计元素的划分与归类。其中，我们把与现行一级科目分类标准与归属相一致的会计元素称之为主会计元素。在此基础上，我们把在企业财务核算与管理中作为一个不可分割的整体出现，其必须由若干会计元素，包含且只包含一个主会计元素组成的会计对象，称之为会计元组。其中，我们把与现行会计科目代码体系的科目级别与排列顺序相对应的会计元组（其组成会计元素个数与科目级别的级别数相等、会计元素排列顺序与会计科目各级排列顺序相当）称之为主会计元组。对于上文提到的例子。库存商品──金属部──二号仓库──螺纹钢由主会计元素“库存商品”和从会计元素“部门”、“仓库”、“商品”共同组成的会计元组。把与库存商品──金属部──二号仓库──螺纹钢对应会计元组称之为主会计元组。因此，与库存商品──金属部──一号仓库──螺纹钢、库存商品──金属部──二号仓库──螺纹钢、库存商品──金属部──三号仓库──螺纹钢都有与之对应的主会计元组。对于过去需要通过并账才能得到的螺纹钢的总存量就可以通过从会计元组“库存商品─金属部─螺纹钢”相对应的帐簿得到。由此可见，通过会计元素和会计元组完全取代会计科目和会计科目体系的同时，还增加了无限的灵活性。

（二）、经济业务事项描述的直观性

会计元素和会计元组的概念比之会计科目和会计科目体系更符合人类自然语言的表述，更容易被人们理解和接受。使用会计元素和会计元组之后，我们可以定义一种称之为“会计事务”的对象。比如：从工行提现1万元这笔业务。用我们现行的会计语言来描述就是：借：现金 10000元，贷：银行存款─工行 10000元。并且将其填制记账凭证。其实，该业务中只涉及三个会计元素（现金、银行存款、工行）和一个业务发生额（10000元）。如果我们定义一个会计事务“从工行提现 元”对应企业发生的工行提现这类业务，让会计事务根据其所涉及的会计元素和会计元组去完成会计分录的描述。那么，我们就只要填入“10000”这个数字就可以借助会计事务去完成会计分录为借：现金 10000元，贷：银行存款─工行 10000元的记账凭证的工作。此时，我们明显可以看到：“从工行提现 元”比“借：现金 10000元，贷：银行存款─工行 10000元”要更符合自然语言习惯、更直观、更易懂。以此类推，其它经济业务我们也可以定义不同的基于会计元素的会计事务去完成。由此我们甚至可以考虑取消会计分录的载体──记账凭证，用会计事务取而代之，即根据会计事务直接出账。

（三）、会计信息加工的简便性

从上文可以看到，会计事务实际上就是对企业发生的经济业务基于会计要素的一种描述。在会计事务中只要完整地描述清楚经济业务所涉及到的会计元素、对应的会计元组及业务发生额，就可以由会计事务完成类似于会计分录的编制、记账凭证的填制、账簿的登记以及报表的编制等。也就是说，借助会计事务我们完全可以不必象现行会计核算方法体系中那样使用严格的处理程序按部就班地处理会计信息。事实上，如果我们乐意借助电脑代替人脑，再加上采用会计事务，那么，我们完全有希望将会计人员从繁重的、重复性的证、账、表会计循环中解脱出来。现代会计电算化的发展已经清楚地告诉我们：即使不改变传统会计的会计信息处理方法及程序，象记账凭证的填制、记账凭证正确性的检验、记账凭证合法性的校验、账证的核对、账账的核对、报表的编制与稽核等都可以交给电脑完成。更何况，我们使用会计事务必将对会计信息加工的简洁性、方便性有更大的提高。

（四）、会计信息结果的重组性

从会计元组实际上就是对主会计元组的重组。如：库存商品──金属部──二号仓库──螺纹钢，这个由四个会计元素组成的主会计元组衍生的从会计元组就有23个。为什么有这么多呢？其实，从会计元素就是主会计元素“库存商品”和从会计元素“部门”、“仓库”、“商品”四者的一个排列减一。即4*3*2*1-1=23。另外，采用可以自定义的账簿格式按以上会计元组出账得到的账簿就更是千变万化。基于会计元组的重组可以完全打破基于会计科目的账户会计信息的呈报方式。从拓扑结构分析，现行基于会计科目的账簿体系是一种树形结构；而基于会计元素的会计元组则是一种网状结构。按科目树形结构归集与分析数据与以会计元素为结点按会计元组网络结构归集与分析数据的方法相比就显得捉襟见肘。

（五）、会计元素体系的扩充性

对某一会计元素除了进行基于传统会计原理的会计信息加工外，还可以添加一些特殊的算法来对该会计元素进行其它目的的信息加工。该信息加工方法、方式可以不拘泥于确定性的会计计量范畴，甚至可以包含非确定性的会计计量范畴。比如：对“职员”会计元素在进行满足借贷平衡关系的传统工资薪金的核算与管理的同时新增符合人力资源管理原则与要求的人力资源管理；对“设备”会计元素进行基于历史成本的传统固定资产的核算与管理的同时新增按重置成本进行的资产评估及设备管理；对如银行会计中的“空白支票”、税务会计中的“空白发票”、外贸会计中的“外汇买卖统计币”、高科技企业的按现行资产确认基础不能入账的技术资产都可以通过进一步扩充表外科目性质的管理属性加强核算与管理，从而摆脱以表内科目为主、表外科目为辅的核算与管理局面；对于象黄金、珠宝行业中的贵重库存存货、医药行业中的药品有效期等可以通过扩充计量属性来增强管理力度以充分满足所在企业的会计核算与管理的特殊要求；甚至我们还可以通过会计事务按权责发生制编制会计分录的同时按收付实现制编制另外一套会计分录，并且让它们各自登记不同的两套账簿，如此我们就可以同时得到基于权责发生制和基于收付实现制编报的两套定期或实时的报表体系；对于一些损益类的会计元素可以增加一些来自于同行的、市场的、政府的参照指标属性加强与同业、与市场、与政府的比较核算和管理。这样就可以将会计核算的财务数据和业务管理的数据进行有机的组合与共享。扩充会计的职能，真正实现会计频道与定制会计节目的功能。

（六）、会计元素体系的兼容性

采用会计元素体系完全可以兼容现行的会计科目体系。通过基于会计科目体系的现行会计核算方法体系所提供的功能完全可以从基于会计元素体系的会计信息处理系统取得。事实上，通过上文的论述，特别是对主会计元素及主会计元组作用的论述，我们可以清楚地看到会计元素体系完全可以兼容并超过现行会计核算方法体系。

四、建立会计元素体系替代现行会计核算方法体系及会计科目体系的必要性、可行性和优越性

（一）、必要性

现行会计核算方法体系已受到越来越多的会计理论界、实务界人士的批评与指责，甚至有人为会计及会计职业在未来是否还有存在的必要而担心。会计的问题似乎到了非解决不可的程度。如果真有这种担心的必要，那么，会计元素体系就有了生存的空间。或者说，会计元素体系就是对传统会计的改革。

（二）、可行性

新的技术和方法是否可行，只要看它是否可以兼容旧的技术和方法。计算机软件如WINDOWS操作系统的普及使用与有效升级都无可争辩地说明：只要新的技术和方法对旧的技术和方法具有兼容性，那么，新的技术和方法替代旧的技术和方法是可行的，也是必然的。由于会计元素体系具有对现行会计核算方法体系的兼容性，因此，会计元素体系替代现行会计核算方法体系是可行的。

（三）、优越性

具有了必要性和可行性还并不表示会计元素体系就一定能够取代现行会计核算方法体系。新的东西还要比旧的东西优越，才有可能取代旧的东西。从上述分析我们可以看出会计元素体系相对现行会计核算方法体系来说具备原理简单、直观、自然，在具备兼容性的同时还具备充分的扩充性。因此，会计元素体系相对现行会计核算方法体系具备无比的优越性。

因此，我们有理由相信，会计元素体系取代现行会计核算方法体系是一种必然。当然，本文论及的会计元素及会计元素体系还只是一个初步的框架，其内涵还需要在今后的研究中不断充实和完善。更需要在会计实践中检验和修正。但是，它确实为重构现代会计信息系统提供了一个好的思路、一个可行的方向。

参考文献：

1.葛家澍.2002.关于财务会计基本假设的重新思考.会计研究. 2002.1

2.薛云奎.1999.会计大趋势.中国财政经济出版社

3.注册会计师考试编委会.2003.会计. 中国财政经济出版社

Research on Accounting Element

Guangdong University of Finance SiXingTang

Abstract：Based on researching on current accounting methods system and accounting item system，this paper presents a new accounting element system，compared accounting element system with accounting item system，and discusses the necessity、feasibility and superiority of establishing accounting element system instead of current accounting methods system and accounting item system.

Keywords：Accounting Renovation，Accounting Element


现代会计信息系统获取

现代会计信息系统获取－支付能力成熟度模型研究

财会通讯.学术版2004年第6期 汤四新

摘　要：本文将软件开发过程的能力成熟度模型CMM引入现代会计信息系统的获取／支付过程，建立一个基于过程改进的获取／支付过程能力成熟度模型。提出一套获取／支付过程能力成熟度模型的评估方法。为企业确立获取／支付业务运作模式提供一套简便、快捷的分析与实施工具。

关键词：会计信息系统　获取／支付过程 能力成熟度模型

一、现代会计信息系统获取／支付业务过程与业务事件概述

现代会计信息系统的获取／支付过程是指一个组织获取、维护和支付该组织所需资源（包括各类存货、固定资产、各种财务资源、人力资源等）的业务过程。因此，获取／支付过程应涵盖与购买、维护及支付组织的各业务过程所需的商品和服务有关的业务事件。

不论组织获取的商品和服务是什么类型，获取／支付业务过程都由三个阶段的业务活动组成：资源的取得、现金的支付、资源的退回。具体来说，包括以下一些典型的业务事件：发出商品／服务请求、授权采购、采购商品和服务、验收商品和服务、存放和保管已验收的商品、为商品和服务付款、退回等。

二、CMM能力成熟度模型的由来与应用特点

CMM（软件能力成熟度模型：Capability Maturity Model For Software）是由美国卡内基梅隆大学的软件工程研究所(CMU/SEI)受美国国防部委托研究制定并在美国，随后在全世界推广实施的一种软件评估标准，主要用于软件开发过程和软件开发能力的评估和改进。CMM根据软件生产的历史与现状，使用5个不断进化的层次表达：初始级是混沌的过程，可重复级是经过训练的软件过程，已定义级是标准一致的软件过程，已管理级是可预测的软件过程，优化级是能持续改善的软件过程。

任何单位所实施的软件过程，都可能在某一方面比较成熟，在另一方面不够成熟，但总体上必然属于这5个层次中的某一个层次。在某个层次内部，也有成熟程度的区别。在一个较低层次的上沿，很可能与一个较高层次的下沿接近，此时由这个较低层次向该较高层次进化就比较容易。反之，在一个较低层次的下沿向较高层次进化，就比较困难。在CMM框架中，需要解决带有不同层次特征的软件过程问题。因此，一个软件开发单位首先需要了解自己处于哪个层次，方能对症下药，针对该层次的特殊要求解决相关问题，这样才能收到事半功倍的软件过程改善效果。任何软件开发单位在致力于软件过程改善时，只能由所处的层次向紧邻的上一层次进化，即软件过程的进化是渐进的，而不是跳跃的。而且在由某一成熟层次向上一更成熟层次进化时，在原有层次中的那些已经具备的能力还应该得到保持与发扬。

三、获取／支付能力成熟度模型框架体系

现代会计信息系统的获取／支付过程，从流程控制、库存管理、业务集成等角度考察，也可使用5个不断进化的能级表达：初始级是混沌的过程，基本级是业务松散的过程，商务级是注重商务的过程，一体级是财务与业务一体化管理的过程，优化级是专家治理的过程。

以下就五个级别分别从管理重点、流程控制、时间控制、成本管理、计划控制、库存管理、客户关系、人力资源、人员沟通、风险控制、业务集成、单据稽核共十二个观察点出发，对获取／支付过程的发出商品／服务请求、授权采购、采购商品和服务、验收商品和服务、存放和保管已验收的商品、为商品和服务付款、退回共七个业务事件进行分析。

（一）初始级：起步管理模型

初始级获取／支付过程管理状况如下：

管理重点：业务事件界限不清，重点不突出，日常管理应付式，危机管理救火式。

流程控制：业务事件不设流程控制，业务事件间也不设流程控制，各业务事件执行无法明确区分先后、主次、缓急关系。

时间控制：业务事件无执行时限控制，业务事件间无时间次序关系。

成本管理：业务事件无标准成本控制，成本核算与管理只能事后进行。

计划控制：无预算编制，无计划管理。

库存管理：库存管理简单，粗放。

客户关系：供应商少、交易方式少，几乎没有客户关系管理。

人力资源：人员职责分配不明确，业务授权混乱。

人员沟通：内部员工沟通方式简单，外部供应商沟通因人而异，组织缺乏周期性协商或协调，几乎没有正式的交流渠道。

风险控制：风险意识淡薄，既无风险预警，亦无事故处理预案。

业务集成：业务事件间界限不清，业务事件间集成度人为控制、时高时低。

单据稽核：业务事件间无稽核控制。

初始级模型的典型特征：业务事件界限不清，单据不全。管理呈现不规范、非正式、粗放型的特征。此模型适用于初创企业或人员少、业务单一、交易量小的企业。

（二）基本级：松散管理模型

基本级获取／支付过程管理状况如下：

管理重点：业务事件界限清晰，业务事件管理有序。

流程控制：业务事件设流程控制，业务事件间不设流程控制，业务事件执行有序，业务事件间执行无序。

时间控制：业务事件有执行时限控制，业务事件间无时间次序关系。

成本管理：业务事件无标准成本控制，成本核算与管理只能事后进行。

计划控制：无预算编制，无计划管理。

库存管理：库存管理简单，粗放。

客户关系：供应商少、交易方式少，客户关系管理简单。

人力资源：人员职责分配明确，业务授权混乱。

人员沟通：内部员工缺乏沟通，外部供应商沟通不规范，组织不重视周期性协商或协调，较少地存在正式的交流渠道。

风险控制：风险意识淡薄，无风险预警，事故处理预案有、但可操作性差。

业务集成：业务事件间界限清晰，业务事件间集成度低。

单据稽核：设有报表级（基于总量）稽核，不提供单据级稽核。

基本级模型的典型特征：业务事件界限较清晰，单个业务事件设流程控制；各业务事件间不设流程控制，不设业务事件间的单据级稽核控制。管理呈现业务松散、低耦合状态。此模型适用于已基本规范业务事件，建立内控基本秩序的企业。

（三）商务级：商务管理模型

商务级获取／支付过程管理状况如下：

管理重点：采购商品和服务、验收商品和服务、存放和保管已验收的商品、退回四个有关商务活动的业务事件是管理重点。特别关注上述四个业务事件之间的数据传递及稽核关系。

流程控制：业务事件设流程控制，有关商务活动的业务事件间设流程控制，业务事件执行有序，有关商务活动的业务事件间执行有序，其它业务事件间执行无序。

时间控制：业务事件有执行时限控制，有关商务活动的业务事件间设时间次序控制，其它业务事件间无时间次序控制。

成本管理：业务事件设置标准成本控制，成本核算与管理能进行事中控制、事后管理。

计划控制：对涉及商务活动的库存物品设有预算编制、计划执行控制。

库存管理：库存管理设置有普通的ABC管理法、安全存量法、经济订购量法等。

客户关系：客户关系注重静态信息的管理。

人力资源：人员职责分配明确，有关商务活动的业务事件的业务授权清晰，其它业务事件的业务授权级别混乱。

人员沟通：部门内沟通顺畅，部门间沟通匮乏；外部供应商沟通较规范；组织设有周期性协商或协调机制，设有较正式的交流渠道。

风险控制：组织渐起风险意识，设置初步的风险预警，事故处理预案具体，可操作性较强。

业务集成：业务事件间界限清晰，有关商务活动的业务事件间集成度高，其它业务事件间集成度低。

单据稽核：有关商务活动的业务事件间设有单据级稽核，其它业务事件间只提供报表级稽核，不提供单据级稽核。

商务级模型的典型特征：业务事件界限清晰，单个业务事件设流程控制；有关商务活动的业务事件间设流程控制，其它业务事件间不设流程控制；有关商务活动的业务事件间可以设单据级稽核控制，其它业务事件间不设单据级稽核控制。管理呈现商务活动高聚合、有关商务活动的业务事件与其它业务事件低耦合的状态。此模型适用于商务类业务事件规范统一，部门内部管理严谨的企业。

（四）一体级：财贸管理模型

一体级获取／支付过程管理状况如下：

管理重点：发出商品／服务请求、采购商品和服务、验收商品和服务、存放和保管已验收的商品、退回、为商品和服务付款六个业务事件是管理重点。除理顺各业务事件的业务流程之外，特别关注业务事件与财务之间的一体化控制与管理。

流程控制：业务事件及业务事件间设流程控制，业务事件执行有序，业务事件间执行有序。

时间控制：业务事件有执行时限控制，业务事件间设时间次序控制。

成本管理：成本核算与管理能进行事前预测、事中控制、事后分析。

计划控制：有预算编制、计划执行控制。

库存管理：库存控制方法设置全面，控制方式灵活。

客户关系：客户关系注重静态信息与动态信息的结合，注重业务数据与财务数据的协同管理。

人力资源：人员职责分配明确，各业务事件的业务授权清晰。

人员沟通：部门内、部门间沟通顺畅；外部供应商沟通规范；组织设有周期性协商或协调的正规交流机制。

风险控制：风险意识强，设置风险预警，事故处理预案具体，可操作性强。

业务集成：业务事件间界限清晰，业务事件间集成度高。

单据稽核：业务事件间设置有单据级稽核，报表级稽核。

一体级模型的典型特征：业务事件界限清晰，单个业务事件设流程控制；业务事件间设流程控制；业务事件间可以设单据级稽核控制。管理呈现商务与财务数据共享、一体化管理状态。此模型适用于业务事件规范，内部控制完善的企业。

（五）优化级：专家治理模型

优化级获取／支付过程管理状况如下：

管理重点：在全面管理发出商品／服务请求、采购商品和服务、验收商品和服务、存放和保管已验收的商品、退回、为商品和服务付款、授权采购七个业务事件的基础上，特别关注企业个性化管理需求的实现，重点关注效益的提高和风险的控制。

流程控制：流程控制进一步提高各部门信息共享、不断完善财务与业务一体化控制。

时间控制：业务事件及业务事件间时间控制进一步优化，不断提高及时性、准时性控制水平。

成本管理：进一步完善事前、事中、事后的成本控制范围与水平。

计划控制：进一步加强预算编制、计划执行控制。

库存管理：库存控制进一步完善。

客户关系：客户关系管理与财务管理、业务管理协同进行。

人力资源：人员职责分配不断明细，业务事件授权不断清晰。

人员沟通：进一步强调和完善组织周期性协商或协调交流机制。

风险控制：进一步完善风险控制与管理。

业务集成：业务事件不断进行流程重组，集成度不断提高。

单据稽核：进一步完善和提高单据级稽核和报表级稽核。

优化级模型的典型特征：组织达到一体级管理能级后，面对日益变化和成长的市场，运用新的管理技术与科学技术不断调整和改善各项管理活动。

四、获取／支付能力成熟度模型的评估方法

获取／支付能力成熟度的评估可以采用百分制，分成五个分值区间，其对应关系如表一的尾行所示。明细评分方式可以分成十一个考察点打分后计算加权平均分。具体数值区间如表一：

级别 考察点 | 权重 | 初始级 | 基本级 | 商务级 | 一体级 | 优化级
流程控制 | 15% | 0~20 | 21~40 | 41~60 | 61~80 | 81~100
时间控制 | 5% | 0~20 | 21~40 | 41~60 | 61~80 | 81~100
成本管理 | 10% | 0~20 | 21~40 | 41~60 | 61~80 | 81~100
计划编制 | 10% | 0~20 | 21~40 | 41~60 | 61~80 | 81~100
库存管理 | 10% | 0~20 | 21~40 | 41~60 | 61~80 | 81~100
客户关系 | 10% | 0~20 | 21~40 | 41~60 | 61~80 | 81~100
人力资源 | 5% | 0~20 | 21~40 | 41~60 | 61~80 | 81~100
人员沟通 | 5% | 0~20 | 21~40 | 41~60 | 61~80 | 81~100
风险控制 | 5% | 0~20 | 21~40 | 41~60 | 61~80 | 81~100
业务集成 | 20% | 0~20 | 21~40 | 41~60 | 61~80 | 81~100
单据稽核 | 5% | 0~20 | 21~40 | 41~60 | 61~80 | 81~100
分值区间 | 100% | 0~20 | 21~40 | 41~60 | 61~80 | 81~100

表一 获取／支付成熟度模型评估矩阵图

一般而言，当组织的加权平均分落入某个分值区间时，宜采用相应的模型。当某个考察点的得分区间与加权平均分区间不相同时，组织应注意采取措施，尽量使其一致。

五、应用获取／支付能力成熟度模型的三个原则

（一）持续性

获取／支付成熟度能级的提高不是一夜发生的，在此过程中的每一阶段，都需要持续不断、循序渐进地改变。其中，全组织范围内的基础理论与方法的培训和教育是必不可少的，因为人们不可能成功地、重复地执行一个他们并不明白的方法。同时，五个不同的能级也为组织能级的变迁提供了一个可供参考的路径图。

（二）匹配性

不是每个组织的所有业务都需要达到第5级能级才能获取重大收益，运用成熟度评估方法，确定组织的成熟度能级，采用与之匹配的成熟度模型，就能获得最佳的收益。

（三）螺旋上升性

成熟度强调连续不断的提高，既使组织达到了最高成熟度能级，也总是还有提高的空间。每过一定的时间（半年或一年），组织应该重新审视它的获取／支付实践、战略、过程和目标。不断优化业务过程与提高风险控制。

六、应用案例

笔者运用该模型框架并加以扩充与具体化，主持开发了一套管理软件，并对十家以上的企业不同程度地成功实施了财务与业务的一体化管理。其中，就获取／支付过程的七个业务事件分别设置了若干单据和机制与之对应，其对应关系如表二：

业务事件 | 单据/机制
发出商品／服务请求 | 询价单、采购订单
授权采购 | 菜单级授权、数据级授权、单据级授权、流程级授权、报表级授权
采购商品和服务 | 采购单、购货单
验收商品和服务 | 验收单、购货单
存放和保管已验收的商品 | 借入单、借入归还单、借入转采购单、采购转借入单、内部调拨单、盘盈盘亏单
为商品和服务付款 | 付款单、采购发票
退回 | 采购退回单、验收退还单、购货退回单

表二 业务事件与单据/机制对应关系

图一：一体级获取／支付业务过程业务流程图

图一是一体级获取／支付业务过程业务流程图，采购业务从“采购订单”开始，经过叁个流程“制单”、“审核”和“执行”后；可以生成“验收单”。图中“采购订单执行”至“验收单制单”之间的虚线表示“验收单”可根据“采购订单”生成，也可单独填制，若生成，那么一张“采购订单”可以多次生成“验收单”，即一次采购订货业务可多次执行验收的过程；“验收单”经过两个流程执行完毕。“验收单仓库收货”至“采购单制单”的实线表示两者之间多对一的必须经过的生成关系。“采购单财务审核”到“采购增值税发票制单”的实线表示两者之间一对多的必须经过的生成关系。“采购增值税发票稽核”到“付款单制单”之间的实线表示两者之间一对一的必须经过的生成关系。

参考文献：

1.[美]卡耐基梅隆大学软件工程研究所.2003.能力成熟度模型（CMM）软件过程改进指南.第三版.北京：电子工业出版社，9-15

2.杨周南.2002.会计信息系统. 第二版.大连：东北财经大学出版社，187-188

Abstract：The article Establishes Capability Maturity Model for Purchasing and Accounts Payable refer to Capability Maturity Model for Software, The Model is based on Process Improvement. Sets up the method for evaluating the Capability Maturity Mode for Purchasing and Accounts Payable. Supplies a set of simple and shortcut utilities of Analysis and implementation for the enterprise.

Keywords：Accounting Information System Purchasing and Accounts Payable Capability Maturity Mode


第三种财务软件

中国会计电算化1999年11期 汤四新

一、 第三种财务软件的概念

经过近二十年的发展，我国财务软件有了一个长足的发展，涌现出了一批非常优秀的财务软件公司和一大批优秀的会计电算化人才。通过他们的努力，使我国许多企业的会计和财务工作告别了传统的手工作业方式，进入到一个崭新的电算化时代。会计电算化事业正以一种前所未有的速度向前发展。

纵观现在大多数企业实现会计电算化的方式一般有两种：一种是购买通用的财务软件，另一种是实行定点开发。所谓“通用财务软件”是指企业可以在市场上购买到一种成型的同时又适应本企业需求的财务软件，拿来就用；所谓“定点开发”是指企业由于自身业务的特殊性和需求的特殊性在市场上寻找不到一个适应本企业要求的软件，只能采用软件工程的方法进行专项的定点开发。然而，随着企业会计电算化工作的进一步开展，当企业的普遍性需求得到满足后，由业务的特殊性和需求的特殊性引发的对软件的个性化要求会越来越明显、越来越多，企业将面临一个使用通用软件满足不了个性化的要求，采用定点开发又周期太长、费用太高、且存在一定的投资风险的困境。如何解决这个难题呢？我们需要引入一种全新的财务软件来解决这个难题，这种全新的财务软件应该是介于通用财务软件与定点开发财务软件之间的既能满足企业的普遍性也就是通用性需求又能企业的特殊性也就是个性化的需求的软件。这种软件我们可以称其为“第三种财务软件”或“个性化的财务软件”。

二、 选用第三种财务软件的前提条件、应用前景和意义

什么样的企业适合选用第三种财务软件呢？或者说企业选用第三种财务软件应该具备什么样的前提条件呢？企业能否选用第三种财务软件一方面要看企业对财务软件有没有个性化的需求，另一方面也要看企业是否具备有使用第三种财务软件能力的会计人员。前一点我们可以看到，随着财务软件向管理型、决策支持型发展，企业这种基于业务特殊性和需求特殊性的个性化需求会越来越多、越来越明显。后一点我们可以通过加强对会计人员的培训提高他们的整体素质来实现，比如：通过推广会计电算化中级培训、通过会计人员后续职业教育等使会计人员初步具备自己分析本企业需求、自己分析本企业业务流程、自定义输出信息内容与格式的能力。再者，我们企业也可以借助软件公司的技术人员或第三方力量（如：管理咨询、实施机构）来帮助企业实施。

通过前提条件的讨论，我们也可以看出第三种财务软件具有非常广泛的应用前景。同时，第三种财务软件的推广与普及也必将进一步提高企业的会计核算、管理与辅助决策的能力，必将进一步提高我们国家会计电算化的整体应用水平，为管理现代化奠定一个更坚实的物质基础。

三、 第三种财务软件的实施方法

值得庆幸的是，在市场上我们已经可以看到第三种财务软件的身影，由湘财三门软件公司出品的三门软件和富港公司出品的富港软件就是其中的优秀代表。它们已经具备了第三种财务软件的某些特征。通过他们的实践，我们可以总结出第三种财务软件的实施方法应该是一种汲取软件工程实施法和原型实施法的新方法。我们可称之为“系统原型法”，它的意思是指实施第三种财务软件首先要有系统工程的思想，但又不能过于求全；其次，在实施过程中更应该采用原型法去分析和实现企业的个性化需求。当然，这种“系统原型法”还需要在不断的实践中不断地完善。

四、 第三种财务软件与MRP、MRPII、ERP的关系

现在，我们很多人把MRP、MRPII、ERP单单看成是一种软件，其实，如果我们认真地分析一下MRP、MRPII、ERP就不难得出一个结论，MRP、MRPII、ERP更多的应该是一种管理思想，确切的讲，是一种适应市场经济模式借助计算机技术才能得以实施的管理思想和实施方法。而我们的第三种财务软件是一种非常灵活的软件，如果我们将MRP、MRPII、ERP的思想加以运用，我们就可以用第三种财务软件实施MRP、MRPII、ERP的管理模式。而且我们用第三种财务软件对不同的企业可以采用不同的步骤实施MRP、MRPII、ERP。在这个过程中我们不难发现采用第三种财务软件实施MRP、MRPII、ERP的一个更适合国情的优点：一般来说，企业实施MRP、MRPII、ERP都要首先进行业务流程重组（BPR）工作，这种业务流程重组工作是颇费人力、财力、物力的风险性极高的工作，在我国由于国情的关系，很多企业往往在此阶段就结束了实施MRP、MRPII、ERP的工作；而采用第三种财务软件，企业大可不必进行声势浩大的业务流程重组工作，企业只要稍加调整或不作调整，就可以采用这种“软件迁就用户”的第三种财务软件通过不断的螺旋式上升的方式实施MRP、MRPII、ERP的工作。

在市场经济模式下，企业的经营环境和业务流程是不断的发生改变和进行调整的，如果我们拥有第三种财务软件，我们的企业就不会因经营环境和业务流程的改变而更换软件，从而大大降低我们企业实施信息化管理的总体拥有成本。由此看来，第三种财务软件是一种值得大力研究和推广的财务软件。


管理软件记账凭证生成机制研究与性能评测

中国会计电算化2003年第10期 汤四新

摘　要：本文通过对现行管理软件的各种记账凭证生成机制的现状分析，建立了一个新的统一的管理软件记账凭证生成机制。并从理论与实务两方面研究其应具备的本质特征与性能评测指标。

关键词：会计电算化　财务软件与管理软件的凭证接口处理

在财务软件中，登记各种分类账的依据是记账凭证，换言之，财务软件的数据源是记账凭证。因此，在业务软件与财务软件的一体化协同处理中，能否科学地将业务单据反映的业务事件，转换成用记账凭证描述的会计事项，并传递至账务系统，成为财务、业务一体化协同管理的关键。

１．管理软件各种记账凭证生成机制现状分析

通过分析目前大多数管理软件，可以发现，记账凭证生成机制大致可以归纳为四种，而且这四种机制相互之间独立性比较强。

１．１从业务备查簿或会计报表取数生成记账凭证

从业务备查簿取数生成记账凭证，是指业务软件日常只处理业务单据，并根据业务单据登记业务备查簿；当需要与会计发生关联时，再根据已登记的业务备查簿按照事先约定的生成机制生成记账凭证。这种方式被许多软件厂商选用。例如：对于零售销售业务，每个工作日都会有很多张零售单据，首先将零售单据登记业务备查簿，再根据业务备查簿生成记账凭证不失为一种可取的选择。

另外，有些软件其业务软件的报表系统与财务软件的报表系统是统一的，主要表现为两者数据的共享性与操作的一致性。这类软件大多提供从报表取数生成记账凭证的功能。此时，也可从业务报表取数生成记账凭证。

１．２从通过财务审核的业务单据自动生成记账凭证

从通过财务审核的业务单据自动生成记账凭证，是指业务软件在处理业务单据的过程中设置有财务审核功能，并且在财务审核的同时就可以自动按事先约定的生成机制自动生成记账凭证并传递至账务系统。例如：对于采购业务，一般不会象零售业务一样频繁发生，而且，在发生采购业务时还会牵涉采购费用和往来账款的结算问题。因此，采购业务比较适宜于逐单生成记账凭证。

１．３从财务软件提供的自动转账功能自动生成记账凭证

从财务软件提供的自动转账功能自动生成记账凭证，是指财务软件本身提供功能较强的自动转账机制，这类自动转账机制能支持多借多贷的会计分录的生成。借助此类机制就可以完成某些与业务有关的记账凭证的自动生成。例如：采用月末一次加权平均法结转销售成本的分录（借：销售成本，贷：库存商品），企业一般月末登记一次财务账，此时采用财务软件提供的自动转账机制生成记账凭证比较适合。

１．４从管理软件提供的记账凭证生成功能自动生成记账凭证

从管理软件提供的记账凭证生成功能自动生成记账凭证，是指当生成凭证时除了需要满足财务软件提供的自动转账机制功能外，还需要从业务单据中取得某些单据要素信息时，就需要采用此类方法。例如：结转采购成本的分录（借：库存商品，贷：商品采购），企业有可能每周或每旬集中登记一次财务账，此时采用财务软件提供的自动转账机制也可以；但是，却不能做到区分供应商生成多借多贷、并且在凭证摘要中注明供应商名称的记账凭证。此时采用从管理软件提供的记账凭证生成机制，问题就可以迎刃而解。

２．统一的管理软件记账凭证生成机制

通过以上分析，不难发现，每一种机制都有其适应的场合。因此，我们也不难发现，许多软件也同时提供其中多种机制。那么，是否可以建立一个包含以上四类机制的一种新机制呢？答案是肯定的。该新机制应在彻底包含以上四类机制的基础上，进一步在机制的内涵与外延上进行高度的统一，具体地讲，就是应以一种统一的内核、一致的操作使用方法，呈现在用户面前。如果采用此机制开发软件，反映在软件上就是以一种统一的操作界面包含以上四类机制。简言之，应该是一个“四合一”且操作风格一致的软件。其应具备的特征可以归纳为如下八点：

２．１生成触发点的自由选择

生成触发点是指在何时启动记账凭证的生成。譬如：当业务单据登记财务账时启动，可以称之为逐单生成；每日汇总某类单据登记财务账或任意指定某几日汇总某类单据登记财务账时启动，可以称之为逐日生成；月末一次性启动的可以称之为逐月生成。因此，生成触发点就可以分成三种，分别是逐单生成、逐日生成和逐月生成。它们都有不同的适应场合。逐单生成适应于平时发生业务少的单据；逐日生成适应于平时发生业务比较多的单据；逐月生成适应于月末一次性结转的单据。

２．２凭证拆分的灵活设置

凭证拆分是指在按汇总单据生成一张记账凭证时，是否需要按某种条件将其拆分为多张凭证。譬如：上文提到的结转采购成本的分录，如果需要按采购部门的不同分别生成多张记账凭证，那么凭证拆分设置成按“部门”拆分。当然拆分条件还可以设置成“币种”、“仓库”、“业务类型”、“客商”、“商品”、“人员”等。

２．３凭证转账过滤的灵活设置

凭证转账过滤是指按汇总单据生成记账凭证时，是否需要按某种条件过滤其中一部分单据。譬如：上文提到的结转销售成本的分录，如果企业不同销售部门采用不同的销售成本结转方法，那么此时就需要给不同的销售部门定义不同的销售成本结转凭证，“部门”就成为了凭证转账过滤的条件。

２．４分录拆分的灵活设置

分录拆分是指在按汇总单据生成记账凭证时，在同一张记账凭证内是否需要再按某种条件将其拆分为多笔分录。譬如：上文提到的结转采购成本的分录在凭证拆分中已按部门进行，也就是说不同部门的业务单据生成不同的凭证；此时如果还需要将不同业务员经手的业务单据独立地编制一条分录就必须借助分录拆分，只要将分录拆分条件设置为“人员”即可。分录拆分条件也可以理解为产生多条分录的条件。与凭证拆分类似，分录拆分条件还可以设置成“部门”、“币种”、“仓库”、“业务类型”、“客商”、“商品”等。

２．５科目组合的灵活设置

科目组合是指在确定记账凭证借、贷方科目时，可以根据单据组合要素分别对应不同的科目，甚至设置单据要素与账务系统辅助核算项目之间的对应关系。譬如：“借：商品采购，贷：应付账款”，分录中，应付账款对应的明细科目要视企业账务系统应付账款的科目结构设置分情况而论。当企业账务系统中应付账款的科目结构设为“应付账款＋往来单位”二级科目时，科目组合只要设置单据要素“客商”与科目的一一对应关系表，就可以满足如何确定应付账款对应的明细科目的要求；当企业账务系统中应付账款的科目结构设为“应付账款＋往来单位辅助核算项目”时，科目组合除了设置应付账款对应的一级科目对应关系表外，还须设置单据要素“客商”与账务系统往来单位辅助核算项目之间的一一对应关系表，才能符合需求。

２．６数据计算公式的灵活设置

数据计算公式可以分解成金额计算公式；外币计算公式；数量计算公式；摘要计算公式四类。所谓数据计算公式的灵活设置是指上述四类公式都可以象报表公式定义一样根据单据要素自由设置。譬如：希望摘要格式为“客商：”＋客商名称＋“单据号：”＋单据编号，那么摘要计算公式应定义为：'客商:'+[客商]+'单据号:'+[单据编号]，其中'客商:'和'单据号:'是字符串常量，[客商]和[单据编号]是单据要素。

２．７分录转账条件的灵活设置

分录转账条件是指某笔分录生效的条件。类似于凭证转账过滤条件，只是前者针对凭证，而后者针对凭证中的单笔分录。在此不再累述。

２．８记账凭证与业务单据的稽核控制

记账凭证与业务单据的稽核控制是指已生成记账凭证的业务单据与该记账凭证间存在互相稽核、互相控制的关系，这种关系主要体现在两个方面：一方面表现为已生成过记账凭证的业务单据不允许再次生成记账凭证；另一方面当对记账凭证实施反审核后就可以重新编辑曾经生成该记账凭证的业务单据并重新生成新的记账凭证。这种控制主要是为了保证财务与业务数据的一致性和二者之间的同步处理，从而达到财务对业务的监控、业务与财务的互相稽核的目的。

３．机制的性能评测指标

一个机制是否合理、正确，或者采用该机制开发的软件是否完备、有效可以从以下五个方面进行考察分析。

３．１及时性

及时性是指业务单据生成记账凭证是否能及时满足企业会计人员收集财务信息的需要。由于不同企业根据不同业务单据制作记账凭证的及时性要求存在一定的差异，使得这个指标看似有些笼统。其实不然，在财务、业务一体化协同管理中系统追求的目标是财务与业务的实时对接。也就是说，只要该业务单据反映的业务事件引起了企业会计事项的变化，就应该立刻生成记账凭证。因此，从理论上讲，及时性可理解为实时性。从实务的角度来讲，及时性也可理解为满足企业单位财务对业务时间上的监控要求。

３．２可验证性

可验证性就是可再现性，具体地讲就是指同一批单据反映的业务事件在不同的时间、地点、由不同的会计来做，只要转账规则没有改变，那么它的结果都应该相同。不会出现张三今天做和李四明日做的结果之间南辕北辙。可验证性的另一层含义是指稳定性和延续性。

３．３可溯性

可溯性也可以叫可逆性，是指虽然已生成记账凭证的业务单据与该记账凭证间存在互相稽核、互相控制的关系，但是这种相互关系也是可回溯的，是可反操作的。当然，这种反操作是留有痕迹的，是可以留有审计线索的。

３．４完整性

完整性也可以叫完备性，是指该机制或根据该机制开发的程序在所有不同类型的业务单据反映的业务事件与其引起的会计事项之间，能全面地、系统地满足全体业务事件对应会计事项的记账凭证生成需要。

３．５一致性

一致性是指根据该机制开发的程序，各种转账机制在操作界面上提供相对一致的操作方法。这是因为，一方面各种转账机制本身存在一致的内在关联逻辑，是可以采用统一的算法的；另一方面由于该机制本身比较复杂，如果提供不相一致的操作界面将会增大使用的难度。


线材企业财务

线材企业财务、业务一体化核算与管理的软件实现分析

中国会计电算化2004年第12期 汤四新

线材企业泛指经营钢材、木材等线型材为主的企业，在长期的业务管理与财务核算上，针对其经营物品的特点，逐渐形成了独具一格的业务控制和财务核算特色。因此，常规的财务、业务一体化管理软件不能适应线材企业日常的出单、制表需要，更不能满足其财务核算与业务管理的需求。本人通过开发与实施线材企业财务、业务一体化管理软件，在详细分析线材企业进销存业务管理与财务核算特殊性的基础上，设计了一套与之相适应的业务流程，通过实践，得出了使用该流程实现线材企业财务、业务一体化核算与管理的关键。整理成文，希望对线材企业或其他特殊行业财务、业务一体化核算与管理软件的开发与实施有所帮助，不当之处，敬请指正。

一、线材企业进销存业务管理与财务核算的特点分析

与其他行业相比，线材企业业务管理与财务核算具有非常突出的行业特点，归纳起来主要表现在以下七个方面。

（一）批次法核算

在线材业务中，由于不同供应商供应的物品的材质不同，甚至同一供应商供应的同一物品在不同时期其材质亦有差异，外加市场价格变动因素的影响，客观上要求线材业务管理的采购、库存、销售三大环节都要求对物品实行严格的批次核算控制。要求财务核算必须采用个别计价法。

（二）双单位计量

线材业务都要求对物品实行双单位计量管理，例如：对于钢材同时进行件数与吨数的双单位计量，对于木材同时进行根数与立方数的双单位计量。而且，同一物品不同批次的双单位间还存在着非确定（粗略、大致）的换算关系。例如：同一批钢材的件数与吨数间存在一个大致相同的换算关系，不同批次钢材的件数与吨数间换算关系就不一定相同。财务核算上以吨数、立方数核算为主，以件数、根数管理为辅。

（三）计划数与实际数双重控制

在线材交易中，交易双方签定合同与提货通常不在同一场所完成。特别是随着现代大物流的盛行，贸易公司大都实行租用仓库方式经营，从而使得物品存储与运输成为相对独立的第三方职能。因此，要求采购与销售环节必须对物品实行计划数与实际数的双重管理。如果加上双单位管理，实际上是执行四重计量管理。例如：对钢材采购环节来说表现为计划件数、计划吨数、实收件数、实收吨数的四重计量管理；而销售环节表现为计划件数、计划吨数、实发件数、实发吨数的四重计量管理。

（四）借出物品、库存物品与自有物品三种物品库存形态管理

如前所述，由于交易双方进行交易与提货是在不同场所、不同时间完成的。这就造成了物品的不同库存形态。例如：公司想知道当前已开出提货单的计划发出物品数量，也想知道当前还可供销售的物品数量，还想知道物品支配权暂时掌握在公司手中的物品数量。这三种数量分别是借出物品、库存物品和自有物品三种从不同角度反映物品形态的数据。

（五）理吨、理价、理金额的计算

所谓理吨、理价、理金额是指理论上应反映的吨数、单价与金额。换言之，理吨、理价、理金额是开发票时使用的数据。该数据与实际吨数、实际单价、实际金额间根据不同的批次存在不同的换算关系。要求财务核算上以理吨、理价、理金额核算为主，以实际吨数、实际单价、实际金额管理为辅。

（六）同仓发货控制

同仓发货主要解决在物品发货业务时，不允许出现同一批次的相同物品在同一仓库件数余额出现负数的情况，换言之，发货管理必须结合物品、批次、仓库或货位三要素进行控制。

（七）杂费价外独立核算

由于大多数线材贸易公司采用租用仓库方式经营，因此，出现了为客代扣代缴仓储费与装卸运杂费等费用事项。而且该费用一般采用按吨数计算的方式计入售价而不计入理价。而财务核算上价外杂费应纳入往来账款的统一管理。

二、线材企业进销存业务流程的设计

通过以上的粗略介绍，可以得知：线材企业业务流程的特殊性主要体现在采购、销售和库存管理三大环节上。此外，在往来核算与管理、资金的预算与管理上，线材企业也显得与众不同。据此，我们设计了与其业务操作与控制相适应的采购业务流程、销售业务流程和直运业务流程。具体流程如图一、图二和图三所示：

图一：采购业务流程示意图

图一中，采购业务从“采购订单”开始，经过两个流程“制单”和“执行”后；可以生成“预付款单”；图中“采购订单审核”至“预付款单制单”之间的虚线表示“预付款单”可根据“采购订单”生成，也可单独填制，若生成，那么一张“采购订单”可以多次生成“预付款单”，即一次采购订货业务可多次执行预付款的操作；图中“采购订单执行”至“购货单制单”之间的虚线表示“购货单”可根据“采购订单”生成，也可单独填制，若生成，那么一张“采购订单”可以多次生成“购货单”，即一次采购订货业务可多次执行购货的操作；“购货单”经过三个流程执行完毕。图中“购货单审核”至“付款单制单”之间的虚线表示“付款单”可根据“购货单”生成，也可单独填制，若生成，那么一张“购货单”可以多次生成“付款单”，即一次购货业务可多次执行付款的操作。

图二：销售业务流程示意图

图二中，销售业务从“提货单”开始，经过三个流程“制单”、“签章”和“已回”，其中，“签章”表示同意执行，“已回”表示提货后仓库已回单，回单中记载了实发件数和实发吨数；图中“提货单已回”至“销货单制单” 之间的线段表示“销货单” 应根据“提货单”生成，且一张“提货单”一对一地生成一张“销货单”；生成“销货单”后，可以生成“收款单”、“杂费收款单”和“销售发票”，且可以一对多地生成。

图三：直运业务流程示意图

图三中，直运业务从“直运购货单”开始，经过两个流程后可以生成“直运付款单”；图中“直运购货单审核”至“直运销货单制单” 之间的线段表示“直运销货单”应根据“直运购货单”生成，且生成关系为一对多；“直运销货单审核” 至“直运收款单制单” 之间的线段表示“直运收款单”应根据“直运销货单”生成，且可以一对多地生成。

由于大多数线材企业采用租用仓库方式经营，因此，线材企业的库存核算与管理大多采用三级核算与委托管理相结合，以便加强业务对仓库的管理。在货物形态上，更是区分借出物品、库存物品与自有物品三种物品形态。其中，借出物品表示已开出提货单、但不能确定是否实际提货的物品数量；库存物品表示企业剔除已开出提货单的未提货物品、目前还可供销售的物品数量；自有物品表示企业不剔除已开出提货单的未提货物品、目前可支配的物品总量。为此，我们可以在业务流程设计中，规定购货单审核后，库存物品和自有物品同时增加同一数量；规定提货单审核后，借出物品应增加、库存物品应减小同一数量；规定销货单审核后，借出物品应减小、自有物品应减小同一数量。企业据此三数量分别可以得到当前已开出提货单的计划发出物品数量、当前可供销售的物品数量、当前物品支配权属于公司的物品数量。

一般而言，线材企业是资金密集型企业，其单笔往来款项都比较大，尤其是以批发为主的线材企业更是如此。因此，其往来管理与资金预算显得尤其重要。线材企业往来款项以采购预付款和销售应收款为主，往来管理的目标是加速资金周转、减少资金占用。因此，在业务流程设计中，应体现预付款与采购订单的关联使用与应收款与销货单的关联使用，并提供相关单据间的稽核控制。

三、一体化软件实现的关键

通过实践，我们发现财务、业务一体化协同处理的关键就在于财务部门与业务部门能够最大限度地共享数据、最大限度地实现二者的确认一致性、最大限度地实现相互间的稽核与控制。具体到线材企业主要表现在以下四个方面：

（一）采购过程中批次控制的严格执行

在采购环节，业务管理以采购订单、购货单为主，财务核算根据预付款单和购货单生成相应的记账凭证登记财务账。其中，购货单是最重要的采购类单据。业务人员在此单中要输入“物品批次”、以及跟随物品批次的“理算系数”、“杂费/吨”，软件要根据“实收吨数”与“实收件数”自动计算“单件重量”，并将“理算系数”、“杂费/吨”、“单件重量”三项数据与“物品批次”捆绑在一起，以便日后在销售类单据中引用。

（二）销售过程中理吨、理价、理金额及杂费的正确计算

在销售环节，业务管理以提货单、销货单为主，财务核算根据销货单生成相应的记账凭证登记财务账。在销货单中，“理吨”等于“实发吨数”乘以捆绑“物品批次”的“理算系数”，“理价”等于“面价”减去捆绑“物品批次”的“杂费/吨”的差除以捆绑“物品批次”的“理算系数”，“理金额”等于“理吨”乘以“理价”，“杂费”等于“实发吨数” 乘以“面价”的积减去“理金额”。其中，“理金额”是财务核算时采用的物品金额，“杂费”是必须纳入往来管理的应收款的组成部分。

（三）库存管理中借出物品、库存物品及自有物品的恒等变换

购货单、提货单、销货单是影响物品库存形态转换的三类单据，但是，在物品形态的转变中存在一个恒等式，即：“自有物品=库存物品+借出物品”。例如：购货单引起自有物品与库存物品的等量同增后，仍保持恒等式的平衡；提货单引起同一数量的库存物品减小、借出物品增加后，仍保持恒等式的平衡；销货单引起同一数量的自有物品减小、借出物品减小后，仍保持恒等式的平衡。

（四）直运业务管理的一气呵成

在直运业务中，由于无须经过仓储环节中转，没有仓储及装卸杂费的产生，因而，无须理吨、理价、理金额及杂费的计算。直运购货单与直运销货单之间在数量上基本相等，而差异主要体现在金额上。因此，直运销货单应该根据直运购货单一气呵成地生成。


网上银行与企业财务软件数据接口分析与设计

中国金融电脑2004年第1期 汤四新

摘　要：随着Internet 网的不断普及，网上银行逐步被人们接受，本文对存在多开户行多户头结算业务的企业如何利用网上银行提供的便利，实现银企对账单数据对接与共享，从而实现自动对账的“计算机自动对账系统”进行分析，通过对实施该系统中发现和解决的一些问题的分析，提炼出一些有益的结论。

关键词：网上银行　银企对账单　数据对接及自动对账

１．应用背景

目前，各家商业银行纷纷推出网上银行、企业银行。象电力部门、电信部门、税务部门等其它公用事业单位也通过银行进行代扣代缴业务。另一方面，广大市民和交费单位纷纷选用各家银行的“交费一户通” 帐户，方便地缴纳水费、电费、煤气费、电话费、保险费、税款等各种费用。与过去“电费只能在工行交，煤气费只能在建行交”相比，对电力、煤气公司等企业而言就形成了不同开户行的多户头结算业务，企业出纳的银企对账工作难度与复杂度较过去有所提高。

最近，笔者参与了广东某电力集团公司的“计算机自动对账系统的开发与实施”项目。该项目是某电力集团公司与广东湘财三门软件有限公司合作开发的一个项目。利用该项目可以从多家银行的网上银行或企业银行中获取企业对帐单数据，经过加工整理自动导入计算机，然后与企业银行日记账进行自动对账，最后将通过对帐的对帐单数据按一定的格式导出，供第三方业务软件使用。通过项目的实施，对财务软件与第三方软件进行数据集成问题，提高了认识，获得了提高。特撰文总结，希望对准备开展此类业务的企业提供参考。

事实上，该方案对其它通过银行进行往来业务结算频繁的企业如外贸企业也大有裨益。

２．系统分析与实施

通过调查分析，我们明确了业务流程。首先，通过各家银行的网上银行或企业银行下载对帐单数据；第二步：必须对下载数据进行格式整理与转换后导入统一格式的企业银行对帐单数据库中；第三步：录入企业银行日记账，第四步：将企业银行日记账与企业银行对帐单进行自动对帐。其中第三步与第四步是传统出纳系统的功能，因此，新系统的关键功能就是如何快速、准确地完成第二步工作。

我们从工商银行的网上银行与企业银行分别得到了两种不同格式的对帐单数据，如表1、表2所示：

表1：工商银行网上银行对帐单格式示例（见附表一）

000004829|02100|010141176|2|1,448,373.12|3602014609000801880|2002-07-01|09.18.37|三峡基金

000004830|02100|010128460|2|14,538,945.47|3602014609000801880|2002-07-01|09.19.38| 网电费

000004831|02100|010141171|2|645,830.58|3602014609000801880|2002-07-01|09.20.41|同价价差

表2：工商银行企业银行对帐单格式示例

从中国银行也得到了两种不同格式的对帐单数据，如表3、表4所示：

表3：中国银行集团格式示例（见附表三）

表4：中国银行企业格式示例（见附表四）

从建设银行得到了一种格式的对帐单数据。如表5所示：

开户机构;账号;账户名称;币种;利率;账户状态

(此处空一行)

东山支行营业室;440400101018888888888;电力集团公司;人民币;;正常

(此处空二行)

交易日期;凭证种类;凭证号;发生额/元:借方,贷方;余额/元;对方户;对方账;摘要;;

(此处空三行)

2003/01/01;其他凭证;000000000;.00,--;.00;;;上年结转;;

(此处空三行)

2003/01/13;进帐单;056;--,45000000.00;45000000.00;;;基建款;;

(此处空三行)

2003/01/14;其他凭证;001;90.00,--;44999910.00;;440400101012000001112;凭证售出;;

表5：建设银行格式示例

由此可见，各家银行的对账单格式都不相同，工商银行和中国银行还分别提供两种格式，建设银行格式尤为复杂。要设计一个对帐单整理程序确非易事。通过分析，我们确定了一个解决方案，通过三个自定义函数很好地解决了这个问题。

第一个函数f_deletelines（string source, integer pi_line_start, integer pi_delete_lines）。该函数将source传入的文件从pi_line_start行开始连续删除pi_delete_lines行。例如当pi_line_start＝0，pi_delete_lines＝3表示从第零行开始连续删除三行。函数体如下：（注：该函数使用PowerBuider8.0实现）

int start_pos=1,delete_pos,i

string ls_look_for='~n'

choose case pi_line_start

case 0

//从文件头开始删除pi_delete_lines行

for i=1 to pi_delete_lines

delete_pos = Pos(source,ls_look_for,1)

source = mid(source,delete_pos+1)

next

case 1000000000

//无穷大表示字符串尾，此部分程序略

case else

//隔pi_line_start行删除pi_delete_lines行

do while start_pos > 0

for i=1 to pi_line_start

start_pos = pos(source,ls_look_for,start_pos)

if start_pos = 0 then return source

next

for i=1 to pi_delete_lines

delete_pos = pos(source,ls_look_for,start_pos+1)

if delete_pos > 0 then

source = left(source,start_pos)+mid(source,delete_pos+1)

if i=pi_delete_lines then start_pos=delete_pos

else

return source

end if

next

loop

end choose

return source

第二个函数f_replace（string source, string look_for, string replace_with）。该函数将source传入的文件中的字符串的值等于look_for的更换成replace_with。例如当look_for＝’ |’， replace_with＝’~t’表示将source中所有的’ |’ 更换成’~t’。 函数体如下：（注：该函数使用PowerBuider8.0实现）

int start_pos=1,len_look_for

len_look_for = len(look_for)

start_pos =pos(source,look_for,start_pos)

do while start_pos > 0

source = replace(source,start_pos,Len_look_for,replace_with)

start_pos = pos(source,look_for,start_pos+Len(replace_with))

loop

return source

第三个函数f_replace_nto1（string source, string look_for, integer pi_max）。该函数将source传入的文件中１到pi_max个look_for字符组成的字符串更换成一个look_for字符。例如当look_for＝’ ’， pi_max=20表示将source中所有的１到20个空字符组成的字符串通通更换成一个空字符。函数体如下：（注：该函数使用PowerBuider8.0实现）

int i,j,start_pos,len_look_for

string ls_look_for

for i=pi_max to 1 step -1

//给ls_look_for赋值

for j=1 to i

if j=1 then

ls_look_for=look_for

else

ls_look_for=ls_look_for+look_for

end if

next

len_look_for = len(ls_look_for)

start_pos=1

start_pos = Pos(source,ls_look_for,start_pos)

do while start_pos > 0

source = Replace(source,start_pos,Len_look_for,look_for)

start_pos = Pos(source,ls_look_for,start_pos+Len(look_for))

loop

next

return source

然后我们编写如下一段程序：（注：该程序使用PowerBuider8.0实现）

// dw_import是一数据窗口

dw_import.dataobject='dw_import_zh_qygs'

// uf_file_read是自定义函数，完成将docname指定的文件读入ls_txt字符串

uf_file_read(ls_txt,docname)

//删除前三行

ls_txt=f_deletelines(ls_txt,0,3)

//替换空格

ls_txt=f_replace(ls_txt,' ','|')

//合并'|'

ls_txt=f_replace_nto1(ls_txt,'|',20)

//用'~t'替换'|'

ls_txt=f_replace(ls_txt,'|','~t')

// uf_file_write是自定义函数，完成将ls_txt字符串写入指定文件c:\cndzd.txt

uf_file_write(ls_txt,'c:\cndzd.txt')

rt=dw_import.ImportFile('c:\cndzd.txt',1,1000000,1,4)

以中国银行(企业格式)为例通过以上程序我们可以得到以下格式的数据：

2003-02-08 2003-02-08 2409000127 75,600.00- 95,514,847.71 0210836589__

2003-02-09 2003-02-09 2409000418 1,968,064.94+ 95,439,247.71 eft4116

2003-02-13 2003-02-13 2409000913 440,000.00- 97,407,312.65 0210836595__

通过前后对比我们可以发现第一列数据表示日期，第二列数据表示结息日期，第三列数据表示传票号，第四列数据表示发生额，其后加‘+’表示借方，加‘-’表示贷方，第五列数据表示上期余额，第六列数据表示摘要。我们可以取其一到四列导入企业银行对帐单数据库。

３．心得体会

随着Internet 网的不断普及，网上银行也会逐步被人们接受，各软件系统如何通过Internet 网进行有效的数据对接与资源共享将日渐突出，数据接口问题的解决方案的可行性与安全性值得注意。

目前各家银行网上银行的对帐单格式差异较大，建议有关管理部门如中国人民银行总行会同各商业银行制订相对统一的对外格式。方便银行系统与其它系统的数据对接与资源共享。


论战略型财务软件的本质特征

中国会计电算化2004年第6期 汤四新

摘　要：本文通过分析战略型财务软件与核算型财务软件、管理型财务软件的关系，从而挖掘战略型财务软件的本质特征。

关键词：会计电算化　战略型财务软件的本质特征

１、战略型财务软件与核算型财务软件、管理型财务软件的关系

从软件功能来划分，国内财务软件可以粗略地划分成核算型财务软件、管理型财务软件、战略型财务软件三个层次。

所谓核算型财务软件又叫“甩账型”财务软件，是基本上模仿手工对财务的核算和管理过程，在计算机里建立一套账本，起到减少工作量、减轻劳动强度的作用。核算型财务软件主要任务是解决财务会计的问题，由于财务会计主要是对企业已经发生的经济业务进行事后的记录和总结，对过去的生产经营活动进行客观的反映监督。按照一般公认会计原则、会计准则和会计制度对日常经济业务进行符合规范的处理，编制各种会计报表，最终以会计报表的形式向企业外部公众如实反映企业的财务状况和经营成果。因此，核算型财务软件结构比较统一，使用比较简单。

当然，企业使用财务软件不会仅仅停留在解决财务会计问题的水平上，企业更需要的是解决管理会计的问题。管理会计是更多地适应和满足现代企业管理的需要，突破传统会计的领域，利用财务会计提供的会计信息和其他业务信息，运用数学、统计等方面的一系列方法，通过整理、计算、对比、分析等个性化手段的运用，向企业内部各级管理人员提供用以短期或长期经营决策、制定计划、指导和控制企业经营活动的对内报告会计。由于管理会计主要向内部公众提供可以用于指导和控制企业经营活动的信息。因此，管理会计所处理的数据对象也多于财务会计、所遵循的原则和使用的方法也更具个性化。所以，能满足管理会计需求的财务软件就不会是核算型财务软件，而是管理型财务软件。管理型财务软件不是一个独立于核算型财务软件的软件，而是基于核算型财务软件又高于核算型财务软件的软件。换言之，管理型财务软件可以全面解决财务会计和管理会计的问题。

随着知识经济的逐步确立，行业竞争的深度和广度都在不断的变化，要想在激烈的竞争中抢得先机，财务人员必须学会如何将数据转化为信息，再由信息转化为知识，最后由知识付诸行动。企业必须放弃狭隘的“闭门造车”式的理财方式，而应采取更加主动的态度和管理方式，完成向战略型财务管理的转变。此时，企业所选择的会计信息系统应该是战略型的财务软件。战略型财务软件与核算型财务软件、管理型财务软件的关系如图一所示。

图一

２、战略型财务软件的本质特征

概括地讲战略型财务软件应该具有如下五个方面的特征：

２．１、数据源多样化

来自于记账凭证的财务信息只够支持财务核算与监督的需要。满足战略型财务管理的财务信息系统还必须添加来自于管理计划与控制的信息，来自于市场的各类信息。这样，就表现出数据源的多样化趋势。

２．２、数据采集环节扁平化、网络化

数据采集环节主要追求的目标是正确性、及时性、完整性和有效性。在传统工具支持下的数据采集过程中，为了保证数据采集的正确性，需要增加一些复核、检查的环节；为了保证数据采集的及时性，不得不以损失完整性为代价简化数据项目与格式；为了保证某些比较重要的数据采集的有效性，不得不牺牲另外一些数据的有效性。总之，在传统工具支持下的数据采集环节层次繁杂、基本呈现出一种树型结构。以电脑为主要工具的数据采集，完全改观了传统的数据采集方式。比如：只要数据源正确，电脑程序正确，那么，数据的后续加工环节将不会减弱这种正确性，几乎所有的检查、复核、对账环节就没有存在的必要，出现了数据采集环节扁平化趋势；借助电脑的数据采集过程，将可以在不损伤数据完整性的前提下极大地提高数据采集及时性，数据采集及时性与完整性的矛盾可以得到有效的调和；同样，基于电脑的数据采集有效性可以在网络化的环境下实现数据的共享，因而，出现了从多角度保证数据的整体有效性的可能，换句话说，就是在保证某些比较重要的数据采集的有效性时，可以不牺牲另外一些数据的有效性，数据采集的整体有效性可以得到显著的提高。

２．３、数据加工多库化

战略型财务信息系统，在数据加工处理环节上应以现代三库理论取代了“数据＋算法＝结果”的简单加工处理方式。出现了数据加工多库化的趋势。如图二所示。

图二

数据加工多库化也就是通常所说的三库理论。即有一个独立的，能提供各种所需数据的数据库。会计数据库存放会计的原始数据和中间数据，包括原始凭证、记账凭证、总账、各种报表等数据。有一个独立的不受数据变化所影响的，提供各种数学方法和其他方法的方法库。在方法库中，以标准模板方式存储了各种算法，如各种矩阵运算、微积分运算、线性方程求解、常微分方程求解及统计计算等。根据管理上的需要，由数据库提供所需数据和由方法库提供所需方法，互相结合在一起，形成一个能提供管理上所需模型的模型库、例如利用成本核算的数据和回归分析方法，可以建立成本估计模型，利用成本、收入、支出账务数据和运筹学的方法，可以建立利润预测模型。

决策支持系统（DSS）是计算机软、硬件技术迅速发展并应用于管理决策领域的必然结果，它能综合利用各种数据、信息、知识与模型技术，辅助管理者解决半结构化和非结构化的决策问题。会计决策支持系统（ADSS）是DSS的理论和方法在会计决策领域的具体应用，是以计算机为基础和工具，应用现代决策会计的理论和方法，为决策者提供各种信息，辅助决策者进行决策的系统。一个较为成熟的ADSS结构是由交互语言系统、问题求解系统和知识系统构成的。

２．４、业务流程可重组化

业务流程重组（Business Process Reengineering，简称BPR），是90年代由美国MIT教授哈墨(Michael Hammer)和CSC管理顾问公司董事长钱皮（James Champy）提出的，1993年，在他们联手著的《公司重组----企业革命宣言》一书中，哈默和钱皮指出：200年来，人们一直遵循亚当斯密的劳动分工的思想来建立和管理企业，即注重把工作分解为最简单和最基本的步骤；而目前不应围绕这样的概念来建立和管理企业，即把工作任务重新组合到首尾一贯的工作流程中去。他们给BPR下的定义是：“为了飞跃性地改善成本、质量、服务、速度等现代企业的主要运营基础，必须对工作流程进行根本性的重新思考并彻底改革。”它的基本思想就是----必须彻底改变传统的工作方式，企业在广泛应用信息技术的前提下，以市场为导向，以降低成本、提高产品质量、关心客户的需求和提高客户的满意度为目的，对企业内外工作流程进行深入分析，加以重新设计和组建。它包括企业组织结构、生产流程和业务流程的重组。

业务流程重组(BPR)的基本原则是以顾客为中心、企业的业务以“流程”为中心、“流程”改进后具有显效性。以顾客为中心，它是指全体员工以顾客为中心，而不是“上司”为服务中心。顾客可以是外部的，如在零售商业企业，柜台营业员直接面对的是真正的顾客，也可以是内部的，如商场的理货员，他的顾客是柜台小组。每个人的工作质量由他的“顾客”作出评价，而不是“领导”。“流程”是指一组结合在一起能为客户创造价值的相关工作，一个流程是一系列相关职能部门或岗位配合完成的，体现于为顾客创造有益的服务。企业的业务以“流程”为中心，它是指企业不再以专业职能部门为中心，工作设计不再基于等级管理和劳动专业化，而是基于从头至尾的整个流程以及与流程有关的岗位和为客户创造价值上。对流程运行不利的障碍将被铲除，职能部门的意义将被减弱，多余的部门及重叠的流程将被合并。“流程”改进后具有显效性，它是指改进后的流程提高了效率，消除了浪费，缩短了时间，提高了顾客满意度和公司竞争力，降低了公司运作成本。

业务流程重组，在具体实施中，体现在三个方面：单据内容的变化；单据传递过程和方式的变化；单据处理方式和结果的变化。单据内容的变化，包括各种业务单据类型的增减、单据格式的调整、栏目的增减分合。单据传递过程和方式的变化，包括传递对象及岗位的增减变化、各对象和岗位工作人员处理的变化。单据处理方式和结果的变化，包括处理的重点、处理的步骤、数据组织格式、汇总统计口径等方面的变化。

战略型财务软件应该是完全支持业务流程重组的。

２．５、理财观念决策化

战略型财务软件除了能够完成财务核算与监督、完成财务管理与控制外，无论从信息源的收集、信息的加工处理方法的选择、信息结果的输出等方面，特别是软件的整体设计思想与实现方式更多地紧紧围绕支持决策的方向展开。或者说是一切工作皆是面向决策的。软件的设计理念与实现功能支持决策化只是一个方面，更重要的是软件使用者的理财观念必须决策化。


论现代会计信息系统对流程管理的依赖性

财会通讯.学术版2004年第10期 汤四新

摘　要：本文通过分析总结现代会计信息系统与流程管理的核心，论证现代会计信息系统的建立、完善与实施对流程管理的依赖性。研究在现代会计信息系统中流程管理的应用原则，并对现代会计信息系统的销售／收款业务进行流程管理应用的案例分析。

关键词：现代会计信息系统　流程管理

如何认识现代会计信息系统的现有理论体系？如何完善现代会计信息系统的理论框架？如何运用现代会计信息系统的理论指导企事业单位实施现代会计信息系统？这三个问题是我们进行现代会计信息系统理论研究、软件开发和系统实施首要解答的问题。笔者从流程管理的角度对上述问题进行研究，试图证明现代会计信息系统的建立、完善与实施对流程管理存在着极大的依赖性。

一、现代会计信息系统的核心：集成

现代会计信息系统大量利用现代信息技术的成就，实现财务信息和非财务信息的实时采集、集中存储、及时处理、全面共享、随意访问，使会计工作的重心由核算向管理转变，为决策提供支持，其核心是业务过程与信息处理过程的集成。

现代会计信息系统的这种业务过程与信息处理过程的集成具体体现在四个方面：（一）与业务处理系统相结合，集成业务信息与财务信息；（二）与业务处理系统相结合，在会计信息系统中嵌入业务处理规则；（三）与业务处理系统相结合，实现信息的实时采集、处理、存储和传输；（四）与业务处理系统相结合，集成存储业务事件的原始数据，支持多种信息的输出要求。

总之，现代会计信息系统的核心是集成，即业务处理与信息处理的集成，财务信息与非财务信息的集成，财务核算与财务管理的集成，从而使会计信息系统由部门级系统升级为企业级系统，由手工系统、自动化系统升级为基于计算机的现代系统。

二、流程管理的核心：流程

流程管理（process management）是一种以规范化地构造端到端的卓越业务流程为中心，以持续地提高组织业务绩效为目的的系统化方法。流程管理的核心是流程，所谓流程就是组织跨越时间和空间的有序的工作活动，它有始点和终点，并有明确的输入和输出。也就是说，流程必须有“时间控制”，即明确的开始和终结；同时，流程必须有明确的预期和对结果的度量，即“明确的输入和输出”。

流程管理可以分解为三个层面：规范流程、优化流程和再造流程。对于已经比较优秀，而且符合卓越流程观点的流程，可能原先没有完全规范，可以进行规范化工作；如果流程中存在一些问题，存在一些冗余的或消耗成本的环节，可以采用优化流程的方法；对于一些积重难返，完全无法适应现实需要的流程，就需要进行再造。

三、现代会计信息系统对流程管理的依赖性

现代会计信息系统对流程管理的依赖性主要表现在三个方面：（一）流程管理是现代会计信息系统建立的前提；（二）流程管理是现代会计信息系统完善的工具；（三）流程管理是现代会计信息系统实施的保障。

（一）、流程管理是现代会计信息系统建立的前提

人们把会计信息系统在处理会计信息时所采用的一系列步骤和方法，称做会计信息系统的体系结构。而现代会计信息系统与手工会计信息系统、传统自动化会计信息系统的最大区别就在于其体系结构的差异。其差异性如表１所示：

系统 差异点 | 现代会计信息系统 | 手工会计信息系统、 传统自动化会计信息系统
信息处理过程 | 业务过程与信息过程有机集成。信息过程伴随着业务过程的发生而发生，财务信息伴随着业务信息的产生而产生。 | 业务过程与信息过程互相分离。业务过程发生后，业务信息按照业务口径采集，财务信息按照财务口径采集。
信息加工顺序 | 业务信息的处理自动触发财务信息的加工。 | 手工触发财务信息加工。
信息加工方法 | 基于业务过程与信息过程集成、业务与财务一体化处理，采用借助计算机的完整、精确的计算方法。 | 基于会计科目表的会计循环、复式记账法，一般采用考虑加工成本因素的简化、粗略的计算方法。
信息加工范围 | 业务数据、财务数据 | 财务数据
信息加工工具 | 计算机、财务业务一体化集成的软件系统 | 手工、计算机、仿真手工流程的软件系统
信息处理结果 | 明细、清晰、精确、业务财务自动稽核 | 基于加工成本考虑只能提供有限明晰度、业务财务稽核不力

表１：体系结构差异一览表

从表１可知，要实现手工会计信息系统、传统自动化会计信息系统向现代会计信息系统的转变，必须大刀阔斧地变革财务信息的处理顺序和加工方法。而这种变革正是流程管理所倡导的再造流程。

简单地说，流程就是做事的顺序。当做事的指导思想、预期目标变化时，就必然采用不同的处理方法和加工工具，就必然需要再造流程，只有通过再造流程才有可能变异出卓越业务流程，才有可能产生奇异性的处理结果。在此，可以得出一个结论：集成依赖于再造流程。因此，可以肯定现代会计信息系统的建立必须建筑在再造流程的基础之上。换言之，流程管理是现代会计信息系统建立的前提。

（二）、流程管理是现代会计信息系统完善的工具

现代会计信息系统理论框架的形成是近十年的新鲜事物，新鲜事物的发展是前进性与曲折性的统一。因此，现代会计信息系统还存在一个不断发展、逐步完善的过程。而所谓完善的过程就是站在前人研究成果的肩上，不断优化与创新的过程。在此过程中，采用流程管理的优化流程技术可以帮助我们如愿以偿地不断优化和继续发现现代会计信息系统的不足。事实上，现代会计信息系统已经越来越多地使用流程管理技术对业务过程、管理活动和信息过程进行分析研究，特别是对三类典型业务过程，即获取／支付过程、转换过程、销售／收款过程的研究更是借重流程管理作为分析研究的利器。因此，流程管理是现代会计信息系统完善的工具。

（三）、流程管理是现代会计信息系统实施的保障

企业实施现代会计信息系统的最终目标是根本变革传统的面向部门/职能型企业组织模式为现代的面向客户/流程型企业组织模式，形成新的基于流程管理的信息加工与报告机制。因此，从结果上看，这种变革必然表现为彻底性、根本性和戏剧性的一面。

然而，对于每一个体的企业，其现代会计信息系统的实施都是一项耗资不菲、技术复杂、管理变革大且历时较长的过程。如果不经过事先详细的分析，周密的规划，循序渐进地实施，必将造成极大的浪费，甚至给企业带来混乱。企业实施现代会计信息系统，核心是对企业过程进行分析，但并不意味着在分析和设计时只是忠实地反映企业中现存的过程情况。新系统的建立和运行应基于旧系统而高于旧系统，要对企业实施必要的业务流程重组。企业在长期的生产、管理、销售活动中，形成了各种各样大家习以为常却并不合理的业务流程，比如因人设岗的情况就相当普遍。在旧系统中已没人追究其必要性与合法性，而在建立新系统时，这些问题必须重新认识并加以改变，才能使新系统发挥效益。因此，在实施现代会计信息系统的过程中必须保持高瞻远瞩的观念，胆大心细的作风，分情况实施“突变式休克疗法”或“渐进式保守疗法”的流程管理。

适宜采用“突变式休克疗法”的企业一般来说，其员工训练有素；企业财务运作稳健；物流管理通畅；企业管理政通人和；管理机制健全；公司治理规范；最高管理层实施现代会计信息系统的态度鲜明、管理人员素质高、善学习、乐变革。特别是通过现代会计信息系统的培训和教育，企业上下共识高、信心足。此类企业可以更多地考虑采用流程管理的再造流程技术实施现代会计信息系统，从而短期内达到彻底性、根本性和戏剧性的变革效果。反之，适宜采用流程管理的渐进性规范流程和局部性优化流程技术。虽然周期会相对延长，投入会相对增大，但变革会相对稳定，实施不致半途而废。此时变革体现的则是系统性、规范性、持续性的“渐进式保守疗法”的一面。

总之，有了流程管理，我们就能比较容易地理解现代会计信息系统的核心为什么是集成、为什么能集成、为什么要集成等一系列问题。那么，在现代会计信息系统中运用流程管理应该如何把握应用原则呢？

四、现代会计信息系统中流程管理的应用原则

（一）、流程管理以人为本

表面上看，流程是为信息系统服务的，而不是为人服务的。其实，无论什么信息系统，无论哪个流程，人都是不可缺少的环节。如果流程不是围绕人，而是围绕机器、网络来设计，那么人最终就会淹没在大量自动化的流程中，就会变成跟着软件流程走，而不是跟着优化了的业务流程走。

另一方面，流程管理要保证流程是面向客户的流程，流程中的活动都应该是增值的活动，要让参与流程的人意识到他们个人的活动都是为客户服务这个大目标下的一个组成部分。此时，这一经过流程管理梳理过的流程，可以使人们心甘情愿并始终如一地执行，管理人员也可以以一种规范的方式对它加以改进。由此可以看出，流程管理的内、外服务对象都是人（员工、客户），因此，流程管理以人为本就不言而喻了。

（二）、流程边界界定清晰

表面上看，企业组织是以业务和职能部门来划分的，但实际上起作用的是流程。实际流程中呈现出来的是人员、物资和资金的流动，然而隐藏在这些可见的“流”背后的却是“知识流动”和“信息流动”。因此，流程边界的确定必须十分清晰，否则会引起企业知识流和信息流的混乱，从而影响到企业资源的价值实现。

另一方面，任何企业的信息系统，都不可能覆盖组织的全部业务内容，信息系统只能承载一部分结构化程度高、流程边界清晰的业务，而其它流程则只能借助手工的无规则记录来实现或被忽略。因此，不同部门、不同人员、企业内外的合作，就是检验流程边界界定是否清晰、完整、有效的试金石。故此，在现代会计信息系统中运用流程管理时，务必确保流程边界界定清晰。

（三）、流程的计算机管理

事实上，并非所有的业务过程和业务活动都能实现计算机化的管理，经分析可以发现：有些业务过程、业务活动可以由计算机自动进行；有些业务过程、业务活动可以人机交互进行；有些业务过程、业务活动仍然需要由人工完成。在现代会计信息系统中必须严格区分流程的计算机化管理的可行性，对于暂不具备计算机化管理的流程要加强其上、下游流程的分析与集成，并对其进行可规范化的研究，创造条件实施该流程的计算机化管理。

五、案例分析：销售／收款业务流程管理

客观地说，我国目前企业实施现代会计信息系统，适宜采用渐进式保守疗法。以下案例就是一个渐进式实施现代会计信息系统的销售／收款过程的范例。按照流程集成度由低到高，销售／收款过程可以分成不同的形态：松散型流程管理、商务型流程管理、一体化流程管理。以下简要分析。

（一）、松散型流程管理

销售／收款过程松散型流程管理如图１所示：

图１：销售／收款过程松散型流程管理示意图

其典型特征如下：业务事件界限较清晰，单个业务事件设流程控制；各业务事件间不设流程控制，不设业务事件间的单据级稽核控制。管理呈现业务松散、低耦合状态。此模型适用于已基本规范业务事件，建立内控基本秩序的企业使用。

（二）、商务型流程管理

    销售／收款过程商务型流程管理如图２所示：

图２：销售／收款过程商务型流程管理示意图

图２中“销售订单执行”到“发货单制单”之间的虚线表示一对多的非必须经过的生成关系；“发货单仓库发货”到“销售单制单”之间的实线表示多对一的必须经过的生成关系。其典型特征如下：业务事件界限清晰，单个业务事件设流程控制；有关商务活动的业务事件间设流程控制，其它业务事件间不设流程控制；有关商务活动的业务事件间可以设单据级稽核控制，其它业务事件间不设单据级稽核控制。管理呈现商务活动高聚合、有关商务活动的业务事件与其它业务事件低耦合的状态。此模型适用于商务类业务事件规范统一，部门内部管理严谨的企业使用。

（三）、一体化流程管理

销售／收款过程一体化流程管理如图３所示：

图３：销售／收款过程一体化流程管理示意图

图３中“销售订单执行”到“销货单制单”之间的虚线表示一对多的非必须经过的生成关系；“销货单财务审核”到“收款单制单”之间的实线表示一对多的必须经过的生成关系。其典型特征如下：业务事件界限清晰，单个业务事件设流程控制；业务事件间设流程控制；业务事件间可以设单据级稽核控制。呈现出业务与财务数据共享、一体化管理的状态。此模型适用于业务事件规范，内部控制完善的企业使用。

参考文献：

１. AMT-企业资源管理研究中心.2003 .业务流程管理（BPM）初阶.电子版，4

２. 杨周南.2002.会计信息系统. 第二版.大连：东北财经大学出版社，90，93，152

Dependency of Modern Accounting Information Systems on Process Management

GuangDong University of Finance SiXingTang

Abstract：The article demonstrates the dependency of to establish,perfect and implement the modern accounting information systems on process management by analysis of the kernel of modern accounting information systems and process management. Investigates the principles of how to apply by the case of cash receipts and disbursements systems.

Keywords：Accounting Information Systems、Process Management


财务软件凭证处理性能分析

中国会计电算化2003年第12期 汤四新

贵刊2003年第10期有一篇文章谈及凭证输入的四大软件比较。本文也拟就凭证处理进行性能分析，目的在于进一步阐明凭证处理性能，从而提请财务软件设计者不断改进软件功能，帮助广大财务软件用户提高凭证处理应用水平。

会计电算化中，账务系统初始化结束后，用户只要录入记账凭证并审核，电脑就能自动登账，生成各类账簿。因此，如何保质、保量、适时地完成凭证处理工作就成了账务系统中最引人关注的焦点。事实上，凭证处理是账务系统日常业务中使用频度最高的模块，它的性能直接影响用户对财务软件的满意度和美誉度。

一、凭证处理涉及的字段与字段值的检测

凭证处理主要是指将手工已编制好的记账凭证输入系统或根据原始凭证直接在电脑上制作记账凭证，同时可对输入的记账凭证进行修改、删除、打印、查找等操作。其处理的字段主要包括凭证头与凭证体两部分。

（一）、凭证头主要组成项目：

日期（年、月、日）：每张凭证的填制时间。该日期可以不同于当前会计期间的日期，但必须大于或等于账务系统当前会计期间。某些软件还允许跨年度输入日期。

凭证类型：从已设置好的凭证类型中选择输入。

凭证流水号：系统自动产生的反映该凭证记录的实际增加次序，它与凭证号可以不一致。事实上，凭证流水号是记账凭证的物理编号，而凭证号是记账凭证的逻辑编号；前者不区分凭证类型编号，后者区分凭证类型连续编号。

凭证号：凭证的编号。此项目受凭证编号控制设置影响。凭证编号控制主要解决凭证填制过程中的凭证编号连续性控制问题，按照会计原理的要求，记账凭证的凭证编号必须连续，不允许出现“断号”现象。优秀的财务软件对于凭证编号连续性的控制比较灵活。主要包含四层意思：在填制记账凭证的过程中系统缺省控制凭证编号的连续性，但允许修改，不硬性强求凭证编号的连续性；凭证审核后，凭证编号不再允许修改；凭证记账时如果发现存在不连续的记账凭证，系统给予断号凭证提示；月末结账时，严格检查凭证编号的连续性，如果没有断号凭证，系统允许结账，否则，系统生成断号凭证表，不允许结账。

附件：输入实际的原始凭证附件张数。

制单：用户以某一个已设好的用户编码登录系统，新增或修改凭证时，财务软件一般自动填入该用户编码对应的姓名于制单栏。

审核：用户以某一个已设好的用户编码登录系统，对凭证进行审核操作时，审核一栏由系统自动填入该用户编码对应的姓名。

出纳：用户以出纳的身份登录系统，对凭证进行签章时，出纳一栏由系统自动填入该用户编码对应的姓名。

记账：记录对该凭证进行登账处理的用户姓名。

状态：记录凭证的当前状态。目前大多数财务软件的凭证状态可以分四类：未完、待审、已审、记账，它们都是由系统自动判断后生成的。未完凭证：是指借贷不平或凭证分录内容没有输入完全的凭证。未完凭证须成为待审凭证才能进行审核。待审凭证：是指借贷相平、每一笔分录已经录入科目、有摘要等，可审核登账的完整的凭证。已审凭证：是指已经审核后不能直接修改的凭证，可以直接记账的凭证。记账凭证：是指标识该凭证已经记账是不能修改的凭证。

（二）、凭证体主要组成项目：

摘要：字符类型不限，字符个数不限，且不能为空。如果您已设置了摘要代码和摘要内容，在“摘要”栏可直接输入相应的摘要代码即可显示摘要内容。如果不记得摘要代码，则可以单击“摘要”栏中光标所在行中的命令按钮进入摘要代码名称对照表，选择您需要的摘要内容，您也可以增加或删除摘要内容，直到您找到您需要的摘要，单击“确定”按钮，确定选择并退出。

会计科目：根据经济业务录入对应的预先设置好的会计科目。会计科目的录入方法有多种。归纳大多数财务软件凭证填制处会计科目的录入方法大致有以下四种：

科目代码录入法：其一是直接录入最低级明细科目科目代码；其二是录入非最低级明细科目科目代码，系统一般会弹出一个包含该非最低级明细科目科目代码的所有最低级明细科目科目代码表让用户选择。

科目别名录入法：如果在科目代码中设置了科目别名，在“会计科目”栏可直接输入相应的科目别名即可显示会计科目。

科目名称录入法：其一是直接录入科目名称，它支持一级到多级；其二是输入科目名称的某一个汉字或一部分汉字然后按回车键，系统将弹出包含所输入汉字的所有明细科目，您可以从中选择需要的科目。

临时增加录入法：对于不存在的会计科目，系统一般提供即时增加会计科目，即刻使用的方式。操作方式大致如下：单击“会计科目”栏中光标所在行中的命令按钮进入会计科目代码名称对照表维护窗口，用户在此可以进行全方位的科目代码维护工作。如增、删、改、选中会计科目等工作。

借方金额、贷方金额：输入实际发生的借方发生额或贷方发生额。

合计、大写金额：由系统自动计算填入。

汇率、原币金额：如果输入的会计科目设置了外币核算，那么当该会计科目输入后汇率、原币金额项目就会被激活并允许且要求输入。

辅助核算项目代码：如果输入的会计科目设置了辅助核算项目例如往来、部门、职工、自定义项目等，那么当该会计科目输入后相应的输入项目就会被激活并要求输入。

业务编号：如果输入的会计科目设置了往来业务核算，那么当该会计科目输入后业务编号项目就会被激活并允许且要求输入。

数量、单价：如果输入的会计科目设置了数量金额核算，那么当该会计科目输入后，数量、单价项目就会被激活并允许且要求输入。

结算类型、结算号：如果在 “凭证基本控制”中设置了“录入银行结算单号”，那么当录入102银行存款的明细科目时，结算类型、结算号就会被激活并允许输入，但可以不输入。

二、凭证处理应具备的基本控制功能

在凭证处理过程中，财务软件一般提供一些基本控制功能，用以控制凭证处理规则。如：审核与记账是否合并控制、制单人与审核人是否允许相同控制、出纳签章控制、资金及往来赤字控制、可以使用其他系统受控科目、允许修改他人填制的凭证、凭证字设置与控制等。

（一）、审核与记账是否合并控制：

如果选择该选项则凭证记账、审核可合并为一个步骤，记账前不需要先审核，否则记账前必需先审核。记账凭证处理存在一个“三步曲”，填制、审核、记账。一张凭证填制完毕后，必须经过审核，只有审核无误的凭证才可以记账。财务软件的审核功能可以简单地归结为当记账凭证准确无误时，就在记账凭证审核栏填入审核人的姓名；当记账凭证存在错误时，就在记账凭证审核栏填入出错标志。记账功能则不同，如果用一句话来概括记账功能的话就是用通过审核的记账凭证中的会计分录更新科目余额及发生额文件。事实上，一张凭证填制完毕后，必须经过审核，只有审核无误的凭证才可以记账。从量上看，凡是经过审核的凭证，都要记账；凡是要记账的凭证，都要经过审核。两者是完全相等的。因此，可以将审核与记账合并，将整个记账三步曲合成两步完成。就好象跳交际舞的“快三”一样，踩着三步的点子实际上只跳两步。这种处理方式可以看成是会计电算化有别于手工会计操作的特色或者进步。

（二）、制单人与审核人是否允许相同控制：

如果选择该选项则制单人与审核人可以相同，否则凭证制单人与审核人必为不同人。按照会计原理的严格规定，凭证的制单人与审核人必须为不同的人，这样规定主要是为了加强对凭证正确性、合法性的监控。会计电算化后，凭证的正确性控制已经完全地交给了系统，合法性控制也部分地交给了系统。这样一来，传统会计的这条规定就可以淡化处理。

（三）、出纳签章控制：

如果选择该选项则含有现金、银行存款科目的凭证必须由出纳人员通过“出纳签章”功能对其核对签字后才能记账。

（四）、资金及往来赤字控制：

如果选择该选项则在制单时，当现金、银行存款科目的最新余额出现负数时，系统将予以提示。

（五）、可以使用其他系统受控科目：

若某科目为其他系统的受控科目（如：客户往来科目为应收、应付系统的受控科目），一般说来，为了防止重复制单，应只允许其受控系统来使用该科目进行制单，总账系统是不能使用此科目进行制单的，但如果您希望在总账系统中也能使用这些科目填制凭证，则应选择此项。

（六）、允许修改他人填制的凭证：

如果选择该选项则在制单时可修改别人填制的凭证，否则不能修改。按照会计原理的规定，凭证的修改只能由原制单人进行。会计电算化后，一般情况下面我们都应该遵循这条规定。但是，我们知道，会计电算化大大提高了会计工作的速度，也为局部改变会计工作的某些传统习惯提供了可能。“发现错误，马上修改”与“发现错误，责成修改”应该选择哪条规则主要看用户单位的具体情况和规章制度而定。因此，优秀的财务软件一般提供允许修改他人填制的凭证复选框控制。

（七）、凭证套打控制：

选择该选项则凭证打印时可按事先设置好的格式、在事先印刷好的凭证打印纸上快速地进行凭证的打印。凭证套打的实现主要包括两方面的内容：第一，设置凭证的输出格式，按设置的凭证格式印刷凭证打印纸。第二，设置凭证套打选项。几乎每家财务软件公司都提供由财政部门监制的本公司统一的凭证套打纸，对于用户单位来说，最简单的方法是选择由软件公司提供的统一格式的凭证套打纸。但是，如果本单位对记账凭证的格式有特殊的要求，并且记账凭证的输出量大。就有必要考虑自行设计印刷凭证套打纸。

（八）、超出计划数报警控制：

选择该选项，如果录入了科目计划或录入了项目计划，则当科目实际发生数或项目实际发生数超过计划数，系统会自动报警。管理会计的预算控制，预算编制、控制（对不同的费用预算采用不同的控制方法）与分析，可以借助财务软件的计划/预算编制机制、超出计划数报警控制机制、生成计划/预算报告表机制、编制包含计划/预算的内部管理报表等机制实现。

（九）、凭证字设置与控制

凭证字设置：凭证字又叫凭证类别，用户单位为了对记账凭证进行分类管理，一般对记账凭证进行分类编制，但各单位的分类方法不尽相同，所以财务软件要提供凭证类别设置功能，用户单位可以按照本单位的需要对凭证进行分类设置。财务软件在进行凭证类别设置，系统一般提供如下几种常用分类方式供选择：

A．记账凭证

B．收款、付款、转账凭证

C．现金、银行、转账凭证

D．现金收款、现金付款、银行收款、银行付款、转账凭证

E．自定义凭证类别

如果贵单位所使用的凭证分类不属于以上A至D选项，那么请选择E，凭证类别完全由用户自行设置。某些类别的凭证在制单时可以对科目有一定限制，这种控制就叫基于凭证字的凭证合法性控制。大多数财务软件一般提供以下限制类型供选择：

A．借方必有：指定该类凭证借方必须存在的科目。如：收款类凭证借方必有的科目可定义为“现金”、“银行存款”等，在录入收款类凭证时，系统就会检查凭证中借方科目是否存在“现金”或“银行存款”科目，如不存在则该凭证不能保存。

B．贷方必有：指定该类凭证贷方必须存在的科目。如：付款类凭证可定义为“现金”、“银行存款”等。

C．借方必无：指定该类凭证借方必须不能出现的科目。

D．贷方必无：指定该类凭证贷方必须不能出现的科目。

E．凭证必有：指定该类凭证的借方或贷方必须存在的科目。如：银行类凭证可指定为“银行存款”科目，即表示该类凭证的借方或是贷方必须存在“银行存款”科目。

F．凭证必无：指定该类凭证的借方和贷方都必须不能出现的科目。如：转账类凭证可指定为“现金” 、“银行存款”科目，即表示该类凭证的借方和贷方不能存在“现金” 、“银行存款”科目。

G．无限制：制单时，此类凭证可使用所有合法的科目。

以上是凭证控制中一些比较重要的控制内容，不同的财务软件在凭证控制中还含有其它更多的控制内容。用户单位要结合自身的实际情况灵活配置。一般来说，大多数的控制参数都是可以在运用过程中随时调整的。

三、凭证处理可提供的辅助工具

在凭证的填制过程中，为了提高凭证的填制速度和准确性，财务软件都提供有若干辅助工具用于帮助用户既快速又准确地完成凭证的填制工作。如：计算器、自动置平、摘要维护、科目维护、辅助代码维护、凭证模板、会计事务、凭证批处理、记账凭证分录序时簿（凭证处理集成环境）等。这些辅助工具大大地提高和保证了凭证处理的效率。

（一）、计算器：

在日常财会工作中，经常要用到计算器。为了方便用户计算，财务软件一般在有可能使用到计算器的位置都提供了计算器功能。有些财务软件的计算器功能非常强大，比如提供税率设置、提供舍位设置等高级功能。并且还提供了计算结果回填功能。计算器回填功能就是首先将光标定位于要填入计算结果的单元内，调用计算器进行计算，系统就可将计算器的计算结果直接填入预先定位的单元内。

（二）、自动置平：

“有借必有贷，借贷必相等”这是填制记账凭证的基本要求。财务软件在填制凭证处一般都提供有一个让凭证满足“有借必有贷，借贷必相等”基本记账规则要求的按钮。单击该按钮，可使光标所在分录行的金额由系统自动填入一个金额，该金额与其他分录行的金额满足记账规则的要求，使得该凭证平衡。严格地说自动置平可以分为自动借方置平、自动贷方置平和自动判断借贷方置平，但财务软件中一般只对应一个按钮。当光标在借方栏时，自动填入一个金额到借方，此为自动借方置平；当光标在贷方栏时，自动填入一个金额到贷方，此为自动贷方置平；不论光标在借方栏还是贷方栏，按与其它分录金额的借贷之和相等、方向相反的方式自动填入一个金额到借方栏或贷方栏，此为自动判断借贷方置平。

（三）、摘要维护：

大多数财务软件在填制凭证的过程中摘要录入处是允许进行摘要维护的。用户可以增、删、改、回填任意一个摘要。

（四）、科目维护：

大多数财务软件在填制凭证的过程中科目录入处是允许进行科目维护的。用户可以增、删、改、回填任意一个科目，如同初始化时进行科目维护一样。

（五）、辅助项目维护：

大多数财务软件在填制凭证的过程中辅助项目录入处是允许进行辅助项目维护的。

（六）、模板凭证：

在填制凭证处，财务软件一般都提供了可随时将某凭证保存为模板凭证和调入模板凭证的功能，以方便在录入凭证时，根据需要可以随时调入模板凭证作为用户输入凭证时的基本界面，以减轻凭证录入的工作量。

（七）、会计事务：

有些财务软件提供了更好的模板凭证方式。比如：有一种软件提供了一种叫会计事务处理的功能。会计事务处理就是将用会计语言描述的处理对象提升为用自然语言描述的会计事项。如提现、报销、销售商品等一些较为频繁，而且凭证的填制模式较为一致的经济业务，就可通过此功能进行描述，用户只需用自然语言描述会计事务的基本要素，会计凭证及其后续作业就可以全部自动完成。

（八）、凭证批处理：

目前，大多数的财务软件都提供有凭证批量处理的机制。提供此机制的主要目的是加快凭证处理的速度，方便用户的操作。批处理一般包括以下几类：

A．批量记账：完成某会计期间批量凭证一次性记账。

B．批量打印：完成某会计期间批量凭证一次性打印。做得好的财务软件在此处还提供有其它打印条件设置功能。如设置凭证合并打印级别（包含三个选项：不合并科目打印、相同科目合并打印、指定合并科目级别打印）等。

C．汇总：提供某会计期间批量凭证任意汇总功能。生成科目汇总表。做得好的财务软件在此处还提供了汇总级别设置功能。

（九）、凭证处理集成环境：

凭证处理比较繁琐，对应凭证处理的操作很多，为了方便凭证的处理和加快处理速度。某些财务软件都提供有凭证处理集成环境。在此环境中将所有关于凭证处理的功能汇集在一起，大大提高了凭证处理的效率。有的软件还提供有类似于传统会计的会计分录序时簿的机制来统一集成管理记账凭证。此功能也是手工会计无法比拟的，当然就是会计电算化的特色和优势。

四、凭证处理的正确性校验与合法性校验

（一）、凭证正确性校验：

凭证正确性校验是指记账凭证填制过程中必须满足的最基本的要求，或者说是凭证填制的语法规定。比如：哪些字段是必录域、字段录入必须满足的权限性或存在性要求。归纳起来大概有以下几个方面的内容：

    凭证第一分录摘要不允许为空。如果为空，系统就应该提示“凭证第一条分录无摘要！”。

    记账凭证的日期不允许为空，也不允许在账务当前会计期间之前（只允许填制当前会计期间及以后的凭证）。

    相同凭证字的凭证号不允许重号。

    不允许录入不存在的科目、不允许录入非最低级明细科目。

    不允许当前操作员录入无权限使用的科目。

    如果启用了某些业务系统，而且选中了业务由业务系统核算选项，在账务系统的凭证填制中就不允许使用相关的科目。比如：已经使用往来核算业务系统进行往来核算与管理，就不能在凭证填制中直接使用往来类科目（如：应收账款、应付账款、预收账款、预付账款等）；已经使用固定资产核算软件就不能在凭证填制中直接使用用固定资产科目。

    不允许录入不存在的核算项目。

    在需要录入往来业务编号时，不允许往来业务编号为空或为录入系统不允许的其它符号。

    不允许录入不存在的币别。

货币汇率必须为正数。

每张凭证借贷平衡：凭证保存时借贷方发生额合计必须相等。每张凭证借贷合计相等是符合“有借必有贷，借贷必相等”这条会计原理的记账规则要求的。在财务软件中对于处于“待审”状态的记账凭证确实应该符合“有借必有贷，借贷必相等”的要求。使用财务软件的最佳方式是借助电脑凭证处理的辅助功能在电脑上直接、快速、准确地填制凭证。而不是先手工填制凭证，再将手工填制好的凭证输入电脑。在手工填制凭证时，凭证的填制过程可以由人灵活控制，比如：一张凭证填制到一半，发现附件不全，暂停下来，等附件齐了接着填，一张凭证填制的时间跨度超过一两天的情况是有可能发生的。但是，在电脑上直接填制凭证时是不可能允许出现一张凭证填制的时间跨度超过一两天的。因此，在电脑上凭证的状态可以分成以下四种：未完、待审、已审、记账，它们都是由系统自动判断后生成的。其中未完凭证是指借贷不平或凭证分录内容没有输入完全的凭证。未完凭证须成为待审凭证才能进行审核；待审凭证是指借贷平衡、每一笔分录已经录入科目、有摘要等，可审核登账的完整的凭证；已审凭证是指已经审核后不能直接修改的凭证，可以直接记账的凭证；记账凭证是指标识该凭证已经记账，原则上是不能再修改的凭证。

（二）、凭证合法性校验：

凭证合法性校验是系统针对输入凭证的合理、合法性检查的简称。或者说是记账凭证填制之后的语义检查。它一般在凭证保存之前检查，或另设检查按钮检查。其检查范围及标准有：

用户自行设置的非法对应科目检查。如：对新增固定资产，应作为资本性支出处理，因此，当凭证的借方出现固定资产科目时，不允许借方再出现应交税金――应交增值税――进项税科目。

凭证字规定许可的会计科目检查。如转账凭证不允许出现现金或银行存款类科目等。

对于凭证合法性控制的使用要特别小心。凭证合法性控制的目的是为了加强凭证编制过程中的会计监控，提高凭证编制的质量，但是，由于凭证合法性控制的使用存在一定的难度，设置不当往往会犯画蛇添足的错误。如果用户不太清楚凭证合法性控制的使用方法，面临的选择只有两个：要么不进行凭证合法性控制的设置，要么咨询有关人士完全搞清楚后再设置，千万切忌似懂非懂地进行凭证合法性控制设置。


财务软件科目代码模式设计比较研究

广东财会2000年03期 汤四新

目前国产财务软件的帐务处理系统中都有一个科目代码模式的设置功能。用户应根据本单位的业务情况进行设置，一旦设定软件系统就不允许随意修改。比如：某企业将科目代码模式设置为３２４３就意味着该企业所使用的财务软件的科目体系一级科目代码长度为三位，二级科目代码长度为二位，三级科目代码长度为四位，四级科目代码长度为三位。本文想综合比较各流行财务软件的科目代码模式的设计实现方式，分析其优劣，进而探讨管理型财务软件应具备的科目代码模式设计方案。

一、科目代码模式的分类及其优缺点分析

目前市场上流行的财务软件科目代码模式可分成两大类：固定型科目代码模式和灵活型科目代码模式。

所谓固定型科目代码模式是指上文中提到的那样（３２４３），企业一旦设定，整个软件系统的科目代码都要遵循相同的模式，且最低级明细科目级数为四，级长为三位。目前市场上流行的大多数财务软件象用友软件、安易软件等都是采用这种科目代码模式。

    所谓灵活型科目代码模式是指财务软件中并没有对科目代码模式作统一的规定，系统只规定相同父科目的明细科目级长一致，而不同父科目的明细科目级长可以不同。例如：１０２１表示银行存款－工行，１１３０００１表示应收帐款－广州金专，这就意味着该企业银行存款的科目代码模式为３１（即一级科目代码长度为三位，二级科目代码长度为一位，且银行存款最低级明细科目级数为二），而应收帐款的科目代码模式为３４（即一级科目代码长度为三位，二级科目代码长度为四位，且应收帐款最低级明细科目级数为二），如果想设置１１３１表示应收帐款－会计研究杂志社就是非法的设置，因为１１３１与１１３０００１为相同父科目１１３的明细科目，其二级科目代码级长不相同。运用这种科目代码模式的典型财务软件是三门软件。

固定型科目代码模式和灵活型科目代码模式各有其利弊和适应场合。 固定型科目代码模式简单、统一，用户容易理解和接受，故大多数财务软件都采用这种模式。但这种模式“钢性”太大，如遇上文提及的某企业用１０２１表示银行存款－工行，１１３０００１表示应收帐款－广州金专，由于其开户行少，所以银行存款二级科目代码用一位足够表示，而往来客户多，应收帐款二级科目代码用四位才够表示。使用固定型科目代码模式，该企业就必须通盘考虑或采用折中方法使得银行存款二级科目代码不用四位而浪费位数，应收帐款二级科目代码不用一位而不够位数表示。（在实际工作中这种情况是普遍存在的）。灵活型科目代码模式顾名思义是一种比较灵活的方式，它可以较好地解决上述问题，应该说它更能适应和方便实际工作。但由于大多数财务会计人员对编码缺乏认识和其它方面的原因，采用这种科目代码模式的财务软件市场上寥寥无几。

其实从本质上讲，灵活型科目代码模式可以包含固定型科目代码模式，是一种比较理想的科目代码模式。

二、管理型财务软件科目代码模式的设想

作为新一代财务软件的管理型财务软件应该具备怎样的科目代码模式呢？这是一直困绕着财务软件理论界与实业界的一个问题。由于管理型财务软件将会计与业务处理紧密地联系在一起,财务数据由业务数据根据一定的关系自动生成，财务软件与业务处理软件构成一个有机的统一体,共同完成企业物流与资金流的信息加工处理。正是管理型财务软件这种财务与业务的一体化特性更加加剧了财务软件科目代码模式固有矛盾的尖锐化。过去，财务软件基本上局限于财务部门使用，科目代码的设计也只需要考虑财务人员的使用方便性，并且大多数财务帐相对业务台帐信息量也相对简单，因此无论是固定型科目代码模式还是灵活型科目代码模式都能满足财务核算的需要。现在，到了管理型财务软件时代，由于财务与业务的一体化，一般而言，财务帐是由业务帐按一定的关系生成的，在软件中既要管理财务帐又要管理业务台帐还要管理业务台帐与财务帐的对应关系，如果科目代码模式还采用过去的方法势必会引发许多矛盾，表现出不适应性。

为了能解决财务与业务的一致性问题本人在此提出几种解决方案供大家参考，以求教于各位会计电算化专家。

方案一：在业务系统中人工维护业务与财务的对应关系，譬如在仓储系统中的物料编码维护中增加一个科目代码项目用以指明某一物料是与哪个原材料科目发生联系。这种方法应该是最原始的方法，而且使用这种方法基本上无须改变财务软件的科目代码模式。

方案二：当物料编码多，与财务核算关系复杂时采用方案一可能会引起维护工作量过大的问题。这时可考虑不在业务系统中逐条维护业务与财务的对应关系，可另设一财务与业务对接模块完成财务与业务的对应关系，譬如也象上述仓储系统的情况，我们无须在仓储系统的物料编码维护中增加一个科目代码项目指明该物料是与某原材料科目发生联系，只须另建一映射关系维护表用以指明某段物料编码而不是某个物料编码是与某科目编码发生联系即可。这样就可大大减轻方案一的维护工作量，提高灵活性。这种方法应该是方案一的改进方案，而且使用这一方案基本上也可不改变财务软件的科目代码模式。

方案三：在实际工作中我们常常会遇到财务统计的口径与业务统计的口径不一致的情形，譬如财务上只设化工原料部，而业务上却分成农业生资化工业务部、涂料化工业务部、燃料化工业务部等等化工业务部，假设所有收入与费用科目都存在如此的对应关系，如果我们都采用方案二的解决方法，那么我们在所有有关部门的业务与财务对应关系上都要进行所有收入与费用映射关系维护表维护工作，如此我们又出现了维护工作量过大的问题。这时我们可采用方案三，首先我们可以进行财务系统科目属性要素的维护和财务系统各明细科目科目模式的维护，其中明细科目科目模式的维护有点类似于灵活型科目模式，有所不同的是当规定好某科目模式中的某级科目为某科目属性要素时该级科目就必为该科目属性要素之一，譬如我们首先设置财务部门科目属性要素编码维护，其中有０１表示化工原料部，０２表示钢材营业部，当我们设置产品销售收入明细科目模式为５０１ＸＸ（其中ＸＸ必为财务部门），那么我们只能５０１０１表示产品销售收入――化工原料部，５０１０２表示产品销售收入――钢材营业部，而不可能出现５０１１表示产品销售收入――化工原料部等其它情况。接着我们可以进行业务系统各管理要素的维护，譬如我们可以设置业务部门的编码维护，用００１表示农业生资化工业务部，用００２表示涂料化工业务部，用００３表示燃料化工业务部，用００４表示螺纹钢经营部，用００５表示角钢经营部等等，在业务系统中只使用业务部门编码。然后我们可以进行财务编码与业务编码对应关系的维护，譬如我们用财务部门编码０１对应业务部门编码００１、００２、００３，用财务部门编码０２对应业务部门编码００４、００５，这样我们就可以实现用５０１０１科目表示农业生资化工业务部、涂料化工业务部、燃料化工业务部的产品销售收入，如果再设置产品销售成本明细科目模式为５０２ＸＸ（其中ＸＸ必为财务部门），那么我们就可以用５０２０１科目表示农业生资化工业务部、涂料化工业务部、燃料化工业务部的产品销售成本等等。如此我们用三个独立的编码系统（财务科目属性要素编码系统、业务管理要素编码系统、对应关系维护系统）就可以完美地实现财务与业务系统的有机对接。

三、关于科目代码维护的几个问题及其解决方法

在科目代码维护方面有几个棘手的问题本人也想在此阐述一下：

问题一：有关科目代码更新（修改与删除）的问题

在什么情况下科目代码允许修改？从原则上讲，只要该科目代码还未曾使用过会计软件就应该允许修改。在目前市面上流行的财务软件各家有各家的控制方式，有的软件规定科目代码只在软件使用的第一个月允许修改、有的软件规定科目代码一旦建立就不许修改、有的软件规定科目代码只在初始化状态时允许修改，本人赞同在软件中设置一个初始化状态标志，当该标志为正在初始化时允许修改，当该标志为结束初始化时不允许修改，当然从正在初始化转换到结束初始化必须满足一定的条件，譬如余额要试算平衡等。在方案三的情形下科目代码的修改问题还要加上代码的存在性（科目属性要素编码系统）检测。

在什么情况下科目代码允许删除呢？从原则上讲，只要该科目代码还有余额或虽然余额为零但有本年发生额时就应该不允许删除。

问题二：有关科目代码的缩位与展位的问题

在财务软件的使用过程中常常会出现某级科目代码位长过长或太短的问题，目前大多数财务软件都不允许使用一段时间后修改某级科目代码位长，理由很简单，就是该科目代码已使用，使用过的科目代码连修改都不允许更何况修改位长呢。其实，我们应该首先来考察允许位长修改的合理性，在企业的营运过程中客观存在着需要变动某级科目代码位长的情况，当企业经营规模扩大或需要加强管理力度时往往需要增加某级科目代码位长，而当企业经营规模萎缩时往往需要减少某级科目代码位长，目前我们只能教育用户在进行科目代码的设置时要考虑可扩充性，实际上这种可扩充性只是一种想象，当真正出现位长不够时用户确实需要增加位长。其次我们从计算机软件技术，更精确的讲从数据库技术来讲这种变动某级科目代码位长的工作技术上是不成问题的，只是当财务软件使用一段时间后再来变动某级科目代码位长逻辑上比较复杂。从满足用户实际需求这个角度来看，财务软件应该具备科目代码的缩位与展位功能。


计算机条件下存货计价方法的改进与创新

财会月刊.会计版 2005年第1期 汤四新

摘　要：本文首先通过分析当前多种存货计价方法，总结了其共性与应用原则；转而分析了计算机条件下多种存货计价方法的应用原则与改进方法；最后对计算机条件下存货计价方法的创新进行了探索性研究。

关键词：存货计价方法　改进与创新

一、对当前存货计价方法的分析

存货计价方法是指采用不同存货成本流转程序，在期末存货与发出存货之间分配成本的方法。具体地讲，存货流转包括实物流转和成本流转两个方面。理论上讲，存货的成本流转与其实物流转应当一致，但在实际工作中，这种一致的情况非常少见。由于多数存货的使用价值基本相同，存货发出的成本流转与其实物流转的顺序可以分离，因此，就形成了不同的存货成本流转程序，即不同的发出存货的计价方法。

发出存货的计价方法的不同，对企业财务状况、盈亏情况会产生不同的影响。表一和表二对不同的计价方法从适用存货特征、计算结果的准确性、价格波动对存货成本和利润的影响、计算方法繁简程度、计算工作量大小、实际操作简易程度、是否随时可结存余额的时效性、计算方法对实物采购顺序的依赖性、实物流转与成本流转的一致性、企业选用率等方面进行了分析与对比。

计价方法 | 个别计价法 | 加权平均法 | 移动平均法 | 先进先出法 | 后进先出法
适用存货特征 | 容易识别、品种少、单价高、差异大 | 全适应，对收发频繁、数量较大、价差较小的存货尤为适用 | 进、出次数少 | 进、出次数少 | 进、出次数少，通货膨胀时保持稳健
准确性 | 精确 | 折中 | 精确 | 期末存货成本接近市值 | 本期发出存货成本接近市值
价格波动影响 | 当进价波动时，选择不同价格的存货，可调整本期发出存货成本和当期利润 | 存货价格差异平均化 | 存货各批价格差异进一步平均化 | 价格上涨时，高估当期利润和存货价值；物价下跌时，低估当期利润和存货价值 | 价格上涨时，低估当期利润和存货价值；物价下跌时，高估当期利润和存货价值
计算方法繁简 | 简单 | 简单 | 适中 | 适中 | 适中
计算工作量 | 大 | 适中 | 大 | 大 | 大
操作简易性 | 困难 | 简单 | 困难 | 困难 | 困难
余额时效性 | 强 | 差 | 强 | 强 | 强
顺序依赖性 | 强 | 弱 | 强 | 强 | 强
一致性 | 一致 | 无关 | 有可能一致 | 有可能一致 | 相反
选用率 | 少 | 多 | 少 | 适中 | 适中
备注 | 理论上最可取，应用成本高 | 普遍肯定与接受，推荐采用 | 对加权平均法的改进 | 可防止陈旧存货的损失 | 可保持现行成本与现行收入的匹配

表一：常用存货计价方法性能对比表

计价方法 | 最后进价法 | 计划成本法 | 毛利率法 | 零售价法 | 成本与可变现净值孰低法
适用存货特征 | 品种繁多、收发频繁 | 品种繁多、收发频繁 | 品种繁多、收发频繁 | 品种繁多、收发频繁 | 从新确定存货期末价值的稳健性方法
准确性 | 倒扎成本 | 折中，通过材料成本差异科目调整 | 倒扎成本，季末调整还原成实际成本 | 折中，通过商品进销差价科目调整 | 折中，通过直接冲减法或存货备抵法调整
价格波动影响 | 价格上涨时，高估当期利润和存货价值；物价下跌时，低估当期利润和存货价值 | 存货价格差异平均化 | 存货类别内部价格差异平均化 | 存货价格差异平均化 | 使存货更符合资产的定义，当可变现净值低于成本时，会歪曲反映各期利润
计算方法繁简 | 简单 | 适中 | 简单 | 适中 | 适中
计算工作量 | 适中 | 大 | 适中 | 大 | 大
操作简易性 | 简单 | 适中 | 适中 | 适中 | 适中
余额时效性 | 差 | 适中 | 差 | 差 | 差
顺序依赖性 | 强 | 弱 | 弱 | 弱 | 弱
一致性 | 无关 | 无关 | 无关 | 无关 | 无关
选用率 | 少 | 适中 | 适中 | 适中 | 适中
备注 | 不建议采用 | 多被制造业使用 | 多被零售商业使用 | 多被零售商业使用 | 不能用于销售成本的结转

表二：简化存货计价方法性能对比表

通过对表一及表二的进一步分析与比较，可以得到以下三个结论。

（一）结论一

存货计价方法大致可以分成三类：第一类是按实际成本（历史成本）计价的方法，包括个别计价法、加权平均法、移动平均法、先进先出法、后进先出法和最后进价法；第二类是平时按估价成本计价、期末或季末调整为实际成本的方法，包括计划成本法、零售价格法和毛利率法；第三类是按成本与可变现净值孰低计价后、再调整为实际成本的方法，即成本与可变现净值孰低法。

（二）结论二

所有存货计价方法对企业财务状况、盈亏情况产生的影响，从某一特定的会计期间看，只能表现为获得时间差异形式的财务利得或承受时间差异所形成的财务损失；而从一段连续的会计期间看，各种不同的存货计价方法都不能脱离历史成本，都只是在保持历史成本总量不变的前提下的对不同会计期间的不同分配。

（三）结论三

企业在选择存货计价方法时都应不同程度地遵守以下五条应用原则。

（１）适用性：企业应从本身的业务出发，根据存货收发的批次、数量、种类、价格等因素来选择适合企业的存货计价方法。

（２）稳健性：一般情况下，从稳健性原则出发，企业宁可选择少计期末存货价值，高估存货发出成本的计价方法，以确保企业的存货重置能力，确定企业的真实利润。

（３）避税性：在准则和税法认可的存货计价方法中，企业有权选择少计当期利润，从而能充分享受递延税收利益的方法。

（４）一致性：由于不同的存货计价方法对企业经营绩效产生不同的影响，因而，计价方法的选择一经确定就不应随意变更。

（５）简便性：存货计价方法的选择还要考虑应用花费的成本。企业应结合自身的存货收发特点，选择既能有利于正确表现财务与绩效信息，又能简化工作量的存货计价方法，使之符合“效益>成本”的原则。

因此，《国际会计准则2——存货》认为：对于通常不能互换使用的存货，以及为特定项目生产和单独存放的货物或劳务的成本应按个别计价法计算。存货成本的基准处理方法应采用先进先出或加权平均法计算。允许选用的处理方法有后进先出法以及成本与可变现净值孰低法。

二、计算机条件下对存货计价方法的改进

（一） 计算机条件下实物流转与成本流转的实质

计算机条件下存货流转的实物流转顺序是通过软件系统中业务单据的登记顺序来表示的，软件系统一般采用一个内部单据ID号为系统中的业务单据统一标识顺序，因此，该内部单据ID号就是存货流转的实物流转顺序。

成本流转顺序相对来说复杂些，一般而言，软件系统采用已被财务确认的业务单据的确认登记顺序来表示成本流转顺序。进一步细分可以将成本流转顺序划分为四种。第一种，财务日期＋登记财务账顺序。选择该项，系统将按照先优先单据中登记的财务日期，再优先单据中登记财务账的先后顺序作为成本流转顺序。第二种，财务日期＋填制单据顺序。选择该项，系统将按照先优先单据中登记的财务日期，再优先单据中填制单据的先后顺序作为成本流转顺序。第三种，登记财务账顺序：选择该项，系统将按照单据中登记财务账的先后顺序作为成本流转顺序，此时单据中登记的财务日期将失效。第四种，填制单据顺序。选择该项，系统将按照单据中填制单据的先后顺序作为成本流转顺序，此时单据中登记的财务日期将失效。选择第四种方案既表示实物流转顺序与成本流转顺序一致。

由此可见，计算机条件下实物流转顺序与成本流转顺序已由软件系统自动管理，不再需要财务人员介入。

（二） 计算机条件下的存货计价方法的应用原则

使用计算机来完成存货成本流转程序，由于计算工具和计算环境的改变，必将引起对整个存货计价方法应用原则的重新思考。

（１）适用性——准确性：存货收发的批次、数量、种类、价格等因素将不再成为企业选择存货计价方法的考虑因素。因为计算机处理数据的特点是“存储程序式”，只要程序不错，处理的数据量大小、计算方法的繁简程度、计算工作量的大小都不构成对选择存货计价方法的影响。因此，为不同存货收发的批次、数量、种类、价格规模而设计的存货计价方法的差异特征在计算机环境下不再具有价值，追求存货计价方法的准确性原则代替了适用性原则。

（２）简便性——完备性：在计算机条件下，大多数的计算与控制工作交给了电脑处理，简便性的体现已不在于尽量简化工作量的范畴上，而在于选择更能完备地正确地表现财务与绩效上。

（３）时效性：在计算机条件下，由于计算机强大的计算能力，导致所有的账表都可由计算机即时生成，因此，对存货计价方法的选用都希望能跟随销售单据的登记产生即时的销售成本，及时地更新账户余额，及时地提供销售毛利信息。

（４）重现性：在计算机条件下，对同一批数据，任意存货计价方法的选用，不论何时、何地、何人进行都必须得到相同的结果。特别对于支持成本重算功能的软件，这一原则是非常重要的、必须遵守的原则。

（５）理财性：在计算机条件下，原来手工条件下的稳健性、避税性、一致性等有助于企业改善财务状况的各种理财原则应同样适用。

（三）计算机条件下对传统存货计价方法的取舍

应用以上原则，对手工条件下的各种存货计价方法逐一分析，可以发现，加权平均法虽然在手工条件下是一种被普遍肯定与接受、使用率最高的计价方法，但在计算机条件下，由于其只能在期末使用，虽然计算量小、但时效性差，因而被移动加权平均法取代。类似地，最后进价法、零售价格法、毛利率法也由于同样的原因，在计算机条件下不被优先采用，甚至有被淘汰的危险。先进先出法、后进先出法、个别计价法、计划成本法由于其时效性好，在计算机条件下仍被广泛采用，某些软件还对其算法进行完善性改进，使其能更充分发挥计算机计算速度快、计算能力强的特点，比原来更准确、更及时。

因此，移动加权平均法、先进先出法、后进先出法、个别计价法、计划成本法符合计算机条件下对存货计价方法的选用原则；加权平均法、最后进价法、零售价格法、毛利率法，在计算机条件下不推荐使用。

（四）计算机条件下对传统存货计价方法的改进

计算机条件下对传统存货计价方法的改进主要体现在三个方面：进价控制、售价控制和成本流转顺序控制。

（１）进价控制

当存货计价方法选择移动加权平均法、先进先出法、后进先出法、个别计价法、计划成本法时，由于货到票未到或财务未能及时入账，经常会出现存货入不敷出的现象，在手工条件下，一般采用期末批量暂估入库的方式解决。在计算机条件下，软件支持随时对货到票未到的存货进行暂估入库的处理工作，而且操作过程非常简单，只要用户选择货到票未到的单据，按一下按钮就可以自动完成对应暂估入库单的填制工作。其二，软件在发现存货入不敷出时可以提示用户是否进行暂估入库处理或检查是否有未及时入账的存货。其三，软件还可以对借入物品进行本期暂估入库单和下期暂估入库冲销单的自动编制。另外，某些软件还提供对最高进价的警戒控制，当采购类单据的存货进价超过预先设置的最高进价时，软件可以进行提示警告或强制不予执行的控制。

（２）售价控制

虽然计算机条件下不提倡选用零售价格法，但并不表示软件不提供零售价格的控制，相反，软件对售价的控制手段比手工方式更多样、更有效。首先，软件提供对最低售价的警戒控制，当销售类单据中存货的售价低于最低售价时，软件可以进行提示警告或强制不予执行的控制。其次，软件还提供等级价、批量价、促销价、最近成交价、会员价等控制机制。因此，在计算机条件下售价核算可以取消，但售价核算的管理功能可以通过售价控制实现。

（３）成本流转顺序控制

在计算机条件下，软件提供多种成本流转顺序选择，用户可以根据自身需要灵活选择，某些软件甚至提供月末改变成本流转顺序控制方式和存货计价方法的成本重算功能，但此项功能用户应在不违背会计制度和税法的前提下使用。

三、计算机条件下对存货计价方法的创新

其实，在计算机条件下，是可以对存货计价方法进行一些创新的，笔者认为，在计算机条件下，如果一个新的存货计价方法既不违背历史成本原则，又能有利于加强成本管理与控制效能，此时，这个计价方法就是可以接受的。在此，笔者提出一种基于计算机的存货计价方法——“区间成本法”，不当之处，敬请批评指正。

简单地讲，区间成本法就是将存货结转成本价格牢牢地锁定在某一个成本区间内的计价方法，也许这是许多企业梦寐以求的效果。实现步骤分为三步：首先，确定好缺省使用的存货计价方法和允许正常变动的成本区间。成本区间是一个以 “参考成本”为中心的上下按某一“浮动率”浮动的价格区间。其次，当存货发出按缺省计价方法计算出的缺省成本价格落在成本区间内时，就接受该缺省成本价格作为存货发出的结转成本价格；当计算出的缺省成本价格不落在成本区间内时，则采用“参考成本”作为结转成本价格。最后，增设“成本差异”账户，用来连续记录采用“参考成本”作为结转成本价格时缺省成本与参考成本的差异额，当计算出的缺省成本大于参考成本时，将二者的差异记入成本差异账户的借方，形成借差；相反，将差异记入贷方，形成贷差。如果出现借差的概率大于出现贷差的概率，表示“参考成本”偏小；反之，则偏大。成本差异账户余额水平的控制可以通过修正“参考成本”和“浮动率”来实施控制。

具体来说，使用区间成本法的关键有两点：第一，如何确定“参考成本”和“浮动率”；第二，如何控制成本差异账户的余额水平。

“参考成本”的确定方法可以参考计算机条件下对传统存货计价方法的取舍一节介绍的方法进行。“参考成本”选用的计价方法与该存货缺省使用的计价方法可以相同也可以不同。“参考成本”的更新频率可以分为“按期更新”和“按次更新”两种。按期更新是指每经过一个规定的期间，如：一月、一旬、一周等，“参考成本”就更新一次。按次更新是指每经过一个规定的使用次数，“参考成本”就更新一次。

在实际使用中，当某存货的“参考成本”选用的计价方法与该存货缺省使用的计价方法一致，“参考成本”的更新频率设置成“按次更新”，且使用次数设置为一次时，该存货的区间成本法就退化为缺省使用的计价方法。另外，首次“参考成本”的确定是系统初始化时可设置的一个数据项，若为空，系统首次自动按该存货缺省使用的计价方法确定。

“浮动率”的确定应根据存货的进价涨落幅度和区间成本控制强度来进行确定。当存货的进价波动幅度大时，“浮动率”应增大；当存货的区间成本控制强度大时，“浮动率”应减小。一般情况下，浮动率可按5%，8%，10%等比率设置。特殊情况下，当“浮动率”设置过大，比如超过该存货的进价涨落幅度时，该存货的区间成本法可能退化为缺省使用的计价方法。

成本差异账户余额水平的控制可以通过设置一个允许差异账户余额占库存商品账户余额百分比的方式来确定。该百分比还可分为“预警控制百分比”和“强制控制百分比”两种，并且“强制控制百分比”应大于或等于“预警控制百分比”。所谓“预警控制百分比”是指当成本差异账户余额大于或等于库存商品账户余额乘以“预警控制百分比”时，系统要求改变该存货的“参考成本”选用的计价方法。比如：系统检测到该存货进价成上升趋势且百分比达到“预警控制百分比”时，要求该存货的“参考成本”应选用后进先出法来确定，反之，则选用先进先出法确定。“强制控制百分比”是指当成本差异账户余额大于或等于库存商品账户余额乘以“强制控制百分比”时，系统强制要求改变该存货的“参考成本”选用的计价方法和增大“浮动率”，迫使系统从按缺省计价方法下计算的缺省成本价和区间成本价中选用较高的成本价作为结转成本价，从而保证成本差异账户余额不再增大。在实际使用中，一方面，企业可以将该存货的“预警控制百分比”与该存货的存货跌价准备占存货的期末库存余额的百分比挂钩使用。这样，既可以将存货跌价准备金的计提作提前的预算，也为差异账户余额的消化提供了一条可选的途径。换言之，如此控制，在未实际计提存货跌价准备时，可以通过差异账户先行归集，当实际核准计提存货跌价准备时，可将差异账户余额结转到存货跌价准备账户。另一方面，成本差异账户的初始余额为零。

使用区间成本法的优点有四点：第一，该法中包含了多种计价方法的同时使用，比方说，缺省使用的存货计价方法是一种计价方法，“参考成本”选用的计价方法是一种计价方法，当达到“预警控制百分比”时，系统要求改变的“参考成本”选用的计价方法是一种计价方法，此三处使用的计价方法是可以不同的计价方法，因此，区间成本法是一种集成法。第二，该法中的许多数据可以为企业管理提供指标指示，比方说，“浮动率”与该存货的进价波动幅度相关；“参考成本”选用的计价方法和缺省使用的计价方法的不同选择与该企业所持理财原则相关；“预警控制百分比”和“强制控制百分比”与该存货计提存货跌价准备占存货期末余额百分比相关；等等。因此，区间成本法是一个企业经营状况的指示器。第三，由于区间成本法的使用，离不开上述诸多控制机制的联合作用，因此，该法亦可为企业管理提供控制手段和工具，是一个企业经营管理的控制器。第四，由于该法中包含有丰富与完善的成本控制与管理机制，因此，该法更象一位成本控制与管理专家，是一个计算机成本控制专家系统。使用区间成本法的缺点主要体现在两个方面：第一，该法逻辑复杂、设置项多、不容易理解；第二，该法计算量大、手工无法胜任。

此外，使用该法有两个方面的注意事项：第一，该法的使用，是否违背计价方法选用的一致性原则。实质上，该法是一种新法，其多种计价方法的同时使用和有规则的切换并未违背历史成本原则。其次，虽然理论上对存货计价方法的选用要求前后各会计期间应尽量保持一致，遵守一致性原则。但是，实务中并不排除对计价方法的变更，合理的有规则的变更是符合谨慎性原则要求的。因此，该法的使用，在理论上会表现出一致性原则与谨慎性原则的矛盾，而在实务操作上，则表现为算法完备性与操作简洁性的矛盾。克服前者比较简单，就是优先遵守谨慎性；克服后者，就必须借助计算机，尽量实现算法完备而操作简洁。第二，控制差异账户的余额大小是该法使用的难点。由于差异账户不象计划成本法的材料成本差异账户可以通过期末调整来定期消化部分余额，而只能通过有规则的切换计价方法，变更“参考成本”和“浮动率”来慢慢地消化部分余额，或通过计提存货跌价准备消化部分余额。因此，“强制控制百分比”的确定至关重要。

综上所述，区间成本法是一种基于计算机的、能有效平衡成本差异的、能对成本实施区间管理和实时控制的、能综合运用多种存货计价方法优点的成本管理专家型的存货计价方法。


辅助核算与管理在财务软件和业务软件中实现之差异

财会月刊.综合版 2005年第2期 汤四新

目前，几乎所有国产财务软件都提供辅助核算与管理功能，许多用户都已习惯并接受此功能；也有不少用户反映财务软件的辅助核算与管理功能存在局限性，没有业务软件来得自然、彻底和干脆利落。鉴于此，本文拟就该问题展开分析与研究，不当之处，恳请赐教。

一、财务软件辅助核算与管理性能分析

财务软件的辅助核算与管理可以划分为单辅助核算和多辅助核算两种形式。其实，无论哪种形式都是建立在项目管理机制之上的，所谓项目管理是指在原来二维树型结构的科目体系基础上，增加一个项目的维度和相关的算法，形成一个三维的科目体系。从而使得财务软件可以将基于账户的核算过程和基于项目的管理过程结合起来。例如：要从财务上了解一个项目，如多个科研课题，可能涉及多个科目，在三维科目体系中，可以在进行核算的同时将有关信息登记到科研课题项目中。比方说，为多个课题发生的一笔差旅费，在记入管理费用差旅费账户的同时也登记到相应的多个课题上；获得一笔课题转让收入，在记入其他业务收入账户的同时也登记到对应的课题上。那么，在查询某个课题的辅助账时，就可以一目了然地查到与该课题有关的收入类账户和费用类账户的数据及其变动情况。

事实上，当项目是部门、职员、往来单位、往来业务、产品、成本中心、工程等管理要素时，辅助核算就表现为部门辅助核算、职员辅助核算、往来单位辅助核算、往来业务辅助核算和自定义辅助核算这些单辅助核算形式；当项目表现为某几个管理要素的组合时，就表现为多辅助核算形式。所谓多辅助核算就是五种单辅助核算的其中两种或多种（最多表现为五种）的复合使用。例如：若应收账款需要分部门分往来单位进行核算时就可以将其设置为部门辅助核算和往来单位辅助核算的复合使用。

由此可见，财务软件是通过事先对科目进行辅助核算项目的设置，然后在填制记账凭证时补充登记有关辅助核算项目的信息，最后由软件自动生成允许跨科目的各类辅助账来实行基于项目的辅助核算与管理的。

二、业务软件辅助核算与管理性能分析

在业务软件中，一方面软件提供大量的用于登记各类业务的单据，单据的头部一般包含客商、部门、制单、经办、用途、业务批次等字段，单据的体部一般包含物品或服务、物品批次、数量、单价、金额等字段。收付款类单据的头部还列有结算资金账户字段。软件通过这些字段可以明确业务发生时涉及的部门、职员、往来单位、往来业务、产品、资金账户等管理要素。

另一方面，软件也提供大量的各类账表，一般而言，一个比较完备的业务软件报表系统应该提供采购、库存、销售、往来、资金及综合分析六大类账表。其中，采购信息是以采购类业务单据为主要数据来源反映企业采购的仓储类、财务类、业务类和稽核类的输出账表。库存信息是以库存类业务单据为主要数据来源反映企业库存的仓储类、财务类、稽核类的输出账表。销售信息是以销售类业务单据为主要数据来源反映企业销售的仓储类、财务类、业务类和稽核类的输出账表。往来信息是用于动态地反映应收款、应付款、其他应收款、其他应付款、预收款、预付款的发生、勾对、冲账情况，便于用户及时了解往来款项，实现实时的动态管理的输出账表。资金信息是用于反映各开户银行资金账户在某一会计期间内的资金的期初、期末余额及本期增加、减少数、各账户合计数等信息，为用户提供企业全面的资金状况的输出账表。综合分析报表是为企业提供在物品经营过程中需要的分析指标，以反映物品在购销、经营、仓储环节和财务处理过程中物品、库存、资金等要素的内在联系；按照各部门对物品管理的不同要求分为物品周转分析、库存指标分析、购销价格分析、财务指标分析和通用分析等。软件通过以上六大类报表可以得到各类包含各管理要素的账表。因此，业务软件的辅助核算与管理机制是通过首先在业务单据登记各管理要素，然后通过各类报表表现，或者通过相关控制机制对业务实施监控。其实，将其称之为“辅助核算与管理”只是为了方便与财务软件相比较的一种称谓，实质上，业务软件的此项功能其实就是业务的进、销、存、往来、分析业务台账及报表和业务管理与控制功能。

三、差异分析

通过分别对财务软件和业务软件辅助核算与管理功能的分析，可以得到二者的差异主要表现在三个方面。第一，在输入环节，前者通过在填制记账凭证的过程中，按科目初始化时设置的辅助核算项目，补充登记辅助核算项目相关信息。此时，如果同一科目的发生额对应多个辅助核算项目，那么，还应按辅助核算项目拆分为多笔分录。而后者通过业务单据登记相关的管理要素。第二，在处理环节，两者的确认机制不同，前者是以科目为中心，以账簿为载体，以财务确认为准则建立辅助核算项目的登记规则；后者是以业务为中心，以单据为载体，以业务确认为准则、建立企业业务的进、销、存、往来、分析业务台账及报表，这些报表包含类似于财务软件的辅助账的报表。第三，在输出环节，前者提供的账表类型大大小于后者；前者反映的信息都是基于财务确认机制的对管理要素的补充性的资料，后者输出的信息还可以包含基于业务确认机制的资料。所谓财务确认机制就是按权责发生制来确认业务的发生；而业务确认机制是以货物的实际收发作为确认业务发生的判断依据。

因此，基于记账凭证的数据登录当然没有基于业务单据的数据登录自然与直接；基于财务确认的账表当然也没有基于业务确认的账表更接近业务实况。实务中，两者在输入、输出、处理方面的差异，最终形成了不同的企业辅助核算与管理应用模式。

四、应用模式

若企业有可能使用财务软件或业务软件或二者同时使用，那么，其辅助核算与管理的应用模式可以分成以下三类：完全财务软件的应用模式；完全业务软件的应用模式；财务、业务一体化协同处理的应用模式。

（一）完全财务软件应用模式

完全财务软件的应用模式是一种辅助核算与管理完全借助财务软件的辅助核算与管理功能实现的模式。采用此模式的企业一般认为财务软件的辅助核算与管理功能基本满足其管理需求，或者由于多方面原因不愿将财务软件与业务软件关联使用，或者由于财务软件与业务软件分别采用不同公司的产品而不能关联使用。此时，企业只能依靠充分挖掘财务软件的辅助核算与管理功能来实现其辅助核算与管理工作。此模式适应于业务的核算与管理可以通过财务部门进行的企业，或者说，可以接受以财务确认口径进行业务的核算与管理的企业。

（二）完全业务软件应用模式

完全业务软件的应用模式是一种辅助核算与管理完全通过业务软件来完成的模式。采用此模式的企业一般认为财务软件的辅助核算与管理功能无法满足其辅助核算与管理的需要，或者企业更侧重于以业务确认作为统计口径的辅助核算与管理，或者没有使用财务软件，或者由于多方面原因不愿将财务软件与业务软件关联使用。此时，企业的财务核算与管理侧重于总括性的核算与管理，有关业务的明细核算与管理，如：数量金额式的核算与管理，辅助项目的核算与管理则借重于业务软件完成。

（三）财务、业务一体化协同处理应用模式

财务、业务一体化协同处理的应用模式是一种辅助核算与管理通过财务软件与业务软件间的关联使用、协同处理共同完成的模式。企业采用此模式时，首先通过业务软件中的单据登记对应于各辅助核算项目的管理要素，业务软件据此登记业务辅助账；然后通过业务软件的凭证生成机制生成包含财务软件辅助核算项目信息的记账凭证，经财务确认后将其传递至财务软件；最后财务软件通过该包含辅助核算项目信息的记账凭证登记财务软件的辅助账。在此过程中，凭证生成机制起了关键性、决定性的作用。它是财务软件与业务软件连接的桥梁。

一般而言，凭证生成机制必须在以下两方面表现良好才能完成辅助核算的财务、业务一体化协同处理。第一，生成触发点的灵活自由设置。生成触发点是指在何时启动记账凭证的生成。譬如：当业务单据登记财务账时启动，可以称之为逐单生成；每日汇总某类单据登记财务账或任意指定某几日汇总某类单据登记财务账时启动，可以称之为逐日生成；月末一次性启动的可以称之为逐月生成。因此，生成触发点就可以分成三种，分别是逐单生成、逐日生成和逐月生成。它们都有不同的适应场合。逐单生成适应于平时发生业务少的单据；逐日生成适应于平时发生业务比较多的单据；逐月生成适应于月末一次性结转的单据。第二、业务软件单据管理要素与财务软件辅助核算项目对应关系的匹配控制，该对应关系的控制是通过一种称之为“科目组合”的机制来实现的。所谓科目组合是指在确定记账凭证的借、贷方科目时，可以根据单据组合要素分别对应不同的科目，甚至设置单据要素与账务系统辅助核算项目之间的对应关系。譬如：“借：商品采购，贷：应付账款”这笔分录，应付账款对应的明细科目要视企业账务系统应付账款的科目结构设置分情况讨论。当企业账务系统中应付账款的科目结构设为“应付账款——往来单位”二级科目时，科目组合只要设置单据要素“客商”与科目的一一对应关系表，就可以满足如何确定应付账款对应的明细科目的要求；当企业账务系统中应付账款的科目结构设为“应付账款加往来单位辅助核算项目”时，科目组合除了设置应付账款对应的一级科目对应关系表外，还须设置单据要素“客商”与账务系统往来单位辅助核算项目之间的一一对应关系表，才能符合需求。

由此可见，此模式会自动形成财务软件辅助账和业务软件辅助账，两账之间的差异是由凭证生成机制的触发点选择决定的。企业运用此模式，一般是通过财务软件的辅助账进行基于财务确认的总括性的核算与管理，通过业务软件的辅助账及其它账表进行单据级的基于业务确认的明细核算与管理，通过财务软件与业务软件的稽核机制完成彼此间的相互稽核。